VPN connection works but cannot map drives / access shares


  • I have a windows xp client that I am trying to connect to a Vista 64 Business SP2 machine via VPN.  I previously had a Windows XP  Pro with the same configuration and was able to connect no problem.  So I replaced the Windows XP Pro machine with the Vista and with all the same IP and everything else the same I can connect via vpn but it wont map any drives.  It just times out.  Once the VPN is connected I can ping the Servers IP address and I can connect to that same machine via RDS but cannot map any drives.  As I said, I am using the exact same method which worked to connect to the XP pro machine that was there: \\\sharename but it just times out. (yes this subnet is different from the servers native subnet).  All usernames and passwords are identical on the machine that I replaced and the Vista machine that I just put in its place.

    I have been able to produce this problem with another Vista 64 machine here in my office. In that test, I created VPN servers on both an XP Pro machine and a Vista 64 bit SP2 Ultimate machine. Connecting from the Vista machine to the XP machine I could map drives no problem but connecting from the XP to the Vista machine, I could connect but again could not map a drive
    Tuesday, September 08, 2009 8:18 AM

All replies

  • Hi,

    Please refer to this article to see how file sharing works in Vista:

    сила в справедливости
    Tuesday, September 08, 2009 8:44 AM
  • Hi Kudrat.  Thank you for the quick reply.  I am pretty familiar with Vista networking but I did read that whole article and there was nothing there I didnt look into already.  Do you have any other suggestions?

    I can connect to network shares on either of the Vista Machines directly if I dont use VPN and I can ping them when I am using VPN.

    I have also tried connecting to this VISTA VPN server using both XP and VISTA machines as clients and both clients can connect to the VPN but neither can map drives (or see any shares for that matter)

    One other interesting thing is that when I go into "Incoming Connections Properties" and go to the Users tab, if I select the box that says "Require all users to secure their passwords and data" and click OK, it does not stay checked when I go back in.

    I thought I would also mention that I have windows firewall turned off and have uninstalled my AV software on the VPN server while testing.
    Tuesday, September 08, 2009 5:54 PM