none
Remote Desktop Authentication Error Has Occurred. The function requested is not supported. RRS feed

  • Pregunta

  • Since the Microsoft Security Patch on Tuesday, we've received many reports of users having connection problems like this:

    An authentication error has occurred.
    The function requested is not supported
    
    Remote computer: <computer name="">
    This could be due to CredSSP encryption oracle remediation.
    For more information, see https:/go.microsoft.com/fwlink/?linkid=866660

    The error impacts:

    • Remote Desktop Connection
    • Remote Desktop Connecting to Azure VMs
    • VPN Network Connections (before one can even try to use Remote Desktop)

    This is quite a mess and seems to be related to the security patch increasing security requirements, but not implementing the change to give the machine the increased security levels. The latter doesn't seem to occur if the machine has automated Windows Updates turned off.

    Unfortunately, Windows Update can't be automated in many environments such as development, build, test, staging and production without creating other problems.

    Wrote a blog post about our findings so far with a workaround on how to reduce Remote Desktop security settings to get around this problem. It doesn't require touching registry settings or other complicated steps:

    Remote Desktop Authentication Error Has Occurred. The function requested is not supported. CredSSP

    Would appreciate any insight on handling this across an enterprise without manually modifying the connecting and host machines.

    A common scenario is a person working from home not being able to connect to their own computer in the office or a VM.

    Thanks.


    Luke Chung
    Microsoft MVP
    President of FMS, Inc.
    Blog Facebook Twitter


    viernes, 11 de mayo de 2018 12:50

Respuestas

  • Here is the FIX for this issue ..

    --> Change the Group Policy on your local client to use the vulnerable setting 

    Run:  gpedit.msc

    Go to à Computer Configuration -> Administrative Templates -> System -> Credentials Delegation -> Encryption Oracle Remediation

    Open - Encryption Oracle Remediation à  choose Enable  à change protection level àVulnerable à Apply

    Thanks and Regards,

    Regu

    • Propuesto como respuesta vor0nwe miércoles, 16 de mayo de 2018 10:22
    • Marcado como respuesta LukeChungMVP jueves, 24 de mayo de 2018 18:29
    lunes, 14 de mayo de 2018 13:40

Todas las respuestas

  • Thank you!!!
    viernes, 11 de mayo de 2018 20:25
  • You're welcome. What was your situation?

    Luke Chung
    Microsoft MVP
    President of FMS, Inc.
    Blog Facebook Twitter

    • Propuesto como respuesta kk92009 martes, 15 de mayo de 2018 2:37
    sábado, 12 de mayo de 2018 12:21
  • Good information, but unfortunately my home PC is running the HOME version of Windows 10 and the RDP settings window does not offer the options shown in the workaround link.
    domingo, 13 de mayo de 2018 14:23
  • Thank you for sharing.

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    lunes, 14 de mayo de 2018 5:41
  • Have this issue as well in our environment.  Typical untested patch that makes a headache for large groups of people.  Very irresponsible of the patch team.

    Remove the tick from the "Allow connections only from computers running Remote Desktop with Network Level Authentication" got us working again

    Windows Desktop Client to Server 2012 R2

    • Propuesto como respuesta thomfl miércoles, 30 de mayo de 2018 16:23
    lunes, 14 de mayo de 2018 7:13
  • Or you can just uninstall update KB4103725 
    https://support.microsoft.com/bg-bg/help/4103725/windows-81-update-kb4103725

    worked for me

    lunes, 14 de mayo de 2018 9:43
  • Thanks for sharing..

    it works with me after following this instruction https://blogs.technet.microsoft.com/mckittrick/unable-to-rdp-to-virtual-machine-credssp-encryption-oracle-remediation/

    we have big headache after KB4103725 patched get installed on clients win8. so should i update the kb4103725 on RDP host server 2012 r2 as well or wait for any further security kb? 

    lunes, 14 de mayo de 2018 12:06
  • Here is the FIX for this issue ..

    --> Change the Group Policy on your local client to use the vulnerable setting 

    Run:  gpedit.msc

    Go to à Computer Configuration -> Administrative Templates -> System -> Credentials Delegation -> Encryption Oracle Remediation

    Open - Encryption Oracle Remediation à  choose Enable  à change protection level àVulnerable à Apply

    Thanks and Regards,

    Regu

    • Propuesto como respuesta vor0nwe miércoles, 16 de mayo de 2018 10:22
    • Marcado como respuesta LukeChungMVP jueves, 24 de mayo de 2018 18:29
    lunes, 14 de mayo de 2018 13:40
  • Here is the FIX for this issue ..

    --> Change the Group Policy on your local client to use the vulnerable setting 

    Run:  gpedit.msc

    Go to à Computer Configuration -> Administrative Templates -> System -> Credentials Delegation -> Encryption Oracle Remediation

    Open - Encryption Oracle Remediation à  choose Enable  à change protection level àVulnerable àApply

    Thanks and Regards,

    Regu



    • Propuesto como respuesta RedITAdmin viernes, 18 de mayo de 2018 14:47
    lunes, 14 de mayo de 2018 13:41
  • Here is the FIX for this issue ..

    --> Change the Group Policy on your local client to use the vulnerable setting 

    Run:  gpedit.msc

    Go to à Computer Configuration -> Administrative Templates -> System -> Credentials Delegation -> Encryption Oracle Remediation

    Open - Encryption Oracle Remediation à  choose Enable  à change protection level àVulnerable à Apply

    Thanks and Regards,

    Regu

    This fixed it for me, thank you!

    Windows 10 Pro --> Logging into a Windows server 2012 R2 on a domain

    • Propuesto como respuesta Seth Weisblatt jueves, 17 de mayo de 2018 16:15
    lunes, 14 de mayo de 2018 14:21
  • Is this the same as the user changing their Remote Desktop setting from the dialog box that we suggested?

    Going into gpedit.msc is much more intimidating, and I don't think end users are allowed to do that.


    Luke Chung
    Microsoft MVP
    President of FMS, Inc.
    Blog Facebook Twitter

    • Propuesto como respuesta techguest martes, 4 de septiembre de 2018 16:34
    lunes, 14 de mayo de 2018 14:34
  • You need to make sure both your workstations and servers are patched with the March CredSSP patch.  On May Patch Tuesday, Microsoft released a patch that basically enforces the March patch, so if your workstation got the May patch but you're trying to connect to servers that haven't received the March patch, you'll get this error.

    As a workaround, you can push a Group Policy out or edit a registry key locally, but neither one of those is considered a long-term permanent solution.

    You can read - How to Fix Authentication Error Function Not Supported CredSSP Error RDP for more information on the Group Policy and registry key.

    For the Group Policy, you'll need the ADMX files from a patched server.  In the article above, there's a link to those files from a patched Windows 2012 R2 server which should work.

    Policy path: Computer Configuration -> Administrative Templates -> System -> Credentials Delegation Setting name: Encryption Oracle Remediation 

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System\CredSSP\Parameters]
    "AllowEncryptionOracle"=dword:00000002

    • Propuesto como respuesta Waterman981 lunes, 14 de mayo de 2018 21:12
    lunes, 14 de mayo de 2018 16:37
  • Are those instructions for end users or administrators?

    Most users can't change registry settings on their own, much less the HKLM hive.

    They can change the check box on the Remote Desktop dialog.

    If it's a setting on the network that's changed, will that support people's home PCs and devices they use to remote into their office PC?


    Luke Chung
    Microsoft MVP
    President of FMS, Inc.
    Blog Facebook Twitter



    lunes, 14 de mayo de 2018 16:39
  • Hi and thanks for your observations.

    Don't you think its ironic that the security patch enforced on us poor sods forces one to operate in a less secure manner and the eta of the patch for the patch is unknown. Thanks again Microsoft, you bunch of gimps.

    KillerWombat

    lunes, 14 de mayo de 2018 22:36
  • its worked for me Thanks 
    martes, 15 de mayo de 2018 9:29
  • This worked for me. Thanks!
    martes, 15 de mayo de 2018 10:30
  • Thanks! Worked for me.
    martes, 15 de mayo de 2018 16:21
  • Thanks . Worked for me. I am using Azure. Worked on both WIndows 10 and WIndows 7 devices.
    martes, 15 de mayo de 2018 19:01
  • Hi Luke,

    Regu Sankar's solution using gpedit.msc is not the same as your solution for the following reason:

    I was able to use gpedit.msc on my local client (which fixed the issue), whereas I was NOT able to open the system properties on the server, because that's a VM running in Azure.

    To change the server's system properties, I would need to connect to that machine via Remote Desktop. See the problem?


    • Editado vor0nwe miércoles, 16 de mayo de 2018 10:35
    miércoles, 16 de mayo de 2018 10:34
  • Thank you for this article, Luke.

    In my user's case, the issue was resolved by updating Windows 10 to the most current version (16299.431 as of today, May 16th, 2018). The machine was missing 2018-05 Cumulative Security Update 1709 - KB4103727. My own Windows 10 box was able to connect to the RDP computer without issue, which helped to lead me in the direction of checking revisions. Being more current, my machine had no problem connecting to the RDP machine. I did not want to reduce the security by unchecking the box for Network Level Authentication, so I was glad that Windows updates fixed this.

    Best regards,

    Philip Schember
    Senior IT Technician
    University of Tennessee

    miércoles, 16 de mayo de 2018 14:44
  • excellent...working properly
    jueves, 17 de mayo de 2018 8:34
  • I see all of the solutions only if you able to access windows server. RDP access was the only way I could manage the server. What should I do now, I am getting this message and cannot access the server any advice ?
    jueves, 17 de mayo de 2018 15:29
  • This worked for me.  

    I installed the Windows 10 "Upgrade" to the latest version, which shows to be Version 1709, build 16299.431.  After that update completed, I received this authentication error.  Using the Fix first posted by Regu Sankar, it worked immediately.  

    So thank you, Regu!

    jueves, 17 de mayo de 2018 16:17
  • Hi All,

    I just provisioned a Windows Server 2012 R2 server in Azure. Everything has installed properly. I can see the boot screen. I cannot RDP to the newly provisioned server from a Windows 7 Enterprise RDP Client. 

    It is not showing the CredSSP part of the message.

    Thanks,

    Ken

    jueves, 17 de mayo de 2018 18:52
  • My ability to remote in stopped this week when the update caused the error you mentioned in the original post. My Remote settings were actually already set the way that you suggested - I checked that first per your suggestion.

    I wanted you to know that the fix that worked for me was going into gpedit.msc as suggested by Regu. I was one of those employees/end users who needed to remote in from home, and as you mentioned, I wasn't sure I'd have the permissions to go in there, but it turns out that I did.  

    Thank you for starting this discussion because in it I found a solution to my issue. I hope my feedback helps you or someone else.

    viernes, 18 de mayo de 2018 2:53
  • It works for me.

    Windows 7 connecting to Windows Server 2016 error.

    Solution:

    In the server you are connecting(in my case winserver 2016) uncheck the "Allow Connections only from computers running Remote Desktop with Network level Authentication(recommended)".

    <img alt="System Properies -> Remote tab -> Uncheck" src="http://blog.fmsinc.com/wp-content/uploads/2018/05/remote-windows10.png" />

    viernes, 18 de mayo de 2018 6:34
  • OK!
    I think I have fixed the issue for me, so let me tell you what I did as it may help others.

    Seeing that 'windows update KB4103725' was a bad release and it was released on the 5/8/18. None of the advice I found worked.

    1) Change:

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System\CredSSP\Parameters]
    "AllowEncryptionOracle"=dword:00000002
    (isn't there in windows 7)

    2) Remove:

    Remove the tick from the "Allow connections only from computers running Remote Desktop with Network Level Authentication"
    (isn't there in windows 7)

    3) Delete:

    Delete windows update 'KB4103725'
    (isn't there in windows 7)

    4) Click the tick:

    Click the tick from the "Allow connections from computers running any version of Remote Desktop"
    (as shown at:
    http://blog.fmsinc.com/remote-desktop-authentication-error-function-requested-is-not-supported-credssp/
    ,but isn't there on my windows 7)


    Finally I saw a windows update 'KB4103718' which was installed on my computer on 5/9/18. As it looked similar to 'KB4103725', I deleted it and restarted my computer. I could then connect!
    viernes, 18 de mayo de 2018 6:47
  • Thanks!
    viernes, 18 de mayo de 2018 7:09
  •  This Fix worked for me. Thank you.

      

    viernes, 18 de mayo de 2018 10:01
  • This worked for me! Thanks so much! .....now back to work!
    viernes, 18 de mayo de 2018 14:48
  • Thanks Regu, this fixed it for me.
    viernes, 18 de mayo de 2018 17:33
  • Do you know if it applies to Windows Server 2016 and / or Windows Server 2012R2?

    For your  help and time, thanks.

    viernes, 18 de mayo de 2018 18:57
  • Similar circumstances in my workplace following the Tuesday updates.  Post any attempts at resolution to this.  
    viernes, 18 de mayo de 2018 20:08
  • Here is the FIX for this issue ..

    --> Change the Group Policy on your local client to use the vulnerable setting 

    Run:  gpedit.msc

    Go to à Computer Configuration -> Administrative Templates -> System -> Credentials Delegation -> Encryption Oracle Remediation

    Open - Encryption Oracle Remediation à  choose Enable  à change protection level àVulnerable à Apply

    Thanks and Regards,

    Regu

    This one fixed my problem. Thanks.
    viernes, 18 de mayo de 2018 22:56
  • Thanks, fixed my problem
    domingo, 20 de mayo de 2018 9:36
  • This worked for me (Windows 10 Pro).

    Thanks a lot "Ragu Sankar".


    • Editado Eddie.Kumar domingo, 20 de mayo de 2018 20:01
    domingo, 20 de mayo de 2018 20:00
  • Thank you, this fix for me.

    Alin Lam

    lunes, 21 de mayo de 2018 6:01
  • I've updated my blog post with the information shared here about editing Group Policy and setting it to Vulnerable. It's an option if you can't modify the target PC/VM, and have administrator rights to your PC.

    The update includes screenshots and step-by-step instructions for doing so: 

    Remote Desktop Authentication Error Has Occurred. The function requested is not supported. CredSSP Workaround

    Sorry to see there are still so many people suffering from this problem in the second week. Hope it helps. 


    Luke Chung
    Microsoft MVP
    President of FMS, Inc.
    Blog Facebook Twitter



    lunes, 21 de mayo de 2018 16:17
  • Thanks

    This worked for me..

    "

    Here is the FIX for this issue ..

    --> Change the Group Policy on your local client to use the vulnerable setting 

    Run:  gpedit.msc

    Go to à Computer Configuration -> Administrative Templates -> System -> Credentials Delegation -> Encryption Oracle Remediation

    Open - Encryption Oracle Remediation à  choose Enable  à change protection levelàVulnerable à Apply

    Thanks and Regards,

    Regu"

    • Editado VaGangal lunes, 21 de mayo de 2018 18:45
    lunes, 21 de mayo de 2018 18:44
  • Thank you!
    lunes, 21 de mayo de 2018 20:57
  • Not a fix if you're running Windows 10 Home.
    martes, 22 de mayo de 2018 16:39
  • I think the this is the best solution since you don't need to reboot your desktop. Thank you Regu!
    martes, 22 de mayo de 2018 22:13
  • This Fixed the issue for me too... 
    Super thanks!!!
    jueves, 24 de mayo de 2018 11:35
  • Worked great thanks.
    jueves, 24 de mayo de 2018 17:29
  • I was locked out of one VM Host machine and one VM on another host, Regu's fix worked for me. Thank you!

    I did remove the KB4103718, but it had no effect.

    jueves, 24 de mayo de 2018 18:28
  • https://portal.msrc.microsoft.com/en-us/security-guidance/advisory/CVE-2018-0886

    Depend on which operating system you have.

    viernes, 25 de mayo de 2018 12:08
  • Hiu Guys.

    Thanks you for share this info.

    It worked for me.

    Client Win7/10 to connect Win Srv 2012/2012R2.

    Have a Niece Day.

    "Here is the FIX for this issue ..

    --> Change the Group Policy on your local client to use the vulnerable setting 

    Run:  gpedit.msc

    Go to à Computer Configuration -> Administrative Templates -> System -> Credentials Delegation -> Encryption Oracle Remediation

    Open - Encryption Oracle Remediation à  choose Enable  à change protection levelàVulnerable à Apply "

    • Editado carlyML587 viernes, 25 de mayo de 2018 21:21
    viernes, 25 de mayo de 2018 21:19
  • thanks 

    sábado, 26 de mayo de 2018 10:04
  • Guys, when specifying fixes, please clearly state if the specific fixes/workarounds pertain to the client or the server.   My understanding is that unchecking NLA pertains to the server, not the client.

    I'm assuming that the 5/16 update pertains to the client, since it was mentioned to be a Win10 patch, not the server, correct?

    A consultant can't RDP into our servers which may be behind in patches, but have NLA disabled throgh local GPO.
    I am unable to reproduce the problem but my personal Win10 desktop is fully patched and on build 1803.
    My laptop was on build 1709 and not yet having patches from 5/8 but after fully patching it, it will be on build 1803.   Our corporate Win10 workstations are managed by SCCM.  I suspect they are still on build 1709 and have received the 8/5 patch, so my tests are probably not exact to reproduce the problem.

    But with all these discussions/comments, many are lacking Win10 builds involved and if the recommended changes are to be applied to client or server.

    domingo, 27 de mayo de 2018 17:38
  • Thank you!
    lunes, 28 de mayo de 2018 3:45
  • Thanks a lot Philip Schember.

    It works for me (and for my team).

    lunes, 28 de mayo de 2018 9:53
  • Have this issue as well in our environment.  Typical untested patch that makes a headache for large groups of people.  Very irresponsible of the patch team.

    Remove the tick from the "Allow connections only from computers running Remote Desktop with Network Level Authentication" got us working again

    Windows Desktop Client to Server 2012 R2

    Yep sadly this level of garbage QA is typical of Microsoft in Win10. For Enterprise, Microsoft's current testing regime is a disaster. Visual Studio, Windows, Teams, Office all buggy, full of regressions. New Remote Desktop app is absolutely abysmal over another RDP. It's atrociously laggy - unusable. Plain vanilla upgrades of apps is a minefield. Stuff just doesn't work.
    • Editado MRR111 martes, 29 de mayo de 2018 3:07
    martes, 29 de mayo de 2018 3:03
  • Thanks Regu, that solved the problem for me.
    martes, 29 de mayo de 2018 16:08
  • use this link:

    https://gallery.technet.microsoft.com/Remote-desktop-authenticati-a9f4b9f8

    • Propuesto como respuesta NICOLA FER jueves, 7 de junio de 2018 1:05
    miércoles, 30 de mayo de 2018 3:21
  • Thank you. This solution worked for me. Hopefully, Microsoft will fix this patch soon. 
    • Propuesto como respuesta ALICE FONTINE sábado, 9 de junio de 2018 4:45
    miércoles, 30 de mayo de 2018 21:35
  • Thanks... :)
    jueves, 31 de mayo de 2018 20:45
  • Thanks, That helped me.... Nice one
    viernes, 1 de junio de 2018 14:37
  • This worked for me.

    Thank you

    sábado, 2 de junio de 2018 6:24
  • Protection level Vulnerable didn't work, changing it to Mitigated worked for me
    • Editado Sujan00 sábado, 2 de junio de 2018 14:53
    sábado, 2 de junio de 2018 14:53
  • Or you can just uninstall update KB4103725 
    https://support.microsoft.com/bg-bg/help/4103725/windows-81-update-kb4103725

    worked for me


    This is the best and safest fix suggested so far, not compromising security like the other suggestions.

    And it works.

    Thank you.

    martes, 5 de junio de 2018 8:52
  • Hi and thanks for your observations.

    Don't you think its ironic that the security patch enforced on us poor sods forces one to operate in a less secure manner and the eta of the patch for the patch is unknown. Thanks again Microsoft, you bunch of gimps.

    KillerWombat

    Patch for the fix is KB4103725 as suggested above by Kristina Chitalovska
    martes, 5 de junio de 2018 8:55
  • Awesome!!! Worked for me!!! Don't know what caused the error thought, but I'm able to Remote in without any issues.

    Cesar Vazquez

    martes, 5 de junio de 2018 20:19
  • Thanks, this worked for me! 
    miércoles, 6 de junio de 2018 14:40
  • use this link:

    https://gallery.technet.microsoft.com/Remote-desktop-authenticati-a9f4b9f8

    Thank you. This solution worked for me
    sábado, 9 de junio de 2018 8:07
  • Here is the FIX for this issue ..

    --> Change the Group Policy on your local client to use the vulnerable setting 

    Run:  gpedit.msc

    Go to à Computer Configuration -> Administrative Templates -> System -> Credentials Delegation -> Encryption Oracle Remediation

    Open - Encryption Oracle Remediation à  choose Enable  à change protection level àVulnerable à Apply

    Thanks and Regards,

    Regu

    Thank you very much for the solution!
    lunes, 11 de junio de 2018 4:59
  • Thank you for the solution
    lunes, 11 de junio de 2018 7:42
  • Huge thanks for this - saved me lots of time and aggravation!

    Sarah.

    miércoles, 13 de junio de 2018 8:53
  • You dont necessarily have to RDP to remote machine when you can manage it using other methods (Powershell/Remote registry) to name a few.

    reg add "HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\System\CredSSP\Parameters" /f /v AllowEncryptionOracle /t REG_DWORD /d 2


    miércoles, 13 de junio de 2018 23:50
  • Thanks
    miércoles, 13 de junio de 2018 23:52
  • Tnx ! its work !! 
    jueves, 14 de junio de 2018 7:13
  • It worked for me.

    Thank You !

    Raghvendra

    viernes, 15 de junio de 2018 6:51
  • Thanks. works perfectly
    jueves, 21 de junio de 2018 7:27
  • You should take into account that by applying your workaround, you're putting at risk the source and destination computer for the RDP connection.

    Microsoft suggests applying the pertinent Security Patch in both ends.

    There's an article from Microsoft for all the scenarios:

    CredSSP encryption oracle remediation

    Regards.


    • Editado fedayn2 jueves, 21 de junio de 2018 9:56
    jueves, 21 de junio de 2018 8:14
  • Thanks for sharing.

    It worked on Windows 8.1 64 bit

    Cheers

    jueves, 21 de junio de 2018 13:03
  • its worked for me Thanks 
    lunes, 25 de junio de 2018 13:01
  • instal in the server the respective KB

    2008 R2-> http://www.catalog.update.microsoft.com/Search.aspx?q=KB4103718
    2012 R2-> http://www.catalog.update.microsoft.com/Search.aspx?q=KB4103725

    miércoles, 27 de junio de 2018 14:37
  • This worked....!! thanks
    viernes, 29 de junio de 2018 6:17
  • Legend! Thank you!
    viernes, 29 de junio de 2018 22:21
  • thanks ...
    lunes, 2 de julio de 2018 5:53
  • Great, this worked perfectly for me
    miércoles, 4 de julio de 2018 9:42
  • Thanks, It works

    jueves, 5 de julio de 2018 12:11
  • Thank you very much , this did the trick

    Sdc

    jueves, 5 de julio de 2018 14:12
  • This began happening after I upgraded my workstation to 1803.  After verifying the server(s) were updated (several were not), I was able to remote connect!

    Tim ...

    jueves, 5 de julio de 2018 17:14
  • Amazing! Thank you
    viernes, 6 de julio de 2018 11:32
  • Hi Regu

    Thanks a lot , your guidance fixed it my problem

    viernes, 6 de julio de 2018 11:43
  • I don't see "Encryption Oracle Remediation" in Windows 10.
    miércoles, 11 de julio de 2018 21:55
  • I don't see "Encryption Oracle Remediation" option in my in Windows 7 gp.
    jueves, 12 de julio de 2018 18:02
  • Dude you saved my life. Microsoft support team is useless...
    sábado, 14 de julio de 2018 14:09
  • Thanks. It's worked to me.

    lunes, 16 de julio de 2018 11:55
  • Worked perfectly. Thank you.
    lunes, 16 de julio de 2018 17:46
  • Thank you so much!! this was driving me crazy for a while now!!
    lunes, 16 de julio de 2018 20:51
  • Thanks. Worked like a charm!!
    martes, 17 de julio de 2018 7:18
  • Thanks!  This worked a treat.  
    miércoles, 18 de julio de 2018 10:14
  • This solution fixed my issue. Thanks you so much. 
    jueves, 19 de julio de 2018 15:20
  • Worked perfectly, THANKS!!!
    jueves, 19 de julio de 2018 17:56
  • Thank you so much.

    this method is working with windows server 2012 R2 also.

    thanks a lot

    T.A.


    sign.

    viernes, 20 de julio de 2018 10:37
  • Which method are you referring to?

    Updating Windows Server with patches or doing the workaround?

    (I have too many servers and VMs to do the workaround on all of them.)

    viernes, 20 de julio de 2018 17:52
  • I ended up going in and running the Security Only updates for all of my Server 2012 R2 hosts and VMs.

    Now RDP from my Windows 7 Pro PC is connecting to them all normally without any workarounds or decreased security.

    The weird thing to me is that this started happening outside of any Windows Updates. In fact, it was almost dead in the middle of my standard patch cycle. So I don't even know if it started with something about my Windows 7 install or something about the Server 2012 R2 installs. I'm guessing it's the Windows 7 installs because I hadn't patched the servers in a while because of fear of this exact thing happening.

    martes, 24 de julio de 2018 16:03
  • Thanks!! This fixed some access errors from my Win7 Pro SP1 workstation. 
    lunes, 30 de julio de 2018 13:25
  • Appreciated 
    martes, 31 de julio de 2018 9:50
  • Thank You, it's worked :) 
    miércoles, 1 de agosto de 2018 7:24
  • Nice My problem solved.
    jueves, 9 de agosto de 2018 16:16
  • Thanks so much, The issue had been solved. 

    domingo, 12 de agosto de 2018 8:55
  • its working thank you
    lunes, 13 de agosto de 2018 6:14
  • Thank You so very much !!! :)
    miércoles, 15 de agosto de 2018 20:34
  • Thanks to my brother this saved me some headaches with windows server 2016 Essentials.

    Could no access The Dashboard in 2016 essentials or used Remote Desk connections.

    After unchecked the checkbox, both options started working.

    thanks again.


    SAEdwards

    viernes, 17 de agosto de 2018 0:02
  • Thank you it works :)
    domingo, 26 de agosto de 2018 8:26
  • Thank you for this.

    As always Microsoft screws up, and it's up to users to solve their mess.

    martes, 28 de agosto de 2018 10:20
  • perfect answer!
    martes, 4 de septiembre de 2018 16:34
  • Thank You!
    lunes, 10 de septiembre de 2018 19:55
  • Thank you so much. It worked!
    martes, 11 de septiembre de 2018 21:21
  • tanx

    viernes, 14 de septiembre de 2018 7:49
  • In my opinion, Microsoft fixed something that wasn't working before. In many environments, you don't want anyone to be able to remote into a server without network authentication, even if they don't have domain admin security permissions on the server. A simple check mark in remote settings on servers that are going to be accessed by non domain admins seems much better to me than anyone able to remote into one of the companies critical servers. 
    viernes, 21 de septiembre de 2018 20:35
  • Worked for me. Thanks a lot. 
    sábado, 22 de septiembre de 2018 16:49
  • Thanks 
    martes, 25 de septiembre de 2018 16:56
  • THANK YOU!  This was making me CRAZY!

    shane

    domingo, 30 de septiembre de 2018 6:25
  • Worked like a charm for me as well. Many thanks!!
    jueves, 4 de octubre de 2018 14:00
  • It worked, thank you.
    martes, 16 de octubre de 2018 6:22
  • Is this safe?

    LM

    martes, 16 de octubre de 2018 7:07
  • Thanks Regu. It did help me alot.

    How can we see sites in a Server that have SSL based service (HTTPS).

    Thanks.

    jueves, 1 de noviembre de 2018 16:23
  • Windows 7  to Server 2012

    I Remove the tick from the "Allow connections only from computers running Remote Desktop with Network Level Authentication"

    It worked for me.

    Thanks
    martes, 13 de noviembre de 2018 0:23
  • This worked for me, thank you.
    martes, 20 de noviembre de 2018 19:20
  • After changing group policy, you need to reset the client one time or two.

    Actually it didn't work for me even after the first reset. But the second did the work.

    Maybe you had the same situation

    jueves, 27 de diciembre de 2018 6:26
  • After changing group policy, you need to reset the client one time or two.

    Actually it didn't work for me even after the first reset. But the second one did the work.

    jueves, 27 de diciembre de 2018 6:27
  • Thanks, it's Working.

    jueves, 27 de diciembre de 2018 15:16
  • This works perfectly for me I am working on Windows 10 computer and taking remote desktop connection of Windows Server 2016.

    These setting worked perfectly on Windows Server 2016.

    Thanks,

    Chandrashekhar 

    MCSA, MCTS, MCITP & CCNA, CCNP (R&S)

    sábado, 29 de diciembre de 2018 4:18
  • Its worked!!!!!

    Thanks

    viernes, 18 de enero de 2019 2:48
  • Done.

    Thank you...

    miércoles, 23 de enero de 2019 9:46
  • This worked for me on my home network! Thanks!
    jueves, 24 de enero de 2019 3:46
  • Have this issue as well in our environment.  Typical untested patch that makes a headache for large groups of people.  Very irresponsible of the patch team.

    Remove the tick from the "Allow connections only from computers running Remote Desktop with Network Level Authentication" got us working again

    Windows Desktop Client to Server 2012 R2


    Thank you. Such an easy fix, but worked for me.
    jueves, 21 de febrero de 2019 18:35
  • Thanks, It worked for me.
    martes, 26 de febrero de 2019 18:26
  • Hello. I have Windows 7 Home Premium, and since the 8th May 2018 Update I can't login via Remote Desktop. I tried several things, including unistalling all updates until that day. I managed to install gpedit even if I am home premium, but of this: Computer Configuration -> Administrative Templates -> System -> Credentials Delegation -> Encryption Oracle Remediation, I haven't "Credentials Delegation", and I am a no point.
    Also, with regedit, of this path:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System\CredSSP\Parameters I haven't CredSSP.
    Someone can help me? It's absurd. Thanks!

    martes, 26 de febrero de 2019 19:22
  • Hi, 

    Similar to this I have faced a problem to login the hyper-v server. The error shows like this. 

    The problem caused after promoting a new domain controller by removing old domain controller which was exceeded the tombstone lifetime. Please advice. 

    Note: we cannot log to the server hence the error appears saying "Trust relationship between this workstation and the primary domain failed"


    miércoles, 13 de marzo de 2019 4:37
  • This one worked for me!! This one saves my day! I am using Windows 7 connecting to Windows Server 2016

    Thanks so much!!

    jueves, 4 de abril de 2019 14:55
  • Thanks Regu,

    I was have this issue with a VM image in Hyper-V, I had to update the VM server and then was able to connect to my image.

    EJ

    viernes, 19 de abril de 2019 11:54
  • Thanks for you help in my case work perfect.
    martes, 30 de abril de 2019 13:29
  • This fixed mine as well.

    Thank you for taking the time to post this solution!!

    lunes, 6 de mayo de 2019 13:59
  • ناموسا دمتگرم مشتی Thankkkkkk you
    lunes, 10 de junio de 2019 16:42