none
MSVCR100.dll is missing RRS feed

  • Pregunta

  • I am trying to install Apache web server using wamp on a windows 8 pro machine when it is installing I get the following error: "The program can't start because MSVCR100.dll is missing from your computer. Try reinstalling the program for to fix this problem." I have tried the suggestions on the web to remove Visual C++ redistribution  and reinstall it and that doesn't seem to work.

    Where can I get this dll and what directory should it be in? Should I be installing a newer version of the Visual C++ redistribution pack, like the 2012 pack? Should I also install older versions of the redistribution pack one of the articles on the web suggested to remove all the versions of Visual C++ redistribution packs and reinstall them; I only have 2010 pack installed. Almost all of the articles were related to Windows 7 not Windows 8 is there something I should be doing for window 8 Pro

    martes, 24 de septiembre de 2013 5:28

Respuestas

  • MSVCR100.dll = Visual C++ 2010 Runtime, not the 2012.

    32Bit: Microsoft Visual C++ 2010 SP1 Redistributable Package (x86)
    http://www.microsoft.com/de-de/download/details.aspx?id=8328

    64Bit: Microsoft Visual C++ 2010 SP1 Redistributable Package (x64)
    http://www.microsoft.com/en-us/download/details.aspx?id=13523


    "A programmer is just a tool which converts caffeine into code"

    martes, 24 de septiembre de 2013 20:12
    Usuario que responde

Todas las respuestas

  • MSVCR100.dll = Visual C++ 2010 Runtime, not the 2012.

    32Bit: Microsoft Visual C++ 2010 SP1 Redistributable Package (x86)
    http://www.microsoft.com/de-de/download/details.aspx?id=8328

    64Bit: Microsoft Visual C++ 2010 SP1 Redistributable Package (x64)
    http://www.microsoft.com/en-us/download/details.aspx?id=13523


    "A programmer is just a tool which converts caffeine into code"

    martes, 24 de septiembre de 2013 20:12
    Usuario que responde
  • You can find the Cause and Solution: http://www.steptoinstall.com/msvcr100-dll-is-missing-when-wamp-server-install.html
    viernes, 2 de mayo de 2014 7:37
  • For the English version of the 32Bit: Microsoft Visual C++ 2010 SP1 Redistributable Package (x86) , I would suggest that you use En-Us download from: 

    http://www.microsoft.com/en-US/download/details.aspx?id=8328

    miércoles, 1 de octubre de 2014 8:56
  • still the problem persists...
    martes, 17 de marzo de 2015 6:42
  • My computer can't open a file because it says there is a problem it said to re-install the file but that didn't work
    viernes, 15 de mayo de 2015 3:22
  • I'm still facing the same issue. I have also install the 64 bit version as you said,
    64Bit: Microsoft Visual C++ 2010 SP1 Redistributable Package (x64) 
    http://www.microsoft.com/en-us/download/details.aspx?id=13523

    but same situation that is "The program can't start because MSVCR100.dll is missing from your computer. Try reinstalling the program for to fix this problem."?

    Please tell me how i can fix it. I'm using Windows 8.1 Pro 64 bit version.

    sábado, 3 de octubre de 2015 4:35
  • I'm still facing the same issue. I have also install the 64 bit version as you said,
    64Bit: Microsoft Visual C++ 2010 SP1 Redistributable Package (x64) 
    http://www.microsoft.com/en-us/download/details.aspx?id=13523

    but same situation that is "The program can't start because MSVCR100.dll is missing from your computer. Try reinstalling the program for to fix this problem."?

    Please tell me how i can fix it. I'm using Windows 8.1 Pro 64 bit version.

    sábado, 3 de octubre de 2015 4:37
  • If the program that won't start is a 32-bit program then you also need to install the 32-bit (x86) version of the runtimes.

    viernes, 13 de noviembre de 2015 1:55
  • 2016 now. I am running Win 10 Insider Preview 11102.rs1_160113-1800 

    Probably 1st boot up after the new system.

    This error induced to WLM (after prior repair from an update Dec2015?) Installed 32 bit. Then 64 bit. OK. Then rebooted.

    Start WLM and get:

    "wlmail.exe - System error

    The program can't start because MSVCR110.dll is missing from your computer. Try reinstalling the program to fix the problem.

    OK"

    about 3 times.

    Someone keeps messing up the same thing over and over at MS.


    Michael

    sábado, 23 de enero de 2016 6:55
  • I recently just had this very same problem.  Except I was trying to open an rpg game client.  Instead I received the same message that you did.  But I also just recently figured it out.  I had to uninstall Microsoft Visual C++ 2010 SP1 Redistributable from my computer via Apps in settings.  Then went to the link given on this forum. Which I will paste.  Once I had reinstalled it, I was then able to open the client.  If your problem still persists I would try uninstalling each Visual C++ and reinstalling them.  Somewhere there is corrupt data.  Which I believe might have had something to do with uninstalling Anti-Virus Software AVG.

    Also my computer is running windows 10 which is why I stated that you might need to try uninstalling and reinstalling the other Visual C++ software.

    http://www.microsoft.com/en-US/download/details.aspx?id=8328

    miércoles, 6 de diciembre de 2017 16:50
  • I recently just had this very same problem.  Except I was trying to open an rpg game client.  Instead I received the same message that you did.  But I also just recently figured it out.  I had to uninstall Microsoft Visual C++ 2010 SP1 Redistributable from my computer via Apps in settings.  Then went to the link given on this forum. Which I will paste.  Once I had reinstalled it, I was then able to open the client.  If your problem still persists I would try uninstalling each Visual C++ and reinstalling them.  Somewhere there is corrupt data.  Which I believe might have had something to do with uninstalling Anti-Virus Software AVG.

    Also my computer is running windows 10 which is why I stated that you might need to try uninstalling and reinstalling the other Visual C++ software.

    http://www.microsoft.com/en-US/download/details.aspx?id=8328

    miércoles, 6 de diciembre de 2017 16:50
  • I've just set up a new machine.  I've installed our software product which seems to require this dll.  I've followed the steps above however the application continues to report the dll is missing

    More googling required as this is clearly not the solution. Its not like im in a hurry to set up a machine for a customer training session.  :(

    Thanks Microsoft!

    miércoles, 10 de enero de 2018 8:21
  • http://www.microsoft.com/de-de/download/details.aspx?id=8328

    For 32 bit Operating System

    sábado, 17 de marzo de 2018 14:11
  • Exactly. The top hits from a Google search talk about "if you have 64bit OS, download the C++ 64bit version". I did that and my app was still failing...then I realized it is probably a 32bit app and sure enough it just needed the 32bit C++ files.

    Surprised I was the first one to upvote your comment.

    lunes, 2 de abril de 2018 15:54
  • MSVCR100.dll = Visual C++ 2010 Runtime, not the 2012.

    32Bit: Microsoft Visual C++ 2010 SP1 Redistributable Package (x86)
    http://www.microsoft.com/de-de/download/details.aspx?id=8328

    64Bit: Microsoft Visual C++ 2010 SP1 Redistributable Package (x64)
    http://www.microsoft.com/en-us/download/details.aspx?id=13523


    "A programmer is just a tool which converts caffeine into code"


    miércoles, 4 de abril de 2018 5:09
  • Here are some updated links to the SP1 version.  Looks like Microsoft may have taken down the old links.  Hope this saves you some time looking.

    Microsoft Visual C++ 2010 SP1 Redistributable Package (x86)
    http://www.microsoft.com/en-us/download/details.aspx?id=8328

    Microsoft Visual C++ 2010 SP1 Redistributable Package (x64)
    https://www.microsoft.com/en-us/download/details.aspx?id=13523



    • Editado mdpry jueves, 26 de abril de 2018 19:16 Readability
    jueves, 26 de abril de 2018 19:15