Vista RTM : CTRL+A, Multi selection of files not working


  • hi,

    I don't know what happened, but I'm not able anymore to use CTRL+A or other multi file selection (shift, ctrl) in windows explorer.

    Anyone knows how to resolve this?

    samedi 2 décembre 2006 22:57

Toutes les réponses

  • Try to change view of files (Click Views) then try some view like Details and give it a try.

    Let me in the know.

    Good luck

    dimanche 3 décembre 2006 12:28
  • Does not work. All multi selection combo does not work either, like Ctrl/Shift + Left Button, Ctrl + Up/Down.
    lundi 4 décembre 2006 20:50
  • Does this only happen on one computer?  I have Vista RC2 on 3 computers, one cannot use IE without comitting suicide, while the other two have no problems.
    mercredi 6 décembre 2006 17:20


    1. Check that the Ctrl button is working

    2. Check Keyboards shorcuts from control panel ---> Keyboards

    jeudi 7 décembre 2006 14:14
  • Go to Ease of Access Center in Control Panel and check keyboard settings, you might changed some settings in there like Sticky Keys in Make the keyboard easier to use.

    Good luck  

    dimanche 10 décembre 2006 13:07
  • I am having the same problem.  I have found the following

    1.  I can use CTRL-Select on my local drives

    2.  I can normally use CTRL-Select on network drives

    3.  On one folder (and all sub folders) on one network drive I cannot do multiple selections.

    4.  I have tried a number of other folders (and created many with near identical names) and cannot reproduce this.

    5. I am not a member of the domain - but "connect as" to this server.

    6.  Another user can access this folder from Vista without an issue.  His computer is a member of the domain.

    7.  When you enable "use checkboxes to select items" - you do not get the "select all" option in the title bar.

    Does any of this sound similar to what you are experiencing?


    dimanche 10 décembre 2006 21:25
  • I have ran into the exact same issue.

    Before becoming crazy, I had a look on the net and several people faced the same weird bug

    It seems to appear when you apply some specific settings globally for all folders.

    To get out of it, the solution is to "Reset Folders" on key folders.

    I have not identified th exact ones but after a few tries, it solved the issue.

    Hope this helps and Merry Chrsitmas.


    dimanche 24 décembre 2006 12:55
  • I'll chime in, having the same problem. Definitely a bug.
    vendredi 19 janvier 2007 16:45

    Same problem here. I've had this behaviour for the last few days on Vista Ultimate RTM. After reading this thread I did a reset in the Folder options and the problem went away.

    dimanche 21 janvier 2007 13:55
  • hi,

    i'm having same prolem. but it is not getting away with folder reset.

    i've three partitions (c,d,e). on c: multiple selection works sometimes, on e: selection works in some folders.

    i'm used to view files in List view. which is my favorite. but this behaviour is suggesting me that this is a CRITICAL bug. as it works in some folders. also works where it isn't when i close all windows, and directly navigate to the location where it wasn't working, it works :/

    pretty odd.

    MS should release a SP1 as soon as possible.

    // chall3ng3r //

    mardi 23 janvier 2007 01:17
  • Thanks for your hint!  It just worked on my PC! :-)

    I had the exact same problem: no multiple selection would work anywhere; local drives, network drives whatsoever (Vista Business). It has been a few weeks already. I already tried resetting folders and other things but it wouldn't work anyway.

    Before becoming crazy, I looked for hints on the Net, found your advice and it just encouraged me to try resetting folders more times. I just reset them 4 times, with checking back and applying the "Remember each folder's view settings" option (which I personally hate). And YES, multiple selections are finally back!  Looks like a nice little bug.

    Advice to others with the same pain: try resetting folders several times in a row, even if it feels silly. It worked for me.

    Vista seems to have more problems in this area. It insists on applying different view settings to different folders of the same kind (changing columns width, etc) even when the "Remember view settings" is unchecked.

    mercredi 7 mars 2007 13:51
  • I tried resetting the folder view, but it seems that you have to reset the right folder for this to work.


    I then tried changing to "classic view" then flip back, then multi-selection now works.

    vendredi 30 mars 2007 14:14
  • It's a quirk of Explorer that's been showing up on some people's machines.
    No known cause yet, but it gets saved with folder views once it happens.

    I've written a script that helps MOST people with the multi-select problem.
    It will remove single-select from saved folder views & saved defaults.
    Right-click the link below & select 'Save Target As..."

    samedi 31 mars 2007 07:52
  •  Keith Miller MVP wrote:
    It's a quirk of Explorer that's been showing up on some people's machines.
    No known cause yet, but it gets saved with folder views once it happens.

    I've written a script that helps MOST people with the multi-select problem.
    It will remove single-select from saved folder views & saved defaults.
    Right-click the link below & select 'Save Target As..."


    Kevin - THANK YOU! This has been driving me nuts for over a month. Glad I stumbled on this here.

    Brian Gallus.

    vendredi 13 avril 2007 18:00
  • You're welcome.


    I just noticed that wasn't a valid link in my post, it just looked like one!


    I edited the post & made it functional for future users

    vendredi 13 avril 2007 18:36
  • I have the same problem, and resetting folder option does not work.

    About a day ago I was using the right-click property page of a folder, using the "Customize" tab,
    and select "Use this folder type as a template".  After that, explorer crash and restart itself.
    (I selected "All Items").  I don't know if it has anything to do with the multiple-selection, but
    this is the first time vista explorer crash since I first used it a month ago.

    Is there a solution or a patch yet?   Please help.

    vendredi 25 mai 2007 06:06
  • Keith Miller


    Thank you very much! 

    Because "reset folder view" doesn't help I've used your VBScript and this bug are gone!


    Thank you!

    samedi 9 juin 2007 11:29
  • Hey Gro,

    Thank you very much! Hurrah!!  After 4th attempt multi selection worked. Smile Is this fixed by Microsoft, because this was logged 7 months before.. I will go mad doing this for every folder... Sad But anyway your solution is better than dealing with single file.



    mercredi 25 juillet 2007 01:40
  • Check out this link... Smile
    lundi 6 août 2007 18:21
  • Good afternoon,


    I'm taking this opportunity to thank you for your script.  There are a lot of talented people in the various forums, blogs and other areas and it's wonderful that they share.


    This new Vista system has been quite a learning experience so far!  I've been using PCs since the Commodore 64 days (yes, I'm not that young!) and am always fascinated everytime I get a new one.  But for the first time ever, it took a good week to get the system really running how I want it to.  Geesh!  Am I getting old or are these fancy new features much more needy?!


    At any rate, thank you again, because the multiple select issue in Vista is THE most annoying problem I've encountered in all my days!




    vendredi 17 août 2007 20:54
  • thank you kevin for the last couple of day this bug has been annoying me



    mercredi 19 septembre 2007 00:02
  • Had the same problem with CTRL+A and other shortcuts - very anoying bug.

    Will MS fix this before my customers start to complain and/or use hammers?


    Thanks to Keith for the script. It fixed the problem for now! Smile


    jeudi 27 septembre 2007 22:18

    Thank you very much ! ....

    It is working fine.

    samedi 22 décembre 2007 12:46
  • You're a genius Keith... and my new personal savior!

    Gosh, this Vista is loaded with little annoyances like this!!!

    samedi 8 mars 2008 02:35
  • Thanks for the feedback, folks!  The link has been updated to reflect my new ISP.  If you saved the old link, it will become inactive at some point.






    samedi 15 mars 2008 04:03
  • I'm very frustrated by this problem and I'd love to try your script, Keith, but attempting to do so reveals another problem.

    When I attempt to launch your script (by double-clicking it), it opens in a text editor (Notepad++).  Apparently this text editor has set itself up as the default application for .VBS files.  I cannot find the correct executable to execute this script (knowing where to look and what to look for would probably be helpful!).  Telling Notepad++ that it is NOT the default app for .VBS files doesn't seem to reset the file association properly.

    Bottom line is that I cannot figure out how to run this script.  Resetting the folders (as others have suggested) has no effect whatsoever, so I guess I'm gonna have to dig into the registry directly and delete some keys, which always makes me a bit nervous.
    lundi 14 avril 2008 17:37
  • For what it's worth, I've found an alternate solution.  I'm posting it here in the hopes that someone might find it useful.

    Basically, it's a .REG (Registry data import/export format) file that simply deletes the two errant keys.  I don't know for sure, but I suspect that it might help if there are no Windows Explorer windows open when using this file.

    All that you have to do is to copy the text between the two lines below (not including the lines themselves) and then paste it into an empty text file with the file extension .reg (Notepad works fine for creating this file).  Make sure that the lines containing the key names are not broken - there are only three lines of text in this snippet.

    Windows Registry Editor Version 5.00

    [-HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\Shell\BagMRU]

    [-HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\Shell\Bags]

    Once you have saved the .reg file, double-click it and answer Yes when asked if you want to continue.

    Keep the .reg file around, because if what other users are reporting is true, the problem will re-appear eventually until Microsoft decides to fix it.

    I have to say that this is one of the nastiest interface bugs Microsoft has ever released.  I don't feel that all of us should have to wait for SP1 to see this fixed - IMNSHO there should have been a hotfix for it months ago.
    lundi 14 avril 2008 18:44
  • Hi,


    I am experiencing exactly the same problem...but under Windows XP SP2.

    Will your script also run under this OS.





    • Proposé comme réponse great gatsby jeudi 9 février 2012 05:51
    • Non proposé comme réponse great gatsby jeudi 9 février 2012 05:51
    jeudi 17 juillet 2008 14:48
  • My Ctrl A (select all) shortcut was no longer working.  After hours trying to figure it out, I realized I had assigned Ctrl A as a hot key in another program.  This kept Ctrl A from working as 'select all' in all other programs.

    Simple fix once I realized what the 'problem' was.  So you may want to check your application hot key assignments if you are having problems with Ctrl + shortcuts.


    jeudi 9 février 2012 05:52