none
Windows 10 : Erreur 0x8007001f MAJ vers windows 1903 RRS feed

  • Question

  • Bonjour

    Après tout avoir essayé... Outils de résolution (réparation Windows Update)

    Script :

    net stop wuauserv 
       net stop cryptsvc

       net stop bits

       net stop msiserver 
    DEL C:\Windows\SoftwareDistribution.old
    ren C:\Windows\SoftwareDistribution SoftwareDistribution.old

    DEL C:\Windows\System32\Catroot2.old

     ren C:\Windows\System32\catroot2 Catroot2.old

    net start wuauserv

       net start cryptsvc

       net start bits

       net start appidsvc

       net start msiserver

    Rien à faire... Ce patch à toujours une erreur 0x8007001f 

    J'ai passé un antivirus.. OK

    Je ne sais plus quoi faire...

    Peut on m'aider

    Merci

    jeudi 31 octobre 2019 13:15

Réponses

Toutes les réponses

  • Bonjour,

    Vous essayez de mettre à jour Win 8 vers Win 10 v1903 ?

    jeudi 31 octobre 2019 13:43
  • Bonjour,

    Installe plutôt la dernière version 1903 par mise à niveau.

    Si un antivirus autre que Windows Defender est installé, le désinstaller et activer Windows Defender.
    http://assiste.com/Comment_desinstaller_completement_un_antivirus.html

    •  Télécharge le fichier ISO > Win10_1903_V2_French_x64.iso 
        https://tb.32767.ga/get.php?id=1384&lang=fr-FR
        ou le fichier ISO > Win10_1903_V1_French_x64.iso
        https://tb.rg-adguard.net/index.php?lang=fr-FR&extract
        ou utilise l'astuce F12 pour télécharger le dernier ISO disponible
        http://dechily.org/Forum_Aski/viewtopic.php?f=63&t=1913
    •  Clique droite sur l'ISO et choisis "Monter" ou double-clique sur l'ISO.
    •  Lance la mise à niveau en exécutant le SETUP du lecteur virtuel qui se crée.
        Sélectionne l'option sans télécharger les dernières mise à jour.


    Cordialement Aski - Windows Insider MVP - http://dechily.org/Forum_Aski/

    vendredi 1 novembre 2019 07:16
  • Non j'ai windows 10 x64

    Je vais télécharger l'iso ci-dessus

    Mais j'espère qu'il y a une option sans perdre mes données

    Sinon autant réinitialiser entièrement l'environnement et j'ai vraiment envie d'éviter

    vendredi 1 novembre 2019 16:40
  • Bonsoir,

    La méthode que je conseille préserve les données et les programmes.


    Cordialement Aski - Windows Insider MVP - http://dechily.org/Forum_Aski/

    vendredi 1 novembre 2019 16:55
  • J'ai téléchargé le 1er lien et j'i lancé l'instal en admin => ECHEC

    Code de l'erreur 0x8007001F - 0x20006

    L'installation a échoué dans la phase SAFE_OS avec erreur de l'opérateur REPLICATE_OC



    samedi 2 novembre 2019 13:01
  • Quel est le SHA-1 de l'ISO que tu as utilisé ?

    As-tu conservé un antivirus tiers. Si c'est le cas, quel est cet Antivirus ?


    Cordialement Aski - Windows Insider MVP - http://dechily.org/Forum_Aski/

    samedi 2 novembre 2019 16:49
  • Salut Aski

    En plus de tes questions judicieuses, je signale aussi au demandeur cet article de Malekal que je trouve assez complet => https://www.malekal.com/erreur-safe-os-windows10/

    Notamment le paragraphe "Les sources de l’erreur SAFE_OS"


    Ex-helpeur de Community. Désormais sur http://dechily.org/Forum_Aski/


    samedi 2 novembre 2019 17:51
  • Aucun antivirus mise à part Defender de Microsoft

    Comment détermine t'on le SHA-1 d'un ISO?

    Pour info, j'ai téléchargé le 1er lien ci-dessus "Télécharge le fichier ISO > Win10_1903_V2_French_x64.iso"

    samedi 2 novembre 2019 18:30
  • Bonjour,

    Je ne comprends pas très bien quand ce produit votre problème.

    Si le téléchargement de la mise à jour fonctionne mais que l'installation ne se produit pas, c'est probablement parce qu'il y a un soucis lors de la phase de vérification des prérequis.

    J'avais fait cet article qui permet de commencer un diagnostic : https://matteu31.wordpress.com/2018/04/10/windows-10-troubleshoot-upgrade/


    Merci de marquer comme reponses les interventions qui vous ont ete utile.

    samedi 2 novembre 2019 23:46
  • L'installation se lance et s'opère très bien au début

    Le process d'installation reboot le poste et à la fin la MAJ est rejetée et il restaure ...

    A l'ouverture de Windows, il ouvre une fenetre et présente l'erreur

    Je n'ai a priori pas le droit de vous poster de copie d'écran... ni lien...

    dimanche 3 novembre 2019 07:13
  • Bonjour,

    Pour le SHA-1, télécharge et installe Hashtab
    http://www.gratilog.net/xoops/modules/mydownloads/singlefile.php?cid=194&lid=1412

    Un onglet Hachages va s'ajouter dans les Propriétés.
    https://assiste.com/Logitheque/HashTab.html
    Tu trouveras ja bonne valeur à la fin de ce tuto


    Cordialement Aski - Windows Insider MVP - http://dechily.org/Forum_Aski/

    dimanche 3 novembre 2019 07:29
  • Merci pour vos idées, j'ai l'impression que j'ai une anomalie dans la base de registre.

    Grace au lien ci_dessus, J'ai trouvé setuperr.log

    2019-11-02 21:42:39, Error                 CSI    00000001 (F) STATUS_OBJECT_NAME_NOT_FOUND #38# from Windows::Rtl::SystemImplementation::DirectRegistryProvider::SysQueryValueKey(flags = 0, key = b24 ('\REGISTRY\MACHINE\SYSTEM\Setup'), vn = [l:7 ml:8]'Compact', kvic = 2, kvi = 2, disp = 0)[gle=0xd0000034]
    2019-11-02 21:42:39, Error                 CSI    00000002 (F) STATUS_OBJECT_NAME_NOT_FOUND #37# from Windows::Rtl::SystemImplementation::CKey::QueryValue(flags = 0, kn = [l:31]'\Registry\Machine\SYSTEM\Setup\', vn = [l:7 ml:8]'Compact', ic = KeyValuePartialInformation, info = {l:0 b:}, disp = 0)[gle=0xd0000034]
    2019-11-02 21:42:39, Error                 CSI    00000003 (F) STATUS_OBJECT_NAME_NOT_FOUND #70# from Windows::Rtl::SystemImplementation::DirectRegistryProvider::SysQueryValueKey(flags = 0, key = b40 ('\REGISTRY\MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Fonts'), vn = [l:21 ml:22]'Arial Nova (TrueType)', kvic = 2, kvi = 2, disp = 0)[gle=0xd0000034]
    2019-11-02 21:42:39, Error                 CSI    00000004 (F) STATUS_OBJECT_NAME_NOT_FOUND #69# from Windows::Rtl::SystemImplementation::CKey::QueryValue(flags = 0, kn = [l:69]'\Registry\Machine\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Fonts\', vn = [l:21 ml:22]'Arial Nova (TrueType)', ic = KeyValuePartialInformation, info = {l:0 b:}, disp = 0)[gle=0xd0000034]
    2019-11-02 21:43:44, Error                 CONX   0xd0000034 Failed to add user mode driver [%SystemRoot%\system32\DRIVERS\UMDF\uicciso.dll]

    2019-11-02 21:44:45, Error      [0x0805ff] MIG    OC::COCCbsAdapter::GetOCsInPackage: EnumerateUpdates failed. hr = 0x800f0831
    2019-11-02 21:44:45, Error                 MIG    OC Exception: OC::CInstalledOCStore::GetOCCollection: Couldn't get the Foundation package OCs
    2019-11-02 21:44:45, Error                 SP     Could not save OC status. Error: 0x8007001F
    2019-11-02 21:44:45, Error                 SP     Operation failed: Gather Optional Component status. Error: 0x8007001F[gle=0x000000b7]
    2019-11-02 21:44:45, Error                 SP     pSPRemoveUpgradeRegTree: failed to delete reg tree HKLM\SYSTEM\Setup\Upgrade[gle=0x00000005]
    2019-11-02 21:46:50, Error      [0x080831] MIG    CSIAgent: Invalid xml format: FormatException: Component with display name: Plugin/{C939EC0F-2F56-4CE8-AF56-2336596A5FA7} already loaded __cdecl Mig::CMXEMigrationXml::CMXEMigrationXml(class Mig::CPlatform *,class UnBCL::String *,class UnBCL::XmlDocument *,class UnBCL::String *,class UnBCL::String *)
    2019-11-02 21:49:33, Error      [0x0808fe] MIG    Plugin {ff9c714f-b864-4f43-ae39-ec07d7385abe}: Root device 'ROOT\MULTIFUNCTION\0000' does not have driver.
    2019-11-02 21:52:18, Error                        CSetupAutomation::Resurrect: File not found: C:\$WINDOWS.~BT\Sources\Panther\automation.dat[gle=0x00000002]
    2019-11-02 21:52:18, Error                 SP     CSetupPlatform::ResurrectAutomation: Failed to resurrect automation: 0x80070002[gle=0x00000002]
    2019-11-02 21:53:46, Error                 MOUPG  Finalize: Error obtaining Update and Shutdown Key: [0x80070002][gle=0x000000b7]
    2019-11-02 21:53:49, Error                 SP     CFinalizeCriticalBoundary::DoExecute: Cannot create hardlink betweeen C:\$WINDOWS.~BT\Sources\SetupPlatform.exe and C:\WINDOWS\System32\OOBE\SetupPlatform\SetupPlatform.exe. Error: 0x000000b7[gle=0x000000b7]
    2019-11-02 21:53:49, Error                 SP     CFinalizeCriticalBoundary::DoExecute: Rollback in system context will not be registered.[gle=0x000000b7]
    2019-11-02 21:53:49, Error                 SP     BFSVC: Error copying boot debugging files from C:\$WINDOWS.~BT\Sources\system32 to \\?\GLOBALROOT\Device\HarddiskVolume1\EFI\Microsoft\Boot (kd_*_*.dll). Last Error = 0x6[gle=0x00000006]
    2019-11-02 21:53:49, Error                 SP     BFSVC: Error copying boot debugging files from C:\$WINDOWS.~BT\Sources\system32 to \\?\GLOBALROOT\Device\HarddiskVolume1\EFI\Microsoft\Boot (kdstub.dll). Last Error = 0x6[gle=0x00000006]
    2019-11-02 21:56:12, Error                 MIG    OC Exception: OC::CInstalledOCStore::GetOCCollection: Couldn't get the Foundation package OCs
    2019-11-02 21:56:12, Error                 SP     Could not save OC status. Error: 0x8007001F
    2019-11-02 21:56:12, Error                 SP     Operation failed: Gather Optional Component status. Error: 0x8007001F[gle=0x000000b7]
    2019-11-02 21:56:12, Error                 SP     COperationQueue::Sort: Could not find an execution phase for 46
    2019-11-02 21:56:12, Error                 SP     Operations can no longer be sorted following an attempt to retry a failed operation.
    2019-11-02 21:56:12, Error                 SP     Operation execution failed: 6. hr = 0x8007001F
    2019-11-02 21:56:12, Error                 SP     ExecuteOperations: Failed execution phase Safe OS. Error: 0x8007001F
    2019-11-02 21:56:12, Error                 SP     CSetupPlatformPrivate::Execute: Execution of operations queue failed, abandoning. Error: 0x8007001F


    dimanche 3 novembre 2019 07:35
  • CRC32: 482385F0
    MD5: DEB3E16871B442A3D04A480C3E3DEE4A
    SHA-1: F6DB17937FC862A7AE3095C782523E1360CA333E
    dimanche 3 novembre 2019 09:04
  • Donc, le fichier ISO est conforme.

    Cordialement Aski - Windows Insider MVP - http://dechily.org/Forum_Aski/

    dimanche 3 novembre 2019 09:53
  • Je ne garanti pas que ce soit ça, mais à priori il y a un problème avec un driver

    2019-11-02 21:43:44, Error                 CONX   0xd0000034 Failed to add user mode driver [%SystemRoot%\system32\DRIVERS\UMDF\uicciso.dll]

    Avez vous bien fait une mise à jour complète de votre OS actuel avant d'effectuer la migration ?

    Ce genre de soucis peut parfois se voir dans les fichier compatdata.xml justement ou on a entre balise blockmigration=true


    Merci de marquer comme reponses les interventions qui vous ont ete utile.

    dimanche 3 novembre 2019 22:23
  • Et ben figure toi que gràce à toi j'ai 2 nouveautés :)

    Si j'analyse le compatdata correctement, les 2 imprimantes suivantes seraient en cause :

    The Microsoft Print To PDF install file

    The Microsoft XPS Document Writer install file

    Je vais les désinstaller....


    François

    lundi 4 novembre 2019 21:36
  • Ben...

    la fenêtre listant les fonctionnalités windows reste vide...

    J'ai tenté en desinstallant les imprimantes XPS et PDF => KO

     <DriverPackage Inf="oem77.inf" BlockMigration="True" HasSignedBinaries="False" />
      <DriverPackage Inf="oem76.inf" BlockMigration="True" HasSignedBinaries="False" />

    ça m'a l'air compliqué...


    François

    lundi 4 novembre 2019 23:18
  • Bonjour,

    Vérifie si la fenêtre est également vide en exécutant directement OptionalFeatures.exe

    Vérifie que le service Programme d'installation pour les modules Windows n'est pas désactivé.


    Cordialement Aski - Windows Insider MVP - http://dechily.org/Forum_Aski/

    mardi 5 novembre 2019 07:52
  • OptionalFeatures.exe vide meme en mode admin

    Le service Programme d'installation pour les modules Windows est actif...

    ça sent la reinitialisation....


    François

    samedi 9 novembre 2019 20:47
  • Bonjour,

    Avant d'envisager une installation neuve,

    1. Lance ces deux commandes Dism.exe (sois patient - leur exécution est assez longue)

    • Appuyer simultanément sur les touches Windows et X
    • Sélectionner invite de commandes (admin) ou Microsoft PowerShell (admin)
    • Appuyer sur la touche Entrée après avoir entré chacune de ces commandes (à copier/coller) et attendre qu'elle s'exécute :
       DISM.exe /Online /Cleanup-image /Scanhealth
       DISM.exe /Online /Cleanup-image /Restorehealth


    2. Vérifie le système par SFC /SCANNOW

    • appuyer simultanément sur les touches Windows et X
    • sélectionner Invite de commande (admin) ou Microsoft PowerShell (admin)
    • entrer SFC /SCANNOW et valider
    noter le message en fin de vérification (durée d'environ 15 min)


    Cordialement Aski - Windows Insider MVP - http://dechily.org/Forum_Aski/

    dimanche 10 novembre 2019 07:25
  • JE vais essayer

    Je tiens à te remercier pour tes aides Aski 

    Sincèrement

    François

    ps : 

    Super long le Restorehealth

    Je l'ai lancé et laissé le pc branché, il stagne à 85%

    lundi 11 novembre 2019 16:12
  • Effectue un diagnostic de ton système avec ZHPDiag afin de vérifier son organisation et ses éventuelles corruptions.

    Téléchargement
    http://www.nicolascoolman.fr/download/zhpdiag/
    Tutoriel
    http://www.nicolascoolman.fr/tutoriaux/

    Transmets le fichier ZHPDiag.txt créé par Mon-Partage.fr
    https://mon-partage.fr/


    Cordialement Aski - Windows Insider MVP - http://dechily.org/Forum_Aski/

    lundi 11 novembre 2019 18:01
  • mercredi 13 novembre 2019 22:22
  • Bonjour,

    Télécharge ce fichier
    https://mon-partage.fr/f/JQ1sHYB2/

    Télécharge ZHPFix
    http://www.nicolascoolman.fr/download/zhpfix/

    Redémarre ton PC en mode sans échec avec prise en charge du réseau.
    https://support.microsoft.com/fr-fr/help/12376/windows-10-start-your-pc-in-safe-mode

    Lance ZHPFix par clic droit sur Exécuter en tant qu'administrateur, clique sur Importer, colle les lignes contenues dans le fichier téléchargé, puis clique sur GO.
    http://www.nicolascoolman.fr/tutoriaux/

    Redémarre en mode normal et fais ensuite un nouveau "diagnostic" de contrôle avec ZHPdiag.

    Transmets le nouveau rapport ZHPdiag.txt.


    Cordialement Aski - Windows Insider MVP - http://dechily.org/Forum_Aski/

    jeudi 14 novembre 2019 07:55
  • Bonjour,

    Il semble que la procédure précédente n'ait pas fonctionné.

    Applique-la une nouvelle fois avec le nouveau fichier en la respectant scrupuleusement.

    Nettoie le disque (ne coche pas la case des téléchargements).
    https://support.microsoft.com/fr-fr/help/4026616/windows-10-disk-cleanup

    Télécharge ce fichier
    https://mon-partage.fr/f/74JpfFUB/

    Télécharge ZHPFix
    http://www.nicolascoolman.fr/download/zhpfix/

    Redémarre ton PC en mode sans échec avec prise en charge du réseau.
    https://support.microsoft.com/fr-fr/help/12376/windows-10-start-your-pc-in-safe-mode

    Lance ZHPFix par clic droit sur Exécuter en tant qu'administrateur, clique sur Importer, colle les lignes contenues dans le fichier téléchargé, puis clique sur GO.
    http://www.nicolascoolman.fr/tutoriaux/

    Redémarre en mode normal et fais ensuite un nouveau "diagnostic" de contrôle avec ZHPdiag.

    Transmets le dernier rapport ZHPdiag.txt.


    Cordialement Aski - Windows Insider MVP - http://dechily.org/Forum_Aski/

    vendredi 15 novembre 2019 07:25