none
Changing monitor identities? RRS feed

  • Question

  • Normally I only have my monitor connected to my PC (via DVI), but occasionally I like to enable my TV (via DVI->HDMI adapter) as a secondary monitor to watch films or play games. Weird thing is, whenever I connect my TV, Windows likes to think it's a good idea to reassign my monitor's identity to 2 and assign 1 to my TV. Normally this wouldn't be a big deal, but it means that should I decide to use the Winkey+P shortcut to disable my TV, I have to click "Projector Only". If I click "Computer Only", which would be the logical choice, Windows switches solely to my TV. I've tried swapping the cables, and even hooking up the TV after the computer has booted, and it seems like the moment I hook up the TV, Windows auto-detects the displays and reassigns identities as it sees fit.

    So, my question is: Is there any way to manually reassign monitor identities, be it through a control panel applet or the registry and have them stick, or maybe tell Windows that the monitor named "SAMSUNG" is a friggin' TV or Projector and not my primary display?

    Primary display: Acer AL1916W
    Secondary: Samsung 32" LCD TV
    Video Card: ATI HD4870 X2, Catalyst 9.12

    mercredi 20 janvier 2010 03:26

Toutes les réponses

  • Hi there,

    First of all, have you tried to reassign your Acer AL1916W as primary monitor yet? I think it’s worth a try.

    Option 1: In Display -> Screen Resolution-> Select the Acer AL1916W and select “Make this my main display”
    Option 2: Use ATI catalyst control center. I use a laptop with Nvidia card and it will remember the display order once I arrange the monitor 1&2 in Nvidia Control Panel.

    mercredi 20 janvier 2010 07:47
  • This has nothing to do with which is marked as my main display. Yes, my Acer is marked as my primary display in the Screen Resolution control panel, and it even remains the primary when my TV is hooked up, but that doesn't stop Windows from identifying the Acer as monitor #2. Declaring which monitor is your primary doesn't affect the numbered identity.
    mercredi 20 janvier 2010 12:11
  • Hi,

    Sorry for not clearly enough in my last post. In order to change monitor identity, I suggest you use a tool named ultramon:
    http://www.realtimesoft.com/ultramon/

    You can find the function to change the Monitor ID via Display Settings -> Action -> Change Monitor Number to …

    What’s the result now?

    jeudi 21 janvier 2010 02:12
  • I've got this same problem, and I tried Ultramon. Ultramon itself identifies the monitors correctly, but it doesn't change anything about the way Windows 7 is identifying them. And stuff inside Ultramon still behaves in ways that make it clear that the way Windows 7 thinks about their ID's is how things are (if inside Ultramon you disable secondary displays, my main LCD monitor on the DVI turns off, despite Ultramon considering it my primary #1 display). It's a majorly frustrating problem, and I might add that I didn't have this issue on the release candidate for Windows 7. I've tried everything I can think of to change the actual ID #'s of the monitors, but nothing does it. I haven't tried diving into the registry itself yet, but that's my next step...
    mardi 23 février 2010 00:54
  • Which connector do you have what monitor plugged into?

    For many video cards the BOTTOM (closest to motherboard) connector is considered 1 and the top 2.

    -Noel
    mardi 23 février 2010 03:11
  • Cannot change it in Windows.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    • Proposé comme réponse AK_Griz mardi 11 janvier 2011 16:49
    mardi 11 janvier 2011 09:45
    Modérateur
  • Windows 7 needs fixed to allow monitor identity change. 

    I have 3rd party apps crashing because monitor configurations do not match.  Catalyst and Ultra Monitor works.  Win 7 always shows the TV HDMI connection as monitor 1. 

    mardi 11 janvier 2011 16:57
  • Normally I only have my monitor connected to my PC (via DVI), but occasionally I like to enable my TV (via DVI->HDMI adapter) as a secondary monitor to watch films or play games. Weird thing is, whenever I connect my TV, Windows likes to think it's a good idea to reassign my monitor's identity to 2 and assign 1 to my TV. Normally this wouldn't be a big deal, but it means that should I decide to use the Winkey+P shortcut to disable my TV, I have to click "Projector Only". If I click "Computer Only", which would be the logical choice, Windows switches solely to my TV. I've tried swapping the cables, and even hooking up the TV after the computer has booted, and it seems like the moment I hook up the TV, Windows auto-detects the displays and reassigns identities as it sees fit.

    So, my question is: Is there any way to manually reassign monitor identities, be it through a control panel applet or the registry and have them stick, or maybe tell Windows that the monitor named "SAMSUNG" is a friggin' TV or Projector and not my primary display?

    Primary display: Acer AL1916W
    Secondary: Samsung 32" LCD TV
    Video Card: ATI HD4870 X2, Catalyst 9.12

    I would like an answer to this also.  For me, under change the appearance of displays in Windows 7, my primary monitor is numbered 2 and in Catalyst Control Center for my ati video card it is identified as 1.  Can I change the numbering system in Windows to make them match?  When I disconnect the TV, my computer monitor switches from 2 back to 1 in Change the Appearance of Displays.
    dimanche 23 janvier 2011 21:27
  • Same problem here. Microsoft has apparently no solution for the displays identity issue as far as I know. We have to live with it... unfortunately !
    mardi 25 janvier 2011 01:27
  • Same problem here. Microsoft has apparently no solution for the displays identity issue as far as I know. We have to live with it... unfortunately !

    Does anyone know if the solution outlined in this link works?

    http://social.answers.microsoft.com/Forums/en-US/vistaappearance/thread/1aa0e862-4455-4d6d-bb08-1ed232dd903d

     

    All the best,

     

    David

    mardi 25 janvier 2011 02:38
  • Same problem here. Microsoft has apparently no solution for the displays identity issue as far as I know. We have to live with it... unfortunately !

    Does anyone know if the solution outlined in this link works?

    http://social.answers.microsoft.com/Forums/en-US/vistaappearance/thread/1aa0e862-4455-4d6d-bb08-1ed232dd903d

     

    All the best,

     

    David


    This solution does not work in Windows 7.
    mardi 25 janvier 2011 06:13
  • Same problem here. Microsoft has apparently no solution for the displays identity issue as far as I know. We have to live with it... unfortunately !

    Does anyone know if the solution outlined in this link works?

    http://social.answers.microsoft.com/Forums/en-US/vistaappearance/thread/1aa0e862-4455-4d6d-bb08-1ed232dd903d

     

    All the best,

     

    David


    This solution does not work in Windows 7.
    What if I were to re-install Windows 7 with only the monitor that I want to use as my primary monitor plugged in?  Would this keep my primary monitor as display 1 even after plugging in a new 2nd display?
    mardi 25 janvier 2011 06:26
  • [What if I were to re-install Windows 7 with only the monitor that I want to use as my primary monitor plugged in?  Would this keep my primary monitor as display 1 even after plugging in a new 2nd display?]

    I don't think so. As soon as you plug your second monitor (in my case to the HDMI output), it will be labeled display #1. I don't know if this is a Windows 7 or a video card problem although poeple reporting this problem have a wide variety of video cards.

    • Proposé comme réponse Sir_JOHN2020 mardi 16 janvier 2018 10:57
    mardi 25 janvier 2011 13:50
  • Here is what I did...

    Go into the Screen Resolution Settings.

    Click Advanced Settings.

    Go to your Graphics and Media Control Panel and assign your multiple displays from there!

    I'm on a Dell laptop using an Acer Monitor as my secondary monitor and have an Intel Graphics card.

    Hopefully that helps!

     

    • Proposé comme réponse Paul_Smith jeudi 26 avril 2012 10:07
    jeudi 10 mars 2011 15:07
  • I have the same issue on my new HTPC. As soon as I turn TV on it becomes #1 and ruins all my settings. Tried all ideas above but without any success. Would be nice to get answer from Microsoft on that.
    lundi 12 septembre 2011 02:30
  • I have just upgraded my PC and i was on Vista with my 40" Lcd tv duplicated and windows 7 will not let me change priority on Vista you just grabbed the screen and move it and it change it to 1 or 2 one being the one on the left 

    Now its two and you carn't move it 

    When my computer re boots i see nothing until my desktop comes on so i have no idea what happening unless i put my 40" TV on 

    When its on duplicate my pc's Monitor needs to be number one the setting for priority is pointless anymberd should change my PC's Monitor to number one 

    This seems to be a problem Nvidea say  its a windows problem 

    so when is this going to get sorted 

    jeudi 13 octobre 2011 14:41
  • Gee, I just checked my ATI Catalyst drivers and the monitor identites can be easily swapped.

    Maybe you just need a new video card from a company with smarter video driver developers.

    -Noel


    jeudi 13 octobre 2011 15:28
  • I have a new HP Z600 workstation.  One monitor plugged into the DVI (labelled 1 of 2 in the Nvidia control panel), another monitor in one of the DisplayPorts (using a DVI adapter).  The 2nd is labelled 2 of 2 in the Nvidia control panel.

    However, Win7 insists that the monitor that Nvidia says is 1 of 2 is "2" and the one marked 2 of 2 is "1".

    The monitor marked "1 of 2" by Nvidia is where the BIOS/boot screen is.

    I went into the display control panel and made "2" as my primary monitor to Windows (the one labelled "1 of 2" by the nvidia driver).

    When I boot, SOMETIMES the "hit control-alt-del" is on Windows 1 (ndivia "2 of 2") and sometimes it is on Windows 2 (nvidia "1 of 2").  And of course, all my desktop icons get reshuffled just about everytime.  something certainly is confused...

    jeudi 13 octobre 2011 16:14
  • well my card is a Nvidia gtx550 and i have tried every way to sort my problem out its picing the larger display every time as the Number 1 i have just tried on My Visa machine and grabing the screen and moving the screens so my small one is on the left changes (On vista( to the main and number one 
    On windows 7 it doesn't. we should have the freedom to change things around just like vista but this on 7 is rubbish  
    vendredi 14 octobre 2011 15:16
  • we should have the freedom to change things around just like vista

    Have you made that known to nVidia?

    For that matter, have you looked to make sure you have the latest display driver from nVidia.com?  Maybe they've already fixed it.

    -Noel

    vendredi 14 octobre 2011 15:22
  • The attached image shows windows 'screen resolution' identifies the number 1 display differently to CCC's display properties. This bug has been evident from Vista to the now installed window 7 32 bit. The BenQ is connected via the ATI card DVI port and is the desired main display. The problem being, when the 2nd display, connected via HDMI directly from the ATI card to TV or Receiver, is turned off the Desktop is lost and the HDMI cable needs to be unplugged to get it back. Can anyone please offer a fix to this very annoying problem. All drivers are up to date.


    EDIT: I have also tried a 2nd ATI graphics card which had the same issue.
    • Modifié drohm68 jeudi 27 octobre 2011 06:24
    jeudi 27 octobre 2011 06:23
  • Yep, I'm having the same issue with an even more annoying twist. Since my primary is defaulting to my HDTV through HDMI and my monitor is changing to "display 2" through DVI, every time I turn off my HDTV it shuts my computer monitor off as well. So I can't use my computer monitor unless my HDTV is constantly on if I have them both plugged in. I can turn my COMPUTER MONITOR off and my TV will still display my desktop, but if I set my monitor as primary and move the desktop (EVEN IF I DISABLE THE HDTV DISPLAY!) and then turn off my HDTV, my computer monitor turns off. I've seriously tried everything I can think of short of purchasing a KVM switch, which I don't want to do. Right now I have to keep unplugging the HDMI cable running to my TV from my computer to be able to turn off my TV without my monitor going to sleep. It's like windows 7 won't divert my display source back to DVI. I've tried changing sources in my monitor as well and that hasn't worked either.
    dimanche 5 février 2012 06:53
  • I just had that problem after dragging IE  to my HD  LCD display to watch some late night TV.

    This leads me to think the problem is not with Windows 7 itself but with Internet Explorer 9. This is because Windows 7 correctly identifies the displays but still IE9 wants to go to the wrong display.
     
    How I fixed the problem.

    I want my 19" LaCie CRT to be the main display. So I figured I had to trick Windows and IE9. I unplugged the power from the HD LCD display as well as the HDMI cables. It's been my experience that the Win7 still "sees" the LCD even when the power is unplugged but the HDMI cables are still connected.
     
    Then I rebooted Windows 7 into Safe Mode. Of course since only the CRT was operating that's where Safe Mode came up. There was no reason to run the "Identify Display" routine since there was only one display connected to the PC, but you can if you like to wear both belt and suspenders.
       
    Shut down the computer. Plug in the HD LCD's power cable and the HDMI cables. Reboot.
     
    What was interesting was to watch what came up on which display when during POST. At first the HD LCD got the initial signal but somewhere along the way the correct displays were identified and I only saw the login password on my CRT. YAY!!
     
    So, Microsoft, take a look at fixing IE9, not Windows 7.
       
    Terry Thomas
    President
    PC Tech Support
    Atlanta, Georgia USA


    mardi 21 février 2012 08:53
  • Former PC Setup

    HP Elite Desktop PC

    Windows XP

    AMD Radeon HD 5550 Video Card with settings for dual display on:

    • DVI-out to 28" PC monitor
    • HDMI-out to AV Receiver to 60" plasma TV

    The DVI PC monitor is my primary monitor, and I loved the ability click a button on my AV receiver to also see the display on the large plasma.

    New PC Setup

    HP Elite Desktop PC

    Windows 7 Professional 64-bit SP1

    AMD Radeon HD 6450 Video Card with settings for dual display via:

    • DVI-out to 28" PC monitor
    • HDMI-out to AV Receiver to 60" plasma TV

    The DVI PC monitor remains my primary monitor.  I am able to view the display on both my PC monitor & my plasma TV when the plasma TV power is on.  The problem is that as soon as I turn my plasma TV off, the display on the PC monitor also goes away, seemingly to an extended desktop view with the PC monitor showing the inactive extended display screen.  As soon as I turn the plasma TV back on, then everything is back to normal with dual display on both.

    The reason why I am posting in this thread is that Windows 7 labels the infrequently-used-plasma-TV as Monitor 1 and the always-used-PC-monitor as Monitor 2.  My theory is that when I turn the plasma off, Windows 7 thinks it is doing the right thing by setting Monitor 2 as the extended display monitor.  Is there any way I can force Windows 7 to always recognize my DVI-out-PC-monitor as Monitor 1?

    If not, is there some workaround until Windows 7 releases a fix?  Perhaps plugging in the HDMI-out cable to some "switch"?  Perhaps not using my HDMI-split and instead splitting my DVI-out into 2 DVI-out -- the first DVI-out to my PC monitor and the second DVI-out via a HDMI-adapter to my AV receiver?

    For now, I have just left the HDMI-out cable unplugged, so that I can use my PC monitor without the TV power being on.



    • Modifié ColinLA mardi 13 mars 2012 02:11
    mardi 13 mars 2012 02:07
  • ColinLA, have you been through the settings afforded to you in the Catalyst Control Center?

    I haven't fooled with changing things around there myself, but it sure looks as though the monitors can be renumbered in the Desktop Management section.

     

    -Noel


    Detailed how-to in my eBook:  
    In development:

    Configure The Windows 7 "To Work" Options
    Configure The Windows 8 "To Work" Options

    mardi 13 mars 2012 03:14
  • Former PC Setup

    HP Elite Desktop PC

    Windows XP

    AMD Radeon HD 5550 Video Card with settings for dual display on:

    • DVI-out to 28" PC monitor
    • HDMI-out to AV Receiver to 60" plasma TV

    The DVI PC monitor is my primary monitor, and I loved the ability click a button on my AV receiver to also see the display on the large plasma.

    New PC Setup

    HP Elite Desktop PC

    Windows 7 Professional 64-bit SP1

    AMD Radeon HD 6450 Video Card with settings for dual display via:

    • DVI-out to 28" PC monitor
    • HDMI-out to AV Receiver to 60" plasma TV

    The DVI PC monitor remains my primary monitor.  I am able to view the display on both my PC monitor & my plasma TV when the plasma TV power is on.  The problem is that as soon as I turn my plasma TV off, the display on the PC monitor also goes away, seemingly to an extended desktop view with the PC monitor showing the inactive extended display screen.  As soon as I turn the plasma TV back on, then everything is back to normal with dual display on both.

    The reason why I am posting in this thread is that Windows 7 labels the infrequently-used-plasma-TV as Monitor 1 and the always-used-PC-monitor as Monitor 2.  My theory is that when I turn the plasma off, Windows 7 thinks it is doing the right thing by setting Monitor 2 as the extended display monitor.  Is there any way I can force Windows 7 to always recognize my DVI-out-PC-monitor as Monitor 1?

    If not, is there some workaround until Windows 7 releases a fix?  Perhaps plugging in the HDMI-out cable to some "switch"?  Perhaps not using my HDMI-split and instead splitting my DVI-out into 2 DVI-out -- the first DVI-out to my PC monitor and the second DVI-out via a HDMI-adapter to my AV receiver?

    For now, I have just left the HDMI-out cable unplugged, so that I can use my PC monitor without the TV power being on.




    I have now resolved my problem and my setup is the same as it was with my Windows XP computer.  The problem was that when I powered-off my 60" plasma, Windows 7 was automatically flipping the Screen Resolution - Multiple Displays setting from Duplicate These Displays to Extend These Displays with the 28" PC monitor as the non-main, extended display.  Through my ignorance of using Windows Key + Shift + R/L Arrows, I was unable to get back into Screen Resolution settings.  Once I learned about Windows Key + Shift + R/L Arrows, I shifted the display to the PC monitor, adjusted the settings in Screen Resolution to Duplicate These Displays (with the 60" plasma off) and saved.  Several reboots laters, the settings have stuck.  My PC is now always (as intended) in Duplicate These Displays mode and the single screen is always displayed to either or both 60" plasma and 28" monitor whenever the plasma/monitor is powered on.
    • Proposé comme réponse Wayne Hewitt mardi 5 juin 2012 02:45
    dimanche 18 mars 2012 17:43
  • I have a related issue in that I have a Dell XPS running Win 7 x64 and Chrome.  It has an NVIDIA card.  I run three displays; the laptop, a 24" landscape off the HDMI and a 24" portrait off a Kensington Docking station which in turn runs off the laptop USB.  Windows 'Screen Resolution' numbers the laptop as '1' and the two 24" as '2' and '3'.  I set '2' as the main screen.  Nvidia recognizes only '2' (the HDMI monitor) but calls it '1'.  It also identifies the laptop as '1' (as if it were duplicated) and it identifies the other 24" as '7'

    The issue is that when I take the laptop standalone it collapses '1', '2' and '3' all back to the laptop and will not recover the proper screens when I later plug it back in.  It also loses track of the correct screens to restore gadgets and windows explorer too after being in sleep.  This all used top work well and behave but after a hard drive failure and rebuild (with I thought all the same software) this stuff has started to happen.

    I have not yet found a solution but I have run across a bandaid that may help some of you.  Check out 'Desktop Restore' by Jaimie O'Oconnell.  It allows you to save multiple icon layouts for multiple screen configurations.  If you use its 'save to file' option you can name the datafile.  It does not do gadgets and windows but I have found what it does do to be very valuable to how I do work.  

     

     
    mardi 5 juin 2012 03:02
  • I have two monitors what should be monitor 1 is a Samsung 1920x1080 and what should be monitor 2 is a Samsung 1440x900.  I have tried all of the above fixs, none worked.  I want monitor 1 to be the Samsun 1920x1080 and monitor 2 to be the 1440x900 Samsung.  My video card drivers have the monitors properly identified, just like the screen shot that drohm68 posted (above).  I had this happen before and I was able to correct it using Catalyst 11.11b, but for some reason Windows7 is just not accepting the change.

    Primary Display: Samsung SA300 1920x1080

    Secondary Display: Samsung Syncmaster 940BW

    Video Card: ATI HD6950 2GB

    Driver: Catalyst 12.6 Beta (I have tried every driver from 11.9 up this time to no avail)

    samedi 23 juin 2012 00:31
  • Has anyone solved that annoying issue yet ?

    It's driving me nutzzzz.....

    My TV when on is ALWAYS nr 1, no matter if i set my LCD monitor as a primary or use Ultramon to swap IDs

    Also when pressing Windows+P my LCD is on the "Projector Only" position and my TV is on the "Computer Only"

    Please, anyone ?

      

    Specs:

    Windows 7 Home Premium x64

    Nvidia 560ti

    LCD ACER x243w - DVI1 port

    TV LG - DVI2 port

      

    p.s. I even bought a dvi to hdmi adapter to use only DVI ports hoping to solve the problem, unfortunately it's the same. No matter how i physicaly connect the displays TV is always nr 1



    • Modifié Oomek mardi 25 septembre 2012 15:42
    mardi 25 septembre 2012 15:37
  • Hi,


    I've got the same issue, and tried "all" the fixes with no effect. In despair I tried the following hotfix, but it didn't solve the issue. So that's tested then:

    http://support.microsoft.com/kb/2581613


    My setup is as follows:

    Asus GeForce GTX 570, Nvidia driver: 306.23

    DVI connector (Monitor 2, win P projector -> wrong) BenQ G2411HD

    HDMI connector (Monitor 1, win P computer only -> wrong), Samsung LED TV

    In NvCP the BenQ changes from Monitor 1 to Monitor 2 when the LED TV is connected with HDMI. Monitor 2 is still my primary display, but with Win P I need to use "Projector only" to get the picture on the BenQ. With "Computer Only" the LED TV is active and the BenQ is black.

    -Martin
    mardi 9 octobre 2012 21:43
  • With an Catalyst Control Panel you can disable a display. Then under Common Display Task on the left menu tab you will find "Exchange Display" Choose a monitor and it will trade places with the number/Identity. Enable the monitor and see how it lines up. I had work through this scenario a few times. Half way through the exercise I rebooted because I was having a hard time lining them up. I finally was able to match Windows display with ATI numbering. Good Luck

    Stanomatic


    Stanomatic

    • Proposé comme réponse Stanomatic samedi 13 octobre 2012 03:27
    samedi 13 octobre 2012 03:27
  • Has anyone solved that annoying issue yet ?

    It's driving me nutzzzz.....

    My TV when on is ALWAYS nr 1, no matter if i set my LCD monitor as a primary or use Ultramon to swap IDs

    Also when pressing Windows+P my LCD is on the "Projector Only" position and my TV is on the "Computer Only"

    Please, anyone ?

      

    Specs:

    Windows 7 Home Premium x64

    Nvidia 560ti

    LCD ACER x243w - DVI1 port

    TV LG - DVI2 port

      

    p.s. I even bought a dvi to hdmi adapter to use only DVI ports hoping to solve the problem, unfortunately it's the same. No matter how i physicaly connect the displays TV is always nr 1



    I have a Philips display and a Sony TV-display which I tried different setting for to find the best setting. I tried clonings of screens.

    Suddenly  the Sony TV got the identy 1 and my Philips got the identy 2 which caused problems.

    I have a NVIDIA Geforce 9300 GE card.

    Sleeping on the problems I found a solution. 

    In short I made it this way:

    Start: Philip screen with identy 2 and the Sony screen with identity 1

    1 I cloned my Philips screen to the Sony screen. I then got identy 2a for the Philip screen and 2 b for the Sony screen.

    2 Unchecked the Sony screen on my Philips. ( I do not know if this is required)

    3 I went to the Sony screen and cloned the Sony screen to the Philips. I then  got identity 1a for the Sony and 1b for the Philips.

    4 Unchecked the Sony screen on the Philip screen. Now the Philip screen has the identity 1

    5 Klick "Apply" Now I was back to normal. A real feel of satisfaction!!

    Regards

    lundi 29 octobre 2012 09:43
  • Sleeping on the problems I found a solution. 

    It's unclear where you made these settings. They don't correspond to what you can do in the windows settings, it seems. And neither does the Nvidia panel show something like 2a or 2b.

    I have the same problem with Windows 8. It's only slightly annoying. My TV is my 1st display. Now when I switch it via the charms bar (the only use I could find for that eyesore) it tells my I have a 2nd screen. But the 2nd screen is actually my everyday monitor. Windows 8 calls the 1st screen the "PC screen". Yep, makes no sense.

    But it's not only a minor annoyance, it should be called a bug. The problem was that when I installed W8 I got a black screen with a white mouse pointer. Nothing was happening. I had to go online to find a solution. It turns out, that the setup didn't crash, but W8 was all the time showing the post-installation setup screen on my TV, which was plugged in but off all the time. That's a very stupid design.

    mercredi 31 octobre 2012 23:58
  • I am running Vista.

    All settings for shared screens are made in NVIDIA window.

    I can chose between following alternatives by right hand click:
    1 Make this the Window primary screen.
    2 Extend desktop on this display
    3 Clone displays (use Philip as primary clone)
    4 Clone displays (use Sony as primary clone)

    After cloning identity, 1a and 1b or 2a and 2b appears in the NVIDIA window.

    Regards

    jeudi 1 novembre 2012 15:43
  • I am having the same annoying issue on Windows 8 Pro. Window does not identify the monitors correctly. 

    My Setup:

    HP 25 inch monitor connected through DVI; My main display, currently marked as (2)

    A 42 inch HDTV connected through HDMI; My second display, currently marked as (1)

    HD Radon 7450 - Drivers and Catalyst Control Center are completely up to date. (CCC correctly identifies the displays)

    The Problem:

    I would like my HP monitor to be set to (1) so that when I use "Windows Key + P" I can select computer only and use my HP monitor. Currently I have to select Second Screen Only to see anything. My HDTV is set as (2) and using "Windows Key + P" I must select PC Screen Only to use my TV. This make zero sense in my mind and there is no option to switch the identity of the monitors in Windows OS. Catalyst Control Center works perfectly but has no control over how Windows itself sees the displays.

    This appears to have been a problem from Windows XP, to Vista, to Windows 7, and now Windows 8. I have found multiple threads on the issue, several user suggested solutions, but not one answer that works. How many OS versions must we wait for a fix, Microsoft? Anyone have a different possible solution?

    I have tried every option though screen resolution, uninstalling monitors and re-plugging them in a certain order, regedit found in one of the links below, and a couple of other options.

    Links:

    http://social.technet.microsoft.com/Forums/en-US/w7itprohardware/thread/f7cb8b78-2920-4334-a29a-85498726f4bb

    http://social.technet.microsoft.com/Forums/en/w7itproui/thread/f9e088f5-5449-4ae6-97a3-92a972d3e1c6

    samedi 16 février 2013 01:28
  • I am a mobile VJ that runs 2 6 port video cards in my media server.  This issue causes me more MS (tm) heartache than any other.   As I roll into a new venue, fire up the box and start plugging in, my main desktop flies all over the various outputs.  Getting it back is virtually impossible at times.  God forbid I need a reboot in the middle of the show.

    Has anyone ever received a MS response for this one?

    Anyone?

    dimanche 4 août 2013 22:26
  • any news??? any solutions how to change identities??? I dont want to see 2. screen as my primary or see my secondary on booting.
    dimanche 11 août 2013 17:46
  • This is not an answer, and please do not mark it as such, it is only a clue, and only for those that could further understand it.  I have solutioned this problem (for ME) in XP, and now solutioned it in windows7. But for me it is rather simple, because I can switch DVI cables, it also is a total pain and a guessing game.  (there is probably a better way).

    Once a monitor gets enumerated, it is basically there to stay. this location in the registry for the monitor enumerations is here:  HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\DISPLAY .
    In XP you would hop into the registry as admin, toss out all the Monitors in there. Then "enum" one at a time on reboot , by having only certian cables connected.  This allowed me to reset the enumerations of the 2 monitors as I saw fit.

    In windows 7, I cannot even seem to set the permissions for these as an admin, and it went something like this instead:

    Previously have made the hidden devices tweak (unknown if this is nessiary) 

    Run Msconfig , set to boot into safe mode.

    Boot into safe mode (probably as a real admin)

    Get into the Device manager

    Uninstall (delete) all the monitors in the device manager. (notice I didn't have to, nor could delete in the registry) Notes: they are hidden because in safe they are not used yet, at the least in View show hidden devices .

    You are now done in the safe admin, before rebooting and re-enumerating those do something to change that enumeration of the monitors?? 

    To exit safe mode, run Msconfig again, and de-select safe mode, and return to normal mode.

    Set your cables right ??  how i dont know, all your systems are different, this could mean switching cables, it could mean having the primary connected, it could mean having one of the secondaries connected only.  Whatever you have cabled up will be what gets tossed back into these enumerations for it and stick.

    Again, this only works for me, it uses the logic that the system uses to lock those things in place, but I guarentee this is not going to be a Fix in itself, and for many you will be right back where you started again when it re-enumerates the exact same way.

    This post can seem cryptic to some, there is nothing I will do to fix that, there is no magic button , some understanding of messing with the system is required.  If more people in the know , test it more ways, they may be able to provide better information.

    Other notes:  This does not work in the device manager when uninstalling there in the active system (waste of time). back in XP I had already known that it didn't change. back in XP it Had To be removed from the registry itself, or it was still the same way as it was.  I can only assume that by removing it in admin safe in win7 that it is, because it changed.  I would have preferred to have just removed it at the registry, where I can see.



    • Modifié psycogeec vendredi 11 octobre 2013 01:41
    vendredi 11 octobre 2013 01:22
  • Probably no longer need to know but here is a solution that worked for me:

    1. Set up multiple display in NVIDIA - then had the problem of my laptop screen being designated as 2 instead of screen 1
    2. Save settings and quit NVIDIA and enter normal windows screen properties (in Windows 7, it is right click on Desktop and click on screen resolution). Once there you can drag and drop screens in the order you want!

    Hope it helps for anyone else who experiences the same problem

    jeudi 12 décembre 2013 11:16
  • For what it's worth, the saga continues...  I have two identical monitors I run full-time on a desktop system.  They're plugged into a single ATI 7850 card.

    When I installed Windows 8.1 as a full clean setup (not an upgrade) the monitors ended up reversed from what Windows 7 had set up.  I had to use ATI Catalyst to swap them.  Now the monitor connected via the Mini DisplayPort jack is considered "1", while the DVI-connected one is "2". 

    I have no idea why Windows 8.1 should have enumerated them in a different order than Windows 7.

     

     

    Sure, I could have just swapped the cables, but then the calibrations I had set up (XML files I oorted in from my Windows 7 system backup) would have to have been redone so I figured I'd see whether just swapping the displays as shown above would work.  So far there doesn't seem to be much of any downside - everything seems to work, though I've noticed some parts of PassMark PerformanceTest now do their test the right monitor instead of the left one.

      

    -Noel


    Detailed how-to in my eBooks:  

    Configure The Windows 7 "To Work" Options
    Configure The Windows 8 "To Work" Options

    jeudi 12 décembre 2013 15:26
  • No. I originally installed Windows with only the monitor connected. As soon as I plugged in my A/V receiver to the HDMI output, that became "Display 1." I'm having the same problem. I don't see why Microsoft doesn't fix this. The assignment of "Display 1" and "Display 2" doesn't seem to by under the user's control, so the "Main Display" should be considered the one that corresponds to "Computer" when Win+P is pressed, or an option should be provided to configure which display is which in the Win+P menu.
    dimanche 9 février 2014 05:13
  • Longer term follow-up...

    I ended up with just enough little niggling issues that I finally decided to physically swap my monitors, then I undid the reversal that I had commanded with ATI Catalyst at the end of 2013.  Now that the Windows monitor enumeration matches ATI and matches my actual usage (1 on left, 2 on right) everything works fine.

    It's like most everything Microsoft does.  99% done, so that it LOOKS like it works, but not quite perfect so that you can't actually USE it that way.

    Mediocrity is the enemy of Microsoft's continuing existence!  You folks need to re-embrace excellence.

      

    -Noel


    Detailed how-to in my eBooks:  

    Configure The Windows 7 "To Work" Options
    Configure The Windows 8 "To Work" Options

    dimanche 9 février 2014 17:37
  • 1. In regedit, delete the following keys:

    HKLM\Systems\CurrentControlSet\Control\GraphicsDrivers\Configuration
    HKLM\Systems\CurrentControlSet\Control\GraphicsDrivers\Connectivity

    2. Disconnect all your monitors excepts the one you want to be display 1.

    3. Reboot

    4. Connect your remaining monitors in the order you want Windows to see them.

    mercredi 12 février 2014 20:41
  • Just tried, didn't work the slightest.
    jeudi 20 mars 2014 08:00
  • This does not work.
    • Proposé comme réponse pellson mercredi 11 juin 2014 07:14
    • Non proposé comme réponse pellson mercredi 11 juin 2014 07:14
    samedi 31 mai 2014 23:40
  • This does not work.
    I have found a solution, finally! I registered here just to help you out :) This thing has been bugging me for so long!

    1. Download ToastyX Custom Resolution Utility. http://www.monitortests.com/cru-1.1.2.zip

    2. Unplug your TV/Secondary monitor that is identified as #1, so that your main display gets the #1 and is the only thing connected to the computer.

    3. Start ToastyX Custom Resolution Utility and choose your TV in the dropdownlist, and in the top right click "Delete.", now its gonna delete all the info from your TV-display the next time you reboot, press OK in the bottom. 

    4. Reboot your computer.

    5. NOW, plug in your TV/Secondary monitor and it will reconfigure and stay at #2!
    mercredi 11 juin 2014 07:19
  • The above solution still doesn't work
    vendredi 8 août 2014 20:33
  • The assignment of the identification numbers isn't permanent, but rather happens when windows initiates its drivers or whatever when it boots.

    I have found that if i have both my Dell monitor and Sony TV plugged in to the graphics card (Dell on DVI port 1, TV on DVI port 2) while windows boots up, the numbering will always become 1. SONY TV and 2. DELL MONITOR.

    The only way to change that is to unplug my TV from the graphics card, restart the computer and let windows boot up. After that i can plug the TV back in and it gets assigned the identification number 2, all as it should be! But as long as the TV is plugged in the next time my computer is booting up, the identification numbers will always become as mentioned above (1. SONY TV and 2. DELL MONITOR).

    Why it picks the TV as number 1 is beyond me.


    • Modifié BustaMime jeudi 11 septembre 2014 17:27
    jeudi 11 septembre 2014 17:15
  • Does it matter whether you swap the DVI cables in that case (in other words, run the Dell on DVI port 2, TV on DVI port 1)?

       

    -Noel


    Detailed how-to in my eBooks:  

    Configure The Windows 7 "To Work" Options
    Configure The Windows 8 "To Work" Options

    vendredi 12 septembre 2014 01:16

  • When both displays are connected in reverse (Sony TV to DVI port 1 and Dell to DVI port 2) the identification numbers always remain 1. SONY TV and 2. DELL MONITOR.

    lundi 27 octobre 2014 13:36
  • I have the same problem. If the setting is to display the desktop only on one monitor, then after sleep the desktop is displayed only on monitor #1 (even if the setting was to display it on monitor #2). That is the desktop is only on the TV. Since the TV is in another room, I have to make a hard reboot (or unplug the HDMI cable) every time after sleep. This is regardless what monitor is "main".

    If to set the monitors to the "double" mode, then the TV limits the max resolution I can set up on my computer display (it has greater native resolution), even if the TV is disabled in Program Manager! This is weird!



    • Modifié Anixxus vendredi 7 novembre 2014 10:22
    • Proposé comme réponse ladybuglet jeudi 20 novembre 2014 16:12
    • Non proposé comme réponse ladybuglet jeudi 20 novembre 2014 16:12
    vendredi 7 novembre 2014 10:21
  • From Control Panel, open the Display option.

    Grab one of the monitor icons and drag and drop it to the desired left/right location to re-assign monitor numbers.

    jeudi 20 novembre 2014 16:29
  • I know this is old but I found this thread when I was searching for my similar problem. The smart HDMI setting on TV's, blu-ray players, messes with your setup. I have my computer running through a receiver and then to my tv but in my setup I also have a blu-ray player ran to the receiver and in the setting for my blu-ray player there is a smart HDMI option the turns on the blu-ray player when a tv is turned on and turning that off got my setup working correctly. Before turning off the tv or the receiver made my windows automatically swap from duplicated to extended and changed the identification and it was all because of the smart HDMI on one of my devices, my Blu-ray player. So if your having issues with screens taking over look at the hdmi settings for all of your device and turn off any settings that allow the device to sense HDMI connections automatically.
    • Modifié bertrenolds vendredi 12 décembre 2014 19:57
    vendredi 12 décembre 2014 19:54
  • Some hints for the next person (probably me in 3 months) person to have troubles with this (Windows 8.1):

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\GraphicsDrivers\Connectivity

    That key contains information about each of the various sets of monitors that can be plugged in.  In my case, I have 3 monitors, 1 TV and a laptop screen.  This yields many possible combinations and each particular combination is listed.  The format is A^B^C^unknown where A, B and C each reference a certain monitor.  I could have A^B, A^B^C, A^B^D, A^C^D, etc.  I am uncertain what the last item is, possibly a hash of some kind?

    The first thing to figure out is which set of monitors you have connected.  In my case, I deleted all of my monitors except the laptop monitor from device manager (show hidden devices to see them when they aren't plugged in) and then plugged them in one at a time, refreshing that registry key to see what was added.  This would let me identify what the ID was for each of my monitors.

    If you look at any of those keys you'll see they have several values.  The interesting ones for me were eXtend and External which has something like A+B+C^unknown.  The data in these values cooresponds to the key right above Connectivity at:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\GraphicsDrivers\Configuration

    In there you will find all previous monitor arrangements.

    In the first set of keys (Connectivity) the monitors were "sorted" in the key name.  You may see A^B^C but you would never see C^B^A or B^A^C.  I believe this is so Windows can identify a set of monitors regardless of what order you plugged them in.  In the second set of keys (Configuration) however, the order has meaning.  It appears that the first item in the key name is monitor #1, the second is #2 and so on.  This means that A+B+C is different from A+C+B.  In the first case, B is monitor #2 and in the second case B is monitor #3.

    Inside of each of the Configuration keys you will find several numbers.  These numbers are a 0-index into the monitor IDs in the key name.  In the example of A+B+C, A is 00, B is 01, C is 02.  Inside those keys is information about the monitor settings.  This includes resolution, color, refresh rate, and relative position around the primary monitor.  Note, the primary monitor is the monitor at position (0,0), not necessarily monitor ID 1!

    All of this information is not particularly useful however because I don't know what that "unknown" value is at the end of the key names.  I haven't tried changing the key names yet, but I am guessing that without knowing how to generate that last value I am guessing stuff won't work correctly.  I was able to manually change the position of my monitors via registry safely, along with the refresh rate (which was one of my problems).

    Tomorrow perhaps I'll give changing the key names a try and see what happens.  If lucky, the last piece of the key name doesn't need to be changed if you are just re-ordering them.  In my case, I would like my monitor 1 to be the monitor that sits at position (0,0) (primary) but I suppose that is actually not terribly meaningful for my use case.  For many hear however, that is the holy grail to solving this problem.

    mardi 27 janvier 2015 07:03
  • According to this, you can safely delete the entire Configuration and Connectivity keys and restart (with monitors unplugged) and then plug them in one at a time to get them added in the right order:

    http://www.dell.com/support/article/us/en/19/SLN137488/EN

    Unfortunately for me, this didn't work out since my laptop can only power 3 of the monitors at a time, though now that I understand how things work a little more I may be able to get around that.

    • Proposé comme réponse MagicTH64 mardi 23 mai 2017 15:15
    mardi 27 janvier 2015 07:06
  • Turns out, that "unknown" chunk is an MD5 of the rest of the string.  Creating your own sets should be pretty easy, just copy an existing one, re-arrange the ordering, calculate the MD5 (e.g., http://www.miraclesalad.com/webtools/md5.php) edit the name, reference it from the appropriate item in Connectivity and you are done.  Piece of cake.  ;)
    mardi 27 janvier 2015 07:17
  • According to this, you can safely delete the entire Configuration and Connectivity keys and restart (with monitors unplugged) and then plug them in one at a time to get them added in the right order:

    http://www.dell.com/support/article/us/en/19/SLN137488/EN

    Unfortunately for me, this didn't work out since my laptop can only power 3 of the monitors at a time, though now that I understand how things work a little more I may be able to get around that.

    The steps on this article solved my issue with wrong monitor order, thanks.
    samedi 7 février 2015 03:27
  • Sadly I've still got the same problem. I've tried twice now, but my TV is still #1. Perhaps it only works with computer monitors. Man I hope this is fixed in Windows 10.
    mardi 16 juin 2015 08:16
  • I have a similar but perhaps odder problem. My Windows 8.1 thinks my #1 is a Sony TV and my #2 is a Dell monitor, but when I use the Identify, I see that 1 on my Dell and 2 on my Sony.  Presently, it's set up right but the kinds of monitors these number 1 and 2's are are swapped. I removed the Sony TV and rebooted and everything seemed right. Dell monitor is a Dell monitor and is #1. But when I plugged the TV back in (HDMI), my one open window (notepad) moved over to the Sony. A look in Screen Resolution gave me the following image (I have to just describe it as this place won't let me put in a picture until my account is "verified". Note, that my Dell is really #1 and main, but it says it is a Sony. My TV is really #2 and says it's a Dell. And it gets really annoying.  Everytime I open a program, it opens over on the Sony TV even though I'm sitting in front of the Dell, the main display. It also moved all my Desktop shortcuts to the Sony TV (Identifies as #2 but labelled Dell monitor).

    dimanche 5 juillet 2015 18:06
  • I have this same problem.  It is identifying them in reverse.
    mercredi 15 juillet 2015 20:43
  • I have the same problem as the OP.

    Its been 5 years, is there still no solution?

    vendredi 31 juillet 2015 10:15
  • You'd think they would have developed a fix for this by now.

    @microsoft   my HDMI TV is not my computer!  please allow me to switch my Dell monitor ran through dvi as my #1 display!  

    samedi 1 août 2015 17:44
  • And the problem still exists with Windows 10. I spent hours talking with both nVidia and Microsoft, and they each point the finger at the other person, neither party taking the blame and saying we have to live with it.

    Hatessunlight

    dimanche 2 août 2015 19:06
  • Yeah, I've been chatting today with the new support, and they told me to call Samsung because I've got a SyncMaster and a led tv.
    vendredi 7 août 2015 14:06
  • I have been having the same issues after i upgraded from AMD to Intel CPU, whilst keeping the X280 amd grapics card. I never got it to work.. Trying almost everything suggest in this thread. Every time i switched off the TV it would also disable my PC monitor.

    After months just pulling out the HDMI cable from the PC... I thought i'd try things again. The issues seems to be on the communicatino between all the HDMI devices and Windows. However, somehow i got it to work now. I can turn off the TV and my main monitor flickers a bit, but stays on. Only thing i changed was disabling the EDID setting under "VGA monitor properties" in catalyst control center. At first it would change my desktop resolution to basic (like 800x600), but after manually setting the resolution to 1080 it stays on that. Even after switching on/of receiver/TV etc.

    Perhaps this is merely a workaround and not a true fix. But hopefully this helps others too. 

    Regards,

    J4ck

    • Proposé comme réponse putserw jeudi 20 août 2015 10:46
    • Non proposé comme réponse putserw jeudi 20 août 2015 10:46
    dimanche 16 août 2015 14:02
  • I had exactly the same issue on my desktop computer.  First identifying my monitor as display 1 but becomes display 2 as soon as my HDTV is connected (in WI10 display settings).  My ATI catalyst settings are correct though.

    Switching off my HDTV messed up my monitor screen (no icons - programs opening invisible on my monitor - ...)

    I was able to fix this issue as follows ...

    I turned off my HDTV which resulted as above.  Then moved my cursor to my monitor screen & right-clicked the desktop to get access to the display settings.  The display settings panel opens ... on my turned off HDTV, so invisible.  I moved this panel to my monitor with keys combination [[shift]-[windows key]-[right arrow]].

    On the now visible display settings panel I re-identified my main display, being the monitor.  Everything was set to normal.  Then I turned the HDTV back on.  The HDTV remains display #1 and the monitor display remains #2 but the issues went.

    Dunno if this may solve some of the issues of you guys, but it sure solved mine ...



    • Proposé comme réponse putserw jeudi 20 août 2015 11:13
    • Modifié putserw jeudi 20 août 2015 12:38
    jeudi 20 août 2015 11:00
  • Dam im having the same problem just the opposite I play "World of warcraft" and i want it to Play on my HDMI (TV)

    But it only displays on my Monitor 

    EXMP: I want to Watch Youtube on my Monitor and Play WoW on The Tv.

    Please help

    dimanche 14 février 2016 14:17
  • Same here my friend, I just got windows 10 today and it's still a problem. I didn't have this problem in Windows 7 out of the box. 

    I want to cry.

    My TV, connected to my HDMI port is always #1 and my monitor on DVI is always number 2.

    lundi 11 juillet 2016 01:27
  • I had the same problem, strangely enough, it seems like it got fixed when i changed the slots where i plugged both hdmi ports , but i plugged in the monitor's cable first so maybe that is also what fixed my problem.

    So it seems like it got fixed by either : changing the slots ; plugging in the monitor first

    lundi 25 juillet 2016 15:02
  • Thanks a lot Gordon 7. It worked for me, i solved my problem.
    jeudi 22 septembre 2016 10:48
  • It also does matter (in my case for sure) if its DMI or RGB cable. I tried to switchthem, but DMI monitor always 1, RGB - 2. But i fixed it with Ultramon, though windows still shows rgb - second dmi - first. But soft (Magic Tune) is working now.
    jeudi 22 septembre 2016 10:51
  • With an Catalyst Control Panel you can disable a display. Then under Common Display Task on the left menu tab you will find "Exchange Display" Choose a monitor and it will trade places with the number/Identity. Enable the monitor and see how it lines up. I had work through this scenario a few times. Half way through the exercise I rebooted because I was having a hard time lining them up. I finally was able to match Windows display with ATI numbering. Good Luck

    Stanomatic


    Stanomatic


    This worked like a charm for me, using AMD Catalyst 15.8.
    vendredi 31 mars 2017 13:40
  • i can confirm that this works for me.
    dimanche 16 avril 2017 10:03
  • It's now MAY 2017, 7 years from the first post.

    This link by Micah Zoltu worked for me. I have 4 regular monitors running on two graphics cards. These monitors have existed the entire time I owned my Win 8.1 64-bit computer. I'm guessing the Nvidia updates mess up the monitor definitions in the noted Registry files because I had maybe 20 or 30 monitors listed in those registry keys. Following the instruction in http://www.dell.com/support/article/us/en/19/SLN137488/EN worked. Each time I added a monitor I checked "Screen Resolutions". Monitors 1,2,3 worked perfect. When I attached the 4th monitor it changed #1 to #2 and gave #4 the4 #1 monitor. I rebooted. It came back corrected with my monitors showing the same as Identity.

    I hope it sticks between reboots. It probably won't stick with the next Nvidia update, but that remains to be seen.

    Thanks Micah!

    mardi 23 mai 2017 15:20
  • Windows defaults to the Video card.
    samedi 11 novembre 2017 15:45
  • I have the same problem!
    mercredi 3 janvier 2018 22:48
  • Works
    samedi 17 février 2018 20:19
  • Probably no longer need to know but here is a solution that worked for me:

    1. Set up multiple display in NVIDIA - then had the problem of my laptop screen being designated as 2 instead of screen 1
    2. Save settings and quit NVIDIA and enter normal windows screen properties (in Windows 7, it is right click on Desktop and click on screen resolution). Once there you can drag and drop screens in the order you want!

    Hope it helps for anyone else who experiences the same problem

    I had to read about 6 pages of post before hiting this solution. Thanks to you Choedan. 

    In my case it was even simpler. I did not have to go to NVIDIA. Simply going to "Screen Resolution" and drag those displays 1 and 2 fixed my problem.

    Quickly: I have one monitor with vertical display and one with Horiz.

    Vert uses the DVI connector on an hp Pavilion Desktop. The Horiz uses the HDMI. I do not care which one is called display 1 or display 2. My Horiz is physically to the left and my Vert is to the right. 

    The problem I had was that in order to bring the mouse from the right Vert display to the left Horiz display I had to drag the mouse to full right so that it appears to the left side of the Horiz display. Not so user friendly. I could have moved my Vert to the left and Horiz to the right, but physically this was inconceavable.

    So, In the "Screen Resolution" window, simply by dragging the Horiz 1 monitor to the left of the Vert 2 monitor (and clicked Apply) I suddently found that the mouse was now moving in a more natural way, from left to right. Finally.

    I wish I had known this possibility sooner.

    Hope this will help someone.

    vendredi 26 octobre 2018 01:34
  • That does not change monitor identities, just the order. They are two different things.
    • Proposé comme réponse tonaz vendredi 14 décembre 2018 13:23
    • Non proposé comme réponse tonaz vendredi 14 décembre 2018 13:23
    mercredi 5 décembre 2018 16:42

  • "Assign" you all are using the wrong word.
    It is all about "Enumeration" and it is something user cannot change. Period. 
    When you plug a monitor the first time, it will be enumerated with a sequential numberation, and it will be bound forever. 
    There is only one way to enumerate the way you would like: let's suppose you have 3 monitors and you want a particular numeration for them. The only way is doong it with a fresh Windows install, install Windows with the monitor you want to be the 3rd, only that one plugged. Once installed plug the one you want to be the 2nd. Reboot. Plug the one you want to be the 1st

    So, short story long, the enumeration in windows is BACKWARDED.
    Absolutely sensless, in perfect Microsoft style. 
    • Proposé comme réponse TroelsB lundi 16 septembre 2019 11:45
    vendredi 14 décembre 2018 13:38
  • Will try this tonight. If it works - you deserve a large GT  / Thanks
    lundi 16 septembre 2019 11:48