none
Option ABE sur mon namespace DFS non présente RRS feed

  • Question

  • Bonjour à tous,

    Je suis en train de monter un nouveau serveur de fichier avec du DFS.
    Je souhaite activer le ABE sur mes dossiers partagés.

    J'ai donc un dossier "Services" qui contient des sous dossiers.
    Exemple :

    - Services

        - Informatique

        - Finance

        - Production

    Je souhaite que seuls les utilisateurs ayant accès aux dossiers puissent les voirs.
    J'ai donc partagé mon dossier "Services" qui contient les sous dossiers.
    Sur ce dossier "Services" j'ai activé le ABE via les paramètres.

    Si je vais sur le répertoire service directement par le chemin UNC avec l'IP du serveur de fichier, ça fonctionne, je ne vois pas les dossiers auxquels je n'ai pas accès.
    En revanche, si j'y vais pas le chemin DFS, je vois tous les répertoires.

    J'ai regardé, et je n'ai pas l'option "enable access-based enumeration for this namespace" quand je clic droit sur mon namespace --> Propriétés --> Advanced.

    Quelqu'un serait me dire pourquoi ?

    Merci à vous.
    Cordialement,

    mardi 4 août 2020 09:32

Réponses

  • J'ai trouvé comment faire.

    Il faut se rendre dans "DFS Management", dérouler l'espace de nom, effectuer un clic droit sur un dossier, propriétés, avancé, pour cocher la case "Utiliser des autorisations explicites pour la lecture".

    Une fois les bons droits positionnés, cela fonctionne.

    Cependant, cela devrait également fonctionner avec les droits NTFS, or, ce n'est pas le cas.

    Si quelqu'un a une solution, je suis preneur.

    Merci
    • Marqué comme réponse Speeedfan mercredi 5 août 2020 13:26
    mardi 4 août 2020 12:01

Toutes les réponses