none
The request to list features available on the specified server failed. RRS feed

  • Question

  • Hi,

    I am getting following error while trying to add Windows Backup feature. Can someone help me resolve it? I restarted the server but that did not fix the error.

    Thanks.



    mercredi 4 mai 2016 18:26

Réponses

  • I see;

    Failed to create dismhost.exe servicing process

    You may be able to do a repair install.

    https://support.microsoft.com/en-us/kb/2255099

    but depending on the roles or applications installed it may be less risky to stand up a new one, patch it fully, and migrate the roles / applications over.

     

     

     


    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows Server]

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.

    samedi 7 mai 2016 00:12

Toutes les réponses

  • It could be the XML here is corrupt.

    \Users\'yourID'\AppData\Roaming\Microsoft\Windows\ServerManager\ServerList.xml

     

     

     


    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows Server]

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.

    mercredi 4 mai 2016 19:45
  • Thank you Dave. How would I fix that then?

    mercredi 4 mai 2016 19:58
  • Delete the file then restart server manager.

     

     

     


    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows Server]

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.

    mercredi 4 mai 2016 22:27
  • Hi,

    Please refer to the following suggestions:
    1. Run sfc /scannow
    2. Run dism /online /cleanup-image /restorehealth
    3. Review the registry
    a. Login as Administrator or Domain Administrator and test the issue again.
    b. Verify that the following registry subkeys are empty:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnce
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnceEx
    c. Check the system for Pending Reboot State
    Look in the HKLM\System\CurrentControlSet\Control\Session Manager\PendingFileRenameOperations key and if none of the files listed  there exist then delete PendingFileRenameOperations.
    d. Check the HKLM\Software\Microsoft\Server manager registry key. What is the value of CurrentRebootAttempts? If it is greater than 0, that means something that Server Manager did requires a reboot. You should check the Server Manager console and  ensure that there's nothing outstanding in there that would require a reboot. Otherwise, you can manually set it to 0. Also, delete another string value 'Action' under 'HKLM\Software\Microsoft\Server manager' and see how it works.
    e. Take a backup from  HKEY_LOCAL_MACHINE\COMPONENTS\PendingXmlIdentifier. Delete the pendingxmlidentifier from the component registry and reboot the server.

    Best Regards,
    Alvin Wang



    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    jeudi 5 mai 2016 06:04
    Modérateur
  • Deleting ServerList.xml did not fix problem. 
    jeudi 5 mai 2016 14:30
  • Hi,

    You could try the suggestions that mentioned in my last reply.

    Best Regards,

    Alvin Wang


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    vendredi 6 mai 2016 02:05
    Modérateur
  • Thanks Alvin. I tried first one and now it requires restart. I will have to wait to restart that server because of office productivity reasons. 


    vendredi 6 mai 2016 14:25
  • Also check the details in cbs.log file or if help needed put it up on OneDrive and share a link.

     

     

     


    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows Server]

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.

    vendredi 6 mai 2016 15:39
  • Here is the cbs.log file

    https://onedrive.live.com/redir?resid=A794A021CEA29598!111&authkey=!ADwefSLnG-QjGQo&ithint=file%2clog

    vendredi 6 mai 2016 16:06
  • Errors are all pointing to pending reboot required. I'd reboot then also try running;

    dism /online /cleanup-image /restorehealth

    and put up new log files if needed.

     

     

     


    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows Server]

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.

    vendredi 6 mai 2016 16:56
  • I shut down and started server. I tried image cleanup but it gave me an error.

    DISM log: https://onedrive.live.com/redir?resid=A794A021CEA29598!112&authkey=!AMnVT85dt4YWoAc&ithint=file%2clog

    Thanks for all the help guys. I really appreciate it.

    vendredi 6 mai 2016 22:05
  • I see;

    Failed to create dismhost.exe servicing process

    You may be able to do a repair install.

    https://support.microsoft.com/en-us/kb/2255099

    but depending on the roles or applications installed it may be less risky to stand up a new one, patch it fully, and migrate the roles / applications over.

     

     

     


    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows Server]

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.

    samedi 7 mai 2016 00:12
  • Hi,

    Just want to confirm the current situations.

    Please feel free to let us know if you need further assistance.

    Best Regards,

    Alvin Wang


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    lundi 9 mai 2016 02:37
    Modérateur
  • I had the same issue and turned out the  %TEMP% folder was deleted. I changed environmental variable  for user and system  TEMP & TMP  to C:\TEMP  and after reboot  issue was resolved.
    vendredi 15 novembre 2019 04:35