Unable to play videos from WMP 12 using the ActiveX control


  • Hi,

    I am running Windows 7 SP1 with VS2010 and have installed the Windows 7 SDK (v7.1), and am trying to get the sample  code in 'Samples/multimedia/WMP/dotNet/csharp' to work.  I copied the sample code to my desktop and used VS2010 to upgrade the projects to version 10, and the code builds without warnings.  But when trying to play any videos that are currently in the library I get the following error:

    Error C00D11B1 in C:\Users\kevin\Desktop\hibiya.AVI
    Windows Media Player encountered a problem while playing the file.

    The same video file plays perfectly well when I try to play it from Windows Media Player directly, whether by double clicking the desktop icon, or starting WMP and selecting the file from the library.  The same error occurs for every video file I have tried, including WMV, M4V, MP4, and AVI files.  The error as far as I can tell is a generic error indicating that WMP can't play the video, and has been mentioned in discussions about DRM, codec installation problems, audio driver problems, file corruption, etc.  Is there any way to narrow down what is causing the error using the ActiveX WMP control? 

    This is the first time that I've tried using the sample code, but I have applications that have used the ActiveX WMP control for the past eight months or so, and it has been at most a month, and at a minimum a couple of days since this stopped working (same videos, same application, no changes to the video API in the last month or so.)



    lundi 10 octobre 2011 18:26


  • And so it goes, just after you think you've already tried everything you stumble across the source of the problem.  I had installed the iZ3d drivers for an unrelated project and had naively assumed that choosing 'Exit' from the driver app would stop the driver.  Restarting the driver and then explicitly choosing to 'Disable' the driver fixes the video playback problem. 

    That said it would have saved hours of work if the generic error C00D11B1 could be replaced with something more useful in debugging.

    lundi 10 octobre 2011 18:37