none
Powershell ISE runs my script with out issues but regular powershell fails RRS feed

  • Question

  • I have a PS script which is communicating to Office 365 management API to extract logs, the script works when I run it on ISE but the same script fails with an error "Unable to connect to remove server" when I run it on PowerShell. 

    I have added [Net.ServicePointManager]::SecurityProtocol = [Net.SecurityProtocolType]::TLS12 and $env:NO_PROXY but no luck.

    Could someone please assist me on this issue?


    Karthikeyan

    vendredi 19 juin 2020 08:17

Toutes les réponses

  • Karthikeyan_messaging, you can try to use google for finding what this error may mean, or share your script for verifying it with comunity members


    The opinion expressed by me is not an official position of Microsoft

    • Proposé comme réponse Vector BCO mercredi 1 juillet 2020 20:52
    vendredi 19 juin 2020 10:12
  • First resolve the server address.  Next try to ping the remote host.  Check to see if your company requires validation on your proxy.  In some cases the request is ignored instead of failing which can cause your message.


    \_(ツ)_/

    mercredi 1 juillet 2020 21:19
    Modérateur
  • Hi,
    Was your issue resolved? 
    If you resolved it using our solution, please "mark it as answer" to help other community members find the helpful reply quickly.
    If you resolve it using your own solution, please share your experience and solution here. It will be very beneficial for other community members who have similar questions.
    If no, please reply and tell us the current situation in order to provide further help.
    Best Regards,
    Yang Yang

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    vendredi 3 juillet 2020 05:44