none
supprimez le rôle Hôte de session Bureau à distance RRS feed

  • Question

  • Bonjour,

    Quand je me connecte à mon serveur virtuel en bureau à distance, j’ai le message :

    Aucun serveur de licences bureau à distance n'est disponible pour fournir une licence.

    Pourtant j’avais bien activer le service et associer les licences !

    Sur le site, j’ai trouvé la commande pour supprimez le rôle Hôte de session Bureau à distance :

    dism /ONLINE /Disable-feature /FeatureName:Remote-Desktop-Services

    Mais elle ne fonctionne pas pour un serveur virtuel 2008 R2, j’ai le message :

    Erreur : 0x800f080c

    Remote-Desktop-Services : nom de fonctionnalité inconnu.

    Quelle commande dois-je utiliser pour supprimez le rôle Hôte de session Bureau à distance sur un serveur 2008 R2

    Merci d’avance


    Stephane

    mercredi 15 janvier 2020 09:39

Réponses

  • Bonjour, Pour pouvoir activer le rôle Hôte de session, les licences devront être installés sur un serveur de licence et que le connectivité établis entre le HS et licensing (Port: https://social.technet.microsoft.com/wiki/contents/articles/16164.rds-2012-which-ports-are-used-during-deployment.aspx) serveur via des GPO: https://www.adminmalin.fr/windows-2012-r2-specifier-un-serveur-de-licences-tserds/ 

    "Vote or mark as answer if you think useful" "Marquer comme réponse les réponses qui ont résolu votre problème"



    • Modifié F.ABASSI jeudi 16 janvier 2020 13:07
    • Marqué comme réponse Stef-AGIR mardi 21 janvier 2020 11:37
    jeudi 16 janvier 2020 13:07
  • Bonjour,

    L'idée était bonne.

    J'ai forcé en powershell l'ip de mon serveur (et la création de la clé qui n'existait pas) avec la commande:

    reg add "HKLM\SYSTEM\CurrentControlSet\Services\TermService\Parameters\LicenseServers" /v SpecifiedLicenseServers /t REG_MULTI_SZ /d "x.x.x.x"

    Et j'ai pu me connecter en bureau à distance sur mon serveur azure.

    Par contre, pour le test j'ai mis mon serveur de licence en DMZ, car je n'ai pas trouvé les port à ouvrir sur mon routeur.

    Quelqu'un connais les ports à ouvrir pour que le serveur de licence , ce serait mieux que de mettre en DMZ le serveur!

    Une fois initialisé la connexion en bureau à distance, j'ai désactivé la DMZ et j'ai pu corriger l'erreur de mon serveur : pas de licence affecter au serveur de licence!

    Merci à tous


    Stephane

    • Marqué comme réponse Stef-AGIR jeudi 16 janvier 2020 17:30
    jeudi 16 janvier 2020 17:30

Toutes les réponses

  • Bonjour Stef-AGIR,

    Veuillez consulter l'article suivant :

    https://docs.microsoft.com/en-us/powershell/module/remotedesktop/remove-rdserver?view=win10-ps

    Je vous remercie par avance pour votre retour.

    Cordialement,
    Nedeltcho


    Votez! Appel à la contribution TechNet Community Support. LE CONTENU EST FOURNI "TEL QUEL" SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. S'il vous plaît n'oubliez pas de "Marquer comme réponse" les réponses qui ont résolu votre problème. C'est une voie commune pour reconnaître ceux qui vous ont aidé, et rend plus facile pour les autres visiteurs de trouver plus tard la résolution.

    jeudi 16 janvier 2020 07:33
    Modérateur
  • Bonjour,

    En PowerShell, la commande Remove-RDServer n’est pas reconnue (message : Le terme « Remove-RDServer » n'est pas reconnu comme nom d'applet de commande).

    J’ai aussi essayé Remove-WindowsFeature (mon serveur est en 2008 R2, et aussi Uninstall-WindowsFeature et Remove-RDSessionHost

    J’ai aussi essayé de me connecter au bureau à distance en admin : mstsc < IP >: <Port> /admin

    Ou : mstsc /v < IP >: <Port> /admin

    Mais j’ai toujours l'erreur : Aucun serveur de licences bureau à distance n'est disponible pour fournir une licence.

    Sur la FAQ, j’ai trouvé une commande pour supprimez le rôle Hôte de session Bureau à distance :

    dism /ONLINE /Disable-feature /FeatureName:Remote-Desktop-Services

    Mais elle ne fonctionne pas (peut-être parce que mon serveur virtuel est un 2008 R2 ?), j’ai le message :

    Erreur : 0x800f080c

    Remote-Desktop-Services : nom de fonctionnalité inconnu.

    Cordialement,

    Stéphane


    Stephane

    jeudi 16 janvier 2020 08:39
  • Bonjour,

    Complément à mon mail:

    Je me suis penché sur la commande :

    dism /ONLINE /Disable-feature /FeatureName:Remote-Desktop-Services

    Quand je lance : Dism /online /Get-Features

    je ne retrouve aucun nom (activé ou désactivé) de rôles liés au bureau à distance.

    Peut-être que sous 2008 R2, Get-Features ne renvoie que les fonctionnalités?

    j'ai essayé avec Get-roles, mais l'option est inconnue!

    Cordialement


    Stephane

    jeudi 16 janvier 2020 11:59
  • Bonjour, Pour pouvoir activer le rôle Hôte de session, les licences devront être installés sur un serveur de licence et que le connectivité établis entre le HS et licensing (Port: https://social.technet.microsoft.com/wiki/contents/articles/16164.rds-2012-which-ports-are-used-during-deployment.aspx) serveur via des GPO: https://www.adminmalin.fr/windows-2012-r2-specifier-un-serveur-de-licences-tserds/ 

    "Vote or mark as answer if you think useful" "Marquer comme réponse les réponses qui ont résolu votre problème"



    • Modifié F.ABASSI jeudi 16 janvier 2020 13:07
    • Marqué comme réponse Stef-AGIR mardi 21 janvier 2020 11:37
    jeudi 16 janvier 2020 13:07
  • Bonjour,

    Le serveur est une machine virtuel Azure directement en IP public sur Internet. Je trouve complexe d'idée du mettre un nouveau serveur pour gérer les licences. Je vais creuser de ce côté, peut-être ouvrir le port sur mon routeur pour lui donner accès à mon serveur de licence.

    A suivre…

    Par contre, je n'ai pas accès à mon serveur. Uniquement avec la console série, si quelqu'un a une commande PowerShell (sous Serveur 2008 R2), pour spécifier le serveur de licences, je suis preneur.


    Stephane

    jeudi 16 janvier 2020 13:46
  • Bonjour,

    L'idée était bonne.

    J'ai forcé en powershell l'ip de mon serveur (et la création de la clé qui n'existait pas) avec la commande:

    reg add "HKLM\SYSTEM\CurrentControlSet\Services\TermService\Parameters\LicenseServers" /v SpecifiedLicenseServers /t REG_MULTI_SZ /d "x.x.x.x"

    Et j'ai pu me connecter en bureau à distance sur mon serveur azure.

    Par contre, pour le test j'ai mis mon serveur de licence en DMZ, car je n'ai pas trouvé les port à ouvrir sur mon routeur.

    Quelqu'un connais les ports à ouvrir pour que le serveur de licence , ce serait mieux que de mettre en DMZ le serveur!

    Une fois initialisé la connexion en bureau à distance, j'ai désactivé la DMZ et j'ai pu corriger l'erreur de mon serveur : pas de licence affecter au serveur de licence!

    Merci à tous


    Stephane

    • Marqué comme réponse Stef-AGIR jeudi 16 janvier 2020 17:30
    jeudi 16 janvier 2020 17:30
  • Bonjour,

    L'idée était bonne.

    J'ai forcé en powershell l'ip de mon serveur (et la création de la clé qui n'existait pas) avec la commande:

    reg add "HKLM\SYSTEM\CurrentControlSet\Services\TermService\Parameters\LicenseServers" /v SpecifiedLicenseServers /t REG_MULTI_SZ /d "x.x.x.x"

    Et j'ai pu me connecter en bureau à distance sur mon serveur azure.

    Par contre, pour le test j'ai mis mon serveur de licence en DMZ, car je n'ai pas trouvé les port à ouvrir sur mon routeur.

    Quelqu'un connais les ports à ouvrir pour que le serveur de licence , ce serait mieux que de mettre en DMZ le serveur!

    Une fois initialisé la connexion en bureau à distance, j'ai désactivé la DMZ et j'ai pu corriger l'erreur de mon serveur : pas de licence affecter au serveur de licence!

    Merci à tous


    Stephane

    Remote Desktop Licensing Server

    Information for Terminal Server in Windows Server 2008 is at http://support.microsoft.com/KB/832017#method26 Jump   The ports used have not changed in Windows Server 2012 | R2.  The summary follows.

    TCP

    • TCP 135 - RPC  for License Server communication and RDSH
    • TCP 1024-65535 (randomly allocated)  Used for RPC For Windows Server pre-2008 (see next line).
    • TCP 49152 - 65535 (randomly allocated) -  This is the range in Windows Server 2012,  Windows Server 2008 R2, Windows Server 2008
    • TCP 445 - SMB
    • TCP 443: Communication over the internet to the Microsoft Clearing House
    • TCP 5985: WMI and PowerShell Remoting for administration
    • TCP 139 - NetBIOS session service

    How to configure which ports (if need to set to specifics) http://support.microsoft.com/kb/154596/ Jump

    NetBIOS

    • UDP 137 - NetBIOS Name resolution
    • UDP 138 - NetBIOS datagram
    • UDP|TCP 389   LDAP - Used with per-user CALs against Active Directory

    From a proxy standpoint, the regkey HKLM\Software\Microsoft\TermServLicensing\lrwiz\Params shows the Microsoft service that the RD LS communicates with.  e.g. clearinghouse.one.microsoft.com



    "Vote or mark as answer if you think useful" "Marquer comme réponse les réponses qui ont résolu votre problème"

    • Proposé comme réponse F.ABASSI mardi 21 janvier 2020 09:57
    vendredi 17 janvier 2020 09:38