none
Files not showing up in networked drive RRS feed

  • Question

  • I have mapped drives on a Windows 7 box. The server is running 2008 Standard.

    We scan files into a mapped drive, but they don't immediately show up on other computers when opening the mapped drive. Is there a refresh rate?

    If so, how can it be changed? It usually works if I have the user do a F5 or right click and click refresh.

    Allen
    vendredi 26 novembre 2010 16:30

Toutes les réponses

  • Hi,

    This issue may be caused by the Automatic refresh folder. You may kindly refer to the following steps:

    1.       Open your Windows Explorer, and click organize.
    2.       Click Folder and search Option.
    3.       Under the General Tab, please check the box before “Automatically expand to current folder”.

    If the issue persists, please try to disable the folder Index, please kindly refer to the following steps:

    1. Click Start Menu, then type Offline files, then click Manager Offline Files in the search result.
    2. Then check whether you enable offline files, if so, please disable it to have a try.

    In addition, can you advise me the following things:

    1. How other computers access the shares? Are they via mapped drive or access directly ?
    2. Are the new components able to be viewed immediately on the local computer ?

    Also, please kindly try the following steps:

    1. Disable Remote differential Compression.
    2. Disable Auto-Tuning.
    3. Disable SMBV2.

    lundi 29 novembre 2010 09:28
    Modérateur
  • Hi,

    This issue may be caused by the Automatic refresh folder. You may kindly refer to the following steps:

    1.       Open your Windows Explorer, and click organize.
    2.       Click Folder and search Option.
    3.       Under the General Tab, please check the box before “Automatically expand to current folder”.

    If the issue persists, please try to disable the folder Index, please kindly refer to the following steps:

    1. Click Start Menu, then type Offline files, then click Manager Offline Files in the search result.
    2. Then check whether you enable offline files, if so, please disable it to have a try.

    In addition, can you advise me the following things:

    1. How other computers access the shares? Are they via mapped drive or access directly ?
    2. Are the new components able to be viewed immediately on the local computer ?

    Also, please kindly try the following steps:

    1. Disable Remote differential Compression.
    2. Disable Auto-Tuning.
    3. Disable SMBV2.


    Hi, I did the organize, folder / search option, as well as automatically expand...

    They are NOT set up as offline files, I checked that.

    All computers are mapped to the S: drive.  Some can see them right away, some it takes a reboot.  When I navigate (on any of the computers) using the UNC path, all files are visable.

    As far as your last three steps, I don't understand what that means.  Also, a correction to my original post, F5 or refresh does not make them show up, only a reboot.

    Thanks,

    Allen

    vendredi 3 décembre 2010 20:36
  • Hi Allen-CCWTech

    Have you had any solution to this error?

     

    I'm having the exact same problem. Some users can view the files, some cannot - however if they log off the server and log onto another terminal server - they can.

     

    Also, using the full UNC name works.

     

    Very strange.

     

    If you have any solution, I’d really appreciate it.

     

    Thanks.

     

    vendredi 10 décembre 2010 09:45
  • Hi Allen-CCWTech

    Have you had any solution to this error?

     

    I'm having the exact same problem. Some users can view the files, some cannot - however if they log off the server and log onto another terminal server - they can.

     

    Also, using the full UNC name works.

     

    Very strange.

     

    If you have any solution, I’d really appreciate it.

     

    Thanks.

     


    No, not yet unfortunately.  Please post here if you find anything as well.
    vendredi 10 décembre 2010 14:07
  • I too am seeing this exact same problem.

    Enviroment: Win7 pc connecting to Server 2008 standard through a mapped drive letter.

    New files created on a mapped drive letter do not show up.  If I disconnect the drive letter and re-map the drive letter to the UNC the files then show up.  This allowed me to create a batch file with a shortcut on the users desktop to temporarily fix the problem until I can find a permanent fix.

    Disconnect share first

    net use P: \\Server\Share /disconnect

    reconnect to share

    net use P: \\Server\Share /presistent:yes

    THe new files are now visable. 

    I would suspect the Microsoft has a hotfix available.


    Kevin
    vendredi 10 décembre 2010 18:04
  • Unfortunately that's not something I can just have my users doing all the time.

    vendredi 10 décembre 2010 20:44
  • A better temporary fix, which works for me - is to get my users to hit F5 which refreshes the folder.
    lundi 13 décembre 2010 13:45
  • "...F5 or refresh does not make them show up, only a reboot."

    That doesn't work I'm afraid.

    mardi 14 décembre 2010 00:29
  • This issue persists, any ideas?
    mercredi 22 décembre 2010 00:11
  • I am facing a similar issue wherein users in US are able to see the files on the share whereas users in India are unable to see any file even after doing a F5 etc. Any help is really appreciated.
    lundi 27 décembre 2010 05:09
  • Hello,

    I have the same issue with a Windows Server 2008 R2 fileserver and Windows 7 clients.
    If a network scanner upload files via SMB to the fileserver, the users doesn't see any new files until they reboot the Windows 7 clients.

    Thats very strange...

    Regards
    Reto

    mardi 25 janvier 2011 10:37
  •  

    I have made several tests. We can see the new file on the share with powershell, but not in explorer:

    After a restart, we can also see the file in the explorer.

     

     

    Thanks and regards

    Reto

    mardi 25 janvier 2011 13:17
  • Same problem here in two offices. Did anyone find any solution?

    • Modifié peroyvind mercredi 9 février 2011 10:15 typo
    mercredi 9 février 2011 10:14
  • Yep same problem here too :( ... Can't find anything on the internet about this... I'm wondering if its lagging permissions if there's such a thing because our AD server is through a VPN on the internet - anyone else have this setup?

    EDIT: I have a feeling this is related to SMB2 - found an article here http://stackoverflow.com/questions/1887732/file-open-fails-initially-when-trying-to-open-a-file-located-on-a-win2k8-share-bu

    EDIT2: Another link to the same issue with a SMB2 reference http://www.laslow.net/2011/01/31/server-2008-r2-and-windows-7-client-smb2-share-refresh-issue/

    EDIT3: After a week of running without SMB2 the issue hasn't shown up ... so while this isin't ideal due to the possible preformance impact its definitely fixed the problem... Microsoft REALLY needs to address this...

    mercredi 2 mars 2011 02:09
  • I have disabled SMB2 on the servers and workstations which made the problem go away.  I have been running with SMB2 disabled shortly after my first post here in December 2010 and have NOT seen the problem re-occur.
    Kevin
    dimanche 6 mars 2011 04:45
  • I have disabled SMB2 on the servers and workstations which made the problem go away.  I have been running with SMB2 disabled shortly after my first post here in December 2010 and have NOT seen the problem re-occur.
    Kevin
    What are the implications of disabling this?
    mardi 8 mars 2011 04:16
  • SMB2 Basically is better performance and beter security but if it does not work right no improvement matters.

    http://www.snia.org/images/tutorial_docs/Networking/JimPinkerton-SMB2_Big_Improvements_Remote_FS_Protocol-v3.pdf

    I have not seen any negative impact on my network with 5 various server 2008 flavors, SQL server 2008, terminal server 2008 and 50+ clients.  All this running on a managed switched gigabit network.

     


    Kevin
    mercredi 9 mars 2011 05:31
  • I am still experiencing this issue.  Windows 7 SP2 (fully patched) client connecting to a mapped drive on a Storage Server 2008 SP2 (fully patched).   Browsing to the folder using UNC works.  As a matter of fact after browsing to the folder using UNC the file showed up in the mapped drive. 

    Disabling SMB2 is not an acceptable workaround for me.

    mercredi 24 août 2011 21:10
  • Has anyone figured out how to resolve this? We're seeing this too, Windows 7 clients connecting to Server 2008 R2 - each fully patched.
    mercredi 12 octobre 2011 19:37
  • Did you try setting DirectoryCacheLifetime to 0 as one of the articles mentioned above suggested?  The length of time that the files aren't visible would seem to preclude that as the problem, but curious if changing it had any impact with SMB2 active.

    http://technet.microsoft.com/en-us/library/ff686200(WS.10).aspx


    mercredi 12 octobre 2011 21:07
  • Did you try setting DirectoryCacheLifetime to 0 as one of the articles mentioned above suggested?  The length of time that the files aren't visible would seem to preclude that as the problem, but curious if changing it had any impact with SMB2 active.

    http://technet.microsoft.com/en-us/library/ff686200(WS.10).aspx



    I think i tried this a year ago when the problem first arose.... I'm not willing to try it again on a live system since disabling SMB fixed the issue... I just wish Microsoft would even acknowledge that this issue exists!.... Until then we are stuck using SMB1 which is slower over VPN etc

    For us the SMB2 problem has more implications than just files not appearing on the drive - it also affects the software package PBBI Mapinfo which uses flat file databases and tracks record locks by checking the last modified stamp.. but if the files aren't showing up and other people are working on the same database it leads to corruption... disabling SMB2 fixed this completely along with the issue of files not shownig up
    mercredi 12 octobre 2011 23:14
  • We are experiencing the same issue but I don't want to disable SMB 2.0 for 2 reasons - 1. I've seen people reporting that offline files won't work, and 2. we don't want to get slower file transfer speeds etc by going back to SMB 1.0.

    Surely Microsoft should have a fix for this by now? SMB 2.0 has been around for quite a while now...

     

    Oh and I looked at the reg keys Scott mentioned (http://technet.microsoft.com/en-us/library/ff686200(WS.10).aspx) but considering it says the default values are 10 seconds and 5 seconds I don't think this is what is causing it (as we can wait for much longer than that before the files appear, and usually just resort to pressing F5 to refresh).

     


    My website: www.cjwdev.co.uk My blog: cjwdev.wordpress.com
    • Modifié Chris128 mardi 18 octobre 2011 13:57
    mardi 18 octobre 2011 13:52
  • Hi Everyone,

    Unfortunately I have found a side-effect of disabling SMB2 on our Server 2008 server.... it causes BSOD issues with rdbss.sys and mrxsmb10.sys when viewing JPEG files using windows photo viewer and also using 7-Zip to extract files... when using a Network drive that is locally mapped back to the same server.... This configuration is because the server in question is a terminal server & file server...

    As documented here http://social.technet.microsoft.com/Forums/en-US/itprovistasecurity/thread/97657c43-de53-43b2-9cc0-3d9f6fe7dd6e

    So that's just something to be aware of if your disabling SMB2 to fix this

    mercredi 9 novembre 2011 12:50
  • I am having the same problem on my 2008 server and win7 clients. any fixes??
    lundi 14 novembre 2011 17:38
  • I'm also having this issue.  I do not want to disable SMB2.

    In my case, we scan to our own network drives.  For a particular user, when there was a file that was scanned in, the number of files in the folder when viewing from the server was N, but I noticed that from the user's computer that couldn't see the file, it showed up that there were N-1 files in the user share.

    jeudi 17 novembre 2011 20:20
  • 1 year later and Microsoft hasn't fixed it. Maybe we'll see a fix on Server 8, but of course something else will break. I have seen this issue on several servers in different customer sites. Very annoying.

    You can replicate the issue pretty easily by droping a file into a network share using an IP based UNC path ie: \\172.16.50.23\Share, then going to a Computer Name based UNC path ie: \\ComputerName\Share and whala no file.



    lundi 28 novembre 2011 14:36
  • One of my clients is also experiencing the same issues. Windows 7 Pro SP1 x64 fully patched connecting to a Windows Server 2008 mapped network drive. Direct connection via UNC does not correct the issue either. What gives? This is really creating issues with scanned files through Sharescan. People are scanning files 5-6 times because they don't "see" the file in their scanned directory. 

    MS, are you listening? 

    jeudi 2 février 2012 15:48
  • What scanner do you have ? Maybe the SMB2 client there is buggy and it is not a primary Windows problem.

    I have the same problem. The scanner vendor is Ricoh.

     

    lundi 6 février 2012 20:55
  • Hi Everyone-

    I too am looking for a fix for this, but I wanted to let you know from our troubleshooting that there appears to be a shorter way of making the files show up.

    If you notice that files are not showing up after transferring them to a network share, you can restart the service "Windows Search" (Windows 7) on the affected client PC, and the file shows right up!

    We have had this problem for awhile, and everytime it appears to happen, this service restart makes it show up. I cannot speak to other environments though, so I hope it works for you as well.

    The alternative is to wait about 10-20 minutes for the file to show up on its own.

    I figure it's something to do with the file indexer, but I haven't found much that would indicate there is a work around other than disabling SMB2 (yuck).

    Hope this gets addressed SOON from MS.


    • Modifié skajervum mercredi 15 février 2012 20:52 added client service for clarity
    mercredi 15 février 2012 20:45
  • I found the answer to this in my environment

    http://shammyowens.blogspot.com/2012/02/windows-2008-r2-shared-files-do-not.html

    removing 2 explorer keys fixed the problem for us.

    jeudi 16 février 2012 10:45
  • Just wanted to weigh in and say that I checked on the registry keys mentioned in the blog posting shamster mentions, and those keys are not present on our server. We have also been struggling with this issue for some time. Running 64-bit Windows Storage Server Standard 2008 SP2.


    Shaun

    jeudi 16 février 2012 14:12
  • I have the same issue in my environment as well. Server 2008, with Win7 clients. It is only an issue for _SOME_ of my users, and we have xerox scanners by the way.
    jeudi 16 février 2012 18:26
  • I have the same issue. Windows Server 2008 R2, Window 7 x64 and Windows 7 x32. We have TOSHIBA and TA scanners, but scanned images are sent to destination folder using FTP protocol.
    mercredi 22 février 2012 09:09
  • We're using Xerox scanners here, that is where we're having the issue (users scan documents to a network share using the Xerox machine). We're using FTP - I've tried using SMB instead but have the same problem that way as well. This was not a problem until we moved from Server 2003 to 2008.

    Shaun

    mercredi 29 février 2012 15:27
  • Can we please stop talking about scanners.... this problem is completely unrelated to scanners... we don't have any scanners and we have this problem... which i have fully documented in my other posts above (as well as unexpected side effects of disabling SMB2 on a terminal server - e.g. causing some programs to BSOD when acccessing a locally mapped network drive)  .... I just can't believe that Microsot won't acknowledge it!
    mercredi 29 février 2012 23:15
  • They are saying scanners, but what you should really be taking from the comment is their method of file transfer.  By default most scanners will use SMB, so simply interpret their message that way and you can still see the trend of SMB file transfers to a Server 2008 File Server is where this issue seems to persist.

    We are having the same issue, but only with some users.  When files are transferred to a network share via SMB (UNC, or mapped)  The files will occasionally not show up for some users.  Another user can open the same location and the files are listed. 

    I went as far as completely replacing a system for one of our users (win7 32bit to win7 64bit, fresh installation, new hardware, etc.) and the issue STILL persists.

    I do not think disabling SMB2 is an option for our environment, since we cannot have the BSOD and reboots occuring on our TS server as mentioned above.  It could be worth testing in our non-production environment - but I can't reproduce the issue consistently there like I can in the real world.  I would hate to resort back to older technology just to get something working on a new system.  Still nothing from microsoft.

    vendredi 9 mars 2012 19:19
  • [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters]

    "DirectoryCacheLifetime"=dword:00000000

    worked for us.

    Daniel


    • Proposé comme réponse ilopezc jeudi 21 juin 2012 20:42
    • Modifié Daniel Be vendredi 22 juin 2012 14:44 same key for 32bit
    vendredi 9 mars 2012 21:06
  • Has anyone resolved this problem!!  Pretty annoying that a reboot is the only option at this time.  We, too, noticed this once we went to server 2008.  Our shared network drive (we receive faxes in this folder) takes up to 15+ minutes for the folder to refresh for users to see the files.  VERY FRUSTRATING!!!

    jeudi 29 mars 2012 13:12
  • Yep the solution is to disable SMB2 ... it's the only way.... Microsoft has pretty much ignored this.
    jeudi 29 mars 2012 21:24
  • I am facing the same problem here. Win2008R2 sp1 server with Win7 sp1 clients. I can reproduce the problem with one particular application: MS Dynamics NAV. Two users are saving files from that application to a file share and other users are reading those files. I created a test VM with Windows server 8 beta and instructed the users to use a share from that server from now on. Since this change (about a month ago) the problem has not occurred.

    Although it's not ready for production, it might be worth looking at Win8.

    vendredi 30 mars 2012 08:29
  • I have same problem with Samba server (!), so it looks like not W2K8R2 server problem, but Win7 client problem.
    mardi 3 avril 2012 17:08
  • I have same problem with Samba server (!), so it looks like not W2K8R2 server problem, but Win7 client problem.
    Now that's interesting! - Now if only Microsoft would at least acknowledge the issue.....
    mardi 3 avril 2012 20:24
  • I have a similar problem where a share on a 2008 R2 box doesn't seem to refresh. Have you guys seen this?

    http://support.microsoft.com/kb/2646563

    I'm considering installing it, as disabling SMB2 and using just SMB1 fixes the issues on my Win7 SP1 box. It has to be an SMB2 problem, and the Samba thing doesn't really change that. Later versions (post-3.6?) of Samba use SMB2 as well.

    John

    jeudi 5 avril 2012 17:04
  • Was that on the desktop or the server?  Please send reply to dan.technet@microent.net . Thanks

    lundi 14 mai 2012 21:30
  • Daniel Be - is this registry key you changed on the Windows 7 PC or the Server?
    vendredi 1 juin 2012 16:57
  • islandgirl2 wrote:

    Daniel Be - is this registry key you changed on the Windows 7 PC or
    the Server?

    As this is a key for the LanmanWorkstation service it is only of use on
    the client PC.


    Wolfgang
    vendredi 1 juin 2012 20:00
  • WolfP is right, it seems to be a bug in the new SMB2 directory cache on client side. Even with http://support.microsoft.com/kb/2646563 (latest SMB2 client) only disabling the cache at the clients using the registry key above makes the problem go away. I've seen no problems in production with the key yet.

    Daniel

    lundi 11 juin 2012 13:48
  • I'm trying this in production now, and so far so good!
    jeudi 21 juin 2012 20:42
  • I've had this problem with cifs shares on NetApp-filers, too - as soon as SMBv2 was enabled on the filer. Fully patched 2008R2 machines (that access these cifs shares on NetApp as clients) and Windows 7 clients all had that issue. (I do not see any issues on serverside of 2008R2 file servers...)

    I support the client-side-problem-with-SMBv2-"theory" as I was able to clearly reproduce it on these testing devices. SMBv2 disabled on filer: files appear immediately on Windows 7 and 2008R2 machines. SMBv2 enabled on filer: files show up 5-20 minutes delayed (but with no need to reboot).

    No difference on XP SP3 machines if SMBv2 is used or not - an no Vista in use here, so no data about Vista :)

    The registry-hack (DirectoryCacheLifetime as described above) is working for me. Thank you very much for the hint, by the way.

    Time by time I'm checking if Microsoft has silently fixed the issue (as I've to push that registry hack via GPO to all my clients) - they didn't until now, but for me this Cache-Lifetime workaround is doing well.

    Cheers

    vendredi 19 octobre 2012 11:50
  • Someone gave me a few more registry lines to add or edit, including the DirectoryCacheLifetime as described above, but adding additonal entries.  I don't know the source, but here it is, it works for me so far:

    You can create registry keys below to control the cache lifetime.

    Under

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentcontrolSet\Services\LanmanWorkstation\Parameters:

    FileinfoCacheLifetime           FileNotFoundCacheLifetime           DirectoryCacheLifetime

    They are all REG_DWORD type in seconds.

    Please be careful if you are going to edit the registry.

    There is a DontRefresh key that should be set to 0

    1.             Open Registry Editor by typing into Start > regedit.exe (or open directly in C:\Windows\regedit.exe)
    2.             Hit Ctrl+F for the search dialog, type "DontRefresh", hit Enter
    3.             After waiting a couple of seconds, the search finds one result: 'DontRefresh REG_DWORD     0x00000001 (1)"
    4.             Double click on DontRefresh and change 1 to 0.
    5.             Done! This should solve your problem.

    You maybe have to reboot your PC afterwards.

    lundi 7 janvier 2013 18:43
  • Here is a Microsoft article that explains the different parameters and their uses:

    http://technet.microsoft.com/en-us/library/ff686200(v=ws.10).aspx

    mardi 29 janvier 2013 20:46
  • Hey mate not sure if you had any luck in fixing this but heres what happened to me:

    Gave access to a couple of users for a folder within the shared drive and in the proccess had to change the ownership to the admin, anyway, only half of the files in the folder and subfolders were visable for them. Under the admin profile and in the server where it was stored the files were still there.

    To cut a long story short heres what I ended up having to do, although the permissions to the folder were correct all the child files and folders within were not inherited (slight over look I know). Heres the steps: Right click parent folder in question -> Properties -> Security Tab -> Advanced -> Change Permissions -> Tick the 'Replace all child object permissions with inheritable permissions from this object' box and click apply then hopefully all will be well.

    This fixed my certain issue, even though I was positive it wasn't a permissions issue, it was.

    • Proposé comme réponse jhg1019 jeudi 13 juin 2013 03:54
    jeudi 30 mai 2013 06:55
  • Thanks Haima!  Your solution about changing the security permissions worked for me.
    jeudi 13 juin 2013 03:53
  • Thank You,

    It worked for me

    vendredi 19 juillet 2013 13:28
  • Thanks Daniel. I created the new DWord "DirectoryCacheLifetime" and voila, the directory is now refreshed.
    mardi 5 novembre 2013 17:58
  • Quick Question:  Do the steps you provided apply for the Server or the workstaion?  "You may kindly refer to the following steps:

    1.       Open your Windows Explorer, and click organize.
    2.       Click Folder and search Option.
    3.       Under the General Tab, please check the box before “Automatically expand to current folder”.

    If the issue persists, please try to disable the folder Index, please kindly refer to the following steps:

    1. Click Start Menu, then type Offline files, then click Manager Offline Files in the search result.
    2. Then check whether you enable offline files, if so, please disable it to have a try.

    In addition, can you advise me the following things:

    1. How other computers access the shares? Are they via mapped drive or access directly ?
    2. Are the new components able to be viewed immediately on the local computer ?

    Also, please kindly try the following steps:

    1. Disable Remote differential Compression.
    2. Disable Auto-Tuning.
    3. Disable SMBV2. "

    I am working a similar issue where another tech referenced this discussion.

    mercredi 30 avril 2014 16:47
  • [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters]

    "DirectoryCacheLifetime"=dword:00000000

    worked for us.

    Daniel



    That's it! Thanks Daniel. And it's another shame on Microsoft not acknowledging the issue.
    vendredi 30 mai 2014 20:42
  • Microsoft has addressed the issue after 2 years!. With this hotfix the problem should be solved:

    http://support.microsoft.com/kb/2769790/en-us

    I'd also used the workaround with the DirectoryCacheLifeTime registry value (applied by GPO), but remember that disabling the cache does increase the client metadata requests to the server.

    Regards,

    Bent

    • Proposé comme réponse Daniel Be mardi 24 juin 2014 09:16
    mercredi 4 juin 2014 12:04
  • After a first test it looks fine with KB2769790 even if the cache is re-enabled, thank you Bent!

    You can also apply the enterprise hotfix rollup (http://support.microsoft.com/kb/2775511 + http://support.microsoft.com/kb/2728738) to have the fix.

    Daniel


    • Modifié Daniel Be mardi 24 juin 2014 09:24
    mardi 24 juin 2014 09:22
  • Most awesome this worked for me also. Thanks Daniel.

    I had a restored Virtual machine (windows 2008) that was having difficulties seeing newly created data on mapped drives. Refresh button didn’t work when creating a new folder or Text files.

    I used

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters]

    "DirectoryCacheLifetime"=dword:00000000

    And then also cleared out old defunct registered Nics from:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services

    And Removed old defunct registered Nics them from

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Linkage\Bind

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Linkage\Export

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Linkage\Route

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Linkage\Bind

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Linkage\Export

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Linkage\Route


    mardi 22 juillet 2014 12:04
  • Hi All,

    I tried all options in this discussion and the issue was present UNTIL I did a Scandisk and defrag of the SSD.

    I guess troubleshooting 101 is always the first course of action even if it seems unlikely...

    Thanks All.

    Daniel Meneghini

    mercredi 22 octobre 2014 17:30
  • This worked for my client pc's as well.
    mardi 2 décembre 2014 18:50
  • >>I found the answer to this in my environment
    >>http://shammyowens.blogspot.com/2012/02/windows-2008-r2-shared-files-do-not.html

    >>removing 2 explorer keys fixed the problem for us.

    These registry keys resolved my issue as well.     I had to add the keys with a DWord value of 0 (zero) and restart explorer.exe, then the problem went away.

    • Modifié Jon Raines mercredi 17 décembre 2014 17:37
    mercredi 17 décembre 2014 17:36
  • Shammy posted to check these registry values and delete them. If they are not there, use Option 2.

    Option 1:

    Registry entries to delete:

    HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer\NoRemoteRecursiveEvents
    HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer\NoRemoteChangeNotify

    Restart Explorer and see if that has helped the problem.

    Option 2: (If DWORD registry entries are missing)

    Try adding the DWORD registry entries from Shammy's post with a 0 value, restart explorer, and see if that helps.

    HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer\NoRemoteRecursiveEvents 
    HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer\NoRemoteChangeNotify

    • Proposé comme réponse Steve-Frost jeudi 1 décembre 2016 23:00
    mercredi 18 février 2015 19:59
  • we have the same issue it's unbelievable how this can be possible... I first tough this could be a NetApp bug or something but now after reading this thread it's just an epic fail of microsoft. just like excel files on NetApp.
    mardi 7 avril 2015 14:21
  • I reviewed over a dozen posts on this problem and NONE of them actually solved the problem.  The mapped network folder continued to show the X's over the folders.  I checked the mapped network folder from other machines and they succeeded in seeing up-to-date content in the target folder.  

    Finally I tried disabling and then re-enabling the network adapter.  PROBLEM SOLVED.  

    All these convoluted answers from so many different forums were useless.

    dimanche 30 août 2015 08:49
  • Absolutely shocking that this has been allowed to remain an issue for so long (a fix not rolled out as an update).

    Practically wasted a full day on this issue, unpicking bat files and vbs scripts and implementing them as GPOs, only to hit this issue when setting up mapped drives (it just didn't occur when the drives were connected with a script!).

    And the hotfix just hangs instead of completing. Sort it out MS :(

    lundi 18 janvier 2016 13:49
  • Iv'e been wrestling with this for quite awhile in windows 10.  Simple mapped network drive on a two-pc home network.  Your solution finally worked for me.  Thank You Very Much!
    mercredi 24 août 2016 13:31
  • Disable the offline files from the control panel --> open sync center ---> offline files and it might work.
    dimanche 3 septembre 2017 10:37