none
Clé de registre utilsateur GPO RRS feed

  • שאלה

  • Bonjour,

    J'ai écris un script qui test des valeurs dans le registre, et si ca ne correspond pas, je les modifie

    $LOADBEHAVIOR = (Get-ItemProperty -path HKCU:\Software\Microsoft\Office\Outlook\Addins\zzz.SafeSend -Name LoadBehavior).LoadBehavior
    $STARTMODE = (Get-ItemProperty -path HKCU:\Software\Microsoft\Office\Outlook\Addins\zzz.SafeSend -Name ADXStartMode).ADXStartMode
    
    if (($LOADBEHAVIOR -ne "3") -and ($STARTMODE -ne "NORMAL")) {
        Set-ItemProperty -path HKCU:\Software\Microsoft\Office\Outlook\Addins\zzz.SafeSend -Name LoadBehavior -Value "3"
        Set-ItemProperty -path HKCU:\Software\Microsoft\Office\Outlook\Addins\zzz.SafeSend -Name ADXStartMode -Value "NORMAL"
    }

    En local, ca fonctionne.

    Cependant je cherche à déployer ce script par GPO, et là ça ne fonctionne pas

    Vu que mes valeurs se trouve dans le HKCU, ca ne va pas me poser problème ?

    Quel est le compte qui lance les scripts d'ouverture de session ? System ou bien l’utilisateur qui se connecte ? 

    Izhocell

    יום שני 15 יוני 2020 13:19

תשובות

  • Bonjour Izho_cell

    Tu dis que ton script fonctionne localement. Bon point déjà.

    C'est la GPO qui ne semble pas ss'appliquer.

    Cette GPO execute un script (LogonScript) dans la section User probablement, sinon si c'est dans la section Computer, la machine ne sait pas qui est le CurrentUser. Partons donc de ce point. Le scope de cette GPO doit doncviser des Utilisateurs, pas des machines. Logique jusqu'à maintenant, je pense. Alors pourquoi cela ne fonctionne-t-il pas ?

    Depuis un hotfix de 2016, les GPOs s'exécutent dans le contexte machine (c'est à dire que c'est le compte machine qui exécute la GPO. Peu importe que les paramètres soient Users ou Computers). N'aurais-tu pas supprimé Authenticated Users dans la partie Security Settings de la GPO ? Tu peux, mais tu dois alors ajouter Domain Computers (Authenticated users est Domain Users + Domain Computers).

    Group Policy Strategy and Tactics -- Redmondmag.com

    Cordialement

    Olivier

    • סומן כתשובה על-ידי Izho_cell יום שלישי 23 יוני 2020 08:19
    יום חמישי 18 יוני 2020 07:54

כל התגובות

  • Personne a d'idée ? 
    יום רביעי 17 יוני 2020 06:38
  • Salut,

    Si ton script fonctionne sur ta machine il fonctionnera sur les postes, vérifie bien si ta gpo est appliqué, et test avec un autre script témoin.

    יום רביעי 17 יוני 2020 20:00
  • Bonjour Izho_cell

    Tu dis que ton script fonctionne localement. Bon point déjà.

    C'est la GPO qui ne semble pas ss'appliquer.

    Cette GPO execute un script (LogonScript) dans la section User probablement, sinon si c'est dans la section Computer, la machine ne sait pas qui est le CurrentUser. Partons donc de ce point. Le scope de cette GPO doit doncviser des Utilisateurs, pas des machines. Logique jusqu'à maintenant, je pense. Alors pourquoi cela ne fonctionne-t-il pas ?

    Depuis un hotfix de 2016, les GPOs s'exécutent dans le contexte machine (c'est à dire que c'est le compte machine qui exécute la GPO. Peu importe que les paramètres soient Users ou Computers). N'aurais-tu pas supprimé Authenticated Users dans la partie Security Settings de la GPO ? Tu peux, mais tu dois alors ajouter Domain Computers (Authenticated users est Domain Users + Domain Computers).

    Group Policy Strategy and Tactics -- Redmondmag.com

    Cordialement

    Olivier

    • סומן כתשובה על-ידי Izho_cell יום שלישי 23 יוני 2020 08:19
    יום חמישי 18 יוני 2020 07:54
  • Ca fonctionne mieux en filtrant sur le groupe Authenticated User

    Merci Olivier

    יום שלישי 23 יוני 2020 08:20