none
Cluster Issue Exchange RRS feed

  • שאלה

  • Hi everyone,

    We encountered an issue which i'm not possible to solve as of now.
    Our databases are balanced 50/50 over our database server.

    For some reason, the Databases on Exchange1 are working perfectly.
    Database on Exchange2 are not able to receive email, these are stuck in the Exchange Mail Queue with the following error:
    "[{LRT=4/14/2017 9:35:04 AM};{LED=441 4.4.1 Error encountered while communicating with primary target IP address: ""Failed to connect. Winsock error code: 10061, Win32 error code: 10061."" Attempted failover to alternate host, but that did not succeed. Either there are no alternate hosts, or delivery failed to all alternate hosts. The last endpoint attempted was ****:475};{FQDN=****};{IP=*****}]" SOLVED: Restarting the Frontend Transport service a few times


    In Failover Cluster manager i found the following:
    Cluster IP address resource 'IPv4 Static Address 1 (Cluster Group)' cannot be brought online because the cluster network 'Cluster Network 2' is not configured to allow client access. Please use the Failover Cluster Manager snap-in to check the configured properties of the cluster network.

    Cluster core resources show our DAG, with 2 IP Addresses:
    DAG IP = Failed
    Exchange IP = Online

    Could this be related to eachother? And do i have to Enable client access on my DAG IP?

    Our environment:
    2x DC
    2x Exchange 2013 CU16

    Kind regards,
    Justin



    • נערך על-ידי Justin BDS יום שלישי 18 אפריל 2017 12:54 1 solved
    יום שישי 14 אפריל 2017 07:51

כל התגובות

  • Hi everyone,

    We encountered an issue which i'm not possible to solve as of now.
    Our databases are balanced 50/50 over our database server.

    For some reason, the Databases on Exchange1 are working perfectly.
    Database on Exchange2 are not able to receive email, these are stuck in the Exchange Mail Queue with the following error:
    "[{LRT=4/14/2017 9:35:04 AM};{LED=441 4.4.1 Error encountered while communicating with primary target IP address: ""Failed to connect. Winsock error code: 10061, Win32 error code: 10061."" Attempted failover to alternate host, but that did not succeed. Either there are no alternate hosts, or delivery failed to all alternate hosts. The last endpoint attempted was ****:475};{FQDN=****};{IP=*****}]"


    In Failover Cluster manager i found the following:
    Cluster IP address resource 'IPv4 Static Address 1 (Cluster Group)' cannot be brought online because the cluster network 'Cluster Network 2' is not configured to allow client access. Please use the Failover Cluster Manager snap-in to check the configured properties of the cluster network.

    Cluster core resources show our DAG, with 2 IP Addresses:
    DAG IP = Failed
    Exchange IP = Online

    Could this be related to eachother? And do i have to Enable client access on my DAG IP?

    Our environment:
    2x DC
    2x Exchange 2013 CU16

    Kind regards,
    Justin


    What kind of AV do you have installed on the Exchange servers?  Has it been configured properly for Exchange?

    https://technet.microsoft.com/en-us/library/bb332342(v=exchg.150).aspx

     Can you telnet over port 25 between servers?

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread

    יום שישי 14 אפריל 2017 13:04
  • What kind of AV do you have installed on the Exchange servers?  Has it been configured properly for Exchange?

    --

     Can you telnet over port 25 between servers?

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread

    I don't have any so far.
    Both are able to Telnet to eachother and shows "ESMTP MAIL service ready"

    What about the following?
    In Failover Cluster manager i found the following:
    Cluster IP address resource 'IPv4 Static Address 1 (Cluster Group)' cannot be brought online because the cluster network 'Cluster Network 2' is not configured to allow client access. Please use the Failover Cluster Manager snap-in to check the configured properties of the cluster network.

    Cluster core resources show our DAG, with 2 IP Addresses:
    DAG IP = Failed
    Exchange IP = Online




    • נערך על-ידי Justin BDS יום שישי 14 אפריל 2017 14:01
    יום שישי 14 אפריל 2017 14:00
  • Hello,

    To fix this event error, please open the Failover Cluster Manager, then locate to DAG ---> Networks, right-click problematic cluster network to open Properties, then ensure “Allow clients to connect through this network” is checked.
    Figure as below:
         image
    If not, check it and active this network for testing.

    Meanwhile, open EMS and run below command to check the status of server components (by default, ForwardSyncDaemon and ProvisioningRps are not active):
    Get-ServerComponentState <Server Name>
    If the state is Inactive, please run below command to active relevant component:
    Set-ServerComponentState <Identity> -Component “component name” -Requester HealthAPI -State Active

    Best Regards,

    Allen Wang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    יום שני 17 אפריל 2017 15:18
    מנחה דיון
  • Hello,

    To fix this event error, please open the Failover Cluster Manager, then locate to DAG ---> Networks, right-click problematic cluster network to open Properties, then ensure “Allow clients to connect through this network” is checked.
    Figure as below:
         image
    If not, check it and active this network for testing.

    Meanwhile, open EMS and run below command to check the status of server components (by default, ForwardSyncDaemon and ProvisioningRps are not active):
    Get-ServerComponentState <Server Name>
    If the state is Inactive, please run below command to active relevant component:
    Set-ServerComponentState <Identity> -Component “component name” -Requester HealthAPI -State Active

    Best Regards,

    Allen Wang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    I've checked the client connect, but is does not enable.
    My Exchange network is Cluster and Client
    My DAG network is Cluster Only (which does not come up online)
    Error is: "The network is now available for clients to connect to clustered roles in the cluster. However, before this can happen, the client access point for the clustered roles needs to be updated with new IP addresses for this network."

    ForwardSyncDaemon and ProvisioningRps were Inactive on Both servers. Enabled them thanks to your command.

    • נערך על-ידי Justin BDS יום שלישי 18 אפריל 2017 12:55 edit
    יום שלישי 18 אפריל 2017 07:02
  • Only problem i'm left with is:

    In Failover Cluster manager i found the following:
    Cluster IP address resource 'IPv4 Static Address 1 (Cluster Group)' cannot be brought online because the cluster network 'Cluster Network 2' is not configured to allow client access. Please use the Failover Cluster Manager snap-in to check the configured properties of the cluster network.

    Cluster core resources show our DAG, with 2 IP Addresses:
    DAG IP = Failed (Replication network)
    Exchange IP = Online (Client/Replication network)

    יום שלישי 18 אפריל 2017 12:57
  • Hello Justin,

    Run "Get-DatabaseAvailabilityGroup -status | FL" and "Get-DatabaseAvailabilityGroupNetwork | FL " to list all configurations with DAG.

    Also, note that the Replication Network "Register This Connection's Addresses in DNS" should be unchecked.

    More details about it, refer to:
    https://blogs.technet.microsoft.com/shekhar37k/2014/06/03/dag-network-shows-misconfigured-in-exchange-2013-server/

    Best Regards,

    Allen Wang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    יום חמישי 20 אפריל 2017 10:52
    מנחה דיון
  • Hi Allen,

    Thanks for your reply.
    The "Register this connection's addresses in DNS" is indeed off on our replication network.

    I copied the output of your commands:

    ------

    [PS] C:\Windows\system32>Get-DatabaseAvailabilityGroup -status | FL


    RunspaceId                             : efc457ca-243a-4d56-a305-944a9d987b77
    Name                                   : EXCHDAG
    Servers                                : {EXCH02, EXCH01}
    WitnessServer                          : dc01.xxx.local
    WitnessDirectory                       : C:\FSW_EXCHDAG
    AlternateWitnessServer                 :
    AlternateWitnessDirectory              :
    NetworkCompression                     : InterSubnetOnly
    NetworkEncryption                      : InterSubnetOnly
    ManualDagNetworkConfiguration          : False
    DatacenterActivationMode               : Off
    StoppedMailboxServers                  : {}
    StartedMailboxServers                  : {}
    DatabaseAvailabilityGroupIpv4Addresses : {10.0.0.10, 192.168.65.20}
    DatabaseAvailabilityGroupIpAddresses   : {10.0.0.10, 192.168.65.20}
    AllowCrossSiteRpcClientAccess          : False
    OperationalServers                     : {EXCH01, EXCH02}
    PrimaryActiveManager                   : EXCH01
    ServersInMaintenance                   : {}
    ServersInDeferredRecovery              : {}
    ThirdPartyReplication                  : Disabled
    ReplicationPort                        : 64327
    NetworkNames                           : {MapiDagNetwork, ReplicationDagNetwork01}
    WitnessShareInUse                      : Primary
    DatabaseAvailabilityGroupConfiguration :
    AutoDagSchemaVersion                   : 1.0
    AutoDagDatabaseCopiesPerDatabase       : 1
    AutoDagDatabaseCopiesPerVolume         : 1
    AutoDagTotalNumberOfDatabases          : 0
    AutoDagTotalNumberOfServers            : 0
    AutoDagDatabasesRootFolderPath         : C:\ExchangeDatabases
    AutoDagVolumesRootFolderPath           : C:\ExchangeVolumes
    AutoDagAllServersInstalled             : False
    AutoDagAutoReseedEnabled               : True
    AutoDagDiskReclaimerEnabled            : True
    AutoDagBitlockerEnabled                : False
    AutoDagFIPSCompliant                   : False
    ReplayLagManagerEnabled                : False
    MailboxLoadBalanceMaximumEdbFileSize   :
    MailboxLoadBalanceRelativeLoadCapacity :
    MailboxLoadBalanceOverloadedThreshold  :
    MailboxLoadBalanceUnderloadedThreshold :
    MailboxLoadBalanceEnabled              : False
    AdminDisplayName                       :
    ExchangeVersion                        : 0.10 (14.0.100.0)
    DistinguishedName                      : CN=EXCHDAG,CN=Database Availability Groups,CN=Exchange Administrative Group
                                             (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=xxx,CN=Microsoft
                                             Exchange,CN=Services,CN=Configuration,DC=xxx,DC=local
    Identity                               : EXCHDAG
    Guid                                   : 5d4af297-4e18-4799-a173-198c1142eb44
    ObjectCategory                         : xxx.local/Configuration/Schema/ms-Exch-MDB-Availability-Group
    ObjectClass                            : {top, msExchMDBAvailabilityGroup}
    WhenChanged                            : 6/24/2016 5:10:38 PM
    WhenCreated                            : 7/8/2015 3:43:00 PM
    WhenChangedUTC                         : 6/24/2016 3:10:38 PM
    WhenCreatedUTC                         : 7/8/2015 1:43:00 PM
    OrganizationId                         :
    Id                                     : EXCHDAG
    OriginatingServer                      : DC01.xxx.local
    IsValid                                : True
    ObjectState                            : Unchanged



    [PS] C:\Windows\system32> Get-DatabaseAvailabilityGroupNetwork | FL


    RunspaceId         : efc457ca-243a-4d56-a305-944a9d987b77
    Name               : MapiDagNetwork
    Description        :
    Subnets            : {{192.168.65.0/24,Up}}
    Interfaces         : {{EXCH01,Up,192.168.65.12}, {EXCH02,Up,192.168.65.13}}
    MapiAccessEnabled  : True
    ReplicationEnabled : True
    IgnoreNetwork      : False
    Identity           : EXCHDAG\MapiDagNetwork
    IsValid            : True
    ObjectState        : New

    RunspaceId         : efc457ca-243a-4d56-a305-944a9d987b77
    Name               : ReplicationDagNetwork01
    Description        :
    Subnets            : {{10.0.0.0/8,Up}}
    Interfaces         : {{EXCH01,Up,10.0.0.5}, {EXCH02,Up,10.0.0.6}}
    MapiAccessEnabled  : False
    ReplicationEnabled : True
    IgnoreNetwork      : False
    Identity           : EXCHDAG\ReplicationDagNetwork01
    IsValid            : True
    ObjectState        : New

    ----

    • נערך על-ידי Justin BDS יום חמישי 20 אפריל 2017 14:49 extra info
    יום חמישי 20 אפריל 2017 14:45
  • I believe 10.* is your replication network IP and should be assigned to DAG.

    if your both the Exch server are in same site \ subnet you should need only one IP 192.* for DAG.


    Thanks, AJ

    יום חמישי 20 אפריל 2017 15:12
  • Hola Como estas tuviste suerte con tu problema yo tengo un caso similar y quisiera saber si pudiste resolverlo.

    שבת 02 נובמבר 2019 11:11