none
Windows 8.1 Hyper-V : IP address conflict on Guest OS RRS feed

  • שאלה

  • Hi ,

    I have just installed Windows 8.1 and I want to move away from VMWare Player  and use Hyper-V instead.

    I have nevertheless issues with it on the networking side.

    Before setting up my VM, I have:

    - converted my vmdk to a vhd.

    - created a virtual switch in Hyper-V Manager.

    After that, i created the VM using the vhd and the virtual switch created beforehand.

    Once I boot up the guest OS (Windows 7), I have no internet connectivity on the guest OS, and it says : windows has detected an IP address conflict

    Also when I run ipconfig in a command prompt on the guest, I can see an ip address which is the same as my host OS (192.168.1.5) but then I guess that my host system takes the IP back as if i run ipconfig again the IP address is gone. 

    So I guess that my host and guest OS fight for the same IP. Also the message "windows has detected an IP address conflict" appears on the Guest OS.

    Also at times, the guest OS receive a strange IP: 169.254.99.175 which I have no clue where it comes from.

    Does anyone has an idea on how to solve the issue?

    Also here is a screenshot of the configuration of the Virtual Switch :

    Thanks for any help,

    Francois

    יום שלישי 05 נובמבר 2013 12:39

תשובות

  • You need to assign a different IP to either the host or the VM.  You can't have the same IP address.  Check your DHCP server and verify you have free IP addresses and that you're not using reservation to assign the same IP to both.

    169.254.99.175 is a self assigned IP address that Windows uses when it cannot find an authoritative source to get an IP address from: Automatic Private Internet Protocol Addressing (APIPA)

    • סומן כתשובה על-ידי Francois Malgreve יום שלישי 05 נובמבר 2013 22:22
    יום שלישי 05 נובמבר 2013 17:54

כל התגובות

  • You need to assign a different IP to either the host or the VM.  You can't have the same IP address.  Check your DHCP server and verify you have free IP addresses and that you're not using reservation to assign the same IP to both.

    169.254.99.175 is a self assigned IP address that Windows uses when it cannot find an authoritative source to get an IP address from: Automatic Private Internet Protocol Addressing (APIPA)

    • סומן כתשובה על-ידי Francois Malgreve יום שלישי 05 נובמבר 2013 22:22
    יום שלישי 05 נובמבר 2013 17:54
  • Hi,

    I forgot that I indeed configured my router at home to use address reservation! That did not matter with VMWare but I guess the network abstraction layer works differently.

    I have since read a very useful article which points out that both traffic from VMs and host will get translated to the physical NIC MAC address: http://blogs.msdn.com/b/b8/archive/2011/09/07/bringing-hyper-v-to-windows-8.aspx

    So what I can take from that is that as the traffic from both my host and guest OS are seen by the router has having the same mac address, the router was assigning the same IP to both.

    I nevertheless like to have a fixed IP for my host machine as I run various services on it and some clients can only connect through the IP address.

    Do you know if it is supported to use fixed IP instead of DHCP? I would configure my router to limit the DHCP range and assign to my host OS a fixed IP above that range.

    Thanks again!



    • נערך על-ידי Francois Malgreve יום שלישי 05 נובמבר 2013 20:32 typo
    יום שלישי 05 נובמבר 2013 20:25
  • You can use fixed IPs with Hyper-V.  Your MAC address for the VM should not be the same as the MAC for the host.  They may be similar, but not the same.  Hyper-V creates a virtual switch that replaces the physical host's NIC.  Check the MAC you have assigned for your reservation. 

    The VM should still have a unique MAC though, otherwise networking would be broken. 

    I've used static IPs with Hyper-V, but I don't think I've ever set up reservations in a Hyper-V environment.

    יום שלישי 05 נובמבר 2013 20:57
  • Thanks for the precisions!

    Everything is working now.

    Francois

    יום שלישי 05 נובמבר 2013 22:22
  • Hi,

    I forgot that I indeed configured my router at home to use address reservation! That did not matter with VMWare but I guess the network abstraction layer works differently.

    I have since read a very useful article which points out that both traffic from VMs and host will get translated to the physical NIC MAC address: http://blogs.msdn.com/b/b8/archive/2011/09/07/bringing-hyper-v-to-windows-8.aspx

    So what I can take from that is that as the traffic from both my host and guest OS are seen by the router has having the same mac address, the router was assigning the same IP to both.

    I nevertheless like to have a fixed IP for my host machine as I run various services on it and some clients can only connect through the IP address.

    Do you know if it is supported to use fixed IP instead of DHCP? I would configure my router to limit the DHCP range and assign to my host OS a fixed IP above that range.

    Thanks again!



    Hi,

    Is there a way such that the same IP address isn't assigned? I thought the MAC would change for the vm, but my router shows the VM machine assigned the physical MAC. So the router is trying to assign the same IP. I'm having the same issue at work. I'm trying to create a separate win 7 vm for for work.

    Thanks,

    -dan

    שבת 23 נובמבר 2013 00:49
  • Hi Dan,

    I guess that you use IP address reservation on your router (configuring your router so that DHCP always gives the same IP address for a particular MAC address).

    As both your virtual machines and host machine will appear on the network as having the same MAC address, they will both get assigned the same IP by the router.

    The solution is to turn off IP Address reservation. Another option is to assign a fixed IP instead of using DHCP.

    I now here have 3 VMs on my Windows 8 machine, some use fixed IP and some use DHCP and they all work fine. The important part is to make sure your router does not have settings to assign a particular IP for a particular MAC address.

    Good luck!

    Francois


    שבת 23 נובמבר 2013 01:42
  • Hi Dan,

    I guess that you use IP address reservation on your router (configuring your router so that DHCP always gives the same IP address for a particular MAC address).

    As both your virtual machines and host machine will appear on the network as having the same MAC address, they will both get assigned the same IP by the router.

    The solution is to turn off IP Address reservation. Another option is to assign a fixed IP instead of using DHCP.

    I now here have 3 VMs on my Windows 8 machine, some use fixed IP and some use DHCP and they all work fine. The important part is to make sure your router does not have settings to assign a particular IP for a particular MAC address.

    Good luck!

    Francois


    Thanks. Reservation is not configured in the router - I have the option of specifying a MAC address and assigning an IP, but the table is blank. I'm guessing it mayb defaults to it? It's a router from the local ISP.

    In the advanced option of the virtual adapter in Hyper VM, I selected a static MAC. For whatever reason, the VM now has it's own IP address, X.X.X.7. Host is X.X.X.3

    2 strange things though.

    1. I can only access the router config page (X.X.X.1) via the VM. On the host, each time I try to login, it kicks me out. It's a Cox branded Netgear router (from ISP). Once I shutdown the VM, I can access the router config page on the host.

    2. When looking at the list of connected clients in the router, it only shows the Machine name for the host - however, the corresponding IP address shown is that of the VM.

    Weird ...

    Anyway, not so concerned with having it work at home - it will be more so for at work.


    • נערך על-ידי dan.crouthamel שבת 23 נובמבר 2013 13:25 Clarification
    שבת 23 נובמבר 2013 06:26
  • Hi all, has this issue been fixed ?? I'm having the exact same problem. Router only sees host physical address
    יום חמישי 10 אפריל 2014 12:42
  • Hi,

    I am not sure if it is clear or not in my previous post but the way I fixed this issue is by giving the host and all VMs a fixed IP address.

    Francois.

    יום חמישי 10 אפריל 2014 14:06
  • Hi. 

    I'm having the same problem.

    But; My computer MAC address isn't locked in the router. I don't want to set static IP addresses as I have different IP ranges at home and at work. If I use static IP addresses I have to manually change them every time I switch location. This is not an option for me.

    I have tried to set different MAC addresses in the settings for each virtual guest OS as not to conflict in any way with the host OS or other virtual guest machines. To no avail since I still get an IP conflict.

    Any bright and shiny new ideas of how to solve it?    =o)

    יום שני 15 ספטמבר 2014 18:18
  • I'm having also, the same issue @ work and because I don't control their WIFI, nor do I really know how they control their super secure network, the issue is very annoying.

    Heck I have a hard time staying connected @ my current work site - and this IP issue doesn't make it any easier.

    Am I also, from the OP, to infer that VMware takes care of this for you?

    Sure would like Microsoft to address this.

     

    יום רביעי 26 נובמבר 2014 01:18
  • VMware Workstation and Player have a build in NAT solution allowing a VM to share the host's network connection.

    If you create a virtual switch, each VM will get it's own unique MAC address.  If you're router is only seeing one MAC and you have a VM running, there's something not configured correctly.

    Alternately, if you're doing something crazy like directly connecting your host PC to your cable/dsl modem and not using a router, you're likely hitting the one IP restriction that most ISPs have.

    יום רביעי 26 נובמבר 2014 19:43
  • Hi. 

    I'm having the same problem.

    But; My computer MAC address isn't locked in the router. I don't want to set static IP addresses as I have different IP ranges at home and at work. If I use static IP addresses I have to manually change them every time I switch location. This is not an option for me.

    I have tried to set different MAC addresses in the settings for each virtual guest OS as not to conflict in any way with the host OS or other virtual guest machines. To no avail since I still get an IP conflict.

    Any bright and shiny new ideas of how to solve it?    =o)

    You don't need to "set" different MAC addresses, Hyper-V will automatically assign a unique MAC to each VM.  There's no need to do this unless you're moving VMs between Hyper-V hosts.

    יום רביעי 26 נובמבר 2014 19:44
  • Well perhaps I'm doing something wrong, allowing the system to do all the wiring.

    The Virtual Switch was configured by the system.

    With respect to what the router sees, considering I use my rig in a corporate environment (on site at a clients office), no really clue what their router sees.

    Also, and when I can get away with it, I use a dedicated RJ45 connection for my Hyper-v image, which resolve the issue completely.  That is, when I can... Network setting at my current client prevent me from using their RJ45... So I'm stuck with WIFI for both my 8.1 Enterprise, and the Windows 7 image that it hosts.


    • נערך על-ידי BillRoberts יום רביעי 26 נובמבר 2014 20:11
    יום רביעי 26 נובמבר 2014 20:06
  • You don't need to "set" different MAC addresses, Hyper-V will automatically assign a unique MAC to each VM.  There's no need to do this unless you're moving VMs between Hyper-V hosts.

    So why this error happens on DHCP addressing?
    שבת 09 מרץ 2019 02:28