none
32 bit ODBC driver for MS Access 2010 (*.accdb) is missing in Win7 64bit RRS feed

  • שאלה

  • I have Win7 and Office 2010 both 64 bit. I also have a 32 bit application running where I need a 32 bit *.accdb  (MS Access) ODBC driver. Using the 64-bit version of the Odbcad32.exe is returning “The specified DSN contains an architecture mismatch between the Driver and Application”. So I need a 32 bit ODBC *.accdb driver for my application.

    My problem:

    When I open c:\windows\SysWOW64\odbcsys32.exe and try to ADD a new dsn there is only a *.mdb driver available for MS Access. Does anyone know how to add a 32 bit MS Access *.accdb driver to c:\windows\SysWOW64\odbcsys32.exe? Maybe I missed something obvious but this is giving me headache after browsing through the Internet for a solution. 

     

    Thanks

     

    יום שני 30 מאי 2011 23:52

תשובות

  • Carl, I just figured out a solution... If you are running a 64-bit Computer and Running Access 2010, you will first need to download the AccessDatabaseEngine.exe from Microsoft.

    http://www.microsoft.com/downloads/en/details.aspx?familyid=7554F536-8C28-4598-9B72-EF94E038C891&displaylang=en

    After the download finishes, and installs, You will need to create an ODBC connection. Instead of creating an ODBC connection through your Administrative Tools, Data Sources (ODBC) interface, you will need to run the 64-bit instance of Data Sources (ODBC). To do this, you will need to click your "Windows" + "R" buttons on the keyboard, and then paste "c:\windows\sysWOW64\odbcad32.exe" -- without quotes into the dialog. Then create the connection to the database as you would on a 32 bit machine.

     

    I had the same issues with the *.accdb not showing up in my 64 bit ODBC connections. It then showed up after performing the above steps.

     

    Hope this Helps,

     

    Alex Mahrou

    • הוצע כתשובה על-ידי Rockymountaingeo יום שישי 10 יוני 2011 15:26
    • סומן כתשובה על-ידי David WoltersModerator יום חמישי 03 אפריל 2014 16:45
    יום שישי 10 יוני 2011 15:25

כל התגובות

  • Hi,

     

    It seems to be more of ODBC drivers configuration, I recommend you to post in MSDN forum so as to get the specific resource.

     

    Meanwhile, I would like to share the following article with you:

     

    Managing Data Sources

     

    Hope it helps.

     

    Alex Zhao


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    יום רביעי 01 יוני 2011 08:01
    מנחה דיון
  • Carl, I just figured out a solution... If you are running a 64-bit Computer and Running Access 2010, you will first need to download the AccessDatabaseEngine.exe from Microsoft.

    http://www.microsoft.com/downloads/en/details.aspx?familyid=7554F536-8C28-4598-9B72-EF94E038C891&displaylang=en

    After the download finishes, and installs, You will need to create an ODBC connection. Instead of creating an ODBC connection through your Administrative Tools, Data Sources (ODBC) interface, you will need to run the 64-bit instance of Data Sources (ODBC). To do this, you will need to click your "Windows" + "R" buttons on the keyboard, and then paste "c:\windows\sysWOW64\odbcad32.exe" -- without quotes into the dialog. Then create the connection to the database as you would on a 32 bit machine.

     

    I had the same issues with the *.accdb not showing up in my 64 bit ODBC connections. It then showed up after performing the above steps.

     

    Hope this Helps,

     

    Alex Mahrou

    • הוצע כתשובה על-ידי Rockymountaingeo יום שישי 10 יוני 2011 15:26
    • סומן כתשובה על-ידי David WoltersModerator יום חמישי 03 אפריל 2014 16:45
    יום שישי 10 יוני 2011 15:25
  • I am having the same problem... the Microsoft Access Driver (*.mdb, *.accdb) does not show up in the 32 bit ODBC driver manager on my 64-bit Windows Vista computer.  I tried the solutions offered thus far but have no luck.

     Did anyone offer a solution?


    Andy
    שבת 25 יוני 2011 03:01
  • I am also facing same issue on Windows Server 2008 R2, any resolution? Where can i download Access 32 Bit drivers?

    Regards,

    Masood Mustufa

    שבת 17 מרץ 2012 08:37
  • Great - that works.

    Many thanks

    יום רביעי 11 ספטמבר 2013 08:31
  • Excelente, busque la solucion por varios dias, trabaje mucho sin resultados hasta que llegue a esta Gran Solucion, Felicidades y Gracias.
    שבת 28 ספטמבר 2013 18:24
  • Correct me if I'm wrong, but isn't odbcad32.exe the 32-bit version of ODBC?

    If you find a reply helpful, please click "Vote as Helpful", if a reply answers your question, please click "Mark as Answer." By doing this you'll help people find answers faster.

    • הוצע כתשובה על-ידי ISS - JohnA יום חמישי 08 ינואר 2015 19:45
    • הצעה כתשובה בוטלה על-ידי ISS - JohnA יום חמישי 08 ינואר 2015 19:53
    יום שישי 10 ינואר 2014 12:13
  • Perfectly works......... *****
    יום חמישי 03 אפריל 2014 06:27
  • GRACIAS, CON ESTO PUEDO CONTINUAR CON MIS PROYECTOS
    יום שלישי 27 מאי 2014 00:46
  • It would seem, from the following responses, that no one really understands our dilemma.  I have a server based app as well as a SQLExpress DB, both 32 bit, trying to connect to a MS 2007 Access Db, also 32 bit, running on Windows 7 (64 bit). If I run ODBCAD32.exe (64 bit), I have all the drivers I need. But, if I run ODBCAD32.EXE (32 bit), ALL I have are 2 32 bit SQL drivers. Hence the Driver Mismatch.  We need the Old  32 bit MS Access Drivers to be installed in the Windows\Systems32 folder.

    Can we just install the files and edit the registry manually?

    Any input form Microsoft would be greatly appreciated.

    Kindest regards

    John Anderson

       
    יום חמישי 08 ינואר 2015 19:33
  • At least for Windows 7, a copy of ODBCAD32.exe exists in both folders:

    C:\Windows\SysWOW64\odbcad32.exe -(64 Bit)

    C:\Windows\System32\odbcad32.exe -(32 Bit)

    When each are Launched, one at a time, the results are different.

    • הוצע כתשובה על-ידי ISS - JohnA יום חמישי 08 ינואר 2015 19:50
    יום חמישי 08 ינואר 2015 19:50
  • I am resurrecting this old thread since this is at the top of search results for 32-bit Access drivers on 64-bit Windows 7 and because the accepted answer is completely wrong.

    The 32-bit ODBC is in the SysWow64 directory and the 64-bit ODBC is in the System32 directory.  If you have 32-bit Office installed or if you have no Office installed, you can use the Office 2010 Redistributable files that others have linked.  If you have 64-bit Office installed, the 32-bit redistributable files will NOT install.  Instead it wants to force you to uninstall 64-bit Office first.  This is pretty severe for just a 32-bit driver! (yes I understand there is more to this than the driver.. My point still stands - it is pretty severe).

    To get around this problem, you must install the 32-bit redistributable files from the command line and pass the argument /passive to it:

    C:\MyDir\> AccessDatabaseEngine.exe /passive

    By using this option I have successfully installed the 32-bit drivers on my 64-bit system and am able to open .accdb files from 32-bit applications.

    • נערך על-ידי Jon Raiford יום שני 08 אוגוסט 2016 19:01 remove footer
    • הוצע כתשובה על-ידי Jon Raiford יום שני 08 אוגוסט 2016 19:03
    יום שני 08 אוגוסט 2016 18:59
  • This solution works fine for me and it is easy to do.... super
    יום שישי 12 אוגוסט 2016 07:56
  • Thank you for completely understanding this issue, and giving the perfect simple solution!! It works!
    יום חמישי 01 ספטמבר 2016 02:28
  • Thank you! The other solution did not work for me, but yours worked perfectly.  Much appreciated.
    יום חמישי 26 ינואר 2017 00:54
  • Six years later and this solution still rocks - thank you!
    יום חמישי 22 יוני 2017 17:27
  • Thank you for this Jon Raiford. I have been struggling with this for a couple of weeks and this solved the problem for me (installing the 32-bit with the /passive argument). I am going to add a little bit of detail about what I had set up just in case it may help someone find this post/solution when searching.

    I am running Visual Studio 2015 on a Windows 10 64-bit machine with 64-bit Office Professional installed. In the Visual Studio Report Designer when I was trying to create a new Data Source pointing to the Access database (.accdb file) I was receiving the following error:

    The 'Microsoft.ACE.OLEDB.12.0' provider is not registered on the local machine.

    I also came across the "solution" of uninstalling the 64-bit version of Access and replacing it with the 32-bit version, but this was unacceptable to me.


    • נערך על-ידי Mike Foitzik יום חמישי 02 נובמבר 2017 21:52
    יום חמישי 02 נובמבר 2017 21:52
  • Could you please elaborate on how to "install the 32-bit redistributable files from the command line and pass the argument /passive to it:"? A step-by-step would be much appreciated as I have no idea what any of this means nor does my IT department.

    Thanks!

    יום שני 08 אוקטובר 2018 21:33
  • Could you please elaborate on how to "install the 32-bit redistributable files from the command line and pass the argument /passive to it:"? A step-by-step would be much appreciated as I have no idea what any of this means nor does my IT department.

    Thanks!

    * Download the 32-bit Access Engine from the following link into a local directory (C:\MyDir\):

    http://www.microsoft.com/downloads/en/details.aspx?familyid=7554F536-8C28-4598-9B72-EF94E038C891&displaylang=en 

    * Open a command prompt:

    https://www.digitalcitizen.life/7-ways-launch-command-prompt-windows-7-windows-8

    * Run the Access Engine installer, passing the "/passive" command line argument:

    Microsoft Windows [Version x.x.xxxx]
    Copyright (c) xxxx Microsoft Corporation. All rights reserved.
    
    C:\Users\xxxx> cd \MyDir
    
    C:\MyDir> AccessDatabaseEngine.exe /passive

    • נערך על-ידי Jon Raiford יום שלישי 09 אוקטובר 2018 13:39
    • הוצע כתשובה על-ידי Jon Raiford יום שלישי 09 אוקטובר 2018 13:40
    יום שלישי 09 אוקטובר 2018 13:37