none
Installed Memory(RAM): 4.00(3.24GB usable) RRS feed

תשובות

  • I confirmed that the maximum memory box is NOT checked. By the way I noticed that in the same dialogue box there was "Number of Processors" which was not check marked.  So, I added a check mark and set the number as 2.  I let the system reboot and found that (3.2GB usable) was no longer there. I removed the check mark(& reboot) but (3.2GB usable) did not come back.  I did not check the Installed Memory(RAM) immediately prior to doing that change so that i am not sure what caused the (3.2GB usable) to disappear.
    • סומן כתשובה על-ידי Dale QiaoModerator יום רביעי 09 ספטמבר 2009 05:54
    יום שלישי 08 ספטמבר 2009 00:57
  • Symptom:  4GB or more than 4GB memory cannot be recognized in Windows 7 x64.

     

    Cause: 1. Motherboard does not support more than 4GB memory.

                 2. Motherboard does not support Memory Remap feature.

                 3. PAE switch has not been enabled.

     

     

    Workaround/Resolution:

     

    Suggestion 1: Use BCDEDIT to enable PAE switch.

    =======================================

    1. Please close all the open windows.
    2. Click the Start Button, click "All programs", and click "Accessories".
    3. Right-click "Command Prompt", in the right click menu, please click "Run as Administrator". (Run Command Prompt as Administrator is the key step.)

     

    Note: If you are prompted for an administrator password or for a confirmation, type the password, or click Allow.


    4. In the "Administrator: Command Prompt" window, type in "Bcdedit /set PAE ForceEnable" (without the quotes) and press Enter.

     

    Please note: There is a space between “Bcdedit”, “/set”, “PAE” and “ForceEnable”.

     

    Reference: http://msdn.microsoft.com/en-us/library/aa906211.aspx

    Suggestion 2: Enable Memory Remap feature and Execute Disable Bit (for CPU configuration) in BIOS/CMOS

    ==========================================

    Please understand that Microsoft does not provide support to enter the BIOS, modify any of the settings or upgrade the BIOS. It is the responsibility of the computer manufacturer to provide support for the BIOS.

     

    Please confirm with your computer or motherboard manufacture if there is a Memory Remap feature and Execute Disable Bit (for CPU configuration) in BIOS/CMOS, and Enable the functions with the help of the Support Engineer of your computer or motherboard manufacturer.

     

    Note: If you are planning to buy a new DIY computer, please confirm with the Motherboard venders that it supports Memory Remap feature.

     

    Suggestion 3: Uncheck the option "Maximum Memory"

    ============================

    1. Click Start, type "MSCONFIG" (without the quotation marks) in the Search Bar and Press Enter to start the System Configuration Utility.

     

    Note: Please click the Continue if the "User Account Control" window pops up.

     

    2. Click the Boot tab, then "Advanced Options".

    3. Uncheck the "Maximum Memory" box if it is checked.

    4. Restart the computer and check if more memory can be recognized by the system.

     

    What’s the result? Is the full memory detected in task manager?

     
    Cheers,
    Michael

    • סומן כתשובה על-ידי Dale QiaoModerator יום רביעי 09 ספטמבר 2009 05:54
    יום שלישי 08 ספטמבר 2009 13:29

כל התגובות

  • Select the Start orb, then type   msconfig   in the  search box and hit enter. Under the Boot tab, Advanced options, make sure that the maximum memory box in NOT checked.

    יום שני 07 ספטמבר 2009 22:14
  • I confirmed that the maximum memory box is NOT checked. By the way I noticed that in the same dialogue box there was "Number of Processors" which was not check marked.  So, I added a check mark and set the number as 2.  I let the system reboot and found that (3.2GB usable) was no longer there. I removed the check mark(& reboot) but (3.2GB usable) did not come back.  I did not check the Installed Memory(RAM) immediately prior to doing that change so that i am not sure what caused the (3.2GB usable) to disappear.
    • סומן כתשובה על-ידי Dale QiaoModerator יום רביעי 09 ספטמבר 2009 05:54
    יום שלישי 08 ספטמבר 2009 00:57
  • Well I'm glad it worked out and I hope it stays that way for you.
    יום שלישי 08 ספטמבר 2009 01:35
  • This is off-topic but it is about "Number of Processors". I never pay attention to this before so that I would think the default setting of no check mark is OK. But I wonder under what circumstance this should be check-marked.  My PC is a dual Opteron cpu system(two single core Opterons).
    יום שלישי 08 ספטמבר 2009 12:21
  • Symptom:  4GB or more than 4GB memory cannot be recognized in Windows 7 x64.

     

    Cause: 1. Motherboard does not support more than 4GB memory.

                 2. Motherboard does not support Memory Remap feature.

                 3. PAE switch has not been enabled.

     

     

    Workaround/Resolution:

     

    Suggestion 1: Use BCDEDIT to enable PAE switch.

    =======================================

    1. Please close all the open windows.
    2. Click the Start Button, click "All programs", and click "Accessories".
    3. Right-click "Command Prompt", in the right click menu, please click "Run as Administrator". (Run Command Prompt as Administrator is the key step.)

     

    Note: If you are prompted for an administrator password or for a confirmation, type the password, or click Allow.


    4. In the "Administrator: Command Prompt" window, type in "Bcdedit /set PAE ForceEnable" (without the quotes) and press Enter.

     

    Please note: There is a space between “Bcdedit”, “/set”, “PAE” and “ForceEnable”.

     

    Reference: http://msdn.microsoft.com/en-us/library/aa906211.aspx

    Suggestion 2: Enable Memory Remap feature and Execute Disable Bit (for CPU configuration) in BIOS/CMOS

    ==========================================

    Please understand that Microsoft does not provide support to enter the BIOS, modify any of the settings or upgrade the BIOS. It is the responsibility of the computer manufacturer to provide support for the BIOS.

     

    Please confirm with your computer or motherboard manufacture if there is a Memory Remap feature and Execute Disable Bit (for CPU configuration) in BIOS/CMOS, and Enable the functions with the help of the Support Engineer of your computer or motherboard manufacturer.

     

    Note: If you are planning to buy a new DIY computer, please confirm with the Motherboard venders that it supports Memory Remap feature.

     

    Suggestion 3: Uncheck the option "Maximum Memory"

    ============================

    1. Click Start, type "MSCONFIG" (without the quotation marks) in the Search Bar and Press Enter to start the System Configuration Utility.

     

    Note: Please click the Continue if the "User Account Control" window pops up.

     

    2. Click the Boot tab, then "Advanced Options".

    3. Uncheck the "Maximum Memory" box if it is checked.

    4. Restart the computer and check if more memory can be recognized by the system.

     

    What’s the result? Is the full memory detected in task manager?

     
    Cheers,
    Michael

    • סומן כתשובה על-ידי Dale QiaoModerator יום רביעי 09 ספטמבר 2009 05:54
    יום שלישי 08 ספטמבר 2009 13:29
  • Thank you for the detailed solutions for this problem case and I permanently saved your post for my future reference.
    The problem, however, has gone away now as indicated in one of my previous posts. I do not know for sure whether what I did solved the problem.
    יום שלישי 08 ספטמבר 2009 15:23
  • It sounds like you simply have some shared video memory consuming a portion of your physical memory (RAM).
    יום שלישי 08 ספטמבר 2009 15:57
  • An external PCI video adaptor is used and there is no integrated video card on the motherboard.
    יום שלישי 08 ספטמבר 2009 17:12
  • An integrated video card on the motherboard is not necessary for Windows (7 or Vista) to allocate RAM to the shared memory pool. See the following discussion, which is fairly exhaustive:

    http://forums.techarena.in/vista-hardware-devices/702054.htm
    יום שלישי 08 ספטמבר 2009 19:32
  • has no bearing on missing memory at all.  This only effects 32bit.. not 64bit.  Check perfmon and see if it is the full amount of memory.
    יום שלישי 08 ספטמבר 2009 20:22
  • I read through the thread and could not determine the conclusion out of the discussions.  Anyway I no longer have that problem as previously stated though I do not know why it went away. 
    יום שלישי 08 ספטמבר 2009 20:41