2 problems after updating to windows 8.1 RRS feed

  • Pertanyaan

  • I have 2 problems after updating to windows 8.1,

    1. My mouse does not work anymore, I`ve tried deleting the drivers and reinstalling them. But still doenst help the problem. Same goes for my external hardrive, the light goes on, so it`s provided with power but I cant make a connection with it.

    2. When i right-mouse click on for example my recycle bin to empty it. The screen flashes and all the active programs close. I thought i might fix this with and update to my graphics card, but that did`t work either.

    I`m using an:

    Asus notebook, N56V.
    Geforce GT630M
    Intel core I7
    Intel CPU

    Thanks allot in advance!

    Kamis, 21 November 2013 21.49


Semua Balasan

  • Update:

    I`ve tried reinstalling the chipset and bios.
    I`ve also tried the troubleshooting tool and its solutions.
    The problems brought up is that the following devices are not working properly:

    Intel(R) 7 Series/C216 Chipset Family USB Enhanced Host Controller - 1E26
    Intel(R) 7 Series/C216 Chipset Family USB Enhanced Host Controller - 1E2D
    USB xHCI - compatible hostcontroller

    If I uninstal these 3 devices and reboot, the problem keeps existing, even when I delete them and reinstal the chipset driver.

    Kamis, 21 November 2013 22.58
  • And now my hotkeys have stopped working aswell...
    I could really use some help guys!
    Kamis, 21 November 2013 23.19
  • Hi,

    According to your description,I suggest you update all drivers to the latest version by Asus website.

    Meanwhile,please update the Host Controller Driver by the following website.

    Keep post.


    Kelvin hsu
    TechNet Community Support

    • Ditandai sebagai Jawaban oleh 暁北Moderator Kamis, 05 Desember 2013 01.00
    Senin, 25 November 2013 14.49
  • Hi.

    You should replace the CM_DEVCAP_REMOVABLE flag with the CM_DEVCAP_SURPRISEREMOVALOK for the device capabilities of the Fresco Logic device (HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\PCI\VEN_1B73&DEV_1000&SUBSYS_10391043&REV_04\...\capabilities)

    Take a look at your USB3 controller - guess that is a Fresco Logic Controller?

    If so, Microsoft is distributing not just an incompatible USB3 driver for that one in this case - but really, the device capabilities flags seem to be set wrongly for the removale capabilities of the Fresco Logic Device (Fresco Logic device or the Asus latop does not support the CM_DEVCAP_REMOVABLE - taking a look at the ASUS software package - ASUS is removing the  CM_DEVCAP_REMOVABLE flag and replacing that setting with the CM_DEVCAP_SURPRISEREMOVALOK).

    Simply, if set the CM_DEVCAP_REMOVABLE flag it will take down the Intel USB Enhanced Host Controller ... i.e. the yellow bangs.

    So start up regedit this way:

    1) ... goto (Microsoft fast download site, i.e. check and download the program psexec

    2) ... in order to change those protected flags .... psexec -i -d -s c:\windows\regedit.exe (-s starts up regedit with the system account taking advantage of the protected permissions setting of that part of the hierarchy in WinDB/registry)

    3) ... and goto HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\PCI\VEN_1B73&DEV_1000&SUBSYS_10391043&REV_04\...\capabilities and remove CM_DEVCAP_REMOVABLE by setting Capabilities from 0x0000006 to 0x00000082 (ASUS setting: remove CM_DEVCAP_REMOVABLE + add CM_DEVCAP_SURPRISEREMOVALOK ... i.e. ASUS sets CM_DEVCAP_SURPRISEREMOVALOK instead of CM_DEVCAP_REMOVABLE. So ASUS must have tested CM_DEVCAP_SURPRISEREMOVALOK  to work more reliably than CM_DEVCAP_REMOVABLE with the Fresco Logic Controller?).

    #define CM_DEVCAP_EJECTSUPPORTED    (0x00000002)
    #define CM_DEVCAP_REMOVABLE         (0x00000004)
    #define CM_DEVCAP_SURPRISEREMOVALOK (0x00000080)



    Some more history on the reporting of this issue for laptops etc with a pre-Ivy chipset from Intel (i.e. 3rd party USB 3.0 controller - typically Fresco Logic in the Asus case):

    See my post on the my testing of this during the Win8 previews:

    See my post on this issue a few days before that:

    See more people about half a year after that having this kind of problem:

    Selasa, 03 Desember 2013 10.33
  • Take a look at my previous post in this thread for more details.

    Microsoft should replace the CM_DEVCAP_REMOVABLE flag with the CM_DEVCAP_SURPRISEREMOVALOK for the device capabilities of the Fresco Logic device ... i.e. 0x00000082 instead of 0x00000006.(HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\PCI\VEN_1B73&DEV_1000&SUBSYS_10391043&REV_04\...\capabilities)

    ASUS found it nessecary to do this. No more yellow bangs.

    During any of the Win8 previews this also happened to make the controller work correctly.

    If not, the Fresco Logic device will for some reason put down the Intel ... USB Enhanced Host Controller with yellow bangs.

    Selasa, 03 Desember 2013 11.00
  • Hello, I have a similar problem with my Intel USB 3.0 eXtensible Host Controller -100 (Microsoft) I have an:

    Asus K55A Notebook

    Core i3-3110M

    Intel 7 Series/c216 Chipset

    8 GB DDR 3 Dual Channel (2x4 GB) 1600 MHz

    Samsung 840 250 GB SSD

    Windows 8.1 Pro (x64) RTM 9600 Build

    I have x1 USB 2.0 and x2 USB 3.0... Everything I connect to usb port 1 which is 2.0, shows up under Usb Root HUB (xHCI) The 3.0 controller... And nothing under the USB Enhanced Controller....  All my ports work, but at 2.0 speeds... The other USB Enhanced Controller has an integrated Asus USB2.0 Webcam under it and it works... The send USB EHCI Controller is what shows nothing connected to it only a root hub and generic usb hub... Also I noticed that the 3.0 Controller Hardware ID's are


    And Matching Device ID is: PCI\CC_0C0330... But this is what it show under Location Paths:


    And under capabilities I only have: 00000000 Windows updated to a new driver with a Nov. 2013 date and I can't even reinstall the original 3.0 driver that was installed during Windows clean install...

    Jumat, 24 Januari 2014 01.20
  • I have Asus X750LA. It upgraded to Windows 8.1, but Asus website has drivers only for Windows 8 yet.

    Loss of USB port was caused by USB charger plus (USBChargePlus_Win*_64_VER315), after installation and following restart. Uninstall of this solves the problem.

    Others also suggested to uninstall LiveUpdate of 8.1 to prevent losing ports again:

    • Diedit oleh maria.g Kamis, 26 Juni 2014 22.42
    Kamis, 26 Juni 2014 22.36
  • Try something simpler...

    Right click on the Intel(R) 7 Series/C216 Chipset Family USB Enhanced Host Controller - 1E26

    Select to update driver, then select Browse My Computer to locate driver and select To Manually select driver.

    You will get 2 option with compatible driver

    a. same Intel(R) 7 Series/C216 Chipset Family USB Enhanced Host Controller - 1E26 and

    b. Standard Enhanced PCI to USB Host Controller. Select this one. Let it finish. It will remove any conflict, will fix all missing USB device not working (mouse etc) and re-install all connected devices to the controller...

    You can try same after all installed to put back specific driver (Intel(R) 7 Series/C216 Chipset Family USB Enhanced Host Controller - 1E26 ) or leave as is... &

    • Disarankan sebagai Jawaban oleh Spiro R Kamis, 25 Desember 2014 14.28
    • Diedit oleh Spiro R Kamis, 25 Desember 2014 15.17
    Kamis, 25 Desember 2014 14.27
  • Thanks, a lot.It solve my problem after few days 'googling'.

    Kamis, 27 Agustus 2015 02.46
  • Hi!

    I realize this post is from almost 6 years ago, but I have been experiencing the same issues, and I think you may know where to direct me. I apologize in advance for the length of this post!

    I have a Dell Precision 5400, with Intel 5400 chipset, and Intel quad-core Xeon E5405 processors, which I have been trying to fix for over 2 weeks! This all started after Windows update on the 17th. I have no USB functionality AT ALL. I am using my old PS/2 keyboard with mouse keys to work on the machine. There is also an "unknown device" stuck in the Universal Serial Bus Controllers section in Device Manager (w/no yellow blast) that I cannot get rid of no matter what I do.

    I was working with Windows 7 when this started (mouse started to hang) , and originally thought it was dying mouse batteries, but they tested fine...then as it progressed  (no mouse, keyboard locking up, then nothing responding...had to do a forced shutdown),  l thought it was ransomware or a virus, but all tests were fine. I contacted Microsoft and they kept pushing for me to do a clean installation, which I tried to avoid at all costs. Days later, after trying everything I could think of, hours on the phone with MS, and searching exhaustively online, I finally gave in and did the clean install from a full version ISO that they sent me...and all that did was make matters worse! Not only did it not fix the issues with the USB, but I lost my Dell service pack drivers, which are no longer available on!

    From there, my only choice was to wipe the drive again, and do a clean installation of Vista (since that's what came on this system, and I had the installation cd, resource cd, and the drivers are available on Dell's site). The plan being to use my Windows 7 upgrade disk to get back to 7 once this is sorted out. Now, I know this is an older system, and with 7 ending support in January, I have every intention of replacing it by then, but I am a freelancer, and I need this system to do my work (not to mention I'd need my usb backup to save everything to transfer it to a new machine),. I had no idea when this started that it would be 2 weeks later and I would still be trying to fix this!!!

    I have come to the conclusion after trying every possible "fix", "tip", and "answer", that there is something that needs to get changed in the registry that is keeping this unknown device stuck on my system, even through multiple clean installations, and that unknown device issue, on top an Intel driver issue, is somehow disabling all usb functionality on the machine.

    Unfortunately, because I am currently trying to figure this out in Vista, I do not have the same folders or key values rhat you are referring to. I get to PCI and then they are all VEN_####&DEV_####&SUBSYS_########REV_## (where # is either a number or letter). Inside these folders (& there are 23 that have some reference to Intel) there are mostly folders named 3&172e68dd&0&## , with only a couple others that are variants of 4&11f150d1&0&0### and 5&33cd923f&0&0######. Inside the second sets of numbered folders are folders named Control, Device Parameters, LogConf, and Properties, and there are some other folders inside some of these folders as well. Unfortunely, I do not see any keys named CM_DEVCAP or anyhing close to that either. i have been working on computers for a long time, but I am not too keen on making guesses when it comes to editing the registry. I don't want to make anything worse! I am hoping that you might know how I can attempt to apply your fix on this OS. I think this may be the trick to finally fix this problem (fingers crossed).

    I am really at my wit's end with this and any help you can offer would be greatly appreciated!

    Thank you very much for your time! I look forward to your response.

    Kamis, 01 Agustus 2019 20.23