none
Configurare uno script di arresto del sistema per impostare il corretto DefaultUserName. RRS feed

  • Domanda

  • Buongiorno,

    ho configurato autologon con la procedura proposta da Microsoft:

    Spesso però sui nostri pc si presenta l'errore come scritto nell'articolo:

    Un accesso interattivo alla console con un altro utente sul server modifica la voce di registro DefaultUserName come l'ultimo indicatore di utente connesso. AutoAdminLogon si affida la voce DefaultUserName per abbinare l'utente e password. Pertanto, AutoAdminLogon può non riuscire. È possibile configurare uno script di arresto del sistema per impostare il corretto DefaultUserName

    Sapete dirmi come fare uno script che ad ogni riavvio o arresto mi imposta il corretto DefaultUserName?

    Saluti

    Carmine

    lunedì 1 aprile 2019 13:25

Tutte le risposte

  • Se ti trovi in un dominio puoi anche creare una GPO che imposta, tramite una voce registry delle preferenze dei criteri di gruppo, la chiave DefaultUserName.

    In alternativa puoi creare un semplice .bat con all'interno un comando reg add:
    https://docs.microsoft.com/en-us/windows-server/administration/windows-commands/reg-add

    E inserirlo come script di avvio sempre mediante le GPO (in questo caso anche locali).

    lunedì 1 aprile 2019 14:18
    Moderatore
  • Ciao,

    mi puoi aiutare a scrivere .bat? Non sono molto esperto

    Grazie

    lunedì 1 aprile 2019 14:57
  • Penso che ci sia qualcosa che non torna nel modo in cui hai settato l'autologon, potresti postare il link con la procedura che hai usato?

    Quello che segue è un batch per abilitare l'autologon, esguito un volta, ad ogni riavvio il pc accederà con l'utente spcificato

    :: EnableAl.cmd @echo off echo Deve essere eseguito come elevato: tasto Dx esegui come amministratore ... echo Abilito AutoLogon: creo il batch eAL.cmd in %TEMP% :: -- Attendo 5 secondi per far leggere il messaggio timeout 5 ::-- creo cmd enable Auto Logon ECHO >"%temp%\eAL.cmd" @ECHO off ECHO>>"%temp%\eAL.cmd" REG ADD "HKLM\Software\Microsoft\Windows NT\CurrentVersion\Winlogon" /v AutoAdminLogon /t REG_SZ /d 1 /f ECHO>>"%temp%\eAL.cmd" REG ADD "HKLM\Software\Microsoft\Windows NT\CurrentVersion\Winlogon" /v DefaultDomainName /t REG_SZ /d DOMINIO /f ECHO>>"%temp%\eAL.cmd" REG ADD "HKLM\Software\Microsoft\Windows NT\CurrentVersion\Winlogon" /v DefaultUserName /t REG_SZ /d utente /f ECHO>>"%temp%\eAL.cmd" REG ADD "HKLM\Software\Microsoft\Windows NT\CurrentVersion\Winlogon" /v DefaultPassword /t REG_SZ /d password /f

    :: -- Eseguo il batch appena creato per abilitare l'autologon "%temp%\eAL.cmd"


    Ciao Gastone


    Gastone Canali >http://www.armadillo.it


    Se alcuni post rispondono al tuo quesito(non necessariamente i miei), ricorda di contrassegnarli come risposta e non dimenticare di contrassegnare anche i post utili. GRAZIE! Ricorda di dare un occhio ai link Click Here andHere


    lunedì 1 aprile 2019 17:46
    Moderatore
  • Ciao,

    di seguito il link:

    https://support.microsoft.com/it-it/help/324737/how-to-turn-on-automatic-logon-in-windows

    ed ho eseguito questo:

    https://docs.microsoft.com/en-us/sysinternals/downloads/autologon

    Grazie

    martedì 2 aprile 2019 08:09
  • Tralasciando il fatto che sono assolutamente contrario ai login automatici tranne che in casi particolari come ad esempio computer kiosk (da come descrivi il problema nel primo post sembra quasi che tu lo stia utilizzando per tutti i computer di un ufficio...spero di no), secondo me fai prima ad attivare il login automatico direttamente con "control userpasswords2":
    https://support.industry.siemens.com/cs/document/23598260/how-do-you-enable-automatic-logon-with-microsoft-windows-?dti=0&pnid=14435&lc=en-US
    martedì 2 aprile 2019 08:14
    Moderatore
  • Sono dei pc che hanno un'utenza di dominio di servizio come login di windows e poi parte un software dove accedono gli utenti con le credenziali di dominio.

    Il problema  è che abbastanza spesso ai riavvii o dopo uno spegnimenti l'autologon di windows fallisce.

    martedì 2 aprile 2019 08:52
  • Mi sembra una situazione alquanto anomala...gli utenti dovrebbero fare comunque il login in Windows a prescindere dal login del software gestionale.
    Capisco che lo stai facendo per non obbligarli a fare un doppio login, ma cerchiamo di non scendere a troppi compromessi.
    PS: Io con il login mediante il pannello userpasswords2 non ho mai riscontrato il minimo problema nemmeno dopo numerosi riavvii o spegnimenti. 
    martedì 2 aprile 2019 09:00
    Moderatore
  • Mi sembra una situazione alquanto anomala...gli utenti dovrebbero fare comunque il login in Windows a prescindere dal login del software gestionale.
    Capisco che lo stai facendo per non obbligarli a fare un doppio login, ma cerchiamo di non scendere a troppi compromessi.
    PS: Io con il login mediante il pannello userpasswords2 non ho mai riscontrato il minimo problema nemmeno dopo numerosi riavvii o spegnimenti. 

    Totalmente d'accordo, con quanto scritto sopra.

    Se ogni tanto non funziona, ci deve essere aquacosa di esterno che interagisce con il sistema; qualcosa/qualcuno deve modificare la chiave di registro di  DefaultUserName

    Ciao Gastone


    Gastone Canali >http://www.armadillo.it


    Se alcuni post rispondono al tuo quesito(non necessariamente i miei), ricorda di contrassegnarli come risposta e non dimenticare di contrassegnare anche i post utili. GRAZIE! Ricorda di dare un occhio ai link Click Here andHere

    martedì 2 aprile 2019 09:45
    Moderatore
  • Il software deve essere sempre in esecuzione e non può essere chiuso per il login e logoff dell'utente.

    martedì 2 aprile 2019 12:05
  • Un avvio automatico al login degli utenti? Una configurazione come servizio?
    Provate a chiedere anche allo sviluppatore, mi sembra impossibile che non ci sia soluzione...
    martedì 2 aprile 2019 12:47
    Moderatore