none
mettere in rete Xp e W10 per condividere file e cartelle RRS feed

  • Domanda

  • Buongiorno,

    ho già fatto questa richiesta nel forum di Windows XP, dove mi è stato consigliato di rivolgermi in questa community in quanto sembra che il problema che ho per mettere in rete 2 computer, un vecchio con sistema XP e uno nuovo con W10, sia più tecnico che non quanto si possa fare con i settaggi usuali del sistema operativo.

    Mi rendo conto che qui trattate problematiche ben più complesse che mettere in rete due computer in un ufficio "casalingo", ma provo lo stesso a sottoporre il problema; uso ancora Xp perchè lavoro con un programma che gira solo con quel vecchio sistema e che al momento non vorrei sostituire; da qui la mia necessità di lavorare ancora con XP e tentare di condividere file e cartelle.

    Questo è il quesito che ho posto nell'altro forum:

    Buongiorno,

    ho un nuovo computer con W10 e uno vecchio con XP.

    Li ho messi in rete nominando una rete Workgroup su entrambi da Sistema.

    Succede che XP vede W10 e posso aprire tutte le cartella di W10 su XP, ma non il contrario.

    Su W10, esplora risorse, rete, appare il computer XP ma non apre le cartelle condivise che ho impostato su XP.

    il sistema dice che non ho l'autorizzazione e contattare l'amministratore di rete etc etc.

    Ho provato a disabilitare su W10 il gruppo home disabilitando i servizi come avevo letto da qualche parte, pensando che quel servizio non fa funzionare la messa in rete di XP, ma niente.

    Da una risposta a un altro utente che aveva lo stesso problema Simone Capparelli aveva scritto, se ho capito bene, che è possibile aggiungere al gruppo Home di W10 anche il computer XP, ma non capisco come, visto che la creazione del gruppo Home in W10 crea una password da inserire sugli altri computer della rete, ma XP non ha questa funzione ... mi potrebbe qualcuno indicare come fare e se è possibile, per cortesia?

    Chiaramente i 2 computer condividono lo stesso router Fastweb e l'IP viene assegnato in dinamico, ma è sempre lo stesso per i 2 computer; su XP ho MacAfee con Firewall con autorizzazione alla rete locale 192.168.1.... e firewall Windows disattivato, su W10 uso il firewall di Windows. 

    La finestra di condivisione di esplora risorse di XP è limitata, non ha l'opzione condivisione avanzata; c'è solo condividi la cartella in rete consenti agli utenti di rete di modificare i file, non c'è come in W10 la possibilità di autorizzare un elenco di utenti o tutti.

     

    Per quanto riguarda l'attivazione della condivisione in rete, su W10 è impostata correttamente.

    Su XP esiste la procedura di installazione guidata rete che ho fatto girare impostando lo stesso nome del gruppo di lavoro in W10 e XP: WORKGROUP. Questa procedura alla fine chiede se si vuole creare un disco di installazione da far girare sugli altri computer della rete, ma non l'ho fatto per non incasinare W10. Chiudo quindi la procedura senza crearlo e riavvio il computer. Ma niente, ancora accesso negato a XP.

     

    Ho provato anche su XP, andando su sistema, nome computer, ID di rete a  far girare l'altra procedura per mettere un computer in rete nominando un gruppo di lavoro, con lo stesso nome del gruppo di W10, ad esempio WORKGROUP; riavvio il computer ... Niente ancora …

    Credo che il blocco sia a livello di XP, lui non invia a W10 la richiesta di autenticare l'utente che sta provando ad accedere alle cartelle di XP, cosa che invece è successa al contrario, cioè su XP ho dovuto inserire le credenziali dell'utente W10 e infatti da XP posso copiare file nella cartella pubblica di W10. Questa potrebbe la soluzione come estrema ratio, ma trovo meglio poter accedere alle cartelle condivise su entrambi i computer.


    Ringrazio in anticipo (e mi scuso per il lungo post) se vorrete darmi un'indicazione per risolvere questo forse banale problema di condivisione, buona giornata.

    Alfredo

    lunedì 6 febbraio 2017 18:29

Tutte le risposte

  • Premetto che Windows XP non è più supportato da tempo, quindi:
    - Ti consiglio di non connettere il computer ad internet
    - La modifica di alcune impostazioni per consentire la connessione a Windows XP potrebbe ridurre il livello di sicurezza anche del computer Windows 10.
    Detto questo, per prima cosa, ti consiglio di abilitare sul computer Windows XP la condivisione di rete avanzata (in modo da poter gestire meglio le autorizzazioni sulle condivisioni):

    - Disabilita l'opzione contrassegnata con il 2.
    A questo punto dovresti vedere più opzioni in fase di creazione delle condivisioni sul computer Windows XP.

    Se anche dopo aver ri-creato la condivisione in Windows XP con le impostazioni corrette hai lo stesso problema, è probabile che il problema sia a livello di autenticazione. Dovresti provare quindi a variare il livello di autenticazione impostato per LAN manager tramite gpedit.msc (Computer Configuration > Windows Settings > Security Settings > Local Policies > Security Options):
    https://technet.microsoft.com/en-us/library/jj852207(v=ws.11).aspx




    martedì 7 febbraio 2017 09:47
  • Buonasera Fabrizio,

    ti ringrazio per la risposta.

    Sto provando a fare le modifiche che mi hai indicato:

    A) - Adesso ho le opzioni complete per la condivisione file su XP, così ho dato a utente "Everyone" il controllo completo sulla cartella SharedDocs.

    B) - Sono passato poi, sempre su XP, a modificare il livello di autorizzazione di LAN Manager, era settato su "invia risposte LM e NTLM", l'ho cambiato in "invia LM e NTLM, utilizza la protezione sessione NTLMv2 se negoziata";

    ho notato che su W10 l'impostazione è su "non definita" mentre su XP non c'è questa possibilità, bisogna scegliere una modalità.

    Quindi su XP ho fatto nuovamente girare "installazione guidata rete", e disattivato il Windows firewall (che ogni volta che faccio la procedura guidata rete me lo riattiva, tengo attivo il firewall di McAfee).

    Su W10, su cui ho disattivato il servizio HOME, ho fatto nuovamente girare da "Sistema/nome computer" la procedura guidata "ID di rete …" mettendo lo stesso nome del gruppo di lavoro di XP.

    Apro esplora risorse su W10, clicco su rete, vedo il computer XP col nome esatto, ma purtroppo mi nega ancora l'accesso da W10 …

    Proverò a cambiare ancora il livello di autorizzazione con le altre opzioni e rifare tutto di nuovo.

    Ma intanto ti chiedo, va bene aver disattivato il gruppo Home su W10? E non è proprio possibile inserire XP nel gruppo Home?

    Grazie ancora per l'attenzione e mi rifarò vivo dopo aver fatto gli altri tentativi, buona serata.

    martedì 14 febbraio 2017 17:18
  • No, Windows XP non è compatibile con i gruppi home. Comunque, come ti dicevo, non modificare con leggerezza quelle impostazioni perché potrebbero abbassare il livello di sicurezza di Windows 10. Semmai valuta direttamente un upgrade del computer Windows XP almeno a Windows 7....del resto siamo nel 2017.
    martedì 14 febbraio 2017 23:21
  • Buongiorno Fabrizio,

    per l'upgrade a W7, lo farei ma credo che il programma che utilizzo (e di cui non ho ancora trovato un degno sostituto) giri solo su XP ...

    Con questi settaggi di "protezione di rete: livello di autenticazione di LAN Manager"

    per W10: "invia LM e NTLM: Utilizza la protezione sessione NTLM2 se negoziata"

    per XP:"invia solo risposta NTLM2\rifiuta LM eNTLM"

    al tentativo di accesso in rete al computer XP, su W10 si apre una finestra con la richiesta delle credenziali di rete per l'accesso al computer XP; metto come utente il nome e la password che utilizzo su XP, ma risponde "utente e password non corretta"!!! ma sono sicuro di aver digitato giusto; ho provato con altri possibili combinazioni di utente e password (tipo Administrators) ma niente ... non capisco quale altre credenziali di rete possano essere impostate, e non credo debba inserire le credenziali di W10 ... c'è da qualche parte (tipo nel registro) la possibilità di vedere le credenziali richieste?

    Grazie come sempre per l'attenzione, buona giornata 


    martedì 21 febbraio 2017 10:28
  • Se le autorizzazioni NTFS e della condivisione sono corrette il problema sembrerebbe proprio a livello di protocolli di autenticazione. In ogni caso, visto che utilizzi ancora XP solo per un'applicazione, ti consiglio di eseguire un upgrade a Windows 7 Pro in modo da poter poi configurare una macchina virtuale gratuita Windows XP (Windows XP Mode) dove poter eseguire il tuo applicativo (anche se secondo me è strano che non funzioni direttamente utilizzando le impostazioni di compatibilità di Windows).
    martedì 21 febbraio 2017 14:34
  • potrei provare a vedere le impostazioni di compatibilità, ma non so come fare.

    Il programma è Microsoft Money 2000 Standard, inserito in un pacchetto di programmi, se non ricordo male Works ... se non sbaglio Microsoft ha cessato di sviluppare Money e non c'è il suo "erede" ... il programma è ben vecchio lo so, ma per quello che devo fare io (gestione contabile di varie entità commerciali e non) va benissimo e funzionale ...

    Credo che se inserisco il cd di installazione in W10 mi dirà che non è compatibile, come devo fare per modificare le impostazioni di compatibilità?

    Nel frattempo mi sto informando sull'upgrade a W7.

    Grazie, buona giornata

    mercoledì 22 febbraio 2017 11:51
  • Ti consiglio di continuare direttamente nella vecchia discussione che avevi inserito sul forum di Microsoft Community.
    Il fatto è che in TechNet possiamo fornire assistenza solo a professionisti IT (persone che lavorano come consulenti per conto di aziende), quindi in realtà già siamo andati un bel po' off-topic....non è una questione di "complessità del problema" ma del regolamento che dobbiamo rispettare.
    giovedì 23 febbraio 2017 12:23
  • ok, grazie mille per il supporto! Buona giornata.
    giovedì 23 febbraio 2017 15:42
  • al tentativo di accesso in rete al computer XP, su W10 si apre una finestra con la richiesta delle credenziali di rete per l'accesso al computer XP; metto come utente il nome e la password che utilizzo su XP, ma risponde "utente e password non corretta"!!! ma sono sicuro di aver digitato giusto; ho provato con altri possibili combinazioni di utente e password (tipo Administrators) ma niente ...
    Alla richiesta di credenziali di rete non dovrai inserire il nome completo (quello visualizzato nella schermata di accesso a Windows XP, per intenderci) ma il nome utente al quale puoi risalire dal prompt dei comandi. Premi perciò  sul sistema al quale vuoi accedere la combinazione di tasti Windows+R (Esegui...) > cmd e scrivi il comando "set username"; dopodiché premi "Invio". In alternativa per conoscere il nome utente su Windows XP apri dallo stesso "Gestione computer": Windows+R > compmgmt.msc > Utenti e gruppi locali > Users.
    sabato 8 settembre 2018 16:53
  • È necessario abilitare il protocollo SMBv1 nel componente client di Windows 10 che è disabilitato per impostazione predefinita essendo utilizzato in questo sistema il protocollo più sicuro SMBv3; il componente server invece su Windows 10 dovrebbe essere già abilitato; la prima versione del protocollo era utilizzata da Windows XP. Per abilitare il vecchio protocollo (meno sicuro) segui i passaggi: Pannello di controllo > Programmi > Programmi e funzionalità > (Barra laterale sinistra) Attivazione o disattivazione delle funzionalità di Windows > Supporto per condivisione file SMB 1.0/CIFS > (Abilita) Client SMB 1.0/CIFS; in alternativa usa la scorciatoia: Windows+R > OptionalFeatures per evitare i primi passaggi. Dopo aver effettuato tutti i passaggi è necessario riavviare Windows 10 per rendere esecutivo il protocollo SMBv1 nel componente client.
    domenica 9 settembre 2018 12:15