none
Schermata "attendi" all'avvio per 10 minuti !! Ma non tutti i client.... RRS feed

  • Domanda

  • Da alcuni giorni si verifica una cosa che non riesco a spiegarmi ne risolvere.

    Lo scenario è il seguente:

    Server SBS 2011 con una decina di client Windows 10 (tutti 1903 o 1909).

    Alcuni client impiegano un sacco di tempo per presentare la schermata di logon.

    Dopo l'avvio regolare del sistema, compare la schermata "Attendi" con le palle che girano (soprattutto quelle degli utenti) per diversi minuti (in alcuni casi addirittura 12 !!).

    Dopo di che, compare la schermata regolare di autenticazione.

    La cosa che mi fa sclerare è che non ho modificato nulla lato server in termini di policy, nessuna nuova installazione o aggiornamento sui client ma, cosa più strana, è che il problema non si presenta su tutti i client.

    Alcuni funzionano regolarmente e altri no. 

    Avete qualche idea su cosa possa essere oppure su come si fa a sapere cosa blocca il sistema ?

    Grazie

    venerdì 3 gennaio 2020 13:11

Risposte

  • AGGIORNAMENTO 2 E (forse) SOLUZIONE !!!!

    Dopo un miliardo e mezzo di prove e riavvii vari, ho provato anche a lavorare sulle GPO.

    Ho tirato giù tutte le policy ed ho visto che i client si avviavano regolarmente.

    Ho quindi iniziato a tirarle su una alla volta sino a che ho notato che abilitando la policy "Windows SBS CSE Policy" il problema si ripresentava.

    Essendo una policy che lancia un eseguibile , probabilmente a Win10 non piace.

    Faccio ancora alcuni test ma sembra proprio aver risolto.

    A questo punto, però, mi chiedo a cosa serve ProcExplorer visto che non c'era alcuna evidenza della cosa...

    Mah...

    • Contrassegnato come risposta Aldo_ venerdì 3 gennaio 2020 18:24
    venerdì 3 gennaio 2020 18:10

Tutte le risposte

  • Così come presnti la cosa, possiamo dire poco (dns corretti? rete ok? etc.) un po' di toubleshooting potrebbe aiutare (es. in queo 12minuti negli eventi viene scritto qualcosa??).

    Sono sonvinto che l'opzione migliore sia di una verifica su diun pc "difettoso".

    Come?

    Ecco un vecchio thread, sempre attuale!

    https://social.technet.microsoft.com/Forums/it-IT/c4e98cba-2cbc-426c-a7d2-77c5a04f1ebe/identificare-processo-che-blocca-la-schermata-di-logon?forum=windows7italian

    più altro

    https://blogs.technet.microsoft.com/yongrhee/2017/10/10/how-to-collect-a-good-boot-trace-on-windows-10-or-windows-server-2016-using-wprui/

    https://blogs.technet.microsoft.com/yongrhee/2018/02/19/how-to-collect-a-good-boot-trace-on-windows-10-or-windows-server-2016-using-wpr/

    Ciao Gastone


    Gastone Canali >http://www.armadillo.it


    Se alcuni post rispondono al tuo quesito(non necessariamente i miei), ricorda di contrassegnarli come risposta e non dimenticare di contrassegnare anche i post utili. GRAZIE! Ricorda di dare un occhio ai link Click Here andHere

    venerdì 3 gennaio 2020 13:55
    Moderatore
  • Ciao Gastone e grazie per la risposta.

    Ti confermo che a livello di network è tutto ok. D'altronde, come dicevo prima non c'è stata nessuna modifica alla configurazione di rete ne su client ne su server e il problema non è presente su tutti i client.

    A livello di eventi, sul client, rilevo i due seguenti (vedi immagine).

    Abbastanza anomali a dire il vero. Ho verificato su di un client che non presenta il problema e non li riscontro.

    Però… non capisco… una volta avviato il client funziona regolarmente (quindi il dns gira bene).

    Potrebbe essere quello ?

    Ho provato con ProcessExplorer a tracciare il boot log ma ci sono tonnellate di righe e non è semplice capire. Ho applicato un filtro sulla durata del processo superiore a 3 secondi ed è uscito quello che vedi nell'immagine sotto. Sembra che il servizio di Windows Defender si prenda un bel po' di tempo insieme a svchost ma , onestamente, faccio fatica a capire se quello è il problema.


    • Modificato Aldo_ venerdì 3 gennaio 2020 15:05
    venerdì 3 gennaio 2020 14:33
  • AGGIORNAMENTO :

    Ho disabilitato il servizio Windows Defender Antivirus e anche Windows Search.

    Ho riavviato e rifatto il boot logging con ProcExplorer e analizzato il risultato con il solito filtro.

    La cosa che si evidenzia è che nelle prime tre righe si capisce molto di più

    Alle 16:36 è quando il pc si è avviato

    Poi, alle 16:38 e 16:39 compare il servizio svchost che va a fare qualcosa in quella directory "...CryptnetUrlCache..". In totale, quelle due righe impiegano circa 9 minuti che è più o meno il tempo di attesa che è passato durante la schermata.

    Infine, alle 16:36, arriva la schermata di login.

    A questo punto la domanda è: che minchia fa svchost in quella cartella ???

    venerdì 3 gennaio 2020 16:13
  • AGGIORNAMENTO 2 E (forse) SOLUZIONE !!!!

    Dopo un miliardo e mezzo di prove e riavvii vari, ho provato anche a lavorare sulle GPO.

    Ho tirato giù tutte le policy ed ho visto che i client si avviavano regolarmente.

    Ho quindi iniziato a tirarle su una alla volta sino a che ho notato che abilitando la policy "Windows SBS CSE Policy" il problema si ripresentava.

    Essendo una policy che lancia un eseguibile , probabilmente a Win10 non piace.

    Faccio ancora alcuni test ma sembra proprio aver risolto.

    A questo punto, però, mi chiedo a cosa serve ProcExplorer visto che non c'era alcuna evidenza della cosa...

    Mah...

    • Contrassegnato come risposta Aldo_ venerdì 3 gennaio 2020 18:24
    venerdì 3 gennaio 2020 18:10
  • ---

    A questo punto, però, mi chiedo a cosa serve ProcExplorer visto che non c'era alcuna evidenza della cosa...

    Mah...

    ProcExplorer fa il suo lavoro, il difficile è interpretare la mole di dati, più semplice è la lettura se si utilizza  il windows performance toolkit.

    ciao gastone


    Gastone Canali >http://www.armadillo.it


    Se alcuni post rispondono al tuo quesito(non necessariamente i miei), ricorda di contrassegnarli come risposta e non dimenticare di contrassegnare anche i post utili. GRAZIE! Ricorda di dare un occhio ai link Click Here andHere

    venerdì 3 gennaio 2020 19:47
    Moderatore