Windows 7 drivers for Realtek RTL8139 ethernet


  • I have installed Windows 7 32 bit to a Sylvania G Netbook, and am overall very pleased. Most devices work well, and Windows 7 seems to run stable, and reasonably quick.

    There is one nagging problem with the above referenced ethernet driver (RTL8139). Using the newest drivers posted by Realtek (as of Nov 15, 2009) the drivers install, but the status of the driver is "code 31", and it does not work. Rebooting does not help.

    Drivers posted here:

    Another thing that strikes me as odd, is that until I install the driver, it does not show up in Device Manager. In the past, even unsupported devices would be detected, and would show up in Device Manager as "Unknown Device" until the drivers were installed.

    Hardware specs:

    VIA C7-M processor
    VIA chipset (CX700 I think)
    VIA HD Audio
    VIA S3 Unichrome Pro II IGP display
    Realtek RTL8139 ethernet
    Realtek RTL8187 WLAN
    Realtek Card Reader
    Mtron 32 GB SLC SSD (PATA ZIF interface)

    EDIT: I have also tried installing the Windows XP drivers in Vista compatibility mode, which did not work, and in XP compatibility mode, which did install, but did not work. It still says under "device status" "This device is not working properly because Windows cannot load the drivers required for this device. (Code 31)".

    lunedì 16 novembre 2009 01:24


Tutte le risposte

  • Thank you for your quick reply. I should have mentioned that I have repeatedly uninstalled, and reinstalled Realtek's drivers. I have also tried running Windows update to see if it detects a better driver. I am beginning to think the chipset drivers are incomplete and therefore don't properly detect devices on the PCI BUS.
    lunedì 16 novembre 2009 01:54
  • Sylvania and partners don't even support XP, (although they make XP drivers available) much less a BIOS upgrade. :(
    lunedì 16 novembre 2009 02:13
  • "What originally came with the machine?"

    A Linux variation called GOS, which never had working drivers for the wireless adapter, accelerated graphics, or cpu scaling. I must say that XP ran great, but I was hoping to use Windows 7.
    lunedì 16 novembre 2009 03:14
  • Thanks for your help, but I have decided to go back to XP. My wireless stopped working in Windows 7 too. I think maybe my manufacturer just doesn't give enough support for their devices.
    martedì 17 novembre 2009 02:08
  • Hi

    I think that VIA gave up on the C-7, it runs great with XP and Windows Home Server but not newer OS'.

    If you did not already tried, log to Realtek TW Tech support and try the OEM drivers for Win 7.

    Jack (MS, MVP-Networking).
    martedì 17 novembre 2009 06:32
  • Thanks all! After going back to XP (a fresh install), my ethernet port now works, but not my WIFI. Windows 7 Realtek drivers either killed my WIFI, or it was going bad anyway. (sigh!) Guess I'll get an external USB WIFI adapter to use up one of my 2 USB ports.

    I really like Windows 7, but wish I had not tried it on this little netbook. My advice is: do not install Windows 7 on the Sylvania G Netbook.

    Not to be all negative, I have installed Windows 7 on 2 other computers with no problems at all. Had to hunt down a couple drivers, but that was all.
    giovedì 19 novembre 2009 00:12
  • Via is still in business, but I am unsure what is going on there.

    Vote if answered or helpful, I am running for Office (joke)! IT/Developer, Windows/Linux/Mainframe

    Server: P4-2GHz, 1.5 GB RAM, Linux Server, need IDE/SATA disks for my chess site

    Workstation: Asus M2NBP-VM CSM, Athlon64 X2 4200+ 65W CPU, 2GB RAM, NVIDIA 8600GT, 320GB + 160G backup, Windows 7 Ultimate x64.

    I did not say that VIA is out of business. Not evry one is as responsible as Microsoft and keep providing services many years after the product release.

    It just seem that VIA abandoned the support for this specific product, C-7, a while ago.

    Thus if one has C-7 mobo, One should not look forward for a trouble free Win 7 installation.

    giovedì 19 novembre 2009 03:38