none
Scarsa velocità rete LAN aziendale RRS feed

  • Discussione generale

  • Salve,

    Nella mia azienda ho installato una piccola rete LAN di 4 pc. Tutti i pc montano sistema operativo Windows 7 Pro x64. I pc sono connessi tra loro tramite un router netgear e ad ognuno di essi è stato assegnato un ip statico, per non creare conflitti.

    Uno di questi 4 pc (con infrastruttura hardware più elevata rispetto agli altri) funge da Server. Ad esso i pc client si connettono per lavorare su file e per utilizzare il programma di amministrazione aziendale. Naturalmente tutti i pc sono collegati tramite gruppo home.

    Il grande problema di questa rete è la velocità. I client che si connettono al pc-server non lavorano fluidi ed alcune volte hanno grandi latenze di rete (diversi secondi per aprire schede del programma di amministrazione o ad aprire un file). In tutti i pc è presente l'antivirus Kaspersky 2014 dove sono impostate tutte le esclusioni di controllo sulle cartelle condivise e sui database che utilizza il programma. 

    Inoltre il pc-server monta un sistema di memorizzazione RAID 1 (non so se può risultare utile)

    Riporto qui un test di velocità fatto con il programma LAN Speed Test:

    Version 1.3.1
    OS Version: Windows 7
    Processor: Intel(R) Core(TM) i5-3570 CPU @ 3.40GHz
    Date: 02/19/2014
    Time: 09:53:47
    Program Parameters: 0
    High Performance Timer: 0.0000003003

    Test File: \\ALESSANDRA-PC\Users\Public\NW_SpeedTest.dat
     Write Time = 1.7544434 Seconds
     Write Speed = 91.1970160 Mbps
     Read Time = 1.8569959 Seconds
     Read Speed = 86.1606640 Mbps

    Test File: \\ALESSANDRA-PC\Users\Public\NW_SpeedTest.dat
     Write Time = 1.8082337 Seconds
     Write Speed = 88.4841360 Mbps
     Read Time = 1.7654345 Seconds
     Read Speed = 90.6292480 Mbps

    Test File: \\ALESSANDRA-PC\Users\Public\NW_SpeedTest.dat
     Write Time = 1.7532665 Seconds
     Write Speed = 91.2582320 Mbps
     Read Time = 1.7613344 Seconds
     Read Speed = 90.8402160 Mbps

    Test File: \\ALESSANDRA-PC\Users\Public\NW_SpeedTest.dat
     Write Time = 8.7531894 Seconds
     Write Speed = 91.3952560 Mbps
     Read Time = 8.8267386 Seconds
     Read Speed = 90.6337040 Mbps

    un Grazie in anticipo per le risposte.

    Fabio



    mercoledì 19 febbraio 2014 09:44

Tutte le risposte

  • Prova a disabilitare l'autotuning in tutte le macchine:

    http://answers.microsoft.com/it-it/windows/wiki/windows_7-performance/rallentamenti-nello-scambio-file-in-rete/69a2c239-5452-428e-995f-2a28e09c456c

    Inoltre , disattiva la Compressione differenziale remota togliendo la spunta relativa in Pannello di controllo > programmi e funzionalità > attivazione o disattivazione delle funzionalità di Windows , in tutte le macchine.

    Ciao


    Franco Leuzzi - Microsoft ® MVP Windows Expert-IT Pro \System Administration

    mercoledì 19 febbraio 2014 10:19
    Moderatore
  • Grazie Franco,

    Ho seguito tutte le tue indicazioni su pc-server e pc-client, effettivamente si nota un leggero miglioramento nelle prestazioni dei client, ma non si può definire eccellente il risultato. E' possibile fare altro?? Incollo il nuovo report del programma Lan speed Test:

    Version 1.3.1
    OS Version: Windows 7
    Processor: Intel(R) Core(TM) i5-3570 CPU @ 3.40GHz
    Date: 02/19/2014
    Time: 14:14:35
    Program Parameters: 0
    High Performance Timer: 0.0000003003

    Test File: \\ALESSANDRA-PC\Users\Public\NW_SpeedTest.dat
     Write Time = 8.8163790 Seconds
     Write Speed = 90.7402000 Mbps
     Read Time = 8.8035849 Seconds
     Read Speed = 90.8720720 Mbps

    i valori sono su per giù uguali, ma io credo che il programma di test non sia adeguato al mio problema. C'è l'opportunità di effettuare altri tipi di test sulla velocità reale della rete lan?

    Ciao

    mercoledì 19 febbraio 2014 13:24
  • Secondo me la cosa ha altre origini.

    Sicuro che l'accesso simultaneo ai dati dell'aziendale sia correttamente impostato?

    Inoltre ricontrollerei anche Kaspersky e Firewall.

    Ciao


    Franco Leuzzi - Microsoft ® MVP Windows Expert-IT Pro \System Administration

    mercoledì 19 febbraio 2014 14:13
    Moderatore
  • Il grande problema di questa rete è la velocità. I client che si connettono al pc-server non lavorano fluidi ed alcune volte hanno grandi latenze di rete (diversi secondi per aprire schede del programma di amministrazione o ad aprire un file). In tutti i pc è presente l'antivirus Kaspersky 2014 dove sono impostate tutte le esclusioni di controllo sulle cartelle condivise e sui database che utilizza il programma. 

    Inoltre il pc-server monta un sistema di memorizzazione RAID 1 (non so se può risultare utile)

    Se il problema si verifica solo durante l'utilizzo del gestionale o di cartelle condivise presenti sul server (quindi, ad esempio, non è lenta la navigazione internet o lo scambio di file verso cartelle condivise su altri computer) allora la lentezza non riguarda la rete ma il server stesso. Hai provato a monitorare l'utilizzo delle risorse?

    mercoledì 19 febbraio 2014 14:51
    Moderatore

  • Sicuro che l'accesso simultaneo ai dati dell'aziendale sia correttamente impostato?

    Inoltre ricontrollerei anche Kaspersky e Firewall.

    Tutti i computer sono correttamente configurati per il gruppo home (il database del gestionale è stato inserito in una cartella dove tutti hanno diritto di accesso, sotto suggerimento dei programmatori stessi)

    Kaspersky sia su client che su server è configurato per escludere controlli sul programma, sulle cartelle del database e sulle cartelle condivise.

    Per il Firewall utilizziamo quello di Windows, ma ora che ci penso non ho mai operato su di quello. Provo e ti faccio sapere.

    mercoledì 19 febbraio 2014 16:51
  • Se il problema si verifica solo durante l'utilizzo del gestionale o di cartelle condivise presenti sul server (quindi, ad esempio, non è lenta la navigazione internet o lo scambio di file verso cartelle condivise su altri computer) allora la lentezza non riguarda la rete ma il server stesso. Hai provato a monitorare l'utilizzo delle risorse?


    Tutti i client e il server si collegano ad internet e scambiano file in maniera fluida e veloce. il mio principale problema è sul gestionale. ti allego un benchmark del server. In questi giorni proverò a monitorare le risorse.

    Mi chiedo se il problema potrebbe essere il sistema di memorizzazione del server che è in raid 1??

    Microsoft Windows 7 Professional
    Intel Core i53570 3.40GHz @ 3401 MHz
    Graphics Card: NVIDIA GeForce 210

    8142 MB System RAM (Score: 191)
    - RAM Speed: 11214 MB/s

    CPU Tests (Score: 501)
    - Floating Point Operations/Second: 102928756
    - Integer Operations/Second: 454801132
    - MD5 Hashes Generated/Second: 1295912

    Graphics Tests (Score: 51)
    - 3D Frames Per Second: 170

    Hardware Tests (Score: 49)
    - Primary Partition Capacity: 466 GB
    - Drive Write Speed: 175 MB/s 

    Grazie, ciao

    mercoledì 19 febbraio 2014 17:03
  • Secondo me invece è da ricercare nell'applicazione aziendale e nel modo in cui gestisce accessi e file.

    Ciao


    Franco Leuzzi - Microsoft ® MVP Windows Expert-IT Pro \System Administration

    mercoledì 19 febbraio 2014 18:07
    Moderatore
  • Sono d'accordo, anche secondo me dipende esclusivamente dal gestionale. Che DBMS utilizza? Una configurazione non corretta dello stesso potrebbe essere la causa di tutti i rallentamenti.
    mercoledì 19 febbraio 2014 21:45
    Moderatore
  • I test della velocità LAN per quale motivo non vanno? Che tipo di programma è il tuo gestionale es. client/server?

    Se vuoi toglierti qualche dubbio, investi su di uno switch in giga e al Netgear fagli are solo il router


    Gastone Canali >http://www.armadillo.it

    Se alcuni post rispondono al tuo quesito(non necessariamente i miei), ricorda di contrassegnarli come risposta e non dimenticare di contrassegnare anche i post utili. GRAZIE! Ricorda di dare un occhio ai link Click Here andHere

    mercoledì 19 febbraio 2014 23:38
    Moderatore
  • Sicuramente le porte del router sono di 100mb/s, i test sono buoni per l'apparato che hai, ricordati che 100mb/s e' un valore teorico nell'applicazione quasi mai raggiungibile perché entrano in gioco altre variabili, come la qualità del cavo. Il passo e' aggiungere uno switch nell'infrastruttura. Ciao
    giovedì 20 febbraio 2014 10:00
  • Buongiorno,

    Il gestionale il questione è questo: http://www.danea.it/software/easyfatt/ nella versione enterprice e questa è il metodo possono essere condivisi i database: http://www.danea.it/software/easyfatt/enterprise/

    Ho controllato il Router che è un Netgear WNR1000v2, quindi ha le porte in 100mb/s. Collegando uno switch giga al router il tutto quindi si renderebbe più veloce? Che tipo di switch mi consigliate?

    Grazie

    giovedì 20 febbraio 2014 11:11
  • Si,si la LAN ci guadagna in prestazione, per lo switch mantiene pure il Netgear l'importante che sia a 1000 mb/s e con numero di porte sufficiente anche per eventuali connessioni future.
    giovedì 20 febbraio 2014 12:10
  • Buongiorno,

    Il gestionale il questione è questo: http://www.danea.it/software/easyfatt/ nella versione enterprice e questa è il metodo possono essere condivisi i database: http://www.danea.it/software/easyfatt/enterprise/

    Ho controllato il Router che è un Netgear WNR1000v2, quindi ha le porte in 100mb/s. Collegando uno switch giga al router il tutto quindi si renderebbe più veloce? Che tipo di switch mi consigliate?

    Grazie

    Da quanto ho letto sembra che il gestionale sia basato sulla condivisione semplice di file, il che potrebbe rappresentare un problema se gli archivi hanno dimensioni elevate.

    A questo punto quindi passa prima ad uno switch gigabit e poi vediamo....alla fine secondo me per 4 pc non ti serve nemmeno uno switch particolarmente raffinato.

    giovedì 20 febbraio 2014 12:32
    Moderatore
  • Ciao,

    leggendo il tuo post parli sia di una lentezza ad aprire le schede del programma gestionale e sia ad aprire file sul server .

    Prova a cancellare tutte le connessioni ad unità di rete create sui 4 pc e da un "client" connetti al server tramite ip    \\indirizzoip\condivisione   , apri uno dei file dove ritieni lento il tempo di apertura e verifica se la situazione migliora.

    uno dopo l'altro riconnetti le unità di rete e ritesta ad ogni passaggio aprendo file della condivisione (senza software diagnostici )

    con 4 pc puoi fare questa prova semplice per escludere quale pc crea il difetto sulla rete.

    se non risolvi prima l'apertura dei file dubito che risolvi anche la lentezza del gestionale.

    aggiornaci ciao

    Marco

    giovedì 20 febbraio 2014 12:52
  • Cambia switch e collega tutti i pc in giga

    Vuoi esagerere: metti gli archivi su raid1 con dischi SSD (a crescere, potesti usare raid + efficienti, dischi sas, controller con ram dedicata, aumentare la ram server e ottimizzare le opzioni di memoria cache dedicata dal SO per lo sharing ... ( leggi qui e Table 2. Factors That Affect File Server Capacity)

    Da subito fai queste modifche:

    Sul server escludi le directory dove risiedono gli archivi dal controllo Real time dell'antivirus

    Sui client escludi la condivisione degli archivi dai controlli i real time dell'antivirus

    Cerca di mantenere deframmentati gli archivi

      Ciao


    Gastone Canali >http://www.armadillo.it

    Se alcuni post rispondono al tuo quesito(non necessariamente i miei), ricorda di contrassegnarli come risposta e non dimenticare di contrassegnare anche i post utili. GRAZIE! Ricorda di dare un occhio ai link Click Here andHere

    giovedì 20 febbraio 2014 13:26
    Moderatore
  • Buongiorno,

    Dopo le varie impostazioni, suggerite da alcuni di voi, sembra sia riuscito ad ottenere un risultato migliore rispetto al precedente. Senza dire nulla ai miei colleghi hanno notato una miglioria in velocità e fluidità sia nel gestionale che nell'apertura dei file.

    Installerò a breve uno switch giga. Così dovrei ottenere un buon risultato, almeno finché la gestione è di soli 4 pc.

    Vi terrò aggiornati.

    Grazie a tutti! 

    Ciao

    venerdì 21 febbraio 2014 10:57
  • Potresti cliccare su "Vota" per i post che ti hanno aiutato e marcare come risposta quello(i) risolutivo(i) e se vuoi anche dettagliare le modifiche che forse sono state significative, questo aiuterebbe gli utenti del forum ad individuare cosa fare...

    Ciao


    Gastone Canali >http://www.armadillo.it

    Se alcuni post rispondono al tuo quesito(non necessariamente i miei), ricorda di contrassegnarli come risposta e non dimenticare di contrassegnare anche i post utili. GRAZIE! Ricorda di dare un occhio ai link Click Here andHere

    venerdì 21 febbraio 2014 13:15
    Moderatore
  • Ciao Fabio,
    dopo 4 anni forse non ricorderai..
    ha migliorato dopo l'esclusione dal controllo antivirus dei dbase ed eseguibili su server e client ?
    lunedì 25 marzo 2019 14:38