none
Problema con la gestione delle stampanti RRS feed

  • Domanda

  • Ciao a tutti,
    ho appena sostituito il Print server ed ho inviato le istruzioni agli utenti su come fare a reimpostare la stampante predefinita. Tutti gli utenti Windows 10 mi hanno tempestato di telefonate perché non riuscivano a gestire le stampanti. In effetti il problema è che, in "stampanti e scanner", quando cliccano sulla stampante per gestirla, compaiono i tasti "Apri coda" e "Gestisci" ma sovrapposti alla stampante seguente, quindi quando tentano di cliccare su Gestisci, di fatto selezionano la stampante successiva. Ho notato che questo comportamento si verifica quando manca il tasto "Rimuovi". Alla fine ho capito come gestire questa situazione, ma i miei utenti hanno una memoria cortissima e se fosse possibile ovviare, ne sarei felice.
    Allego due immagini per far capire meglio cosa intendo. la prima è la situazione anomale, la seconda è la situazione normale.
    Grazie.


    -------- Mauri

    giovedì 4 luglio 2019 07:22

Tutte le risposte

  • Ciao. 

    Perché far fare il lavoro ai tuoi utenti con la memoria cortissima quando puoi farlo fare al server.....?https://www.adamfowlerit.com/2017/11/default-printer-first-logon-via-group-policy/

    A parte questo, i pc erano originariamente in inglese e hai installato l'LP in italiano?

    Dal pannello di controllo classico di Windows riesci a settare la stampante come predefinita?

    Che autorizzazioni hai dato alla stampante condivisa?

    Nel pesto alla genovese ci va una manciata di pepe?

    Etc etc.

    Ciao Marco

    giovedì 4 luglio 2019 07:59
  • Ciao Marco e grazie per la risposta.
    I PC sono sempre stati in italiano e dopo qualche indagine non sono più sicuro che il problema sia sorto col cambio del print server, ma potrebbe essere che fosse già così (dall'ultimo aggiornamento?).
    Comunque per rispondere alle tue domande:

    Dal pannello di controllo classico funziona tutto perfettamente e se non riesco a venirne a capo dirò agli utenti di utilizzare questa procedura.

    le autorizzazioni sono le stesse che c'erano sul precedente print server, anche se poi, nel tentativo di risolvere ho dato permessi al mondo intero senza successo. Adesso ho riportato tutto alla normalità.

    Nel pesto alla genovese non mi risulta vada il pepe  https://www.mangiareinliguria.it/consorziopestogenovese/pestogenovese.php :).

    Ciao.


    -------- Mauri

    giovedì 4 luglio 2019 12:10
  • Bah,

    a questo punto ti consiglierei un piccolo bat

    Esempio:

    vediamo qual'è la stampante predefinita

    comando:

    wmic printer get name,default

    settiamo la HP come default

    Comando:

    RUNDLL32 PRINTUI.DLL,PrintUIEntry /y /n "HP Color LaserJet Pro MFP M177fw" 

    e controllo nuovamente con: wmic printer get name,default


    Crea un bat con il comando RUNDLL32 PRINTUI.DLL,PrintUIEntry /y /n "nomestampante" 

    lo fai lanciare all' utente e non ci pensi più...

    Con le gpo ti togli il pensiero.

    Marco

    P.S. grazie per il pesto ;-)

    giovedì 4 luglio 2019 12:48
  • Ciao,
    ti ringrazio dei tuoi suggerimenti, ma per quanto riguarda la stampante predefinita ormai ho risolto impostandola manualmente agli utenti che hanno Windows 10 (non sono molti). Il mio intento era fare in modo che la prima volta che devono cambiare una qualsiasi impostazione (Fronte retro, ecc), siano in grado di farlo senza chiamarmi (vedi la memoria corta del primo post). 

    Non è un grosso problema, anche perché non cambiano spesso impostazioni alla stampante, però mi sarebbe piaciuto capire da cosa è stato causato il problema e magari se qualcun altro ha avuto lo stesso mio problema.

    Grazie.


    -------- Mauri

    giovedì 4 luglio 2019 15:55
  • Mi è capitato spesso con pc nativi us e con lp i stallato.

    Ma se col vecchio printserver non accadeva..... non è tuo caso.

    Giusto per capire....postesti su un client condividere una stampante fittizia e da un client che ti dà il problema collegarti a quella stampante per vedere se il problema si ripropone.

    Ciao

    venerdì 5 luglio 2019 06:56
  • Come ho scritto in un post precedente non sono più sicuro che il problema sia dovuto al cambio del print server. Ho provato a ripristinare il vecchio print server ed ho fatto un po' di prove su un paio di PC ma la situazione non cambia, da qui il mio dubbio.
    In ogni caso, se un utente con problemi si collega ad una stampante condivisa, diversa da quelle distribuite tramite GPO, quella e solo quella stampante, è gestibile normalmente (è visibile anche il tasto Rimuovi, che le stampanti problematiche non mostrano, vedi primo post).
    Come detto non è un grosso problema, se qualcuno ha necessità di modificare qualche parametro, gli insegnerò come utilizzare l'interfaccia classica dal pannello di controllo.
    Ti ringrazio del tempo che mi hai dedicato.

    Ciao.


    -------- Mauri

    venerdì 5 luglio 2019 08:05