none
Windows server 2019 - Problemi su servizi "Accesso rete su Computer locale", "servizi di dominio AD" e DNS RRS feed

  • Domanda

  • Buongiorno, ho un problema su un server DC con Windows server 2019 R2 non virtualizzato, ci siamo accorti di non riuscire a pingare più il server ma internet funzionava, poi lo abbiamo riavviato e adesso non è raggiungibile in rete e non naviga nemmeno più in inernet. L'icona della sk di rete segnala il triangolino giallo di "rete non identificata". Ha 2 sk di rete a bordo della sk madre. Poi sono sopraggiunto subito altri problemi. L'AD ha smesso subito di funzionare assieme al DNS. Il server è stato installato nuovo e configurato,appena1 settimana fa.

    Senza la rete funzionante non riesco nemmeno a verificare se i ruoli sono attivi con Netdom query fsmo.

    Cosa può essere successo o come posso far ripartire il servizio bloccato ?

    Grazie


    Fabio Celli



    • Modificato Fabio Celli mercoledì 18 settembre 2019 13:41
    mercoledì 18 settembre 2019 13:39

Tutte le risposte

  • Ciao Fabio, direi che la pulizia dei log ed un riavvio per vedere cosa scrive è il minimo. Disattiva la scheda di rete non utilizzata e verifica se sono stati installati degli aggiornamenti prima del problema.

    Saluti
    Nino


    www.testerlab.it

    giovedì 19 settembre 2019 04:01
    Moderatore
  • Salve e grazie per la risposta.

    Ho ripulito i log degli eventi come mi hai consigliato.

    Riporto qui sotto gli errori che si sono generati subito all'avvio e che si ripetono col tempo.

    -------------------------------------------------------

    Oigine : Service Control Manager
    ID evento : 7023
    Impossibile trovare la descrizione per l'ID evento 7023 dall'origine Service Control Manager. Il componente che ha generato l'evento non è installato nel computer locale oppure l'installazione è danneggiata. È possibile installare o ripristinare il componente nel computer locale.
    Se l'evento ha avuto origine in un altro computer, le informazioni per la visualizzazione sono state salvate con l'evento.
    Con l'evento sono state salvate le informazioni seguenti: 
    Accesso rete
    %%3221225572
    La risorsa specifica per le impostazioni locali del messaggio desiderato non è presente



    Origine :NETLOGON
    id evento:5602
    Errore interno durante l'accesso al computer locale o di rete del computer.



    Origine:GroupPolicy (Microsoft-Windows-GroupPolicy)
    id evento:1110
    Elaborazione dei criteri di gruppo non riuscita. Impossibile determinare se l'account utente e l'account computer sono presenti nella stessa foresta. Verificare che il nome di dominio dell'utente corrisponda al nome di un dominio trusted che risiede nella stessa foresta dell'account computer.




    Origine: GroupPolicy (Microsoft-Windows-GroupPolicy)
    id evento: 1129
    Elaborazione dei Criteri di gruppo non riuscita a causa di problemi di connettività con un controller di dominio. Il problema potrebbe essere transitorio. Se il computer si connette al controller di dominio e i Criteri di gruppo vengono elaborati correttamente, verrà generato un messaggio di operazione riuscita. Se dopo alcune ore tale messaggio non viene visualizzato, contattare l'amministratore.




    Origine: DistributedCOM
    id evento:10000
    Impossibile avviare un server DCOM: {9C38ED61-D565-4728-AEEE-C80952F0ECDE}. L'errore 
    "%%0"
    si è verificato durante l'avvio del comando 

    ------------------------------------------------------------


    Fabio Celli

    venerdì 20 settembre 2019 16:46
  • Ciao Fabio, ma il server arriva da una migrazione? 

    Puoi postare il risultato di un dcdiag e di un ipconfig /all (anche se secondo me fai prima ad eseguire una installazione clean…)

    Saluti
    Nino


    www.testerlab.it

    venerdì 20 settembre 2019 16:53
    Moderatore
  • Si esatto il server proviene da una migrazione 2003 -> 2012 -> 2019

    Lunedi mattina eseguo quei 2 test e li posto.

    In che senso una installazione clean ? Comporterebbe perdita di dati o possiamo recuperare l'AD ?

    PS : Il server era perfettamente funzionante dopo la fine della migrazione. Tutti questi problemi sono venuti fuori successivamente.

    Grazie


    Fabio Celli


    • Modificato Fabio Celli sabato 21 settembre 2019 12:06
    sabato 21 settembre 2019 12:04
  • Si, la soluzione migliore è quella di partire da una installazione pulita (ovvero nuova). Se non hai un altro Domain Controller spento che può (forse) risolvere la situazione la vedo dura…

    Saluti
    Nino


    www.testerlab.it

    sabato 21 settembre 2019 20:31
    Moderatore
  • Allora un DC spento c'è ma è un 2003. Per riportarne le funzionalità sul 2019 devo passare prima da un 2012 e poi convertire il sysvol da rfs a dfs ed è un lavorone che non vorrei rifare.

    Io ho anche una copia della AD in formato csv esportata dal 2003.

    Non posso tramite powershell importarla in una AD vuota di un nuovo server 2019 dopo averlo attivato come DC ?


    Fabio Celli

    domenica 22 settembre 2019 06:34
  • Buongiorno, allego gli screenshot dei due test richiesti.

    Le schede di rete non sono al momento configurate con un IP fisso come si puo' vedere da IPCONFIG ma solo perché il server è momentaneamente staccato dalla rete per manutenzione.


    Fabio Celli



    • Modificato Fabio Celli lunedì 23 settembre 2019 08:46
    lunedì 23 settembre 2019 08:28
  • Sembra comunque dai test precedenti che ci sia un problema con le autorizzazione dell'utente administrator. Come se non potessimo gestire in locale alcune cose come ad esempio i servizi. E' possibile ?


    Come faccio ad assicurarmi ad esempio nella MMC  secpol.msc "Criteri di sicurezza locali" che l'utente administrator abbia tutti i permessi necessari ? Non vorrei che si siano create incongruenze dopo l'importazione della vecchia AD dal server 2003. Posso forzarlo ?

    Fabio Celli




    • Modificato Fabio Celli lunedì 23 settembre 2019 08:57
    lunedì 23 settembre 2019 08:47
  • Buongiorno, allego gli screenshot dei due test richiesti.

    Le schede di rete non sono al momento configurate con un IP fisso come si puo' vedere da IPCONFIG ma solo perché il server è momentaneamente staccato dalla rete per manutenzione.


    Fabio Celli



    come fai ad avere un domain controller che prende l'indirizzo ip da un dhcp server ?

    i parametri della configurazione di rete sulla NIC 1 sono totalmente errati per un domain controller e vanno sistemati


    Edoardo Benussi
    Microsoft MVP - Cloud and Datacenter Management
    e[dot]benussi[at]outlook[dot]it


    lunedì 23 settembre 2019 09:53
    Moderatore
  • Salve Edoardo, se leggeva bene il mio post alla riga : "il server è momentaneamente staccato dalla rete per manutenzione" vedeva che il server non è in una posizione operativa e non prende nemmeno l'ip da un dhcp server visto che il server dhcp è lui e che è fisicamente scollegato da tutto.

    Per la riconfigurazione delle NIC ci penseremo poi. Ho dovuto eliminare le impostazioni fisse perché ho riattivato le funzionalità di rete delle schede come i protocolli che si erano stranamente disabilitate.

    Mi sembrava fosse  ovvio, mi sono spiegato male forse...


    Fabio Celli


    • Modificato Fabio Celli lunedì 23 settembre 2019 14:16
    lunedì 23 settembre 2019 14:14
  • ok, in queste condizioni il domain controller non può funzionare. deve sentire la connessione di retet attiva sulla scheda di rete ed avere una configurazione corretta della scheda di rete.

    Edoardo Benussi
    Microsoft MVP - Cloud and Datacenter Management
    e[dot]benussi[at]outlook[dot]it

    lunedì 23 settembre 2019 14:35
    Moderatore
  • Al di là di capire davvero poco di questo thread, ho una curiosità: ma quanti client hai su questa rete?

    A.

    martedì 24 settembre 2019 15:43
    Moderatore