none
Store app does not start RRS feed

  • Domanda

  • I keep seeing this in the logs. Any ideas?

    Log Name:      Microsoft-Windows-TWinUI/Operational
    Source:        Microsoft-Windows-Immersive-Shell

    Description:
    Activation of the app winstore_cw5n1h2txyewy!Windows.Store for the Windows.Launch contract failed with error: The system cannot find the file specified..
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Microsoft-Windows-Immersive-Shell" Guid="{315A8872-923E-4EA2-9889-33CD4754BF64}" />
        <EventID>5961</EventID>
        <Version>0</Version>
        <Level>2</Level>
        <Task>5961</Task>
        <Opcode>0</Opcode>
        <Keywords>0x4000000000000000</Keywords>
        <TimeCreated SystemTime="2012-08-25T20:24:20.136403700Z" />
        <EventRecordID>751</EventRecordID>
        <Correlation />
        <Execution ProcessID="1688" ThreadID="3028" />
        <Channel>Microsoft-Windows-TWinUI/Operational</Channel>
        <Computer>YPITSCH-PC</Computer>
        <Security UserID="S-1-5-21-3567703334-768078712-405437120-1000" />
      </System>
      <EventData>
        <Data Name="AppId">winstore_cw5n1h2txyewy!Windows.Store</Data>
        <Data Name="ContractId">Windows.Launch</Data>
        <Data Name="ErrorCode">-2147024894</Data>
      </EventData>
    </Event>

    sabato 25 agosto 2012 20:43

Risposte

  • Joe: I had this same issue with the license message, which was caused in my case by the C:\ProgramData directory having been moved to D:\ProgramData using an Autounattend.xml file at installation. Apparently W8 expects some files to be on C: only. After doing a reinstall with C:\ProgramData hosting programdata and D:\Users hosting user data, it's working for me.
    giovedì 6 settembre 2012 09:23

Tutte le risposte

  • What version of Windows 8 are you using?

    Did you installed any new software or program before problem happen?

    Is your PC update?

    Did you upgrade or run a clean install?

    domenica 26 agosto 2012 06:03
  • sfc /scannow?
    domenica 26 agosto 2012 14:21
  • sfc / scannow: Windows Resource Protection did not find any integrity violations.

    I user RTM version from MSDN Developer download - clean install

    • Proposto come risposta PSGS domenica 27 ottobre 2013 14:28
    • Proposta come risposta annullata Andre.ZieglerEditor venerdì 15 novembre 2013 05:09
    domenica 26 agosto 2012 17:20
  • What happens when you create a new user? Does the store works for it?

    Also, did you move your user profile folder?

    • Modificato AnthonyDa domenica 26 agosto 2012 17:53
    • Proposto come risposta Yamasix martedì 1 dicembre 2015 09:06
    domenica 26 agosto 2012 17:53
  • So I created a new local user and it works

    In fact I had Win8 consumer preview. When installing RTM, even if it is a clean install, user settings were maintained and store for these accounts does not work...

    Still now idea how to recover my existing accounts..

    Thanks

    domenica 26 agosto 2012 19:31
  • Then the broken folder is inside appdata\local\Microsoft\Windows store (maybe there's the same inside the roaming folder).

    You can try to copy/paste the one from the new user (that is working) to the broken one.

    Make sure to backup the old one before.

    domenica 26 agosto 2012 19:50
  • hmm, still the same issue
    martedì 28 agosto 2012 05:00
  • The Store App will not start on my computer.  The event log indicates a "license" issue.

    This computer is running Windows 8, RTM, 64bit.  This is an upgrade from Windows 7 Pro.  The computer is joined to a domain.

    Creating a new local user and trying from that account also does not work.

    The event log record:

    Log Name:      Application
    Source:        Microsoft-Windows-Immersive-Shell
    Date:          8/30/2012 12:49:13 PM
    Event ID:      5973
    Task Category: (5973)
    Level:         Error
    Keywords:     
    User:          HQ\xxx
    Computer:      obsidian.xx.com
    Description:
    Activation of app winstore_cw5n1h2txyewy!Windows.Store failed with error: This app failed to launch because of an issue with its license. Please try again in a moment. See the Microsoft-Windows-TWinUI/Operational log for additional information.
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Microsoft-Windows-Immersive-Shell" Guid="{315A8872-923E-4EA2-9889-33CD4754BF64}" />
        <EventID>5973</EventID>
        <Version>0</Version>
        <Level>2</Level>
        <Task>5973</Task>
        <Opcode>0</Opcode>
        <Keywords>0x2000000000000000</Keywords>
        <TimeCreated SystemTime="2012-08-30T19:49:13.219000400Z" />
        <EventRecordID>70437</EventRecordID>
        <Correlation />
        <Execution ProcessID="1672" ThreadID="3824" />
        <Channel>Application</Channel>
        <Computer>obsidian.xx.com</Computer>
        <Security UserID="S-1-5-21-2997049106-738835354-2595110391-1109" />
      </System>
      <EventData>
        <Data Name="AppId">winstore_cw5n1h2txyewy!Windows.Store</Data>
        <Data Name="ErrorCode">-2144927140</Data>
      </EventData>
    </Event>

    giovedì 30 agosto 2012 20:19
  • Joe: I had this same issue with the license message, which was caused in my case by the C:\ProgramData directory having been moved to D:\ProgramData using an Autounattend.xml file at installation. Apparently W8 expects some files to be on C: only. After doing a reinstall with C:\ProgramData hosting programdata and D:\Users hosting user data, it's working for me.
    giovedì 6 settembre 2012 09:23
  • Tomas can you please describe how exactly you reinstalled it? Did you formatted it or refreshed it?

    I do not have programdata or users on my D:\ drive ad already tried  refresh it with no joy. I still keep getting below error:

    Log Name:      Application
    Source:        Microsoft-Windows-Immersive-Shell
    Date:          29/10/2012 19:47:42
    Event ID:      5973
    Task Category: (5973)
    Level:         Error
    Keywords:      
    User:          IJPC\IJ
    Computer:      IJPC
    Description:
    Activation of application winstore_cw5n1h2txyewy!Windows.Store failed with error: This application failed to launch because of an issue with its licence. Please try again in a moment. See the Microsoft-Windows-TWinUI/Operational log for additional information.
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Microsoft-Windows-Immersive-Shell" Guid="{315A8872-923E-4EA2-9889-33CD4754BF64}" />
        <EventID>5973</EventID>
        <Version>0</Version>
        <Level>2</Level>
        <Task>5973</Task>
        <Opcode>0</Opcode>
        <Keywords>0x2000000000000000</Keywords>
        <TimeCreated SystemTime="2012-10-29T19:47:42.062261000Z" />
        <EventRecordID>393</EventRecordID>
        <Correlation />
        <Execution ProcessID="4004" ThreadID="1648" />
        <Channel>Application</Channel>
        <Computer>IJPC</Computer>
        <Security UserID="S-1-5-21-2266226180-4205988184-1454161716-1000" />
      </System>
      <EventData>
        <Data Name="AppId">winstore_cw5n1h2txyewy!Windows.Store</Data>
        <Data Name="ErrorCode">-2144927140</Data>
      </EventData>
    </Event>

    lunedì 29 ottobre 2012 21:23
  • Run the following in a Command Window to re-register the Store app:
    powershell -ExecutionPolicy Unrestricted Add-AppxPackage -DisableDevelopmentMode -Register $Env:SystemRoot\WinStore\AppxManifest.xml

    This resolved my issue

    • Proposto come risposta William Assaf mercoledì 19 marzo 2014 19:00
    domenica 10 novembre 2013 19:50
  • Re-register the Store app fixed my problem.

    Sharkrit

    venerdì 15 novembre 2013 03:44
  • In a week of days, I tried absolutely everything! Then came across this. Well done! It worked a treat,

    all the best and many thanks.

    martedì 19 novembre 2013 16:38
  • Your fix worked for me & is much appreciated.   JB
    mercoledì 20 novembre 2013 21:12
  • If that does not work, try the following (it worked for me though):

    In an Elevated Command Prompt -> CMD.EXE (Run As Administrator):

    dism.exe /online /cleanup-image /restorehealth

    Reboot the computer and then, in an Elevated Command Prompt:

    sfc.exe /scannow

    Success,
    Best regards
    MP.VS


    MP VS

    • Proposto come risposta vanSijll mercoledì 19 marzo 2014 21:09
    giovedì 5 dicembre 2013 16:57
  • Thanks this worked for me perfectly.
    sabato 31 maggio 2014 11:46
  • Hey brother, 
    I had the same issue and, this commad just save me a lot of time of hardwork...

    I just went to "Search" of Win 8.0
    Input there "powershell"> open the app (looks like a CMD screen)
    and at the prompt I just paste the following command:
    #powershell -ExecutionPolicy Unrestricted Add-AppxPackage -DisableDevelopmentMode -Register $Env:SystemRoot\WinStore\AppxManifest.xml

    # -> remember to get out this prompt "#" before the command line.

    At Late of Oct'14's still working fine.
    Thanks bro!!!

    giovedì 23 ottobre 2014 04:02