none
Aggiorna e arresta durante l'arresto del sistema Windows 10 Pro RRS feed

  • Domanda

  • Buongiorno a tutti.

    Dispongo di numerose postazioni client Windows 10 Pro 1903 (Build sistema operativo 18362.175), alcune a dominio ed altre no. In "Impostazioni PC > Aggiornamento e sicurezza > Windows Update" riscontro la voce "Aggiornamenti disponibili" ed è visibile l'elenco degli aggiornamenti contrassegnati come "Stato: Download in sospeso". Tale elenco è seguito dalla voce "Gli aggiornamenti sono pronti per il download" ed è possibile cliccare il bottone "Download". Ciò nonostante non vengono mai proposte le voci "Aggiorna e arresta" e "Aggiorna e riavvia" durante la normale procedura di arresto del sistema. Questo è un problema, dato che gli utenti non saranno in grado di mantenere il proprio pc aggiornato. Problema che non c'era prima dell'installazione del Cumulativo 1903, o su Windows 7 Pro.

    Spero possiate aiutarmi a capire.

    Un cordiale saluto - Luca


      

     

    venerdì 9 agosto 2019 05:37

Tutte le risposte

  • Ciao Luca,

    tralasciamo gli aggiornamenti di 7 rispetto a quelli di 10 vuoi? era un diverso sistema con diverse funzionalità.

    Anche XP era diverso da 7.

    Il problema che hai tu chiaramente non può essere un problema di tutte le 1903 in circolazione altrimenti qui saremmo subissati. Penso debba essere ricondotto alla iso specifica che stai usando.

    La cosa che devi provare a fare è una installazione pulita su un client partendo da quella iso e provando ad aggiornare. Va bene anche virtuale. Se li il problema non c'è mi viene da pensare che ti si sia sporcata l'upgrade.

    Quindi poi dovrai muoverti con perlomeno degli inplace versione su versione. Il problema però non si evince se ce l'hai su tutte o solo su alcune e quante sono. Controlla anche le suite antivirus, in alcuni casi sono state le colpevoli di comportamenti analoghi.

    ciao.

    A.

    venerdì 9 agosto 2019 06:03
    Moderatore
  • Ciao e grazie per la tempestiva risposta.

    Sei stato chiarissimo, interverrò in questo modo.

    Un cordiale saluto, buon lavoro.

    Luca

    venerdì 9 agosto 2019 06:31
  • Ciao.

    Ho eseguito una prima prova sul pc dove l'installazione di Windows 10 (1903 x64) è stata eseguita da zero e dove non c'è alcun prodotto antivirus. In Windows Update compare l'aggiornamento, ma la procedura di arresto non menziona la voce "Installa e arresta". Creare subito una nuova ISO 1903 con Media Creation Tool potrebbe avere senso? Rispetto a quella generata due mesi fa cambierebbe qualcosa secondo te?

    Grazie – Luca
    venerdì 9 agosto 2019 07:13
  • Fermiamoci. E' un'immagine iso pulita lustra di fabbrica o ci hai messo le mani? perchè c'è una bella differenza..e leggo "generata". 

    Devi prendere una iso di MS e provare con quella, non con delle generalizzate, personalizzate. Siccome su quelle il tuo problema non esiste, sicuramente c'è qualcosa nella personalizzazione che hai fatto.

    Potresti provare a mettere in piedi un client con una iso pulita, aggiornarlo fino ad oggi e poi rifare il master, ma DEVI partire da una iso standard.

    venerdì 9 agosto 2019 08:12
    Moderatore
  • Ciao.

    Per "generata" intendo creata attraverso MediaCreationTool1903.exe, scaricabile dalla pagina software-download del sito Microsoft. Non è la strada corretta?

    Grazie - Luca



    venerdì 9 agosto 2019 10:05
  • Ciao.

    Volevo aggiornarti in merito ad uno dei pc "incriminati". Ho aggiornato il sistema con la ISO 1903 scaricata due ore fa. Rispetto a quella del mese di giugno, ha una dimensione di poco superiore ai 4gb. Dopo l'installazione e il riavvio, il sistema presenta una icona in basso a destra (di fianco all'ora di Windows) che recita: "Il dispositivo deve essere riavviato per installare gli aggiornamenti. Seleziona un'ora per il riavvio". Ora è presente anche la voce "Aggiorna e arresta" durante l'arresto del sistema.


     




    venerdì 9 agosto 2019 10:48
  • Il media creation tool non genera immagini, scarica l'ultima disponibile con gli ultimi aggiornamenti.

    Sicuramente tu hai preso giù una delle prima iso. Tieni presente che, in produzione, non si aggiornano mai i sistemi operativi con l'ultima release uscita da 1 mese. E' una prassi per sopravvivere agli inevitabili bug che vengono sistemati man mano che gli utenti (consumer di solito che fanno da cavia..) li notificano. Per quanto riguarda una rete aziendale devi prima di tutto avere una macchina di test su cui carichi la iso nuova, se non ha problemi di sorta perchè l'hai provata in tutte le sue sfaccettature allora fai un deployment a step sui client.

    Sulle mie strutture prima di un anno dal rilascio non entra niente come client, in laboratorio ed a casa non c'è problema al massimo ripristini.

    La versione attuale sicuramente è più stabile. Tieni conto che la 1903 è anche slittata di 2 mesi per vari problemi quindi doveva essere di Marzo\Aprile ed è uscita a Giugno...tu l'hai piazzata su subito...

    Ciao!

    A.

    • Contrassegnato come risposta Luca Borini sabato 10 agosto 2019 11:15
    • Contrassegno come risposta annullato Luca Borini sabato 10 agosto 2019 11:15
    venerdì 9 agosto 2019 13:24
    Moderatore
  • Per le postazioni di produzione abbiamo scelto a priori di mantenere Windows 7 in effetti.

    Grazie per la spiegazione.

    Luca

    sabato 10 agosto 2019 11:14