Task Scheduler: "MMC has detected an error in a snap-in..."


  • Serious problem--My Vista computer is not creating any scheduled restore points.  When I try to open Task Scheduler to see what is going on, I get a popup dialog saying, "MMC has detected an error in a snap-in and will unload it."

    Is there any way to repair Task Scheduler? 

    sfc did not fix it.

    A message inside Task Scheduler is here:

    Error messages when attempting to close it are shown as:

    at System.RuntimeTypeHandle.CreateInstance(RuntimeType type, Boolean publicOnly, Boolean noCheck, Boolean& canBeCached, RuntimeMethodHandle& ctor, Boolean& bNeedSecurityCheck)
       at System.RuntimeType.CreateInstanceSlow(Boolean publicOnly, Boolean fillCache)
       at System.RuntimeType.CreateInstanceImpl(Boolean publicOnly, Boolean skipVisibilityChecks, Boolean fillCache)
       at System.Activator.CreateInstance(Type type, Boolean nonPublic)
       at Microsoft.ManagementConsole.FormView.InternalInitialize()
       at Microsoft.ManagementConsole.View.HandleInitializationRequest(IRequestStatus requestStatus)
       at Microsoft.ManagementConsole.View.ProcessRequest(Request request)
       at Microsoft.ManagementConsole.ViewMessageClient.ProcessRequest(Request request)
       at Microsoft.ManagementConsole.Internal.IMessageClient.ProcessRequest(Request request)
       at Microsoft.ManagementConsole.Executive.RequestStatus.BeginRequest(IMessageClient messageClient, RequestInfo requestInfo)
       at Microsoft.ManagementConsole.Executive.SnapInRequestOperation.ProcessRequest()
       at Microsoft.ManagementConsole.Executive.Operation.OnThreadTransfer(SimpleOperationCallback callback)
    mercoledì 10 febbraio 2010 20:02

Tutte le risposte

  • Is the Task Scheduler service running? Enter services.msc in the Windows Search bar that appears after you click the Windows Orb in the lower-left corner to access service control console. Also check the last post in this thread.
    mercoledì 10 febbraio 2010 20:17
  • Task scheduler is running.
    I will check the other thread.
    mercoledì 10 febbraio 2010 20:49
  • BTW, I have .NET 1.1 and 3.5 SP1 installed. I assume some app caused the duplication.
    I have no ...\System32\mmc.exe.config file.
    mercoledì 10 febbraio 2010 20:52
  • Yet more info...
    In Turn Windows Features On or Off, only .NET 3.0 (note zero) shows. 
    Within it, only XPS Viewer is checked as ON.
    Communication Foundation HTTP and non-HTTP are checked OFF.

    (Aside-how did you make a word into a link?)
    mercoledì 10 febbraio 2010 21:01
  • Yet more info 2...

    I have discovered that Event Viewer presents the same error when attempted to access via mmc.

    Is this a known problem of Task Scheduler and Event Viewer "going south?"
    giovedì 11 febbraio 2010 15:24
  • Apparently, the MMC depends on .NET Framwork (3.0, I guess). Try to uninstall .NET 3.5 (it also features updates to .NET 3.0) and reboot. Afterwards check if MMC works. Then try to install .NET 3.5 SP1 again, install the recommended update and run Windows Update afterwards (there should be some updates for .NET 3.5).
    giovedì 11 febbraio 2010 18:13
  • As suggested, I did uninstall NET 3.5.
    MMC will run (Rt click computer>Manage) --it always would open to the MMC main window--but as soon as you click on either Task Scheduler or Event Viewer, the error appears.
    Reinstalled NET 3.5 and all updates, but as soon as you click on either Task Scheduler or Event Viewer, the error appears.

    In other words, no change.

    I have done lots of web searching about this...using search terms:
    [Vista "Task Scheduler" and "Event Viewer" MMC]
    This problem is discussed multiple times in numerous forums--since LONG ago.  It is a well known symptom that has been around a LONG time.

    Many fixes are suggested, then followed by the originator saying "that didn't work," just as I have done here. The only consistent fix is a Vista reinstall.  One person indicated a "repair" works, but I have an OEM Vista Home Premium and thus do not have an installation disk.

    I am getting a real bad feeling about this.
    giovedì 11 febbraio 2010 20:43
  • This is insane. 

    This problem of "Task Scheduler" and "Event Viewer" dying is discussed all over the net.  Yet Microsoft ignores it. 

    There is no fix anywhere.  There is no MS acknowledgment of it.  Restore point creation is essentially dead.  Can never use event viewer.  I sure would like a procedure to reinstall or otherwise reliably fix whatever it is that has failed.  Dream on. One more major strike against Microsoft.

    Yes, I am highly disturbed about this.  I have spent DAYS (several hours each day) working on this, and all I find is people in the same boat as I am.  POS.
    sabato 13 febbraio 2010 20:06
  • This is not such a widespread issue as you may believe it is. The question is what has happened? Have you tried to install .NET 1.1, 2.0, 3.0 by yourself or perhaps one of your applications did it for you and have overwritten some files.
    Let's try Process Monitor traces. Maybe somehow we can figure this out. If you have never used Process Monitor before take your time to familiarize yourself with it.
    I've taken a trace of what happens when I launch the Event Viewer using Start -> Run -> eventvwr.msc. It was done on a Polish version of Windows Vista SP2 without .NET 3.5. Get it here. You can open the trace using Process Monitor. You may want to apply the filter so that you would only see mmc.exe process. Note that it seems that .NET 2.0 is used for Event Viewer.
    Try to capture a trace using Process Monitor when you access Event Viewer on your computer. Stop the capture when the error message comes up. The compar the traces (there is no built-in tool for that so...). Check if the same .NET Framework is used (the subfolder in c:\Windows\Microsoft.NET). Check if you get many "Access denied" or "Name not found" results and compare them with the "correct trace" (check if they occur on the same files, registry entries).
    Also check the file sizes of c:\windows\system32\eventvwr.exe and eventvwr.msc. On my install they have 79 872 bytes and 145 127 bytes repectively.
    Yes, reinstalling Windows Vista is going to be easier...

    martedì 16 febbraio 2010 18:20
  • "Also check the file sizes of c:\windows\system32\eventvwr.exe and eventvwr.msc. On my install they have 79 872 bytes and 145 127 bytes repectively."

    Same size on my Vista.
    giovedì 25 febbraio 2010 20:53
  • Try this - uninstall every Microsoft .NET product you see in Programs and Features and reboot. Next, download and run .NET Framework Cleanup Tool. Choose ".NET Framework - All Versions (Windows Vista and Windows Server 2008)" as "Product to cleanup" and click "Cleanup Now" button. Reboot after the operation completes and check if it somehow helped.
    venerdì 26 febbraio 2010 17:46
  • gladiator is right, this problem is everywhere and nobody can come up with a fix. I consider myself somewhat of an expert at finding things on the interweb and, after searching fruitlessly, on and off, for 6 months or more, i have reached the conclusion that a solution to this cannot be found. only thing i know for sure is that it's related to windows updates and, specifically, framework 3.5 .... and it doesn't matter how many times i uninstall/reinstall it, or run the .net framework cleanup tool, or even system restore the problem persists. and it doesn't matter how many other 'fixes' i try the end result is the same.


    gladiator, do yourself a favour, man, and run a repair install (instructions here: you will save yourself days, weeks, months of headaches. failing that the only other option is to forget that task scheduler and event viewer ever existed. 




    domenica 9 maggio 2010 17:28
  • You have well expressed my immense frustration over this, and Microsoft's attitude (thumb-your-nose at your customers) about it. Unfortunately, the repair approach presents a seemingly insurmountable issue as well. My laptop has SP1 (it has an incompatibility with SP2--or so the install says), and no original CD, which would not be a correct one anyway. So, what am I to do? Purchase a retail one? Can they be found with SP1 level in them? Microsoft sucks and this is but one further piece of evidence.
    domenica 9 maggio 2010 19:20
  • sfc did not fix it

    Did you check the sfc log file %windir%\Logs\CBS\CBS.log? In my case it failed to repair the mscorwks.dll file (and possibly other files that was causing the error) because the copy of mscorwks.dll in %windir%\winsxs was also corrupted. sfc will never read the file from the installation media, so if the %windir%\winsxs copy is corrupted too it will say "Cannot repair member file ... hash mismatch".

    Since I had dozens of "hash mismatch" I found it best to automate the replacement of all those files. I wrote a c# program that reads the hash mismatch from the CBS.log file and replace them, you find the program here

    Task Scheduler, Event Viewer and Computer Management now works on the machine instead of crashing mmc.exe.

    mercoledì 21 settembre 2011 11:18
  • The final fix, for me, was a "repair re-install".  As indicated above, getting to that was problematic because the OS was SP1, meaning I would have to have an OS disk at SP1 level.  They aren't just laying around everywhere.

    After much effort, I finally wound up in email contact with an MS person who gave me a gratis code for MS support because of all the trouble I had with the problem.  EVENTUALLY, and I don't mean it was easy (as in delivery promised several times and it not showing up), an SP1 Vista disk came, and the repair-the-OS proccedure solved the problem.

    OF course, we still don't know what file(s) or corrupted registry data was the problem--so the problem remains unfixable except by a full OS repair, after which you must reinstall all updates to the OS.

    I urge everyone reading this to web search on slipstreaming and make yourself a disk if you do not have an OS disk AT YOUR PRESENT SP LEVEL.

    Oh, interestingly, after the repair, the machine would accept the upgrade to SP 2 whereas before it would not.
    • Modificato gladiator- mercoledì 21 settembre 2011 12:13
    mercoledì 21 settembre 2011 12:11