none
Activating TLS 1.2 on Windows 7 for .NET web server RRS feed

  • Domanda

  • We have a .NET web server hosted on NancyFx, that we are trying to keep working cross-platform between Windows 7 and 10. We recently migrated from HTTP to secure HTTPS, and there is a discrepancy. Looking from Chrome dev tools, our server running on Windows 7 is serving requests with TLS 1.0, while on Windows 10 it is using TLS 1.2. We have tried a number of instructions, published by Microsoft and others, but none of them had any effect:

    https://docs.microsoft.com/en-us/configmgr/core/plan-design/security/enable-tls-1-2
    https://support.microsoft.com/en-us/help/3140245/update-to-enable-tls-1-1-and-tls-1-2-as-default-secure-protocols-in-wi
    https://docs.microsoft.com/en-us/dotnet/framework/network-programming/tls#configuring-security-via-the-windows-registry
    https://docs.microsoft.com/en-us/windows-server/security/tls/tls-registry-settings
    https://docs.microsoft.com/en-us/windows/win32/secauthn/protocols-in-tls-ssl--schannel-ssp-?redirectedfrom=MSDN
    https://documentation.cpanel.net/display/CKB/How+to+Configure+Microsoft+Windows+7+to+use+TLS+Version+1.2
    https://mycloudtree.co.uk/knowledgebase/19/Enabling-TLS12-on-Windows-7.html
    https://www.ryadel.com/en/enable-tls-1-1-1-2-windows-7-8-os-regedit-patch-download/

    The application targets .NET 4.0, but we are are currently running it on the latest .NET Framework installation 4.8. We know this had previously fixed issues with TLS support for our .NET client applications.

    The application does set the SecurityProtocol globally (in try/catch in case that is not available): ServicePointManager.SecurityProtocol = SecurityProtocolType.Tls12

    Is there any way for us to check that TLS 1.2 is available in any way, shape or form on that system? That would be a Windows 7 embedded target platform, though we are also testing on Windows 7 Professional.

    I don't think we have to change anything within the application code itself, but I may be wrong about that.

    lunedì 13 gennaio 2020 15:26

Tutte le risposte

  • Since the app targets .Net 4.0, Have you specified this registry value for 4.0?

    Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework\v4.0.30319

    Create REG_DWORD, SchUseStrongCrypto, 1

    Here's a screenshot:


    Seth

    A user just like you

    lunedì 13 gennaio 2020 16:13
  • Hi,

    Just checking in to see if the information provided was helpful.

    Please let us know if you would like further assistance.

    Best Regards,

    Ellen


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    mercoledì 15 gennaio 2020 09:32
  • Hi,

    You could mark the useful reply as answer if you want to end this thread up.

    If there is anything else we can do for you, please feel free to post in the forum.

    Best Regards,

    Ellen



    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    martedì 21 gennaio 2020 06:16