none
Explorer not refreshing on create / rename / Delete folders RRS feed

  • Domanda

  • Any help with this?

    It seems to be an old problem with various fixes suggested, but all the ones I try don't work.

    It has just started in the last week or so.

    When I am in Window explorer (Win 7 64 bit) If  I create a new folder, nothing happens, it does but I have to hit F5 for the new folder to appear. Same thing when I rename or delete a folder.

    I understand this has affected a lot of people but until now it has not been a problem for me.

    Can anyone suggest a fix for this it is infuriating.

    Thanks.

    venerdì 7 aprile 2017 16:32

Tutte le risposte

  • Curious.

    Since this problem started I left the machine on overnight and there appears to have been some sort of update and the machine updated then restarted.

    ( I had tried a reboot several times along with searching for the dontrefresh registry entry - there wasn't one. And the reboots made no difference) 

    The problem now appears to have gone.

    lunedì 10 aprile 2017 07:42
  • Hi,

    Here is an incredibly simple solution that worked for me. It may work for you as well:

    In Windows Explorer: choose Tools, Folder Options > Click the Search tab > Check or uncheck ANY option

    Apply.

    If this solves your problem, you can revert to your original setting and the problem will remain solved.

    In addition, I also found if we disable the client for Microsoft Networks in properties of Local Area Connection - the issue disappear (maybe only in my case).

    Hope that helps.

    Best Regards,

    Tao


    Please remember to mark the replies as answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    martedì 11 aprile 2017 05:48
    Moderatore
  • Hi,

    We haven’t heard from you for a couple of days, have you solved the problem? We are looking forward to your good news.

    Best Regards,

    Tao


    Please remember to mark the replies as answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    mercoledì 19 aprile 2017 02:37
    Moderatore
  • Thanks! The solution for me on Windows 10 was als to check -> apply and uncheck -> apply a random option in the search tab. :)

    • Modificato FrankJNL91 venerdì 23 febbraio 2018 11:01
    venerdì 23 febbraio 2018 10:59
  • In addition to the problems RobMcP2 was having, Windows Explorer on my computer was locking up. I had to push the reset button on my computer to restart it. I made a change in options that Tony_Tao suggested (but in my case it was: Organize - Folder and Search Options. I changed an option on the General tab.), and it locked up after I Applied the change. I hit the reset button again to restart the computer (it would not restart normally). When Windows restarted it had accepted the change and everything worked normally.
    giovedì 16 agosto 2018 13:13
  • Hi,

    Here is an incredibly simple solution that worked for me. It may work for you as well:

    In Windows Explorer: choose Tools, Folder Options > Click the Search tab > Check or uncheck ANY option

    Apply.

    If this solves your problem, you can revert to your original setting and the problem will remain solved.

    In addition, I also found if we disable the client for Microsoft Networks in properties of Local Area Connection - the issue disappear (maybe only in my case).

    Hope that helps.

    Best Regards,

    Tao


    Please remember to mark the replies as answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Worked for me on Windows 10.

    Thanks a lot.

    venerdì 14 settembre 2018 03:58
  • For what is is worth, I  have had this problem on a Windows 10 system since I completed the install.

    For months it has bothered me and eluded remediation. What's worse, the Microsoft keyboard I am using does not have clearly marked Function keys, so hitting F5 every time I need the screen to refresh really stops my work in its tracks.

    I followed dozens and dozens of "fixes", from scanning the system, to recreating the profile to hacking Registry keys and hives.  Today I thoughtI would spend a few minutes walking through a collection of 18 possible fixes. On a Windows 10 system here is what worked, 

    Just right click on desktop 

    Click Personalize 

    Click Themes

    Click Change desktop icons 
    Restore default & OK  

    And instantly it began to auto refresh with a new folder, rename, delete, copy, etc.

    Yeah....

    • Proposto come risposta TechyBit mercoledì 16 ottobre 2019 14:47
    venerdì 5 ottobre 2018 03:32
  • in windows 10, Tony_Tao s answer works but "Folder options" is named "options" and located under "file".

    file explorer -> file ->options -> search tab ->  uncheck or check any option (I unchecked "Include system directories") 

    reverting the change did not cause any problems


    • Modificato mnuman martedì 26 febbraio 2019 06:01 credit to original answer
    martedì 26 febbraio 2019 05:57
  • Second this!  it worked!  Thanks Tao!
    sabato 9 marzo 2019 23:34
  • If changing settings under Search doesn't work, try enabling or disabling "Launch folder windows in a separate process".

    To check/uncheck from Win Explorer: File > Change Folder & Search Options > View [Tab] > Uncheck the box.

    martedì 9 aprile 2019 16:29
  • I have experienced the same problem for the past couple of months.

    Seach tab solution didnt help me at all, but this with the "Launch folder windows in a seperate process" did solve my problem. Im happy again! :)

    giovedì 2 maggio 2019 20:36
  • This started on my flawless 1607 14393.2941 LTSB dev bench machine today and I am beyond surprised.

    I have not seen this since 7.

    None of the above 'fixes' do anything at all.

    lunedì 6 maggio 2019 03:25
  • I was skeptical with this but it fixed the issue immediately, nice workaround. Now all we need is for Microsoft to pull out their finger and fix the issue instead of sitting on them.

    Come on Microsoft, we've paid money for this OS get it fixed.

    domenica 12 maggio 2019 17:41
  • Worked. Thanks!
    mercoledì 12 giugno 2019 15:35
  • None of the above worked for me either, but this did:  I reset all my folder and search views to default and applied them, then restarted.  So with "This PC" highlighted in Windows Explorer, I;

    • Selected FILE > CHANGE FOLDER AND SEARCH OPTIONS
    • GENERAL TAB > RESTORE DEFAULTS > APPLY
    • VIEW TAB > FOLDER VIEWS > RESET FOLDERS > YES
    • VIEW TAB > RESTORE DEFAULTS > APPLY
    • SEARCH TAB > RESTORE DEFAULTS > APPLY
    • I then rebooted, just to make sure - all fixed!!

    Thank God, cuz this was driving me NUTS for a LOOOOONG time!! :P

    Good luck!

    • Proposto come risposta CodyPredy sabato 5 ottobre 2019 18:12
    lunedì 26 agosto 2019 00:52
  • Like Thrashin, I also tried all the previous suggestions with no joy. Plus many others I googled. 

    Thrashin's process worked for me. Thank you so much! It was driving me nuts as well! 


    sabato 7 settembre 2019 20:04
  • Simply wow! I regularly had this issue every about 6 months. Usually I'll format my laptop but I got tired of it. Thx for the tip.
    lunedì 14 ottobre 2019 08:17
  • This one worked for me - Thanks!!!
    venerdì 20 dicembre 2019 02:07
  • Thank you! This worked for me on Windows 10 with a bit of trial and error. For anyone with this issue on Win10:

    1. Open Windows Explorer and go to File > Change folder and search options
    2. Click Restore Defaults
    3. Close all Windows Explorer instances
    4. Right click the task bar and open the Task Manager
    5. Find Windows Explorer and click restart (there may be multiple in the list)

    No further issues for me after following those steps! Cheers,

    DR

    venerdì 10 gennaio 2020 01:28
  • Thanks, it works on my Windows 10 1909.
    venerdì 10 gennaio 2020 05:06
  • Worked like a charm. Thanks.

    domenica 26 gennaio 2020 15:10
  • Superb!

    This was the only solution that worked for me - thanks!

    mercoledì 29 gennaio 2020 12:11
  • I have noticed this behavior, and it always goes away after a restart. I have never heard of it persisting after a restart, and I would be interested to hear from anyone who has the problem persist after a restart. For me it kicks in after only a couple of days without a restart. And I have done a fresh wipe and re-install only 3 months ago. Please let me know if restart fixes problem
    giovedì 6 febbraio 2020 16:42
  • OH MY BUTT! After ONE YEAR you FINALLY fixed my issue! THANK YOU! NOTHING else listed here worked. What a ridiculous thing that this bug has been going on this long with no fixes...
    venerdì 28 febbraio 2020 11:27
  • thx, save my day
    sabato 7 marzo 2020 05:47
  • So i am on windows 10 , and i do not know how to acces tools from Windows explorer, please help me, i encountered the same problem.
    lunedì 30 marzo 2020 16:50
  • Hey, this actually worked! Thanks!
    mercoledì 22 aprile 2020 17:42
  • Thanks! This solution worked for me!
    sabato 11 luglio 2020 21:46
  • Thanks, worked for me
    lunedì 13 luglio 2020 12:41
  • I was having this issue.  I discovered it was because I had a specific single board computer attached to the USB ports.  It's a board that emulates a FAT16 flash drive by way of the bootloader firmware thereon.

    Disconnecting this resolved the issue I was seeing.  I was also having an issue with the board being attached preventing windows from shutting down properly or starting up properly - just the win10 spinning wheel of boredom.

    Just wanted to advise my findings in case someone else was in a similar situation.  Take care.

    -MHz


    • Modificato Tod Wulff sabato 25 luglio 2020 02:29
    sabato 25 luglio 2020 02:29