none
Evitare mail vadano in spam con smarthost autenticato Exchange 2016 RRS feed

  • Domanda

  • Ciao a tutti,

    chiedo a voi esperti un parere. Ho un Exchange 2016 che per motivi di connettività usa uno smarthost per spedire posta. Lo smarthost ha lo stesso dominio del dominio pubblico della struttura. Nel connettore è specificato nello scoping dell'Helo request il nome dello smarthost. Esiste un record spf sul dominio con dentro il nome dello smarthost con il softfail ~all.

    Nonostante questo, su alcuni domini, tipo libero e gmail, randomicamente, le mail finiscono in cartella spam.

    Da cosa può dipendere? cos'altro dovrei mettere come impostazioni? Il Dkim che io sappia non è percorribile in questa configurazione.

    Grazie delle idee.

    lunedì 21 ottobre 2019 08:20

Risposte

  • Allora, ho fatto questo cambiamento:

    alla fine dell'spf record, dove erano contenuti solo 2 record:

    - l'fqdn del server smtp del provider

    - l'ip pubblico del server exchange

    ho cambiato alla fine invece di ~all ho messo ?all

    le mai non arrivano più in spam ma vanno nella casella princiale senza marcatura.

    vorrei capire però il perchè. A mio avviso era più corretto con la restrizione precedente.

    • Contrassegnato come risposta Wade Watts mercoledì 30 ottobre 2019 08:20
    mercoledì 30 ottobre 2019 08:20

Tutte le risposte

  • Ci sono dei passaggi che non capisco:

    1) Cosa intendi con "ha lo stesso dominio del dominio pubblico"?

    2) Lo smart host dove sta? E' quello di un provider?

    3) Lo smart host si presenta all'esterno con un un ip definito e conosciuto?

    4) Quando dici che "su alcuni domi, le mail finiscono nella cartella spam", cosa intendi? Le mail che invii tu a questi domi vanno nella loro cartella spam?

    Roberto


    Roberto Ferazzi
    Microsoft® MVP Office Apps & Services (Exchange, SFB, Teams)
    Moderator in the Microsoft TechNet Italy Forums
    My MVP Profile

    MSExchange.Community

     

    lunedì 21 ottobre 2019 10:02
    Moderatore
  • 1) intendo che il dominio aziendale è azienda.it e lo smarthost è smarthost.azienda.it avevo letto che se erano di differenti domini alcuni server potevano rifiutare la connessione anche se c'erano spf.

    2) si è quello di un provider, dedicato solo al dominio azienda.it

    3) direi proprio di si...è register il provider, è un smtp di register.it

    4) esatto. Quello che esce, random, su alcuni domini, finisce in spam, sul 95% delle mail non succede.

    Grazie.

    martedì 22 ottobre 2019 10:22
  • Il problema è che la reputazione degli IP usati dai provider come register è piuttosto bassa, visto che ospitano un grande numero di utenze, tra cui tanta fonte di spam.

    Temo che non ci sia una soluzione se non uscire direttamente o usare come smarthost un servizio migliore.

    Roberto


    Roberto Ferazzi
    Microsoft® MVP Office Apps & Services (Exchange, SFB, Teams)
    Moderator in the Microsoft TechNet Italy Forums
    My MVP Profile

    MSExchange.Community

     

    martedì 22 ottobre 2019 12:23
    Moderatore
  • Grazie Roberto,

    pensavo di aver sbagliato io qualcosa nella config. A questo punto potrei provare a farlo spedire direttamente con i suoi dns.

    Cambio l'spf e ci metto l'ip pubblico del cliente, faccio una zona di terzo livello con tipo mail.azienda.com con dentro solo l'ip come record A e poi lo metto nel connettore di uscita al posto dell'helo return togliendo smarthost e flaggando "use dns record of the domain". E' corretto? Od in quel caso mi serve anche il dkim? non mi è chiaro il suo funzionamento, nel senso, dovrebbe essere un certificato? 

    grazie.

    giovedì 24 ottobre 2019 05:53
  • Solitamente val la pena di coivolgere anche provider internet, chiedendo di creare recort PRT (o reverce dns), di modo che il tuo ip pubblico corrisponda al nome esterno.

    Per molti provider internt basta uan telefonata o un mail.

    ciao

    Carlo

    venerdì 25 ottobre 2019 05:58
  • ciao, intendi PTR record? non PRT.. Vero? ma sapevo che non era più necessario...ora quindi serve ancora?
    lunedì 28 ottobre 2019 09:11
  • Allora, ho fatto questo cambiamento:

    alla fine dell'spf record, dove erano contenuti solo 2 record:

    - l'fqdn del server smtp del provider

    - l'ip pubblico del server exchange

    ho cambiato alla fine invece di ~all ho messo ?all

    le mai non arrivano più in spam ma vanno nella casella princiale senza marcatura.

    vorrei capire però il perchè. A mio avviso era più corretto con la restrizione precedente.

    • Contrassegnato come risposta Wade Watts mercoledì 30 ottobre 2019 08:20
    mercoledì 30 ottobre 2019 08:20