Windows Search doesn't


  • If i use win+f to bring up the search window, type anything and hit enter nothing happens. The search isn't initiated. It just sits at the "To begin, type i the search box. Adding filters has on effect.

    Other search usage works, the start menu works, in directories in windows explorer typing and hitting enter starts a search correctly as expected. The windows search service runs. Indexing is enabled and working

    I've got a pretty new Win7 ultimate 64 build. From clean on bare metal, fully patched to current. I've got visual studio 2008, a couple of platform sdk's (which i'd like to be able to search without locating the folder first) and some other stuff like sql express installed. I haven't got any alternative search providers indexers or anything like that because mostly the windows search got me what i needed.

    I've reset all my search options to the defaults. When that didn't work i tried combinations of all the available settings, no change. Then i reset everything again. I've forced an index rebuild (succeeded), no change.

    I have found that if i disable the windows search service searches work. If i then start or allow an automatic restart of the services searches no longer initiate. This looks like a single part of the system can't connect to the indexing service. I haven't altered any permissions and i'm not aware of any settings that would affect this.

    Does anyone have any pointers or suggestions i haven't tried to get the system-wide search through win+f working?

    mercoledì 14 marzo 2012 19:08


Tutte le risposte

  • The items i want to search quickly have been added to the index, searches outside the index being slow is acceptible because it is quite rare. At the moment i don't have the option to use the index in system-wide though and i'd like to fix that.
    giovedì 15 marzo 2012 00:53
  • When i do that the search initiates (and completes if i let it) and doesn't ask if i want to index the drive, because it's already configured to be indexed. As i said in the original post that works, i want to search from the windows front end reached using win+f. It should work, it's entire purpose is to search and it doesn't. I'd like to fix it. Alternatives while they may work are not what i'm looking for.

    giovedì 15 marzo 2012 19:48
  • Wraith... definitely an interesting problem. I almost feel like this is an obscure registry entry gone awry since (and correct me if im wrong), the search feature looks to be running of the Windows Explorer backbone. Can you try a basic step first and go to the command prompt and type sfc /scannow ? Let that run for a few minutes, reboot and lets see if anything changes.

    Have you tried using Windows search under a different profile name on the computer?

    venerdì 16 marzo 2012 03:37



    Before moving on, I would like to confirm if you have tried to remove and reinstall Windows Search. If not, let us remove and reinstall Windows Search first.

    1. Click Start, type in “appwiz.cpl” and press Enter.

    2. Click “Turn Windows features on or off” in the left panel.

    3. Uncheck “Windows Search” and click OK.

    4. Reboot the system.

    5. Repeat the step 1 to 2.

    6. Select “Windows Search” and click OK.

    7. Test the issue. If it persists, please restart the system.

    If the issue still cannot be resolved, I will provide the details of registry keys to repair it in the future.

    Best Regards,

    Kim Zhou

    venerdì 16 marzo 2012 09:35
  • I hadn't tried uninstalling and then reinstalling. I have now followed the steps you provided. No change.

    I have tried it from a second profile, one that i setup when i installed so i had a backup operator setup so if my primary failed i could access the running system. I hadn't logged into it before, i have now and search using win+f works for it. So it looks like the search system and indexing in general are working (all other searches work that i've found) but that something in my user profile is either broken or setup somehow to prevent working.

    The obvious solution is to create another profile. Really i'd rather not if possible, it took me a week to get things installed and setup in this one and starting again wouldn't be a lot of fun. Can you suggest any steps i could take to narrow down what might be blocking the search from starting?

    domenica 18 marzo 2012 00:03
  • Did you run the system file checker as suggested by garvey?

    Open an elevated command prompt and type sfc/ scannow and tap enter. Be patient and let it run.

    domenica 18 marzo 2012 13:14
  • No, i didn't because it seemed a bit pointless. I have now and as expected there are no integrity violations.

    mercoledì 21 marzo 2012 18:57
  • Try and create a new admin user and then log in to the new account and test the Win Key + F.

    If it works, you can transfer your data and such to the new account and delete the old.

    It's worth a few minutes to test.

    I am guessing the issue is VS 2008 related as it's in legacy status as of Vista.

    giovedì 22 marzo 2012 11:46