none
Check that the Virtual Machine Management service is running and that you are authorized to connect to the server RRS feed

  • Domanda

  • Hi all,

    I am getting this error, whenever I try to connect to server from Hyper-V, I choose local server then I get this message

    Check that the Virtual Machine Management service is running and that you are authorized to connect to the server.

    In the services, I don't have this service... What should I do...?


    Mai Omar Desouki | Software Consultant | Infusion | MCP, MCTS, MCPD, MCITP, MCT Microsoft Certified Trainer & MCC Microsoft Community Contributor | Email: mai_omar_86@live.com | Blog: http://moresharepoint.wordpress.com

    mercoledì 19 settembre 2012 17:42

Risposte

  • Here is the solution

    1-make sure turn on virtual platform on bios

    2- from turn windows features on or off expand hyper-v and enable hyper-v platform (Must)

    3- restart your machine it should be working without problem.

    This 100 % works

    lunedì 2 giugno 2014 13:47

Tutte le risposte

  • Disabling the server firewall and check if it works.

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”

    venerdì 21 settembre 2012 03:05
    Moderatore
  • But I don't have this service already "Virtual Machine Management service" that hyper-v is saying in my services, what does it has to do with Firewall !

    Mai Omar Desouki | Software Consultant | Infusion | MCP, MCTS, MCPD, MCITP, MCT Microsoft Certified Trainer & MCC Microsoft Community Contributor | Email: mai_omar_86@live.com | Blog: http://moresharepoint.wordpress.com

    domenica 23 settembre 2012 06:27
  • I am getting this error, whenever I try to connect to server from Hyper-V, I choose local server ...

    I'm confused by your description.  You say you are connecting from Hyper-V.  Do you mean you are connection from the Hyper-V Management console?  Are you trying to connect from a different Hyper-V server system back to your local Windows 8 desktop instance of Hyper-V?

    tim

    lunedì 24 settembre 2012 22:15
  • Any news? I`ve got same issue. Windows 2012 HYPER_V server in workgroup. and Windows 8 Ent. Try everything, firewall off, adding trusted host ? same error...
    martedì 30 ottobre 2012 13:16
  • I succeeded with  steps below, from the bottom of this link http://technet.microsoft.com/en-us/library/jj647788.aspx#1, with some remarks about configuring firewall.

    ------------------------------------------------------------------------------------

    Guide to remote manage Hyper-V servers and VM's in workgroups or standalone

    This guide is based on the following 3 products:
    Windows server 2012 (core)
    Windows 8
    Hyper-V server v3 / Hyper-V server 2012

    The following guide will enable you to:

    1: remotely manage your Hyper-V Virtual Machines with Hyper-V manager
    2: remotely manage your Hyper-V servers' firewall with a MMC snap-in. --- I did not succeeded this,..
    3: remotely manage your Hyper-V server (2012) with server manager

    ! This should also work for Core installations of server 2012, but I haven't tried.

    This guide is purely focussed on servers in a WORKGROUP, or as a stand alone.
    I CAN NOT tell you what you need to do to get it working in a domain.

    * You can run these commands straight from the console (Physically at the machine) or through RDP.
    * You will need to be logged on as an administrator.
    * Commands are listed in somewhat random order; I do however advise to follow the steps as listed.
    * Commands with ? in front of them are only ment to be helpfull for troubleshooting,
    * and to identify settings and changes made.
    * Commands and instructions with ! in front of them are mandatory.

    - server: means the server core or hyper-v server (non gui)
    - client: means the machine you want to use for remote administration.
    - Some commands are spread over 2 lines; be sure to copy the full syntax.
    > To enable the Hyper-V manager to connect to your server, you need to perform the following 2 actions: (Assuming you have already installed the feature)
    1:
    ! Client: Locate the C:\Windows\System32\Drivers\etc\hosts file.
    ! right-click --> properties --> security
    ! click --> edit --> add --> YOURUSERNAME or Administrator --> OK
    ! then select this new user, and tick the "modify"-box under the "allow"-section.
    ! apply the change, and close.
    ! doubleclick the file, and open with notepad
    ! add the ip-address and name of your server (no // or other *** needed)
    ! Save the file
    # I recommend putting a shortcut to this file on the desktop.
    # If you change the ip-address of your server (e.g. move the server from staging to a live environment)
    # you might forget to do so in the hosts file.
    # Hyper-V manager, MMC, RSAT, and Server-manager all rely on the hosts-file to resolve the name.
    # some of these might connect to their respective service on an i.p.-level, but some don't.
    # This is the main reason you need to modify this file.

    ! USE AN ELEVATED CMD/POWERSHELL PROMPT TO CONTINUE !
    # the next config needs to be done on windows 8.
    # It seems that it's already preconfigured under server 2012

    2:
    ! Client: dcomcnfg
    ! open component services --> computers
    ! right-click -> my computer -> properties
    ! select "COM SECURITY" tab
    ! under "ACCESS PERMISSIONS" select "edit limits"
    ! select "ANONYMOUS LOGON", and tick "remote access" under ALLOW
    # Without this adjustment, you can't connect to your Hyper-V server
    # with the Hyper-V manager if you're not in a domain.

    > And if you haven't done so already... make sure you have enabled remote management number 4 on the Hyper-V server console.
    ----------------------------------------------------------------------

    > Next, is to get the MMC firewall snap-in working.
    The reason for this, is to have a GUI available to configure it.
    If you're happy without it, you may skip this and use a shell instead to do so.

    ? server: netsh advfirewall show currentprofile
    # shows the current profile (public/domain/private) and its settings
    # depending on your needs, you should set the right profile to fit your needs.
    # You can easily do this when the MMC snap-in is done. (after you've followed these steps)

    ! server: netsh advfirewall set currentprofile settings remotemanagement enable
    # enables remote management of the firewall on an application level 
    # (In other words: allows the firewall to be remotely managed)

    ! server: netsh advfirewall firewall set rule group="Windows Firewall Remote Management" new enable=yes
    # allows remote management of the firewall, through the required firewall ports with TCP protocol.
    # 4 rules will be updated to allow access: public & Domain, dynamic and endpoint-mapper.
    # You can disable/add/change the rule from the MMC snap-in after finishing this guide.
    # e.g. set the firewall through the MMC-GUI to only allow specific ip-addresses etc.

    ? server: netsh advfirewall firewall show rule all
    # Shows a list of available rules, and their current state.
    # when run from cmd, the list exceeds the maximum length for review.
    # (from cmd,type:) start powershell, and run the command from there.

    ! Client: cmdkey /add:YOURSERVERNAME /user:USERNAMEONTHESERVER /pass:THEPASSWORDOFTHATUSER
    # I recommend you to use a username with enough privileges for management
    # All capital letters need to be replaced with your input
    # CMD answers "credential added successfully" when you're done

    ! Client: locate MMC, and run it as an admin.
    # In windows 8/2012, go to search and type MMC. Right-click the icon, 
    # and choose run as admin on the bar below.

    ! Client: application MMC: select "file" --> Add/remove snap-in 
    ! --> (left pane) scroll down to "windows firewall" --> select and click "add"
    ! select "another computer"
    ! type the name of the server you want to manage (NO workgroup/ or //, just same name as you typed for cmdkey)
    My Remark -- Cannot complet this but at the end everthing works no matter of this,
    * Part 2 is done.
    # Have a look by doubleclicking the firewall icon in the left pane.
    # It looks and works the same as the GUI version that you are familiar with.

    -------------------------------------------------------------------------------

    ! Next is the Server Manager.
    # Follow the steps listed to get your server listed and manageable in the server manager.

    ! Client: Open the created Firewall snap-in for your server.
    ! Find the 3 "Remote Event Log Management" entries in the list of INBOUND rules, and enable them.

    ! Client: PS C:\Windows\system32> set-item WSMAN:\localhost\client\trustedhosts -value YOURSERVERNAME -concatenate

    # WinRM Security Configuration.
    # This command modifies the TrustedHosts list for the WinRM client. The computers in the TrustedHosts list might not be
    # authenticated. The client might send credential information to these computers. Are you sure that you want to modify
    # this list?
    # [Y] Yes  [N] No  [S] Suspend  [?] Help (default is "Y"): y
    #
    # I recommend to choose yes; unless you like to pull some more hairs...

    ! Client: open the server 2012 server manager
    ! click manage -> add server
    ! select the DNS tab, and type the name of your server

    Done.

    You can now manage your remote server through the familiar computer management GUI.

    ! Right-click your remote server, and select "Computer Management"

    --------------------------------------------------------------------------

    A few side notes:

    ? The Performance tab seems to list the local machine's performance, in stead of the remote servers'
    ? If you want Windows server backup, you need to right-click the server in the server manager, and select "add roles and features.
    ? it will then become available under the "computer management" of the remote server.

    If you liked this guide you may thank my employer, Mr. Chris W.
    for giving me the time to work it all out.
    Cheers!
    martedì 30 ottobre 2012 14:12
  • I am getting exactly the same problem as you and none of the answers given here are of any use. Did you work out how to get the Virtual Machine Management Service up and running?

    To explain the problem in my own words. I folowed the instructions to install Hyper-V on Windows 8 to the letter.  When I run the "Hyper-V Manager" and connect to the 'local' server, I get the message "Hyper-V encountered an error trying to access an object on computer 'localhost' because the object was not found.....Verify that the Virtual Machine Management Service on the computer is running...."

    I opened my services and there is no service with that name. I stepped through the names of all services on the machine and there is nothing close to that name. There are six that start with Hyper-V (Data Exchange Service etc) but no Virtual Machine Management Service or Hyper-V Virtual Machine Management Service.

    Note that I don't want to do remote management I just want to run and manage a Virtual Machine on the one (Windows 8) machine. I don't see what firewalls would have to do with it but I have disabled the firewall. It seems to me that I somehow have to get the Virtual Machine Management Service installed and running but after several weeks of trying to find out how I have not been able to do this!!

    domenica 28 aprile 2013 11:00
  • The service name is "Hyper-V Virtual Machine Management"  and vmms is
    the one you'd use on the command line if needed.
     
    You have to be running Windows 8 Pro to install hyper-v, but I can't
    really understand why it would fail to install as I'm sure you're
    running pro or you wouldn't get the other services.
     
    What happens if you run an elevated command prompt and typing "net
    start vmms"?
     
    Maybe calling Microsoft support is the best thing to do with this
    one..
     
     

    Bob Comer - Microsoft MVP Virtual Machine
    domenica 28 aprile 2013 12:39
  • > net start vmms

    The service name is invalid.

    More help is available by typing NET HELPMSG 2185.

    > net helpmsg 2185

    The service name is invalid.

    ----

    Yes, I am running Windows 8 Pro (64 bit).

    Also if I try to un-install Hyper-V (in order to re-install) I get: "Windows couldn't complete the requested changes. Unspecified error. Error code: 0x80004005".

    Perhaps I just have to reinstall the OS, but I am loathe to do that as I have no reason to believe it will be OK next time.


    lunedì 29 aprile 2013 04:56
  • That means it's really not there, but its odd the other services are
    there. Something must have happened on first install, but it didn't
    detect the problem.
     
    >Perhaps I just have to reinstall the OS, but I am loathe to do that as I have no reason to believe it will be OK next time.
     
    Unfortunately that may be the only way to get it to work.
     
    If you don't really need Hyper-V for a specific reason, maybe using
    another virtualization product like VMWare Player or VirtualBox would
    work better for you.
     
     

    Bob Comer - Microsoft MVP Virtual Machine
    lunedì 29 aprile 2013 13:54
  • Hi Mai,

    It seems you are seeing nothing under the Hyper-V Manager node on the left pane (Console Tree)!?

    By the way it is not available in the 32-bit systems and sort of CPUs.

    Please read this well described guide here. Sure you are considering the Requirements there.

    Good luck

    domenica 8 settembre 2013 18:07
  • The reason Hyper-V won't work is because virtualization is not enabled in the BIOS.  When you go into the Programs in the Windows 8 Control Panel, select Turn Windows features on or off,  under Hyper-V you'll see that it won't allow you to to install the Hyper-V Platform because virtualization support in the firmware is disabled.  You need to go into your motherboard BIOS, and under the CPU settings you should see an option to enable Virtualization.  Once this is enabled, go back into Programs/Turn Windows Features on or off/ and install the Hyper-V Platform.  This is the required component of Hyper-V to run Hyper-V from your local machine.  Your motherboard must support hardware virtualization in order for this feature to be available in the BIOS.  All Intel VPro motherboards support virtualization.  If you have a media, or basic motherboard, chances are you will not be able to run Hyper-V.  Hardware Virtualization may not be required to run Virtualbox, and Virtualbox is an open source product, so it's free.  It's similar to Hyper-V and it's easy to configure.  Good luck!
    giovedì 7 novembre 2013 16:39
  • I am getting exactly the same problem as you and none of the answers given here are of any use. Did you work out how to get the Virtual Machine Management Service up and running?

    To explain the problem in my own words. I folowed the instructions to install Hyper-V on Windows 8 to the letter.  When I run the "Hyper-V Manager" and connect to the 'local' server, I get the message "Hyper-V encountered an error trying to access an object on computer 'localhost' because the object was not found.....Verify that the Virtual Machine Management Service on the computer is running...."

    I opened my services and there is no service with that name. I stepped through the names of all services on the machine and there is nothing close to that name. There are six that start with Hyper-V (Data Exchange Service etc) but no Virtual Machine Management Service or Hyper-V Virtual Machine Management Service.

    Note that I don't want to do remote management I just want to run and manage a Virtual Machine on the one (Windows 8) machine. I don't see what firewalls would have to do with it but I have disabled the firewall. It seems to me that I somehow have to get the Virtual Machine Management Service installed and running but after several weeks of trying to find out how I have not been able to do this!!


    I have exactly the same, the six Hyper-V services are there but no Virtual Machine Management Service. Running Windows 8.1 Enterprise x64 and my BIOS is correct, I could run Hyper-V successfully in Winodws 8.0 Enterprise x64.
    martedì 19 novembre 2013 08:32
  • Did you already try this?

    Uninstall Hyper-V
    Reboot

    dism.exe /Online /Cleanup-image /Scanhealth
    dism.exe /Online /Cleanup-image /Restorehealth

    Reboot
    Install Hyper-V

    This worked for me! Now the next challenge, let my VM talk to the internet over my wifi NIC. This worked in Windows 7.0/8.0 via Internet Connection Sharing but it doesn't in Windows 8.1

    martedì 19 novembre 2013 12:19
  • Here is the solution

    1-make sure turn on virtual platform on bios

    2- from turn windows features on or off expand hyper-v and enable hyper-v platform (Must)

    3- restart your machine it should be working without problem.

    This 100 % works

    lunedì 2 giugno 2014 13:47
  • My operation system was Windows 8.11

    The above post lead me to resolution. I had NOT enabled Virtualization in my bios when I originally added the Windows 8 feature. As such, I was only able to add part of the hyper v features in appwiz.cpl. After rebooting and enabling the virtualization in BIOS, I was able to add the rest of the features, reboot and VMM is working. My exact error was Check that the Virtual Machine Management service is running and that you are authorized to connect to the server

    lunedì 25 agosto 2014 22:26
  • This was my exact issue. Thank you so much. I had done it backwards as well the first time. The "Hyper-v Platform" option had been grayed out. After the BIOS turn on of VT, it is now available.
    giovedì 2 ottobre 2014 14:51
  • I had same problem with one of my clients system. In BIOS virtualization was enabled, I was able to turn on Hyper-V in Windows features, but Hyper-V Virtual Machine Management service didn't appear (some other Hyper-V related were there). Then I checked computer properties and found that there was a 32-bit operating system installed with 64-bit processor.

    Suggestion to MS to show some explanation message when turning on Hyper-V feature on 32-bit operating system.

    Thanks,
    Koit

    mercoledì 9 marzo 2016 14:20
  • Above solution helped me solving my issue. Thanks a Lot.

    I Enabled Virtualization in BIOS and again in Windows Features i selected Hyper-V Platform option and restarted computer, It Worked.. 

    martedì 27 novembre 2018 07:34
  • I now had the same issue. I had a Win 10 with Hyper-V and it stopped working and I got this error.

    I had to remove the feature from Windows, in Add/Remove features and re-add it. It worked afterwards. As a result I also had to reset the Heyper-V network settings.


    • Modificato gthegreat1 martedì 15 gennaio 2019 17:59 spell check
    martedì 15 gennaio 2019 17:58