NTLMv2 Authentication problems


  • "Logon failure: unknown username or bad password" when trying to access my Windows 7 Home Premium 64bit desktop from my Windows 7 Home Premium 64bit laptop. Connecting from the desktop to the laptop works perfectly. 

    However, it works in Safe Mode. But no matter what I disable, the problem persisted. So I performed a clean install and it worked just fine. I would test it after each update that installed and everything was good until the last batch of updates. 

    So after a few searches, it seems that a Local Security Policy needs changing, but Group Policy is noticably missing from 7 Home Premium. I found several articles that described adding a DWORD value called LmCompatibilityLevel and setting the value to 1. I made sure to set it on both machines to ensure that they're able to connect to one another. 

    After I rebooted the laptop, it worked...for about 2 minutes, then the password was prompted again. I am litterally at my wits end here. I've never had so many problems connecting two computers together. 

    Incidentally, homegroup doesn't work from the laptop to the desktop either, but I surmise the problem is related. 

    • Modificato msugar domenica 18 marzo 2012 01:48
    sabato 17 marzo 2012 18:05

Tutte le risposte

  • If you really want to go to the lowest authentication level, then  set LmCompatibilityLevel to zero (0).

    Next , for test purposes I would disable local firewalls and catch the authentication traffic between peers. Listing from Security Event logs would be helpfull too.



    domenica 18 marzo 2012 19:48
  • Milos,

    In an interesting turn of events, now the desktop is unable to connect to the laptop, but the laptop has full connectivity to the desktop. There have been no software changes on either the desktop or the laptop (no updates have been installed or uninstalled, no settings changes, etc) since my last post in an effort to preserve the system integrity.

    Following the latest issue, I adjusted the LmCompatibilityLevel to 0 per your instructions. I've also disabled the firewalls on both machines. I am not exactly certain how to capture the authentication traffic between peers, however, I've cleared both security logs and attempted connections on both machines.

    Both the desktop and laptop security logs display an event id 4648 and claims an Audit Success. Which leads me to believe that this may <i>not</i> be an authentication issue now. However, I'm not entirely certain as what to look for. I did notice in the XML code that the "level" tag is set to zero.  

    What do you recommend for my next steps? If requested, I can provide the event logs.

    Thanks for your input thus far. Hopefully, we'll be able to solve this.

    • Modificato msugar martedì 20 marzo 2012 03:13
    lunedì 19 marzo 2012 23:02
  • Well, it looks like no one will respond to this, but I will still post an update.

    I was frustrated and gave up on the situation for the time being. My wife was using the laptop the other day and I noticed that the touchpad mouse wasn't scrolling. I reinstalled the Synaptics driver and decided to fiddle with the networking problem again.

    The absolutely unexplainable happened. It worked. It worked on both computers with no adverse affects. As I'm writing this, it continues to work - after reboots and other changes. The homegroup still only works one-way (desktop to laptop), but I've decided that I'm through messing with that for now. If I recall correctly, it never worked in the first place.

    I know that I should figure out why the homegroup still won't work, but I'm done messing with it at the moment. I will also not alter the title of the post to say <SOLVED>. The issue is now non-existent, but there was no definitive solution.

    lunedì 2 aprile 2012 17:34