none
Remote Desktop access suddenly stopped working on one domain workstation RRS feed

  • Domanda

  • After installing a QuickBooks update on a Windows 7 workstation, it required me to restart the computer, which I did. When it came back up Remote Desktop access was not (and still is not) available. This workstation is an Active Directory member. Remote Desktop is controlled by Group Policy. I've run 'gpupdate /Force' on this workstation. There are 9 other such workstations in the office. All can be accessed via Remote Desktop except this one. I've verified that Remote Desktop access is enabled, "Allow connections from computers running any version of remote Desktop ..." I've verified that Remote Desktop is enabled on the firewall. I've even turned off the firewall completely. This computer is able to access the network, the Internet and RDC to other local workstations. It can ping other workstations, but other workstations cannot ping it. Nor can other workstations access this computer's shared drive. Network discovery and file and printer sharing are turned on. I've shutdown and restarted this workstation. The error message when trying to connect to this computer is:

    Remote Desktop can't connect to the remote computer for one of these reasons:

    1) Remote access to the server is not enabled.
    2) The remote computer is turned off.
    3) The remote computer is not available on the network.

    Make sure the remote computer is turned on and connected to the network, and that remote access is enabled.

    In case there was some lurking update waiting for the next reboot to bite me, I've rebooted other workstations in the office with no subsequent problem Remote accessing them.

    I've been working on this for several hours and I'm at a loss for ideas. Anyone?

    lunedì 15 luglio 2019 23:24

Risposte

  • Hi,

     

    It seems like you did not install RDS roles in this workstation but enabling Remote desktop access.

     

    For the warning message Event ID 17, please refer to the following article.

     

    Event ID 17 — Remote Desktop Services Availability

    http://technet.microsoft.com/en-us/library/ee891136(v=ws.10).aspx

     

    May I know if you have patched the win7 with latest update? Per my researching, there was one update (but long time ago) that will kill the RDP. Please confirm the patch you've installed on this win7.

     

    Thanks,

    Jenny


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Contrassegnato come risposta jmarkfoley venerdì 19 luglio 2019 19:36
    venerdì 19 luglio 2019 06:14

Tutte le risposte

  • Hi,

     

    1. Have you checked the anti virus tools installed on the problematic win7 in case of any blocking settings while restarting the PC?

     

    2.  Have you disabled the GPO of remote desktop?

    • Go to Computer Configuration -> Policies -> Administrative Templates -> Windows Components -> Remote Desktop Services -> Remote Desktop Session Host -> Connections
    •  Allow users to connect remotely by using Remote Desktop Services

     

    3.  Kindly check the event logs to see if anything related when issue happened.

    Event log checking:

     

    TerminalServices-RemoteConnectionManager and TerminalServices-LocalSessionManager logs to view information about connections.

     

    Step 1: Press Windows+R to open the Run dialog, enter eventvwr (or eventvwr.msc) and hit OK.

     

    Step 2: Navigate to Event Viewer\ Applications and Services Logs\ Microsoft\ Windows\ TerminalServices-*

     

    Thanks,

    Jenny


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    martedì 16 luglio 2019 06:35
  • Hi,

    Is there any update? Please feel free to let us know if more assistance needed.

     

    Have a nice day.

     

    Thanks,

    Jenny


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    mercoledì 17 luglio 2019 02:52
  • Jenny - thanks for your reply. I don't use GPO very often. I assume you are referring to the Domain-wide policies, not the local computer? Furthermore, I assume your RSAT "path" begins with Group Policy Management > Forest > Domains > [mydomain] > Group Policy Objects > Enable Remote Desktop > (edit) . If so, I have:

    Group Policy Management > Forest > Domains > hprs.local > Group Policy Objects > Enable Remote Desktop > (edit) > Computer Configuration > Policies > Administrative Templates, but no 'Windows Components' under that. I've recently re-installed RSAT on the admin computer, so maybe I need additional 'Windows features' turned on?

    As to events, I have:

    TerminalServices-LocalSessionManager/Operational:

    [Error] Event Id: 17 - Remote Desktop Service start failed. The relevant status code was 0x800706b5.

    TerminalServices-RemoteConnectionManager/Operational

    [Informational] Event Id: 1136 - Terminal Server role is not installed.
    [Informational] Event Id: 258 - Linstener RDP - Tcp has started listening
    [Informational] Event Id: 1155: The Remote Connection Manager selected Kernel mode RDP protocol stack.

    As mentioned, all other computers in the domain are working fine. No idea what happened to this one.

    Thanks for your help.

    giovedì 18 luglio 2019 22:39
  • Hi,

     

    It seems like you did not install RDS roles in this workstation but enabling Remote desktop access.

     

    For the warning message Event ID 17, please refer to the following article.

     

    Event ID 17 — Remote Desktop Services Availability

    http://technet.microsoft.com/en-us/library/ee891136(v=ws.10).aspx

     

    May I know if you have patched the win7 with latest update? Per my researching, there was one update (but long time ago) that will kill the RDP. Please confirm the patch you've installed on this win7.

     

    Thanks,

    Jenny


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Contrassegnato come risposta jmarkfoley venerdì 19 luglio 2019 19:36
    venerdì 19 luglio 2019 06:14
  • My system is up-to-date.

    That link solved it! Thanks. For whatever reason, Remote Desktop Services were set to Manual, albeit it also said "started." I change that to Automatic and restarted the service and was able to get the connection. I do want to try this from an offsite computer, which I'll do ASAP, before really, really considering it fixed, but it looks good so far.

    I have no idea how this service got set to Manual. I am very doubtful that the QuickBooks upgrade would do that and no one else accesses this computer other than me.

    Thanks again -- will post back with the results of an offsite access.

    Later ... yup, I'm able to get in from an offsite computer. Problem solved!


    • Modificato jmarkfoley venerdì 19 luglio 2019 19:36
    venerdì 19 luglio 2019 17:15