none
Windows 10 Hypver-V does not connect to or start virtual machine connection RRS feed

  • 質問

  • On a new build machine and recent upgrades/patches, Hyper-v on windows 10 1803 17134.191 does not start virtual machine connection from the hyper-v terminal.  I can see the processes start in task manager but there is no visible window, but it is using consider cpu. Multiple attempts result with multiple processes using up cpu with no visible window.

    Basically all i'm doing it right mouse clicking on the vm in hyper-v manager and saying connect.

      Manually running virtual machine connection works, but only after starting using administrative rights.  Without admin rights it errors when trying to see the vms.


    2018年8月8日 20:31

すべての返信

  • Do your user account belongs to the local administrators group?

    You can also add an account to the Hyper-V Administrators group and test if it helps.

    2018年8月9日 4:39
  • Yes, my account is part of the administrators group.  Checked it again to make sure.

    The hyper-v administrators group is empty. Trying to add the local administrators group to it did not work.  I get an error message saying that an object name administrators cannot be found.  Adding my own local admin account to the hyper-v administrators group did not fix the problem. I still can’t get vmconnect  to start through the hyper-v tool.

    Thanks for the suggestion though.  This problem started with the latest patches after 1803 was released.


    2018年8月9日 5:10
  • Hi,

    Based on your situation, I suggest you restarting Hyper-V service.

    Also you can use DISM to repair corrupt system files which may cause your issue.
    https://answers.microsoft.com/en-us/insider/forum/insider_wintp-insider_install-insiderplat_pc/how-to-repair-your-system-files-using-dism-and-sfc/1021b42a-09ff-41a0-a95a-48f3ee3ae699

    In addition, try to create a new administrator account to see if issue happens.

    Hope these could be helpful.


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    2018年8月9日 13:05
  • Creating a new admin account did not work either.  All i got was another vmconnect ghost process using up 300k and 10% cpu under the test user account still with no visible window.  For every time i try to start the process through hyper-v managment console, i get another ghost process using up another 10% cpu.

    Here are the other things I tried that did not work:

    • Deleting and recreating the vm
    • uninstalling and re-installing the hyperv mgmt tools
    • uninstalling and re-installing all of hyper-v
    • adding my local admin account to the hyper-v admin group
    • running system file checker
    • rebooting
    • stopping and restarting the services
    • Starting vmconnect.exe directly as a normal user manually

    The only thing that does work:

    • right mouse click on vmconnect.exe and run as administrator - this results in a process that uses 40000k and almost 0 cpu and everything appears to work normally

    2018年8月9日 19:06
  • Exactly the same issue and made the same steps.. 

    https://www.windowslatest.com/2018/08/01/list-of-whats-fixed-and-broken-in-latest-windows-10-build-17728/

    Seems it's an issue .. Waiting for a fix

    2018年8月25日 22:34
  • the only slight improvement right now, is that with the most recent updates vmconnect can run without admin rights and works.  Trying to start vmconnect through hyper-v results in a dead process sucking up cpu.  I didn't see anything in the list you included.  Did i miss it?  I don't get any errors.  It just doesn't work and there is nothing in the logs.
    2018年8月25日 23:13
  • Hi,
    Please use Process Monitor to collect the trace when issue is reproduced.
    Process Monitor v3.50
    https://docs.microsoft.com/en-us/sysinternals/downloads/procmon
    How to capture a Process Monitor trace
    https://blogs.msdn.microsoft.com/dswl/2010/01/10/how-to-capture-a-process-monitor-trace/

    Then upload the file to your OneDrive and share us the link.

    Regards,


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    2018年9月3日 15:05
  • I have the same exact issue on Windows 10 Pro version 1803 Build 17134.228
    2018年9月9日 0:26
  • Exact the same issue I got with using windows 10 version 1803 build 17134.254. VMconnect stuck in the task list without any VM console coming up.  Manually run vmconnect.exe can connects to VM. hope fix from MS soon.

     

    2018年9月11日 16:15
  • I have the same problem... 
    2018年9月13日 3:09
  • Running build 17134.285, same issue. I made what has turned out to be a duplicate post here.


    • 編集済み Garrett B 2018年9月25日 20:10 added os build
    2018年9月25日 20:09
  • Same issue.  It started for me back in April/May 2018 after a monthly update.  Installing the new RSAT tools did not fix the issue.  It is pervasive across any computer in my domain.  
    2018年9月28日 13:13
  • We have the same issue on all fresh installed Microsoft Windows 10 1709 (Build: 16299.699) 64-bit machines.
    2018年10月1日 16:18
  • Looks like the problem has finally been fixed in version 1809 which was just released.
    2018年10月2日 22:18
  • Looks like the problem has finally been fixed in version 1809 which was just released.

    For me 1809 created this problem.
    2018年10月5日 7:19
  • Me too after upgrading from 1803 to 1809 Hyper-V is broken
    2018年10月5日 12:27
  • Looks like the latest update broke hyper-v vmconnect again.  Its not working after applying the following updates



    KB4464330

    KB4465477

    2018年10月10日 19:29
  • I have 1809. I was able to run vmconnect with administrator rights.

    2018年10月16日 16:04
  • Any updates on this? I am having the exact same issue. 
    2018年10月17日 12:54
  • Thank you!!  I hadn't gotten as far as you and couldn't find any way to access my running virtual machine.  I'll try some of the suggestions you got from others, but as long as I can get to the machine and use it, I'm happy.  My OS is Windows 10 Enterprise, Version 1709, Build 16299.402 (for anyone who's curious)
    2018年11月2日 14:06
  • So this is still happening? I've now tried this on a windows 10 machine where I try to get access to a new VM and try to get access to a brand new VM created and I cannot connect to it. I try to connect to a VM, it spins for a moment, then nothing happens at all.

    2018年11月15日 14:02
  • I found running .\virtmgmt.msc in PowerShell elevated mode allows you to connect to VM's.
    2018年11月16日 13:29
  • Exact same problem for me as OP. I am on Windows 10 1709. I had the Hyper-V module installed locally on my Windows 10 machine, and when I connected to a VM on my local machine, it would open, but the remote Windows 2012R2 machines do not. I have since removed the Hyper-V features and reinstalled the Hyper-V management tools only, but still the problem persists. I have put a shortcut to vmconnect6.3.exe on my desktop to use as a workaround.
    2018年11月27日 18:42
  • If you're using Symantec Endpoint Protection, please check if you're also using Application Control as it turns out to have a compatibility issue. Please reference the article here for more info: https://support.symantec.com/en_US/article.TECH251121.html

    In case the link changes, here are the relevant parts of the article:

    Situation

    Hyper-V Manager on Windows 8 and Windows 10 fails to connect to a locally hosted virtual machine (VM) when Symantec Endpoint Protection (SEP) has injected sysfer.dll into the Hyper-V process vmconnect.exe.  No errors are generated and Task Manager will show vmconnect.exe is running, however the expected user interface (UI) is not generated.

    Environment

    Symantec Endpoint Protection 14.2

    Microsoft Hyper-V running on Windows 8 or Windows 10

    Solution

    Symantec is aware of this issue and will update this article when a solution becomes available. Click the Subscribe to this Article button to be notified of future updates through email.

    To workaround this issue create an Application Control Exception for vmconnect.exe to prevent sysfer.dll injection: https://support.symantec.com/en_US/article.HOWTO95454.html

    2018年11月28日 18:47
  • Have the same issue. Making an exception in SEP did not help. Launching within an elevated PowerShell session did. I would troubleshoot further but I just want to run VMs on my PC for lab purposes so this is fine. If this was occurring on a "real" Hypver-V host, that would be another story.
    2018年12月6日 22:45
  • Hi, I am with Windows 10 version 1809, inside a domain, after an upgrade from Windows 8.1 Pro and cannot run succesfully Hyper-v Manager to connect to my Hyper-v host (inside Workgroup) , although previously everything worked flawlessly.

    If I run Hyperv with my domain user (local admin) which is replicated inthe host machine, I get the known Kerberos error (cannot find machine by name, etc) . When I use different user credentials  (run as machine/user) , I get the error that this version of Hyper-V Management Tools cannot be used to manage servers running Windows 2012 or Windows 2012 R2.

    However, by looking at the Program Files\Hyper-V\ folder I find two vmconnect denominations, in the 6.2 and 6.3 subfolder respectively. If I just run vmconnect6.3.exe manually, I can see and open my VMs with no problem! The 6.2 version fails to open anything.

    I tried every possible method foound on forums for of corecting this, with no solution so far, reinstalling RSAT tools offline, removing Hyper-V from Settings, restaring and reaading, etc. None worked.

    Why is there Hyper-V Manager apparently uses the 6.2 version of vmconnect and how can I redirect it to the correct version installed locally?

    Thanks

    • 回答の候補に設定 YueXu 2019年3月4日 16:17
    • 回答の候補の設定解除 YueXu 2019年3月4日 16:17
    2019年1月15日 10:38
  • Well, my windows ENV is 1809 OS ver. 17763.316.

    After half of a day, I somehow figured out the permission problem. And @T. Kujala is RIGHT!

    Solution: Add your local account to that group. However this ONLY works with vmconnect.exe. I still have no idea within the manager and conncect without no responding. BUT I believe there is ONE solution after hyper-V quick start.

    The true vmconnect.exe is under C:\Windows\System32. And due to the permission settings, only the hyper-V admin can remote your VMs. You can try adding a new account to this group and try SHIFT+RIGHT CLICK to the vmconnect.exe. 

    But I still recommend MS fix it and add some helpful and organized docs for this.

    PS. may upload some screenshots if any progress made.

    2019年3月4日 16:56
  • Had the same issue.  Really after everything suggested by the SEP support document, things were still not working very good.  On a whim I installed 1903 to see if randomly would just be fixed.  Low and behold, running SEP 14.2 and 1903 all seems to work fine with hyper-v.  I am back to the expected cpu usage and snappiness while opening VM Connect.  No this is not a fix, but for the small number of machines that run hyper-v vms in our environment, I may just upgrade those devices to 1903 vs 1809 as they are IT people anyways.
    2019年4月25日 13:16
  • Hi

    I have solved this problem using: https://support.symantec.com/en_US/article.HOWTO95454.html.

    We use Symantec Endpoint Protection 14.2 client agent.

    1. Login to SEP Manager.

    2. Go to Cloud and log on to web site.

    3. Select Policies > Imported Exceptions policy(WL). Select "excluded by Filename. Add entry:

    Prefix          Filename

    [System]     System32\vmconnect.exe

    Save policy and Apply. Wait a few minutes minutes to propagate this policy.

  •                 


  • Kind Regards Tomasz

2019年4月26日 8:31
  • This worked for me. Thank You!

    2019年5月14日 20:56