none
There must be a real solution to "Windows found driver software for your device but encountered an error installing" RRS feed

  • 質問

  •  

    "Windows found driver software for your device but encountered an error installing"

    I've spent hours researching this error - Seems like many people have the same issue although there is no difinitive fix or known cause.

    I'm hoping someone here has an answer.

    Windows 7 Home Premium x64 OEM (HP)

    This is not an upgraded Vista system.

    It's not a specific driver related issue as it's the same response/effect be it graphics/chip set/usb/printer drivers.

    Please dont suggest to flatten and re-install or run a repair install - It's not an option, I only have remote access to the unit
    as it's currently in field use.

    This is a machine specific issue - identical machine purchased at the same time and configured the same has no issue.


    So the story.

    User has been fine for weeks - no hardware of software changes except Windows Updates.

    A Camera/USB connection that was working no longer does.
    Tried in all USB ports

    Plug in - windows announces found new hardware, tries to install drivers then fails
    with "Windows found software for your device but encountered an error installing ...."

    Device manager finds and identifies device although it is in the 'Unknown Device" category.

    Manually updating drivers via search/internet or point directly at a driver has exactly the same effect.

    Thinking this was just the camera drivers - I researched and downloaded new drivers from camera manufacturers sites
    Fuji and Canon.

    Same effect.

    Deleted/uninstalled drivers completely, deleted/uninstalled all USB root hub and USB devices (hidden and visible)

    SFC /Scannow finds no error

    Cold boot finds USB and chipset(?) devices on boot attempts to reinstall then we get

     "Windows found driver software for your device but encountered an error installing"

    So now I have no usb devices at all - memory stick/card reader/printer...... nada.

    in fact if I try to update any device driver I get the same message generated.

    Restore point does not help either. 

    After much trawling I found reference to a permisions issue and stale driver cache data.
    (This is using an administrator account - not user with admin permissions?)
    I'm willing to try anything at this time

    I deleted the infcache.1 and other .dat files under c:\windows\system32\driverstore
    Copied the usb  .inf and .pnf from the appropriate FileRepository directory into c:\windows\inf
    Uninstalled all the usb/unkown devices from device manager again.

    Rebooted

    Takes a little longer to boot as I take it it's rebuilding the driver cache then

    a very short hurrah!!!

    I can now use usb memory card and pen drives - no issue

    Plug in a camera or printer...

    "Windows found driver software for your device but encountered an error installing"


    Several attempt at this trying different driver versions.
    It should not be vendor specific, the other field machine that works is using Microsoft drivers for these devices.
    I even copied the drivers from one machine to the other - repeated everything above...

    "Windows found driver software for your device but encountered an error installing"


    And then the nail in my sanity

    Try windows update....
    Reboot

    "Windows found driver software for your device but encountered an error installing"

    but this time its different.

    The device it thinks it cannot install is the generic MTP-PTP drivers  (Photo Transfer Protocol -so am I getting somewhere)
    so it still finds but cannot install.

    The cameras are always found but appear as 'unknown devices' and cannot be accessed

    Uninstall all USB/unkown again - reboot..

    Same message and this time I've lost all the USB again.

    Restore point to before Win Update gets me USB back again although I still have no cameras  - so theres an update issue as well.

    This has to be tied down to a file access/ registry problem although I'm loath to go cutting about without some guidance.

    I'm no great believer in 'registry cleaners' unless anyone can point to a definitive/no ad's/sales version that really works.

    As I said above, flattening/rebuild at this time is not an option - the user is not best pleased and I'm completley stumped.

    If anyone has experienced(manu of you have) and fixed(still to find one) this issue please let me know how as soon as possible.

    Chris 


     

    2011年7月29日 9:28

回答

  • Hi Chris,

    This issue occurs due to Driver software path is not specified .

    In-place upgrade would be the best choice.

    If you would like to fix them one by one, please Locat and install the driver software from the c:\windows\winsxs folder.

    Regards,


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    2011年8月4日 7:38
    モデレータ

すべての返信

  • Hi Chris,

    This issue occurs due to Driver software path is not specified .

    In-place upgrade would be the best choice.

    If you would like to fix them one by one, please Locat and install the driver software from the c:\windows\winsxs folder.

    Regards,


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    2011年8月4日 7:38
    モデレータ
  • Hi Magon,

     

    Thanks for this.  The solution worked for my flash drives.  And the problem was getting to be a major headache.

     

    Thanks again

    2011年9月20日 9:55
  • Hi Magon,

    Your solution worked great...

    Cheers,

    dkerai

    2012年6月5日 3:47
  • Hi Magon, thank you for this fix, this ended my month long problem with my messed up bluetooth stack ;D
    2012年6月15日 5:29
  • I.... dont understand what this means, but i am also having the same problem, what do you do in the winsxs folder to fix this issue?

    • 回答の候補に設定 kjeasyy 2013年7月10日 15:36
    • 回答の候補の設定解除 kjeasyy 2013年7月10日 15:36
    2012年8月2日 1:51
  • me to :'( Please help anyone :( 
    2013年3月19日 11:44
  • It means

    • you go into Control Panel -> System -> Device Manager.
    • Device Manager will display the non working device
    • right click on that device
    • choose Update Driver Software
    • choose Browse my computer fro driver software
    • Enter "c:\windows\winsxs" in the edit field named "search for driver software in this location".
    • Please verify that this directory exists on your computer. If your windows directory is named or located somewhere else, replace c:\windows by whatever you have.
    • Driver Update will search c:\windows\winsxs for the drivers there, this will take a while.
    • Good news. This will also fix this issue for subsequent driver installations - at least on my computer.

    Good luck.


    KLAUS J ISBRUCH

    • 回答の候補に設定 Tintu Joy 2016年5月19日 10:40
    2013年7月10日 15:44
  • It means

    • you go into Control Panel -> System -> Device Manager.
    • Device Manager will display the non working device
    • right click on that device
    • choose Update Driver Software
    • choose Browse my computer fro driver software
    • Enter "c:\windows\winsxs" in the edit field named "search for driver software in this location".
    • Please verify that this directory exists on your computer. If your windows directory is named or located somewhere else, replace c:\windows by whatever you have.
    • Driver Update will search c:\windows\winsxs for the drivers there, this will take a while.
    • Good news. This will also fix this issue for subsequent driver installations - at least on my computer.

    Good luck.


    KLAUS J ISBRUCH

    2013年7月10日 15:44
  • This worked Perfect (KLAUS J ISBRUCH)  I had 2 Techs remotely take over my business PC trying to install a receipt printer USB.  They Failed,  so i hooked this up using the serial COM1 port and it worked fine.  BUT I was trying to install a Barcode Printer now using the USB since i only have one serial connection. I received the same Windows 7 Driver error message as with the Receipt Printer. So that is when i started to research my problem and located on this blog.   Thanks a million for giving out FREE info and explaining your answer in easy to follow terms.  The instructions you posted worked and i am very pleased! A++++++++++
    2013年7月13日 18:49
  • After 2 Days I found this answer!! Same cycles same problem;( but solution is working!!! Thanks!
    2013年10月8日 21:20
  • I tried this, but it said the driver wasn't found in that folder either.  The missing driver is for a "Universal Serial Bus (USB) Controller" listed under Other Devices.

    I've done an online diagnostics from the Dell site and installed the latest updates it recommended, but this item still keeps popping up.

    Any other suggestions?

    2013年10月18日 14:49
  • this did not work for me, I have a intel hd 4000 driver not working comes up in device manager under other devices. i tried up dating it so many times and keep getting the same results. Please help


    • 編集済み bwill24 2013年11月29日 4:58
    2013年11月29日 4:54
  • Dear I dont know how to thank you for this post as it was really useful for me , i have spent days to solve this problem but you saved me, Many thanks
    2014年1月23日 23:21
  • I tried this, but it said the driver wasn't found in that folder either.  The missing driver is for a "Universal Serial Bus (USB) Controller" listed under Other Devices.

    I've done an online diagnostics from the Dell site and installed the latest updates it recommended, but this item still keeps popping up.

    Any other suggestions?

    Exact same as me. Any suggestions?

    2014年3月17日 21:37
  • Hi Magon,

    U r Awesome ..!!

    I thought it was over in my lap, but hardly searching for the solution. When I read your answer, without hope I was trying but exactly solved my issue. cheers man ..keep rocking ..

    Thanks a lot ...

    2014年4月21日 13:27
  • I followed the steps you gave but with no success, i got the message below:

    Windows found driver software for your  device but encountered an error while attempting to install it.

    USB composite device
    Access is denied.

    Do you know how i would resolve that?

    Thanks

    2014年6月7日 15:39
  • i have the same problem!!!
    i didn't find a single solution after months of researching.
    someone please help
    2014年6月10日 15:03
  • I followed the steps you gave but with no success, i got the message below:

    Windows found driver software for your  device but encountered an error while attempting to install it.

    USB composite device
    Access is denied.

    Do you know how i would resolve that?

    Thanks

    Me too. Exactly the same message.

    Please help.

    2014年6月21日 2:36
  • I tried both of the suggestions:

    • you go into Control Panel -> System -> Device Manager.
    • Device Manager will display the non working device
    • right click on that device
    • choose Update Driver Software
    • choose Browse my computer fro driver software
    • Enter "c:\windows\winsxs" in the edit field named "search for driver software in this location".

    And also installing Download Driver Booster By Iobit.

    Still seeing this error when plugging my Nikon camera:

    "This device is not working properly because Windows cannot load the drivers required for this device (Code 31)"

    When I try to update this driver in Properties:

    "Windows has determined the driver software for your device is up to date" for MTP USB Device.

    Any ideas?

    2014年6月24日 19:08
  • just try the same steps in safe mode...
    • 回答の候補に設定 hamdan27 2014年6月25日 23:39
    2014年6月25日 23:39
  • just try the same steps in safe mode...
    2014年6月25日 23:40
  • just try the same steps in safe mode...
    2014年6月25日 23:40
  • Hello,

    I just wanted to post what worked for me. I had trouble installing my Canon scanner driver and would get the failure to update message. I disabled web root and went to update the driver and the scanner was detected successfully. So it could be your antivirus.

    Regards

    Brian

    2014年12月9日 23:12
  • I know I am replying to an old thread - but I have the answer and resolved this error, and since this message comes up first in search results, and part of my answer came from this thread, I wanted to help someone else as this took an extra 12 hours and a lot of technical insight to resolve. See below for detailed explanation that others ask for above.

    My original issue was that iTunes didnt reinstall. generating this error that said I am trying to access an unavailable network resource and to browse to find itunes64setup (again). This may partly have been due to me deleting old install version folders.

    Research led me to completely uninstall apple products and reinstall per their instruction and fixed the issue with iTunes. see Remove and reinstall iTunes and related software components for Windows Vista, Windows 7, or Windows 8 - Apple Support

    The SAME error I had while updating itunes recurred while uninstalling it from my Windows 7 SP1 system...so I went to microsoft Fixit and attempted to correct and it properly uninstalled iTunes for me, which allowed the reinstall.

    What didnt work was my USB web root/ root hub, which partly involved my older system and USB 1.0, and the delete/reinstall existing drivers with the c:\windows\winsxs folder as source of drivers (thank you Magon Liu!!!) which I had to figure out what/why and how.

    Then I had an intel chipset issue...my new Iphone wasn't recognizing in plug and play, and there was an error with installing the device drivers for my new iphone 6. Manual applications didn't work, even though a generic device showed in control panel - device manager with a yellow !

    Per above blog answer - I tried to remove and reinstall my USB controller or update the drivers (I have an Alienware M15 laptop - a few years old.) I discovered that the USB host controller - an Intel(R) 5 Series / 3400 Series Chipset family USB Enhanced Host controller - (port) was not covered by current Intel chipset programs which are Series 6 and later, but did have an update (8/20/2009 v9.1.1.1020)  that supported USB 2.0 (and therefore 3.0 backwards compatibility which as an issue with my new iPhone and some USB thumb drives.) To find this I had to look at the Support - Downloads and Drivers - browse for drivers and somewhere found an option to look for older no longer supported drivers. I found infinst_autol.exe for my case.

    Once downloaded I tried to install and failed. Found the log in C:\Intel\Logs and contains:

    [InstallDev]

              [Device]

                Driver = C:\Users\DAVIDS~1\AppData\Local\Temp\IPMx7\WIN7\ibexusb.inf

                INF = C:\Users\DAVIDS~1\AppData\Local\Temp\IPMx7\WIN7\ibexusb.inf

                Installed INF =

                Previous driver package =

    !           Warning 0xE0000235: DriverPackageGetPath failed.

                Difx = 64 bit

    Execute command: C:\Users\DAVIDS~1\AppData\Local\Temp\IPMx7\x64\Difx64.exe -DriverInf "C:\Users\DAVIDS~1\AppData\Local\Temp\IPMx7\WIN7\ibexusb.inf" -Flags 20 -KeyPath "Software\Intel\Difx64"

                Using RegDeleteKeyEx

    !!!         ERROR 0xE0000246: DriverPackageInstall generated an unexpected error

     HERE'S THE ADDED EXPLANATION TO BRIAN'S POST THAT EXPLAINS THE SECURITY ISSUE:

    This turned out to be an error for two reasons. First, after manually running the command in an "run as administrator" window (same error result), thinking it related to my anti-virus (turned that off/disabled firewall and A/V), and from this thread granting my user administrative rights to files in an install folder and trying to reinstall inf files and drivers from C:\Windows\winsxs vs my copied infinst_autol.exe expansion (as found from log in C:\Users\David Samuels\AppData\Local\Temp\IPMx7\WIN7 folder).....that there was an easier solution as the reason this error actually happens is a permissions problem.

    To access the proper windows system folders - you have to be the TrustedInstaller service - not just in the administrator group...or you have to be the actual "Administrator" account. To become actual administrator on your own laptop, Open a command window "run CMD.exe as administrator", then execute command

    > net user administrator /active:yes

    This creates a local PC Administrator account with no password. Coincidentally it has proper permissions to windows directories for installing drivers. Log in as this user, go to device manager and update the USB hub and any other drivers. if updating the USB root - it doesn't replace it right away as the system cant disable the currently resident in memory "running" driver  - you have to update, then restart the system, log in as administrator and repeat at the next lower layer that has issues.

    Once completed - log in as yourself again and disable the administrator account in a command window with > net user administrator /active:no

    This in my case enabled all my USB 2.0 and 3.0 devices on my originally only USB 1.0 laptop and everything else works properly again - I hope this helps many of you to resolve your own issues that were difficult to find and resolve and that got as far as this thread. Good luck!

     Regards,

     Dave Samuels


    2015年2月6日 6:44
  • on windows 8.1

    1] look in the view event logs under event viewer / custom views / device manager - unknown.  You may see something like:

       Driver Management concluded the process to install driver fi6130-x64.inf_amd64_ce675c0dbcd5b137\fi6130-x64.inf for Device Instance ID USB\VID_04C5&PID_114F\6&26C369D9&0&4 with the following status: 0x2.

    status 0x2 is file not found.  Nice of them not to tell you what file it was looking for...

    2] look in c:\windows\system32\driverstore\filerepository\XXX, where XXX is the path in the message.  e.g. fi6130-x64.inf_amd64_ce675c0dbcd5b137

    3] see the driver files there?  I just copied them in from the driver distribution .cab file.   Maybe deleting the XXX folder and reinstalling the driver software would put everything back.

    if you need to debug further, the event viewer message tells you what inf file the system is reading to install the drivers.  You can look at that file with notepad.

    e.g. in my case, c:\windows\system32\driverstore\filerepository\ fi6130-x64.inf_amd64_ce675c0dbcd5b137\fi6130-x64.inf and look in the [SourceDisksFiles] section.  Those are the files it's trying to access and they weren't there.




    2015年3月11日 16:56
  • Hi,

        I have the same issue above. I tried all the options above and in other related threads but of no use. It is really frustrating. Please help. Whatever I do, I still get "Windows found driver software for your device but encountered  an error while attempting to install it....  The system cannot find the file specified". 

    I am exhausted and desperately need help. Thanks in advance.

    2015年6月16日 17:04
  • THANKYOU THANKYOU THANKYOU.

    was having issues with windows 10. I don't know why maybe because I run Tweaking.com - Windows Repair

    I was trying to install my 4770k i7 cpu graphics driver. iris 64 bit driver. couldn't do it with drivers I downloaded manually so I decided I would try to use windows to search for driver auto online. then I got this issue, ive never had it before. so is a new one for me. anyway your guide really helped me out a lot. I read above comments and had no idea what he meant. I looked into that folder but no idea what he meant by it. so your guide helped 10 fold. am very grateful fixed now. drivers installed thankyou.

    2015年8月5日 18:55
  • Very Good this is the fix
    2015年10月11日 7:33
  • Thanx after tryin everything on earth, this worked!!!
    2015年10月11日 19:06
  • Hi, Magon

    You Are Great.....I want to thank you for solve my problem. I spent a Couple of week with sadness. Finally i Found a solution From you. This time i feel like awsome. thank you so much again.

    2015年12月20日 20:36
  • Hi KLAUS J ISBRUCH

    You my friend are a bloody genius!!   I have been searching the internet for weeks trying to find a solution to this problem?       My computer has had no sound since installing windows 10, neither Microsoft or Hewlit Packard have had a fix for this issue.

    Thank you millions

      Regards Martyn

    2016年1月10日 22:21
  • thank you very much

    2016年5月19日 10:41
  • Thanks, i looked for that solution EVERYWHERE
    2016年7月19日 17:06
  • Thanks a lot sir.................you comment saved my day.
    2016年8月22日 16:43
  • THANKS SO MUCH IVE BEEN LOOKING FOR A SOLUTION FOR MONTHS 
    2016年9月14日 0:15
  • Hi,

    Run cmd and then run msconfig and choose startup selection as Normal startup and then restart your PC. then your device will be installed correctly.

    2016年12月11日 19:59
  • Run cmd and then run msconfig and choose startup selection as Normal startup and then restart your PC. then your device will be installed correctly.

    2016年12月11日 20:00
  • You're a genious man. That totally worked Magon. Thanks a bunch.
    2016年12月15日 6:30
  • Your solution worked great...

    Thanks

    Nagarjuna

    2016年12月18日 4:17
  • Thanks a lot for the solution brother.

    I was just tying to fix it for last 1 and half hour.

    Thank you for your solution. it worked for me on windows 10.

    2017年2月1日 18:38
  • hi KLAUS J ISBRUCH!

    thank you so much you solved my problem :)

    2017年2月12日 4:47
  • Thanks a lot. This solution really worked for me.
    2017年3月11日 10:29
  • HOT DAMN!!!  We could not get our studio cameras running on a computer that we rebuilt (USB) for months.  Klaus and Dav you guys got us back up and running!!  It appears, for whatever reason, between Klaus's answer and also Dav's, the biggest problem is that for whatever reason, "Trustedinstaller" is probably not running on our systems!!  That is the biggest case in our problem.  Not sure how to "enable it" for the new devices yet, but that seems to be the main answer, is "trustedinstaller"!!  

    THANKS EVERYONE!!  This is a solution for alot of people out there who can't get their hard drives to get recognized as well!!

    2017年3月14日 5:39
  • Hello, I have this same issue and tried to follow your steps but when I create the administrator account and try to switch users to the new account it asks for a password...? (I get a 'password incorrect' message when trying to log in). As you can probably tell, I'm not that savvy, but this seems to be pretty simple and its not working.

    2017年7月14日 18:54
  • Wow! You're the man! Thank you very much!
    2017年8月6日 10:57
  • Hello Sir,

    I have a problem in my dell laptop ...When i opened cyberlink youcam then it  shown that "no webcam detected..If you have integrated camera plz turn on" ...

    Then i went to CONTROL PANEL-DEVICE MANAGER-IMAGING DEVICE -LEXMARK X422

    But when i want to update device it shown "windows encountered problem to installing the driver software for your device"

    What should I do please help to fix this problem..reply me as soon as possible..

    • 回答の候補に設定 VP_GOKU 2017年8月31日 16:18
    • 回答の候補の設定解除 VP_GOKU 2017年8月31日 16:18
    2017年8月31日 16:16
  • If trying to install a driver, we get a message that "Windows found driver software for your device
    but encountered an error installing", this is because WE have made changes to our system folders,
    especially the "System32" and the "SysWOW64" ones. The problem is, that we have either removed
    the "Trustedinstaller" account or we have restricted its permissions on these folders.

    The solution is:
    - Right click on the "System32" folder, select "Properties" > "Security" and click "Edit"
    - If the "Trustedinstaller" account is present in the top list, click on it to select it
    - Check "Full control" in the bottom list and click the "Apply" button. Wait for the system to apply
        the new permissions. If any files can not be accessed, click OK to skip them.

    - If the "Trustedinstaller" account is NOT present in the top list, click the "Add" button to add it to the list.
    - Do the same for the "SysWOW64" folder

    Problem solved and drivers can be installed now.

    The (winsxs) solution is valid only if the driver already exists there.

       
    2017年9月4日 7:27
  • Hi im confused i have tried to open the folder and boot drivers from there but it says access denied?
    2017年9月23日 3:19
  •  1 minut please......

                                  i have another one problme in such a job. when i goes to connect my device with window to flashing it, it  dose detected correctlly but till then my device is awakened. but when i try to connect it with window after switching off it, it dose detected for few second and then its disconnect automatichally.

                                                          please do have someone the solution of such problem. its is big for me.

    2018年1月17日 15:12
  • Thank You! It Worked Perfect I really Recomend This!

    • you go into Control Panel -> System -> Device Manager.
    • Device Manager will display the non working device
    • right click on that device
    • choose Update Driver Software
    • choose Browse my computer fro driver software
    • Enter "c:\windows\winsxs" in the edit field named "search for driver software in this location".
    • Please verify that this directory exists on your computer. If your windows directory is named or located somewhere else, replace c:\windows by whatever you have.
    • Driver Update will search c:\windows\winsxs for the drivers there, this will take a while.
    • Good news. This will also fix this issue for subsequent driver installations - at least on my computer.

    Good luck.


    KLAUS J ISBRUCH

    2018年1月20日 22:40
  • Nice. Thanks it worked for me to

    2018年2月12日 0:37
  • I tried this and get the message "Windows has determined the driver software for your device is up to date", but the USBs still aren't working. Any ideas? 

    Thanks!

    2018年3月21日 0:44
  • I tried this but my computer wouldn't let me check any boxes... 

     
    2018年3月21日 0:59
  • Afternoon Klaus, it has taken me weeks of searching for a fix to the USB problem, and behold your solution worked a treat, even my computer provider couldn't fix it of come up with a solution.

    Your post maybe almost 5 years old, but it worked a dream on my Windows 10 HP Z800.

    You a star 5 Stars Klaus 

    2018年5月13日 13:37
  • Had the OS scan the "windows old\windows" folder, which includes the old system, system32 and winsxs folders. Took a while but found the correct driver.

    2019年5月27日 4:38