none
Windows10にてインターネット接続を遮断するとIMEが効かなくなる RRS feed

  • 質問

  • 初めて質問させていただきます。

    Azure上で稼働させる仮想マシンのWindows10にてIMEが使えなくなった件について教えてください。

    Azure上で稼働させる仮想マシンのWindows10(Windows10 Pro N)にて、自社アプリのテストをしております。

    自社アプリは個人情報を扱うので、ネットワークセキュリティグループ(NSG)にて

    ・168.63.129.16に対する全ての通信を許可

    ・自社固定IPアドレスからのRDP接続を許可

    ・仮想マシンからインターネットに対する接続を拒否

    させたところ、IMEが使えなくなりました。

    ・仮想マシンからインターネットに対する接続を拒否

    を外し、仮想マシンを再起動させたところIMEが使えるようになります。

    教えていただきたいのは、

    Q1.IMEをオフラインで使用する方法はないのか?否か?

    Q2.IMEをオフラインで使用する方法があれば、どのような設定を行う必要があるのか?

    Q3.IMEをオフラインで使用する方法がなければ、どこに対する通信を許可すればよいのか?

    以上3点です。

    よろしくお願いいたします。

    2019年8月21日 6:47

回答

  • 日本語を追加するとその後で「日本語ローカル エクスペリエンス パック」がダウンロードされてインストールされます。これが完了していないということだったのかもしれません。


    Hebikuzure aka Murachi Akira

    • 回答としてマーク natuminoru 2019年8月22日 19:36
    2019年8月22日 8:32

すべての返信

  • 「IME が使えなくなりました」とは具体的にどのような動作/状態になるのでしょう。操作手順と結果を具体的に示されると良いと思います。

    また Microsoft IME には「クラウド候補」の機能があり、これはインターネット接続が必要ですが、この設定はどうなっているでしょう。有効であれば無効にしたら現象に変化はありますか?


    Hebikuzure aka Murachi Akira

    2019年8月21日 13:45
  • 返信いただきありがとうございます。

    >「IME が使えなくなりました」とは具体的にどのような動作/状態になるのでしょう。操作手順と結果を具体的に示されると良いと思います。

    については、

    ・IMEツールバーが表示されなくなる。

    ・半角/全角ボタンを押下してもIMEツールバーが表示せず、漢字入力ができない。

    という現象を確認しました。

    併せて、

    >また Microsoft IME には「クラウド候補」の機能があり、これはインターネット接続が必要ですが、この設定はどうなっているでしょう。有効であれば無効にしたら現象に変化はありますか?

    についても、「クラウド候補」のチェックを入れたり外したりしましたが何ら前記のような状況は変わりませんでした。

    よろしくお願いいたします。

    2019年8月21日 20:18
  • IME 自体はオフライン(インターネット接続)であっても通常は起動(日本語入力の有効化)・ローカル辞書を使った変換ともに正常に利用できるので、何か個別の環境依存する原因があるかと思います。

    書かれている状態だとテキストサービス自体が動作していないようにも見えますが、ctfmon.exe は起動しているでしょうか?


    Hebikuzure aka Murachi Akira

    2019年8月22日 1:09
  • ご回答いただき、ありがとうございました。

    >ME 自体はオフライン(インターネット接続)であっても通常は起動(日本語入力の有効化)・ローカル辞書を使った変換ともに正常に利用できるので、何か個別の環境依存する原因があるかと思います。

    とのことですが、AzureのNSGでインターネット接続でよく使う

    TCP 20,21(FTP)

    TCP 22(SSH)

    TCP 23(Telnet)

    TCP 25,465,587(SMTP)

    TCP 110,995(POP3)

    TCP 143,993(IMAP)
    UDP 123(NTP)

    TCP 80(HTTP)

    TCP 443(HTTPS)

    を徐々に閉めていったのですが、IMEが使えなくなることはありませんでした。他のポートを使用しているのかもしれません。

    >書かれている状態だとテキストサービス自体が動作していないようにも見えますが、ctfmon.exe は起動しているでしょうか?

    ctfmon.exeを起動させると

    なるメッセージが表示されて終わりです。

    (紹介が誤字もあるような気がしますが・・・)

    また、ctfmonm.exeをタスクスケジューラにて起動時に起動させようとしている設定を見つけたのですが、”実行”を押下しても実行しませんでした。

    azureだから何でしょうか???



    2019年8月22日 5:13
  • サーバーから紹介が返ってきました」は Microsoft あるあるの珍訳で、「A referral was returned from the server」が原文です。プログラムの互換性設定や(根本原因は同じですが)実行権限に問題がある場合に出ることがあるようです。

    コンピュータはワークグループ環境でしょうか、ドメインに参加した環境でしょうか?


    Hebikuzure aka Murachi Akira

    2019年8月22日 5:26
  • ご回答いただき、ありがとうございます。

    機械翻訳でしょうから、誤訳もさもありなん・・・ですね。


    今回の環境はAzure上でワークグループ環境で使用しています。

    一つ気が付いたことがあるのですが、

    ・Azureで提供されているWindows10が英語版

    ・今回使用したい言語が日本語

    ということで、日本語化の対応をする必要があったのですが、


    Windowsの設定→時刻と言語→言語→優先する言語の中の”日本語”をクリック→”オプション”をクリック

    から、言語パックは入れていたのですがどうやら”基本の入力”が入っていなかったようで、IMEを使うたびに443ポートを通じてInternetに問合せいていたようです。


    現在、”基本の入力”もインストールしたので、NSGにてインターネットへの通信をすべて遮断し、様子を見てみようと思います。

    取り急ぎご報告申し上げます。



    2019年8月22日 8:15
  • 日本語を追加するとその後で「日本語ローカル エクスペリエンス パック」がダウンロードされてインストールされます。これが完了していないということだったのかもしれません。


    Hebikuzure aka Murachi Akira

    • 回答としてマーク natuminoru 2019年8月22日 19:36
    2019年8月22日 8:32
  • ご回答いただき、ありがとうございます。

    仰る通り、

    >「日本語ローカル エクスペリエンス パック」がダウンロードされてインストールされます。これが完了していないということだったのかもしれません。
    ということではないかと思います。

    よろしくお願いいたします。


    2019年8月23日 0:20