none
EventID: 7024 "The DPMRA service terminated - Only one usage of each socket address" on Sharepoint 2013 RRS feed

  • 質問

  • Hi!

    I have permanent error on my Sharepoint 2013 with DPMRA. About twice time a week it's fault to start, because his port  is stolen by mssearch.exe.

    I changed DPMRA port from 5719 to 11000, but it's not help. mssearch.exe sometime use this port too.

    Try to use port reservation, like listing bottom, but it does not help too.

    REG_MULTI_SZ ReservedPorts 11000-11000
    (HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\ReservedPorts)
    (https://support.microsoft.com/ru-ru/help/812873/how-to-reserve-a-range-of-ephemeral-ports-on-a-computer-that-is-runnin)

    What have i to done to isolate DPMRA port from mssearch.exe? May be there is some pools of ports, that already reserved?

    • 編集済み AleksKey 2018年5月29日 7:03
    2018年5月29日 7:00

すべての返信

  • Hi there!

    have you tried the Resolution 1 on this page?

    https://support.microsoft.com/en-ph/help/947682/the-dpm-protection-agent-service-cannot-start-in-system-center-data-pr

    To change the ports that are used by the DPM agent, follow these steps on the protected computer that is experiencing the problem. Make sure that the ports that you reassign will not used by any other applications.
    1. Locate the SetAgentcfg.exe file from the DPM server. By default, the file is located at the following path:
      %PROGRAMFILES%\Microsoft DPM\DPM\Setup\SetAgentCfg.exe
    2. Copy the file to the protected computer that is experiencing the problem. Copy the file to the agent DPM\Bin directory. By default, the file is located at the following path:
      %PROGRAMFILES%\Microsoft Data Protection Manager\DPM\bin
    3. On the protected computer that is experiencing the problem, open an administrative Command Prompt window.
    4. In the Command Prompt window, change to the directory to which the SetAgentCfg.exe file was copied. For example, change to the following directory:
      %PROGRAMFILES%\Microsoft Data Protection Manager\DPM\bin
    5. Run the following command to change the ports that are used by the DPM Agent:
      SetAgentCfg e dpmra <port number> <alternate port number>
    6. Restart the DPMRA service.

    See if this works out for you.


    Best regards,
    Leon


    Blog: https://thesystemcenterblog.com  LinkedIn:   

    2018年5月29日 7:13
  • Hi, yes i I tried.

    Program, that affect DPMRA is a mssearch.exe (part of Sharepoint 2013 responsible for search), so if I stoped it problem will gone, but there will be no search in Sharepoint.

    Can't find information about range of ports, that mssearch.exe is using. I changed ports of DPMRA several timese form 5719 to 5000, and than from 5000 to 1100. Every time this ports is using by mssearch.exe and the issue repeat.

    2018年5月29日 7:24
  • If you change these in the registry it might require a reboot before it comes into effect, did you try rebooting?


    Blog: https://thesystemcenterblog.com  LinkedIn:   

    2018年5月29日 7:27
  • Yes, I already rebooted server, DPMRA now using port 11000 see picture bellow:


    2018年5月29日 7:35
  • Okay that's very odd, the registry port change should work. 

    Are you able to restart the SharePoint services / server?

    When changing the ports you will also have to make sure that the firewall allows them.

    In worst case scenario, you can reinstall the DPM agent on the SharePoint server.


    Blog: https://thesystemcenterblog.com  LinkedIn:   

    2018年5月29日 7:51
  • SharePoint was restarted after changing port for DPMRA. Firewall is Disabled. Hmm, agent was reintalled half a year ago, may be I'll do it. Thank you for idea.


    2018年5月29日 9:30
  • SharePoint was restarted after changing port for DPMRA. Firewall is Disabled. Hmm, agent was reintalled half a year ago, may be I'll do it. Thank you for idea.


    Reinstalled DPMRA, but it does not fixed the problem. Does anyone know some another solution? 
    2018年5月30日 5:53
  • Has this problem always occured? Or did it start at some point? Usually restarting the DPM agent works in this case, have you checked the DPM RA permissions in the DCOM configuration?

    Blog: https://thesystemcenterblog.com  LinkedIn:   

    2018年5月30日 6:41
  • Has this problem always occured? Or did it start at some point? Usually restarting the DPM agent works in this case, have you checked the DPM RA permissions in the DCOM configuration?

    Blog: https://thesystemcenterblog.com  LinkedIn:   

    Yep, I did it. Problem occured about twice a week, when DPMRA port is occupy by mssearch.exe it is affect making backup jobs. After mssearch.exe release port DPMRA make backup success. May be you could tell me ports, that mssearch.exe does not occupy (I can't find them))?
    2018年5月30日 8:56
  • I suggest create a ticket to Microsoft about this to see if they have a fix for this, you can use the workaround below for now:

    • Stop mssearch.exe
    • Stop the DPM agent (DPMRA)
    • Start DPM agent (DPMRA)
    • Start the mssearch.exe and it should find alternative port to connect and run.

    Best regards,
    Leon


    Blog: https://thesystemcenterblog.com  LinkedIn:   

    2018年5月31日 13:29