none
Windows 7 error: Location is not available or Item not found RRS feed

  • 질문

  • I'm using windows 7 ultimate. I have a directory on a 1TB external usb drive called "1976 T.N.T". I am neither able to access this directory nor am I able to delete it. When I double click to access it windows says -

    Message Title: "Location is not available"

    Message Text: J:\Music\Library\Rock-Metal\ACDC\1976 T.N.T refers to a location that is unavailable. It could be on a hard drive on this computer.or on a network. Check to make sure that the disk is properly inserted, or that you are connected to the Internet or your network and then try again. If it still cannot be located the information might have been moved to a different location.

    When I try to delete it windows says -

    Message Title: Item Not Found

    Message Text: Could not find this item.

    This item is no longer located in J:\Music\Library\Rock-Metal\ACDC. Verify the item's location and try again.

    I have tried the following -

    1. Deleting file using command prompt but that doesn't work

    2. Check disk with both options "File system errors" and "Bad sector recovery" selected - it does not report any errors and the problem persists

    3. Rebooting the computer

    4. Disconnecting the drive and connecting it to my xp pro laptop (messages on xp are slightly different but to the same effect)

    Any suggestions short of formatting the drive will be appreciated.

     

    2010년 6월 23일 수요일 오전 12:01

답변

  • Wow! I aparantly fixed it 2 mins after posting this question. Here is what I did in case it can help someone else.

    I created another directory in J:\Music\Library\Rock-Metal\ACDC with the same name as the problem directory in my case 1976 T.N.T. (I just tried it and it worked. I actually saw two directories with the same name and different creation dates)

    Then I backed out one directory to J:\Music\Library\Rock-Metal\ in windows explorer

    Then I deleted the parent directory i.e. J:\Music\Library\Rock-Metal\ACDC

    ... and to my utter disbelief it actually got deleted.

    • 답변으로 제안됨 M.Glenn 2010년 7월 19일 월요일 오전 11:22
    • 답변으로 표시됨 Carey FrischMVP, Moderator 2012년 1월 19일 목요일 오전 3:36
    2010년 6월 23일 수요일 오전 12:09

모든 응답

  • Wow! I aparantly fixed it 2 mins after posting this question. Here is what I did in case it can help someone else.

    I created another directory in J:\Music\Library\Rock-Metal\ACDC with the same name as the problem directory in my case 1976 T.N.T. (I just tried it and it worked. I actually saw two directories with the same name and different creation dates)

    Then I backed out one directory to J:\Music\Library\Rock-Metal\ in windows explorer

    Then I deleted the parent directory i.e. J:\Music\Library\Rock-Metal\ACDC

    ... and to my utter disbelief it actually got deleted.

    • 답변으로 제안됨 M.Glenn 2010년 7월 19일 월요일 오전 11:22
    • 답변으로 표시됨 Carey FrischMVP, Moderator 2012년 1월 19일 목요일 오전 3:36
    2010년 6월 23일 수요일 오전 12:09
  • I had the same issue as it was stopping winrar from working, I tried to unistall and install winrar but still would not work.  I  found this thread, tried it, and to my surprise "It worked as well". Thanks
    2010년 7월 5일 월요일 오전 2:53
  • I had a similar issue. In my case, when trying to Add a location to one library, I received the "Location is not available" error for a completely different library where I had moved a subfolder (not a top-level location defined in the library, but a subfolder). Then I realized Libraries was probably pointing to that subfolder as the last location I had open in a previous session. BTW, this was not the default save location. I had to temporarily create another subfolder with the same name to get Add Location working again.

    Windows 7 Libraries are a good feature, but they seem to be a work in progress. As we can see, Libraries are sometimes broken by making changes in Windows Explorer even though they're are supposed to monitor Windows Explorer activity. This is a bug. Also basic functionality seems to be missing, such as the ability to sort the added locations or include network shares (which I understand can be done in Win 7 Enterprise, but sadly may have been left crippled in other editions on purpose). Some workarounds for the latter are available on the Internet.

    2010년 7월 19일 월요일 오후 12:16
  • I have spent the morning and most of the afternoon on every site I could find to fix the dreaded "verify item's location . . ." then I came upon the M.Glenn solution of creating an exact duplicate of the offending folder and then deleting the parent. WOW!

    Thanks

    2011년 3월 10일 목요일 오후 7:58
  • Wow! I aparantly fixed it 2 mins after posting this question. Here is what I did in case it can help someone else.

    I created another directory in J:\Music\Library\Rock-Metal\ACDC with the same name as the problem directory in my case 1976 T.N.T. (I just tried it and it worked. I actually saw two directories with the same name and different creation dates)

    Then I backed out one directory to J:\Music\Library\Rock-Metal\ in windows explorer

    Then I deleted the parent directory i.e. J:\Music\Library\Rock-Metal\ACDC

    ... and to my utter disbelief it actually got deleted.


    Thank you thank you thank you.  I've been messing with this problem for the last 2 hours.  Crated an identical folder and was able to delete the parent folder.

     

    Thank you!!!

     

     

    2011년 4월 25일 월요일 오전 3:18
  • :( this didnt work for me

     

    2011년 4월 26일 화요일 오후 10:11
  • Thanks for posting. I had multi level empty directories and it was the lowest dir that needed to be duped. 
    2011년 9월 30일 금요일 오후 2:14
  • Wow! I aparantly fixed it 2 mins after posting this question. Here is what I did in case it can help someone else.

    I created another directory in J:\Music\Library\Rock-Metal\ACDC with the same name as the problem directory in my case 1976 T.N.T. (I just tried it and it worked. I actually saw two directories with the same name and different creation dates)

    Then I backed out one directory to J:\Music\Library\Rock-Metal\ in windows explorer

    Then I deleted the parent directory i.e. J:\Music\Library\Rock-Metal\ACDC

    ... and to my utter disbelief it actually got deleted.

    Thanks Hchari. I had the same problem and was messing with it by deleting registry entries, restoring, rebooting etc. however, your solution was superb. I did the same. First created duplicate of the problematic folder and then deleted it along with the parent folder. Thanks again. God bless you.

    2011년 10월 5일 수요일 오전 10:24
  • What do you do if it's on the desktop?
    2011년 10월 23일 일요일 오전 7:55
  • You rock!  Thanks a million for posting the fix.
    2011년 11월 16일 수요일 오후 4:08
  • This also worked for me.  When backing up a file with an unsually long name from one drive to another, it crashed saying it could not copy a folder so i opted for the "skip the file" command which landed me into creating these zombie directories - all empty of the files, of course and unable to be deleted!  As the origianl poster noted, I created a new folder, copied the name over exactly - right beside it...low and behold the directory now held two identical folders - not a normal Windows law!  I backed out a level and deleted the parent folder holding the newly created folder and the zombie folder - the parent folder with the zombie and newly created duplicate vanished - well done hchari!
    2012년 1월 4일 수요일 오전 3:42
  • I too have the same problem with my desktop. I shut down my computer last night and it started updating. When I woke up this morning and signed on, my desktop had been cleared other than my Recycle Bin and I cannot download files because of the same error message that is being discussed in the thread. Any help would be great! I cannot re-download Skype or else I would share screen with a more tech savvy friend than me!
    2012년 1월 11일 수요일 오후 1:00
  • The cause of this is as follows:

    The directories in question were created or last modified by a process other than Windows Explorer. This process created a directory name with a space at the end. When you created a duplicate directory, the exact directory name you created was therefore not exactly the same; it had no space on the end. That is why both directories with the apparent same name could coexist.

    Note: if you attempt to create a directory from within Windows Explorer with a space on the end, the process explorer.exe is designed to prevent this from happening. That's why it's never usually an issue.

    To reproduce this problem, you could do the following:

    1) Create C:\foo
    2) Create C:\bar
    3) Use Robocopy to create the erroneous directory using the following command:

    robocopy "C:\foo" C:\bar" /E

    Notice that I missed the first double-quote on the target location. Robocopy should have responded with an error, but due to the way it interpreted my input, it didn't.

    Now you will see a directory called C:\foo\bar

    Except this directory is actually: "bar " - the word "bar" with a space on the end.

    Now try deleting C:\foo altogether. It won't because there is a directory underneath it that has an invalid name.

    Now try entering C:\foo, and creating a second directory called "bar". This will work, and there will appear to be two directories named "bar".

    But this time you can go up a level and delete "C:\foo".

    Put it down to a bug in Windows, a bug in Robocopy, whatever you like! That's the reason though...



    • 편집됨 hazymat 2012년 2월 25일 토요일 오후 6:17
    • 답변으로 제안됨 navyjax2 2012년 3월 22일 목요일 오후 2:51
    2012년 2월 25일 토요일 오후 6:15
  • I had this issue with a file, not a directory. I narrowed it down to either an inode issue (because NTFS is terrible), or the fact that the file name ended in a ".", which Windows refuses to allow me to replicate.  Since you can't name files that way in Windows, maybe the programmers forgot to put things in place to deal with such filenames?  

    Either way, this fix didn't work for me, but I was able to fix it using Linux.  I originally had tried this method, along with the command prompt as administrator.  I have linux utils installed, and ls -al didn't show the file, but "dir" did. 

    What I did was I shared the directory the file was in over the network, and just removed the file on a linux box as normal.  No issues, and it solved the problem.  Hopefully this helps someone else.

    • 답변으로 제안됨 rannmann 2012년 4월 29일 일요일 오후 7:59
    2012년 4월 29일 일요일 오후 7:59
  • As easy and step by step as you make this sound. Im baffled by your direction because it doesn't work. I'm having an issue deleting a folder named rsbot, that has nothing in it. but when i click on it it gives me the same error you have. Is there any way you could dumb down these instructions for me?
    2012년 5월 26일 토요일 오후 8:16
  • i too had a problem with a folder that ended in a trailing balnk: it showed in explorer as 0 bytes big - but would open and contained all my files.

    But since Windows does not support folder names with thrailing blanks I could not access it or the files.

    Eventually i found this post here  which solved it for me.

    In a CMD window I was able to copy the folder to another one using the "move" command. 

    2012년 6월 7일 목요일 오전 1:30
  • Wow thank you...That worked for me too
    2012년 6월 27일 수요일 오후 11:06
  • I need help with deleting those invalid files also, how do i create another directory?
    2012년 9월 19일 수요일 오후 4:48
  • Had the same issue, in my case couldn't remove a directory whose name ended with a "."; also, I think a long file name inside had something to do with the issue..

    In any case.. hchari's fix didn't work for me -- I just couldn't create a directory with the same name in Win 7 (in any location!), neither in explorer or cmd terminal.. Maybe the end "." has something to do with it.

    But rannmann's linux idea worked! I just downloaded cygwin linux tools for win (probably all you need is something that will let you work with linux terminal on win). Then in cygwin terminal basically all the normal commands for working with files/directories worked.. Like rannmann said, "ls -al" to make sure you see the problem directory.. and then I was able to "cd" in, "rm" the files, and then "rmdir" the directories. (For some reason recursive rmdir was not working, but w/e).

    So this particular incarnation of the problem didn't seem to have any serious underlying issues behind it.. apparently all one needs is a good tool for working with the filesystem -- which makes me think that there has to be a native windows utility that can do that, too. It's pretty silly to use linux tools to solve windows filesystem issues :)

    2013년 9월 9일 월요일 오후 11:26
  • Yep, worked for me.

    I created a folder with the same name, right-clicked on it and hit delete. Boom - both gone :)

    Thanks!!!

    2013년 10월 1일 화요일 오후 5:08
  • I can confirm making a second folder with the exact same name worked for me in Windows 8.1!
    2013년 10월 30일 수요일 오전 9:41
  • Hello!

    With regards to this error type, do you have any idea of what to do if I am trying to retrieve the file instead of deleting it? Any help will be much appreciated please, as my hard disk has crashed :( Thank you so much!

    2014년 7월 4일 금요일 오후 1:38
  • I got similar problem with my small portable HDD. The HDD has NTFS file-system and was connected to Linux-system for a while. The problem occurs with a folder ending with a "." symbol (i.e. "Some name A.T.U.") .

    It looks that under Windows the "." is not allowed at the end of folder name, but NTFS itself can store it. Therefore Disk-Check doesn't see/fix any problem but Windows tools can't work with this path. If you try to add manually the "." at the end of the path when renaming or moving the folder - the Windows API/tools remove the "." and get the access error because can't reach the real path (i.e. the folder is shown but no actions can be performed).

    The solution was to connect the HDD to Linux-system, rename the folder (e.g. add some "normal" symbol after the ".") and then connect the HDD back to Windows. Now the Windows can work again with it.

    Theoretical it would be also possible to rename from Android-System (i.e. mobile-phone supporting connection of external HDD per USB), but you might get problem with power-supply for your HDD as well as write-access rights on modern Android-versions.

    I think the "not displayed dot" at the end of the name is also the reason why you can create a folder with same name. In fact the names are different (one with dot and another one without, but they are displayed similar without ending dot).

    I hope this information helps to someone...

    2019년 5월 3일 금요일 오후 1:56