none
Terminalserver - Standarddrucker - "Fehler 0x000000709" RRS feed

  • Pergunta

  • Guten Tag,

    wir haben eine Remote-Desktop-Server Umgebung (Windows Server 2016).

    Die Drucker werden per Login-Skript an die Benutzer verteilt. (Funktioniert soweit)

    Der Standarddrucker wird auch per Login-Skript festgelegt.

    Installiert und freigegeben sind die Drucker auf dem Domänencontroller - "SRV-DC" (Windows Server 2008 R2) 

    Die Benutzer bekommen sporadisch nach dem Anmelden die Fehlermeldung:

    "Der Vorgang kann nicht abgeschlossen werden (Fehler 0x000000709).

    Überprüfen sie den Druckernamen, und stellen sie sicher, dass der Drucker mit dem Netzwerk verbunden ist."

    Seltsamerweise wird der Standarddrucker korrekt gesetzt. Die Benutzer können auch Drucken. Sie erhalten lediglich öfters diese Fehlermeldung.

    Das Login-Skript bleibt bei folgender Zeile stehen:

    if %username% == BENUTZERNAME rundll32 printui.dll,PrintUIEntry /y /n \\SRV-DC\DRUCKERNAME

    Jeder Benutzer hat seine eigene Zeile in dem Skript in der sein Benutzername eingetragen ist und der für ihn vorgesehene Standarddrucker.

    Ich bin für jeden Tipp zu dem Thema dankbar.

    terça-feira, 12 de novembro de 2019 13:10

Todas as Respostas

  • Könnte ein Timing-Problem sein, da die physische Existenz des Druckers bzw. die Netzerreichbarkeit getestet wird.
    Vielleicht bringt dich das weiter:
    https://support.microsoft.com/de-de/help/2965564/errors-when-you-connect-to-a-shared-printer-by-using-a-cname-record-in

    reg add hklm\system\currentcontrolset\control\print /v DnsOnWire /t REG_DWORD /d 1reg add hklm\system\currentcontrolset\services\lanmanserver\parameters /v DisableStrictNameChecking /t REG_DWORD /d 1
    reg add hklm\system\currentcontrolset\services\lanmanserver\parameters /v OptionalNames /t REG_SZ /d " aliasname " 

    terça-feira, 12 de novembro de 2019 14:35
  • moin,

    wir haben leider auch das selbe Problem. Ich kenne dieses Fehlverhalten seit beginn von Windows 10. Hier wurden leider grundlegende Änderungen vorgenommen. Bisher konnte man bei Benutzer-Problemen einfach das Profil löschen und neu machen und der User konnte danach wieder gut arbeiten. Mit Windows 10 und Server 2016 werden die Drucker der User auch unter Local Machine abgelegt und automatisch beim erstellen des Profiles gemappt. Jedoch nicht sauber.

    Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Print\Providers\Client Side Rendering Print Provider

    du könntest nochmals das Profil löschen und versuchen manuell die Keys des Benutzer unter Local Machine zu bereinigen. Ich habe selbst noch keine saubere Anleitung gefunden wie hier vorgegangen werden soll. Tatsache ist, das es nicht mehr korrekt funktioniert wenn ein Profil gelöscht wird.

    Der Drucker ist zwar sichtbar wird aber nicht sauber unter

    Computer\HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Windows

    als Default Drucker hinterlegt. Dies führt dann immer wieder zu Problemen bei div. Anwendungen.

    Nachtrag:

    habe noch etwas gefunden

    https://www.windows-faq.de/2017/05/15/fehlercode-0x00000709-beim-setzen-des-windows-standarddruckers/


    Chris



    quarta-feira, 13 de novembro de 2019 07:55
  • Danke für die Beiträge,

    @bfuerchau

    habe die Anleitung befolgt, hat leider nichts verändert.

    @chris

    unter

    "Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Print\Providers\Client Side Rendering Print Provider"

    gibt es zwar einen Ordner für jeden Benutzer, dort ist das einzige was man jeweils findet "Printers\Connections" In keinem davon gibt es einen Schlüssel.

    unter

    Computer\HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Windows

    ist der default Drucker bei allen sauber hinterlegt. Habe dort die Schlüssel auch bereits gelöscht. ( Wie in der Verlinkten Anleitung) - brachte auch keine Besserung.

    Betroffen von der Fehlermeldung sind alle Benutzer, auch wenn ich komplett neue anlege, mit Namen die in diesem AD noch nie vorkamen.

    Wenn ich einen neuen Benutzer anlege kommt die Meldung zuverlässig beim ersten ausführen des Skriptes, auf beiden RDP Servern jeweils. Wenn ich das Skript danach nochmal ausführe oder neu anmelde kommt der Fehler nicht mehr. Wenn der Benutzer eine Zeit lang abgemeldet war, Kommt die Fehlermeldung sporadisch.



    • Editado Silberer quinta-feira, 28 de novembro de 2019 21:02
    quinta-feira, 28 de novembro de 2019 20:56