Power options stop working – MS please take pay attention!!!


  •             I (and many others) have our power configuration screen disappearing intermittently.  When we go to C.P.—Power Options—Change Plan Settings we see “Your power plan information isn’t available..”.  This problem is common and have been many postings about it on these forums.  For example, here:  Or here:  I am creating this new post to shed some more light on the issue because the problem goes on and on.  There is a strong need for MS to address this.  Maybe it is stumping them, but I see no evidence I can see that they are doing anything.

                There are several fixes that many of us have discovered.  None of them always work.  Sometimes they work the first time and sometimes they must be repeated several times.  Sometimes they work when used in combination, but not as a single fix.  I have always been able to fix it, but the problem always comes back and I have wasted many, many hours on this.  It’s very frustrating, and I’m far from the only one.  I’m sure MS could fix this with an update if we could just get them interested. 

    To help MS research a fix, here are all the “fixes” that I know of that help:

    *           From command prompt as administrator:  powercfg –restoredefaultschemes then reboot.

    *           From command prompt as administrator:  sfc /scannow then reboot

    *           Clean registry then reboot

    *           Do not allow the hard drive to turn off before entering sleep.

    *           ChkDsk

    *            Uninstalling APC PowerChute (UPS) and disconnecting USB connection. 

    *           There are also some computer-specific things that seem to help, like disabling “Fast start” in Samsung.  My machine is a custom with an Intel MB and doesn’t fit into any of those categories.  I have another machine that is identical to the troubled machine that has never shown the problem  The only significant difference between the two is that the troubled machine has a RAID 10 drive setup and the other does not.

    Gary Burton

    • Editado techniq1 segunda-feira, 4 de junho de 2012 20:56
    segunda-feira, 4 de junho de 2012 20:15

Todas as Respostas

  • Hi,

    Have you tried the resolution in the link below.

    Actually, this is not a bug, the cause of this issue is the corrupted registry hive which is related to Power option. If it does not help, please try In-place upgrade.

    Juke Chou
    TechNet Subscriber Support
    If you are TechNet Subscription user and have any feedback on our support quality, please send your feedbackhere.

    Juke Chou

    TechNet Community Support

    terça-feira, 5 de junho de 2012 07:14
  •             I appreciate your thoughtful response.

                I saw that thread weeks ago and I downloaded the .reg file, but I never downloaded PSTools or attempted the registry fix for the following reasons:

    *           Although this thread addresses the same issue, it addresses the problem in Vista instead of Windows 7.  I was afraid to mess up my Windows 7 registry with a Vista registry fix.  I saw no postings by anyone who tried it in Windows 7.

    *           It didn’t work for everyone who tried it on the forum – even in Vista.

    *           If the problem is caused by a corrupt registry, I would think that it would stay fixed once I found a way to fix it.  I have gone as little as a few hours and as long as a month with it working perfectly, but the problem always comes back.  The registry couldn’t keep re-corrupting itself because the registry is only data.  It’s passive and performs no action on its own.  I’m not arguing that the problem isn’t in the registry, but something has to be driving it and the registry doesn’t drive.  It seems to me that it would have to be a programming problem to corrupt the registry at the same spot every few days. 

                I have it fixed for the time being.  Please comment on my rationale before I take the plunge with the PSTools fix.  By the way, what is an “In-place upgrade”?

    Gary Burton

    terça-feira, 5 de junho de 2012 17:32
  • Hi,

    How to Perform an In-Place Upgrade on Windows Vista, Windows 7, Windows Server 2008 & Windows Server 2008 R2

    There are a couple of things that could cause rigistry to be corrupted, typically the 3rd party applications. So it does not mean a issue is fixed, and then it will never occur again.

    Juke Chou

    TechNet Community Support

    quarta-feira, 6 de junho de 2012 01:53
  • Hi,

     Open the command prompt with admin privilegeand execute the command

     powercfg -RestoreDefaultSchemes

    Regards Jinish.K.G|HCL Infosystems LTD

    quarta-feira, 6 de junho de 2012 08:49
  • That is one of many fixes I and others have tried as you can see from my original post.  It only works "sometimes" for many of us.  If it always works for you, you are fortunate.

    Gary Burton

    quarta-feira, 6 de junho de 2012 18:38
  • I checked out the in-place upgrade.  That's what I was afraid you might be talking about. It's almost as disemboweling as reinstalling Windows.  I would elect to live with the problem before I would take a week off to do that.  If I were to go through all that, there might be something in my installation that conflicts with a “good” install and I would still have the problem. 

    A lot of us have worked very hard on this, and we have not been able to identify any non-O/S cause for it.  We have suspected and eliminated other software such as Samsung’s Quick Start and APC’s PowerChute.  Although these other programs seem to exacerbate the problem, none have proven to be the consistent culprit.  If the problem occurs as a result of a conflict with another program, MS is the only party with the tools, resources, and intricate knowledge of the OS to find it.  If someone else is causing this problem, they are probably unaware of it and believe they are following MS’s standards.

    See why I (and many others) want MS to take a look at this?  It’s been going on since Vista.  It affects a lot of people.  As moderator for this forum, perhaps you can flag this to the attention of the MS engineers.  If so, please do.

    Gary Burton

    quarta-feira, 6 de junho de 2012 19:07
  • Hi, 

    Have you checked the SecurityDescriptors for the power plan?

    Please go to the following registry key, and change to the by default setting:



    If that doesn't help this issue, please let let us know:

    1. Does this issue always occur after a fresh installation?

    2. If you create and open a power plan by the local administrator account?

    “Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.”

    segunda-feira, 25 de junho de 2012 16:25
  • Thanks, Kevin:

              The default key is exactly as you describe, but I also have another value listed under the same key.  Value name: “0E796BDB-100D-47D6-A2D5-F7D2DAA51F51”, Value data: “O:BAG:SYD:P(A;CI;KR;;;BU)(A;CI;KA;;;BA)(A;CI;KA;;;SY)(A;CI;KA;;;CO)”, which is only slightly different from the default value.

              I have chased the problem away for the time being, so this may not be representative of what I will have when it comes back.  I will post back when I get the problem again, but in the meantime please tell me if you see anything wrong with the oddly-named key.  Should I delete it?

              In answer to your first question, I have only done one installation.  For me, it seems more intrusive to do a fresh installation or an in-place upgrade than to keep fixing it.  Fixing it almost always takes many attempts and gobbles up a lot of time, but reinstalls are even more time-consuming and there is no assurance that a reinstall (or an in-place upgrade) will fix it.  I don’t doubt that a reinstall will fix it, but I’m thinking that it will probably just add one more possible temporary fix to my list.  In other words, when I reinstall, I will just reinstall whatever it is that keeps corrupting my setup.

              I’m not sure I understand your second question.  I am the only user and it is an administrator account.  I haven’t used the built-in administrator account.  I only use the regular power plan.  I haven’t opened or created other power plans.  I’m very reluctant to complicate my system.  I seem to always get bit when I do.

              Please also weigh-in on this:  There is a proposed registry fix at  I haven’t had the courage to try it because it makes a lot of changes to the registry and is on a Vista forum.  Applying a large Vista fix to my Windows 7 registry scares me.  Do you think I should risk it?

    Gary Burton

    segunda-feira, 25 de junho de 2012 17:40
  • Hi, 

    Please leave the "“0E796BDB-100D-47D6-A2D5-F7D2DAA51F51”" on the server, OS usually only check the "default" key to determine if the power plan is available for current user.

    I checked the link you provided, the fix is try to fix the registry corruption. You can try to follow them, i test it and listed the steps as below:

    1. Run "powercfg.exe" under an Administrators command prompt", it will list all the Power Scheme (power plan) on your PC.

    2. GO to [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\user\PowerSchemes] you can find the "ActivePowerScheme", check it if the values if the exact the above Power Scheme listed, if not, correct it.

    3. If still fail, user "powercfg.exe -delete GUID" to delete the affected Power Scheme, and change the registry key to a build-in one. 

    4. recreate your power plan and apply again.

    “Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.”

    • Marcado como Resposta techniq1 quarta-feira, 11 de julho de 2012 22:42
    • Não Marcado como Resposta techniq1 sábado, 14 de julho de 2012 20:38
    quarta-feira, 11 de julho de 2012 08:07


                You probably think I haven’t responded to you, but I have.  I have had some posts disappear even though I verified that they were there.  No, I didn’t use any bad language either.  Unfortunately, I didn’t save copies so I can only go from memory to reconstruct.  This was happening a few months ago too.  I suppose I will just have to save all my posts separately.

                Anyway, in one disappearing post, I responded to your post of 7/11 to say that I confirmed that the GUID for the ActivePowerScheme” keys matched.  I wanted to use the “powercfg.exe –delete GUID” anyway just because I’m ready to try anything.  But I could never get the syntax right.   Even though I found the GUID (381b4222-f694-41f0-9685-ff5bb260df2e), I kept getting syntax errors.  This GUID was listed as active in both POWERCFG and in the registry.  It also matches what I have on my other computer, which does not have this problem.

                In another missing post, I documented how I fixed the problem -- actually just chased it away.  I wrote down all the steps.  I tried everything I mentioned in my earlier posts plus booting into safe mode.  I found out that the power options show up when I boot into safe mode even though they go away when I boot normally.  Interestingly, in safe mode, the power options only show the display setting, but that may well be normal for safe mode.  That might be a clue.        Many of the steps I took were repeated.  What works best to chase the problem away for a while is what I call my “Triple Threat” solution.  I clean the registry, execute “sfc /scannow”, then execute “powercfg –restoredefaultschemes”, then reboot.  Usually, the first triple threat doesn’t work, but if I keep repeating all three I eventually get it.

                I also proposed the theory that there might be something wrong with the magic packet I send from the other machine.  However, I disabled the Wake On LAN function and the problem came back again, so that was another blind alley. 


                Thanks again for trying to help, Kevin.  I’m still open to suggestions.

    Gary Burton

    sexta-feira, 20 de julho de 2012 01:07
  • bump!  There must be an answer out there somewhere -- something other than reinstalling windows or an in-place upgrade.  Does anyone know how to get Microsoft to address this?

    Gary Burton

    sexta-feira, 17 de agosto de 2012 23:27
  • I found something that seems to help!!!

    If anyone is still following this thread, you will probably like to know this.

    I have been able to make the problem go away twice now by compacting the registry and it has only taken one attempt.  I used PowerTools to do the compacting, but I doubt that it matters how you do it.  It is time-consuming, but takes less time than multiple instances of the "triple threat solution" I mentioned above.

    It could be a big help to those of us that are having the problem, but it isn't something you could call a solution because the problem still comes back and there is still no insight as to what is causing it.  

    I hope this helps someone and I hope it generates some interest -- from anyone, but particularly from of Microsoft.

    Gary Burton

    sábado, 8 de setembro de 2012 18:14
  •             I have some clues that I’m sure are significant, and could very likely lead to a solution.  I am still hoping someone who is involved in system level programming is monitoring this.

    *           I have two almost identical computers.  They have the same hardware and same software.  The only significant difference between the two is that while one has a standard hard drive (Machine C) and the other (Machine B) contains a RAID 10 array built from 4 drives identical to the one in Machine C.  They both have an Intel DP55WG mother board running Windows 7 Ultimate, 64-bit.  Machine C has NEVER exhibited the problem.  Machine B exhibits the problem often. 

    *           The problem almost always follows something else that went wrong such as an application that would not properly close.  I know that sounds like a memory error and that would also explain why it happens in one machine and not the other.  However, the failure is usually predictable and repeatable, which would probably rule out a memory error.  I often get impatient and start clicking on icons before an application has a chance to get fully initialized or while it's busy doing something else.  Some of my applications are confused by that.

    *           I can fix it any time, but the fix only lasts until something else goes wrong.

    *           Lots of things will sometimes work at fixing it (but usually not) as I detailed above.  The ONE THING that has fixed it every time I have I have tried it (about 5 times now) is to compact the registry, but that is very time-consuming.

                Please help if you can.

    Gary Burton

    • Editado techniq1 segunda-feira, 15 de outubro de 2012 05:15
    segunda-feira, 15 de outubro de 2012 04:17
  • I have even more information.  By now, I collected enough information to make me pretty sure that a decent system-level programmer at MS could solve this problem, and I am still begging them to take an interest.

    New information is as follows:

    * Compacting the registry ALWAYS fixes it.  I have done it that way about 30 times now.  

    * It isn't necessary to compact the whole registry.  It works if you only compact the HKLM/System key, but it's still a pain in the neck.  

    * The problem appears after a reboot.  If the power options seem normal just prior to the reboot, it is likely to be messed up when the machine boots up.  I am having no other problems with this computer.

    * My primary computer is the troublesome computer and it has a RAID 10 array.  However, I have a second computer that is almost identical in hardware and software but the second computer has never displayed this problem.  The only significant difference with the second computer is that although it uses the same hard disk as my primary computer, that secondary computer is not configured in a RAID array.  I am convinced there is a connection.  Both machines use Intel DP55WG Mother Board, Win7 Ultimate, and the same software loaded.

    I know I am probably whistling in the dark.  If not, however, Microsoft, PLEASE HELP!

    Gary Burton

    terça-feira, 18 de dezembro de 2012 02:59
  • I have the exact same issue with Win7 PRO 64bit on two different computers.   I can change what plan I want on either but I cannot modify any of the plans.  Since I can't see what is in ANY plan (always says they are unavailable!!) you have no idea how things are set.  This is a pain in the ?ss.  Seems to be a universal problem for sure.   :-(
    • Editado MillerRL46 domingo, 24 de março de 2013 14:10
    domingo, 24 de março de 2013 14:09
  •             Be sure to read my very first and last posts.  They have a lot of good info on the issue. 

                I have Win7 Ultimate 64-bit.  I also have a RAID 10 array of 4 disks.  I think the array may be related to the problem because few people have this problem and that is about the only thing about my system that could be called "unusual".  It is part of my Intel DP55WG mother board and I use Intel's software

                On my system, I discovered that when it says "...unavailable"; it implements the default power plan.  Although I don't like it, I can live with it.  I stopped fighting it and just decided to try to like the default power plan.

                Compacting is only a temporary fix.  I have used 2 compacting routines and both of them fix the problem temporarily.  The one I still use is in JV16 PowerTools.  I seem to always get the problem back as soon as I reboot.  

                I also discovered that all Microsoft updates also serve as temporary fixes -- probably because they compact the registry. 

    *          Do you have a RAID 10 (or any other RAID) array?

    *          Have you tried compacting the registry -- at least the system key? 

                It is really nice to see some feedback on this issue.  There are at least hundreds of us that have it, but that apparently isn't enough to generate interest on the part of Microsoft.  I begged them to look at it  for about a year.

    Gary Burton

    • Editado techniq1 domingo, 24 de março de 2013 22:09 Reworded
    domingo, 24 de março de 2013 18:31