Canon Camera Software


  • Has anyone tried plugging in the USB from one of the Canon Powershot family of cameras? Win 7 brings it up as an unrecognised device. Trying to install the camera WIA drivers or applications from the disk (using software compatibility) or Zoombrowser 6.1.1 ( updater from Canon for Vista as long as earlier Zoombrowser is on the system) ends in early failure.

    I was ever so pleased with Win7 until this happened!   


    terça-feira, 27 de janeiro de 2009 00:50


Todas as Respostas

  • Remember it is still the early days of the Public Beta, a lot of software and Hardware isnt yet recognised, and will need newer/compatible drivers made.

    However, have you tried installing it in compatibility mode?

    Right click the installer file, Select Properties, Compatibility Tab, and then OS either Vista/XP

    at bottom put a tick in Run as Administrator Apply/OK

    then try running the install file and see if that makes a difference.
    terça-feira, 27 de janeiro de 2009 00:54
  • Thanks Sanginius. Tried all that with baited breath but to no avail. As you say early days. Never mind.
    terça-feira, 27 de janeiro de 2009 01:27
  • It might be worth checking on canon's site to see if there are any updated camera drivers newer than what came on the cd. I just decided to try installing My camera and software, Its a FujiFilm F480 and that installed quite happily, the software installed Finepix viewer wont actually pull the images from the camera, but right clicking on the icon im my computer and seecting import imageand video will work, as will going right into the memory of the camera and copy/pasting.
    terça-feira, 27 de janeiro de 2009 01:46



    As Windows 7 is still in beta and Canon has not released drivers for Windows, you can try the latest drivers for Windows XP or Windows Vista from the following site:



    Tim Quan - MSFT


    quinta-feira, 29 de janeiro de 2009 08:08
  • Ok, so its now the end of August, running Windows 7 64 bit release code on a Dell e6400.  My Powershot A40 still doesnt work.

    quinta-feira, 27 de agosto de 2009 22:20
  • Ok, so its now the end of August, running Windows 7 64 bit release code on a Dell e6400.  My Powershot A40 still doesnt work.


    I'm a little surprised that the Vista software didn't work, particularly the newest version (6.3.1, from 6/12/2009).

    I have a Canon digital camera, but I haven't been keeping up with the software. I use a card reader to copy the data off the CF card. I guess I've always done it that way.

    I assume that the drivers for the cameras are proprietary, and not produced by Microsoft. Maybe Canon support will have something more to say than that they don't support unreleased operating systems. If you find out anything, please let us know.
    sexta-feira, 28 de agosto de 2009 03:35
  • The Canon Vista 64 bit drivers and software does not work on Windows 7 RTM either.  According to Canon support, they don't have a release date for the 64 bit Windows 7 software nor do they have any beta that they will let you try.

    The Canon 32 bit drivers do work on Windows 7 32 bit.
    • Sugerido como Resposta barkdust45 sexta-feira, 11 de setembro de 2009 06:26
    segunda-feira, 7 de setembro de 2009 21:40
  • The following works for Canon Powershot G3.

    Goto to tools menu (middle tab).
    Scroll down to the bottom (Communications)
    Set to "PTP".

    Turn off camera.
    Plug into usb port.

    The Canon browsers won't pick up the camera
    but you can get your pictures off using Windows software.

    • Editado fanfarenj segunda-feira, 11 de junho de 2012 22:49
    segunda-feira, 11 de junho de 2012 22:44