none
Redhat Enterprise Linux 8.0 Will Not Boot in Hyper-V RRS feed

  • Discussão Geral

  • Running Microsoft Windows [Version 10.0.18362.175], RHEL (Redhat Enterprise Linux) 8.0 will not properly boot in either a generation 1 or generation 2 Hyper-V virtual machine following installation.  Latest previous version of RHEL 7.6 installs, boots, and operates normally.

    After boot of RHEL 8.0, the screen reads:
    [   11.046716] piix4_smbus 0000:00:07.3:  SMBus base address uninitialized - upgrade BIOS or use force_adr=0xaddr



    • Editado DarienHawk67 quinta-feira, 13 de junho de 2019 19:31
    quinta-feira, 13 de junho de 2019 19:13

Todas as Respostas

  • Hi Darien,

    Can you please share with me the details you used during setup - like disk partitioning info or any other choices different from the default ones?

    sexta-feira, 14 de junho de 2019 13:59
  • Hi Darien,

    I happened to run into the same issue today with installing RHEL 8 developer.

    You'll want to use their Hyper-V install guide.

    https://developers.redhat.com/rhel8/install-rhel8-hyperv/

    I believe the key was to select the software to be installed and not choosing "Server with a GUI"

    Select software to be installed.  Choose the Workstation base environment, add Development Tools, Graphical Administration Tools, and Container toolsNote: Do not select Server with a GUI.

    Hope that helps.

    quarta-feira, 26 de junho de 2019 17:22
  • Hello,

    While I don't have access to a Windows 10 with Hyper-V machine to test this, I cannot reproduce the issue on WS2016.

    During install I selected the Server role (no GUI) and without any components selected.

    Was able to then boot the installed OS just fine into text mode.

    Some info/versions for reference:

    RHEL 8.0 RTM

    Kernel: 4.18.0-80

    VM specs: 8GB RAM / 2 cores / gen1vm

    quinta-feira, 27 de junho de 2019 06:33
  • RHEL 8 boots sans GUI.  For a simple LAMP or some other "headless" purpose, straight terminal would be fine.  However, for my purposes, I need the GUI.

    sábado, 20 de julho de 2019 06:53
  • For an Oracle Database, and other purposes, I need the GUI.
    sábado, 20 de julho de 2019 06:54
  • I have found the "magic" combination.  For GUI, must select Workstation.  For whatever reason, selecting Server with a GUI will cause RHEL 8 to hang on boot.

    ** closed **

    sábado, 20 de julho de 2019 07:11
  • All other options work except for "Server with GUI."  Interesting.  Nonetheless, since I can get the GUI with the workstation option, that is good enough for me.

    

    sábado, 20 de julho de 2019 07:19
  • The problem with "Server with GUI" is due to a missing driver.

    The problem is described in RHEL 8.0's release notes and on an article in Red Hat's knowledge base.

    To fix the issue, either:

    • Open a virtual terminal;
    • ssh into the box;
    • Reboot changing the target to multi-user.target in GRUB;

    Then install the base-x package group. Following are instructions on how to install base-x from RHEL 8.0's installation media.

    Suppose the installation media is at /dev/sr0:

    mount /dev/sr0 /mnt
    rpm --import /etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-release
    yum --repofrompath AppStream,file:///mnt/AppStream -y groupinstall base-x  


    There's a bit more details in a blog post I published at:

    Error: There are no enabled repos.



    Alfred Myers http://alfredmyers.com | http://twitter.com/AlfredMyers

    segunda-feira, 23 de setembro de 2019 13:30
  • @Alfred Myers

    Thank you for the solution. I naively installed CentOS 8 in Hyper-V using "Server with a GUI" option without reading RHEL 8 documents. Found your solution here. A quick SSH session and reboot. All is well now.

    quinta-feira, 3 de outubro de 2019 17:53