none
Erro ao enviar e-mail : SSL is not available on this server. RRS feed

  • Pergunta

  • Olá, boa tarde

    Estou tentando enviar e-mail a partir de um aplicativo de terceiros e são retornados os seguintes erros:

    Falha ao conectar do servidor.
    Erro: 10091 - Network subsystem is unusable.

    Ou SSL is not available on this server.

    Esse erro ocorre usando os servidores smtp.live.com , smtp.office365.com e smtp-mail.outlook.com. A porta utilizada é 587, e a opção de conexão segura com SSL/TLS está marcada.

    Antes funcionava normalmente, agora ora funciona, ora não. Com outros provedores (gmail, yahoo, bol) é possível realizar o envio.

    Uso apenas o Windows Defender (está desativado), o Firewall está desativado. Não tenho proxy.


    • Editado SilvaniaSousa quarta-feira, 20 de novembro de 2019 21:08
    quarta-feira, 20 de novembro de 2019 21:08

Todas as Respostas

  • Estou enfrentando o mesmo problema,  isso começou a acontecer a partir do dia 19/11/2019
    quinta-feira, 21 de novembro de 2019 11:23
  • Exatamente.
    quinta-feira, 21 de novembro de 2019 19:29
  • Estou com o mesmo problema e começou no mesmo dia também.

    sexta-feira, 22 de novembro de 2019 12:21
  • Alguns clientes relatando o mesmo problema aqui. No Portal do Office 365 não informa nenhuma alteração de TLS/SSL recentemente. :S

    Alexandre Smialoski

    sexta-feira, 22 de novembro de 2019 12:45
  • Aqui começamos a ter este mesmo problema.

    Estou procurando alternativas o quanto antes pois alguns sistemas criticos estão sendo afetados.

    sexta-feira, 22 de novembro de 2019 13:34
  • Pessoal, se alguém encontrar uma solução por favor postem o resultado.
    sexta-feira, 22 de novembro de 2019 17:59
  • boa tarde pessoal,

    Uma pergunta, a aplicação de vocês de desenvolvida pela IDE da Embarcadero (Delphi)?

    Olha o que encontrei no link abaixo.

    https://docs.microsoft.com/pt-br/exchange/mail-flow-best-practices/how-to-set-up-a-multifunction-device-or-application-to-send-email-using-office-3

    segunda-feira, 25 de novembro de 2019 17:04
  • Boa tarde Pessoal, aqui deu certo após atualização de 2 DLL's 
    libeay32.dll

    ssleay32.dll

    segunda-feira, 25 de novembro de 2019 18:25
  • Boa tarde.

    Salvou a lavoura Rs Atualizei as dll e também deu certo. Obrigada.

    segunda-feira, 25 de novembro de 2019 21:33
  • Boa tarde. Aqui apresentou erro com Delphi e Lazarus.
    segunda-feira, 25 de novembro de 2019 21:33
  • qual o site que vc baixou?
    terça-feira, 26 de novembro de 2019 12:10
  • Por favor, me indiquem o site de onde foram baixadas as DLLs que supostamente resolvem o problema. 

    Existe algum procedimento a ser fazer na substituição das DLLs? Ou apenas copiar e colar?

    Pois não funcionou comigo!

    Obrigado!

    quinta-feira, 28 de novembro de 2019 12:05
  • Bom dia.

    Eu baixei as dlls nesse site http://www.dlldownloader.com/libeay32-dll/

    Renomeei as dlls da pasta SYSWOW64 e colei essas lá. Fiz o mesmo procedimento na pasta de instalação do sistema. Contudo, notei que no Windows 10 funcionou em alguns computadores, em outros não. No Windows 7 nem funcionou.

    Não sei o quanto seguro são essas dlls, então optei por manter as dlls padrão do Windows mesmo.

    segunda-feira, 2 de dezembro de 2019 14:38
  • Para o pessoa que desenvolveu o software utilizando a IDE do Delphi tenho um má notícia, esse problema somente será contornado se você possuir uma das últimas versões da IDE. Não adianta atualizar somente as DLL's que não vai resolver.

    Baixei a última versão do Delphi 10.3.2 (free por 30 dias) para realizar alguns. Após a instalação o procedimento que realizei foi atualizar as DLL's e recompilei um projeto de teste e funcionou perfeitamente.

    Após esse teste entrei em contato diretamente com o suporte da Embarcadero e eles me deram essa terrível notícia, que na versão que possuímos (2007) não suporta os novos requisitos de autenticação a solução seria atualizar a IDE.

    Resolvi compartilhar com vocês caso alguém esteja enfrentando o mesmo problema, provavelmente o mesmo ocorre com o Lazarus.

    terça-feira, 3 de dezembro de 2019 12:59
  • Depois de muito pesquisar e quebrar a cabeça, encontramos uma solução.

    Para aqueles que usam Delphi ou Lazarus devem atualizar os componentes Indy, segue link abaixo.

    https://indy.fulgan.com/ZIP/Indy10_5520.zip


    quarta-feira, 4 de dezembro de 2019 19:46