none
Explorer not refreshing on create / rename / Delete folders RRS feed

  • Pergunta

  • Any help with this?

    It seems to be an old problem with various fixes suggested, but all the ones I try don't work.

    It has just started in the last week or so.

    When I am in Window explorer (Win 7 64 bit) If  I create a new folder, nothing happens, it does but I have to hit F5 for the new folder to appear. Same thing when I rename or delete a folder.

    I understand this has affected a lot of people but until now it has not been a problem for me.

    Can anyone suggest a fix for this it is infuriating.

    Thanks.

    sexta-feira, 7 de abril de 2017 16:32

Todas as Respostas

  • Curious.

    Since this problem started I left the machine on overnight and there appears to have been some sort of update and the machine updated then restarted.

    ( I had tried a reboot several times along with searching for the dontrefresh registry entry - there wasn't one. And the reboots made no difference) 

    The problem now appears to have gone.

    segunda-feira, 10 de abril de 2017 07:42
  • Hi,

    Here is an incredibly simple solution that worked for me. It may work for you as well:

    In Windows Explorer: choose Tools, Folder Options > Click the Search tab > Check or uncheck ANY option

    Apply.

    If this solves your problem, you can revert to your original setting and the problem will remain solved.

    In addition, I also found if we disable the client for Microsoft Networks in properties of Local Area Connection - the issue disappear (maybe only in my case).

    Hope that helps.

    Best Regards,

    Tao


    Please remember to mark the replies as answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    terça-feira, 11 de abril de 2017 05:48
    Moderador
  • Hi,

    We haven’t heard from you for a couple of days, have you solved the problem? We are looking forward to your good news.

    Best Regards,

    Tao


    Please remember to mark the replies as answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    quarta-feira, 19 de abril de 2017 02:37
    Moderador
  • Thanks! The solution for me on Windows 10 was als to check -> apply and uncheck -> apply a random option in the search tab. :)

    • Editado FrankJNL91 sexta-feira, 23 de fevereiro de 2018 11:01
    sexta-feira, 23 de fevereiro de 2018 10:59
  • In addition to the problems RobMcP2 was having, Windows Explorer on my computer was locking up. I had to push the reset button on my computer to restart it. I made a change in options that Tony_Tao suggested (but in my case it was: Organize - Folder and Search Options. I changed an option on the General tab.), and it locked up after I Applied the change. I hit the reset button again to restart the computer (it would not restart normally). When Windows restarted it had accepted the change and everything worked normally.
    quinta-feira, 16 de agosto de 2018 13:13
  • Hi,

    Here is an incredibly simple solution that worked for me. It may work for you as well:

    In Windows Explorer: choose Tools, Folder Options > Click the Search tab > Check or uncheck ANY option

    Apply.

    If this solves your problem, you can revert to your original setting and the problem will remain solved.

    In addition, I also found if we disable the client for Microsoft Networks in properties of Local Area Connection - the issue disappear (maybe only in my case).

    Hope that helps.

    Best Regards,

    Tao


    Please remember to mark the replies as answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Worked for me on Windows 10.

    Thanks a lot.

    sexta-feira, 14 de setembro de 2018 03:58
  • For what is is worth, I  have had this problem on a Windows 10 system since I completed the install.

    For months it has bothered me and eluded remediation. What's worse, the Microsoft keyboard I am using does not have clearly marked Function keys, so hitting F5 every time I need the screen to refresh really stops my work in its tracks.

    I followed dozens and dozens of "fixes", from scanning the system, to recreating the profile to hacking Registry keys and hives.  Today I thoughtI would spend a few minutes walking through a collection of 18 possible fixes. On a Windows 10 system here is what worked, 

    Just right click on desktop 

    Click Personalize 

    Click Themes

    Click Change desktop icons 
    Restore default & OK  

    And instantly it began to auto refresh with a new folder, rename, delete, copy, etc.

    Yeah....

    • Sugerido como Resposta TechyBit quarta-feira, 16 de outubro de 2019 14:47
    sexta-feira, 5 de outubro de 2018 03:32
  • in windows 10, Tony_Tao s answer works but "Folder options" is named "options" and located under "file".

    file explorer -> file ->options -> search tab ->  uncheck or check any option (I unchecked "Include system directories") 

    reverting the change did not cause any problems


    • Editado mnuman terça-feira, 26 de fevereiro de 2019 06:01 credit to original answer
    terça-feira, 26 de fevereiro de 2019 05:57
  • Second this!  it worked!  Thanks Tao!
    sábado, 9 de março de 2019 23:34
  • If changing settings under Search doesn't work, try enabling or disabling "Launch folder windows in a separate process".

    To check/uncheck from Win Explorer: File > Change Folder & Search Options > View [Tab] > Uncheck the box.

    terça-feira, 9 de abril de 2019 16:29
  • I have experienced the same problem for the past couple of months.

    Seach tab solution didnt help me at all, but this with the "Launch folder windows in a seperate process" did solve my problem. Im happy again! :)

    quinta-feira, 2 de maio de 2019 20:36
  • This started on my flawless 1607 14393.2941 LTSB dev bench machine today and I am beyond surprised.

    I have not seen this since 7.

    None of the above 'fixes' do anything at all.

    segunda-feira, 6 de maio de 2019 03:25
  • I was skeptical with this but it fixed the issue immediately, nice workaround. Now all we need is for Microsoft to pull out their finger and fix the issue instead of sitting on them.

    Come on Microsoft, we've paid money for this OS get it fixed.

    domingo, 12 de maio de 2019 17:41
  • Worked. Thanks!
    quarta-feira, 12 de junho de 2019 15:35
  • None of the above worked for me either, but this did:  I reset all my folder and search views to default and applied them, then restarted.  So with "This PC" highlighted in Windows Explorer, I;

    • Selected FILE > CHANGE FOLDER AND SEARCH OPTIONS
    • GENERAL TAB > RESTORE DEFAULTS > APPLY
    • VIEW TAB > FOLDER VIEWS > RESET FOLDERS > YES
    • VIEW TAB > RESTORE DEFAULTS > APPLY
    • SEARCH TAB > RESTORE DEFAULTS > APPLY
    • I then rebooted, just to make sure - all fixed!!

    Thank God, cuz this was driving me NUTS for a LOOOOONG time!! :P

    Good luck!

    • Sugerido como Resposta CodyPredy sábado, 5 de outubro de 2019 18:12
    segunda-feira, 26 de agosto de 2019 00:52
  • Like Thrashin, I also tried all the previous suggestions with no joy. Plus many others I googled. 

    Thrashin's process worked for me. Thank you so much! It was driving me nuts as well! 


    sábado, 7 de setembro de 2019 20:04
  • Simply wow! I regularly had this issue every about 6 months. Usually I'll format my laptop but I got tired of it. Thx for the tip.
    segunda-feira, 14 de outubro de 2019 08:17