Windows Server 2012 stuck in reboot loop “Configuring Updates: Stage 2 of 4" RRS feed

  • Pergunta

  • Hello.

    After installing November monthly updates from WSUS server, about 80% of 2012 Servers stuck in loop.

    Server (VMware VM) launches a stage 2 of 4 again, then it goes shutdown of services and reboot.

    All Servers restored from backup.

    Any updates tried to install cause loop.

    Previous monthly updates uninstalling cause loop.

    Renaming of SoftwareDistribution, rescanning of updates and installing cause loop.

    Last monthly installation has been made without any problems on all Servers.

    Some 2012 Servers, including ADs, have installed current monthly updates successfully without any issues.

    2008 R2  Servers have no any issues on monthly updates.

    Space on HDDs is OK.

    I tried to compare software components installed - there are no real differences between servers with issue and without ones.

    Has anybody the same? Any ideas?

    I need help.

    • Movido Vector BCO quinta-feira, 14 de novembro de 2019 17:03 moved from ru-ru forums
    • Editado Sergey Litovchenko sexta-feira, 15 de novembro de 2019 10:04
    quinta-feira, 14 de novembro de 2019 16:47


Todas as Respostas

  • For WSUS issues I'd reach out to experts in dedicated forum over here.



    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows Server] Datacenter Management

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees, and confers no rights.

    quinta-feira, 14 de novembro de 2019 17:12
  • That is not a WSUS issue but Windows Updates one.
    quinta-feira, 14 de novembro de 2019 17:53
  • You can also start a case here with product support.



    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows Server] Datacenter Management

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees, and confers no rights.

    quinta-feira, 14 de novembro de 2019 18:03
  • Same issue here. Server 2012 DC continually rebooting after the last batch of updates
    quinta-feira, 14 de novembro de 2019 21:34
  • Workaround is to interrupt boot and use Safe Mode. It will still reboot at the same stage trying to boot into safe mode but next boot works.
    sábado, 16 de novembro de 2019 15:57
  • That worked. Thank you.
    sábado, 16 de novembro de 2019 17:18
  • How did you get into safe mode? My options are very limited when using command prompt, unable to list any volumes besides X: (Current config = 2 logical Volumes (RAID),1 for OS and 1 for data)

    Tries to make Windows display boot manager, but command fails..

    bcdedit /set {bootmgr} displaybootmenu yes

    Any help would be appreciated.



    Managed to bully it into safe mode & neathead-hmd's solution worked for me too.


    • Editado David N (ZA) segunda-feira, 18 de novembro de 2019 12:56
    segunda-feira, 18 de novembro de 2019 11:51
  • Thanks!  had 2 clients with this issue and this worked for me
    segunda-feira, 18 de novembro de 2019 14:48
  • Same issue here. Windows Server 2012. Update reboot loop for several hours before I was called in.

    Reset the VMware VM, hit F8 on boot, picked "Safe mode with command prompt". First time, I tried this, it rebooted without bringing me into safe mode. Tried it again, it booted into command prompt

    Restarted with shutdown /r, the server came back up properly

    After checking for updates again, I saw that one more update still needs to be installed. Since it's almost 2 AM here I decided to not try to push this in.

    terça-feira, 19 de novembro de 2019 00:41
  • Workaround offered really helps to resolve the issue.

    For checking I launched one of updates, waited for Stage 2 started and pressed with F8 (single mode) once on reboot: I chose "Safe Mode with Network Support".

    "Stages" disappeared and VM started successfully with the update installed.

    All next updates installed correctly WITHOUT any "stages".

    2 VMs have tested and installed correctly. All others VMs resolving has been planned.

    Thanks a lot for your advice!

    I hope this Microsoft Windows 2012 Server bug will be resolved and explained by vendor.

    terça-feira, 19 de novembro de 2019 20:51
  • This affected 7 of our virtuals, so does not appear to relate to a hardware vendor issue. Attempting to boot in to Safe mode also results in it restarting but it completes the update process on the next normal boot.

    Considering Azure only has a serial text console, how would one remediate something of this nature there?

    quarta-feira, 20 de novembro de 2019 04:38
  • We were able to reproduce the boot loop issue on Server 2012 (nonR2) if we installed the November MSRT with the other released updates. If we did not install the MSRT with the other updates the reboot loop doesn’t occur. We pulled the MSRT from our Server updates deployment for this month (nov 2019). I have not tried installing the MSRT after the reboot of the other updates.

    so- KB890830 which we removed from this month SUG

    Thanks!<v:shapetype coordsize="21600,21600" filled="f" id="_x0000_t75" o:preferrelative="t" o:spt="75" path="m@4@5l@4@11@9@11@9@5xe" stroked="f">
     <v:stroke joinstyle="miter">
    <v:formulas>  <v:f eqn="if lineDrawn pixelLineWidth 0">
      <v:f eqn="sum @0 1 0">
      <v:f eqn="sum 0 0 @1">
      <v:f eqn="prod @2 1 2">
      <v:f eqn="prod @3 21600 pixelWidth">
      <v:f eqn="prod @3 21600 pixelHeight">
      <v:f eqn="sum @0 0 1">
      <v:f eqn="prod @6 1 2">
      <v:f eqn="prod @7 21600 pixelWidth">
      <v:f eqn="sum @8 21600 0">
      <v:f eqn="prod @7 21600 pixelHeight">
      <v:f eqn="sum @10 21600 0">
     <v:path gradientshapeok="t" o:connecttype="rect" o:extrusionok="f">
     <o:lock aspectratio="t" v:ext="edit">
    </o:lock></v:path></v:stroke></v:shapetype><v:shape alt="" id="Picture_x0020_1" o:spid="_x0000_i1025" style="width:433.7pt;height:159.85pt;" type="#_x0000_t75">
    <v:imagedata o:href="cid:image001.png@01D59ED9.3BFCE920" src="file:///C:/Users/z013sfp/AppData/Local/Temp/1/msohtmlclip1/01/clip_image001.png">


    quarta-feira, 20 de novembro de 2019 04:49
  • Had this happen to a client this morning, server 2012.  Booting to safe mode fixed the issue.
    quarta-feira, 20 de novembro de 2019 20:51
  • Thank you!  Solution works!
    quinta-feira, 21 de novembro de 2019 16:43
  • Thank you. It worked.
    sábado, 23 de novembro de 2019 02:10
  • Same here and solution works. Thanks!
    domingo, 24 de novembro de 2019 12:49
  • I tried to install another update, allowed by WSUS manually (not November month updates) and the loop took place also.

    I assume that the source of problem is in previous (October) month updates.

    Uninstalling of past updates caused the same loop.

    segunda-feira, 25 de novembro de 2019 07:04
  • how did you get it to boot in safe mode?
    terça-feira, 26 de novembro de 2019 08:19
  • after booting into safe mode, what next?
    terça-feira, 26 de novembro de 2019 13:10
  • I concur with this finding.  I've pulled MSRT from our SUG as well.  As others indicated, going into safe mode seems to get it out of the reboot loop then the system will come up normally.  I'm just glad we found this in test and not production.
    terça-feira, 26 de novembro de 2019 15:53
  • me too

    Any update how to solve this problem?

    quarta-feira, 27 de novembro de 2019 11:28
  • Thanks for the advice! It worked perfectly for me too.
    quarta-feira, 27 de novembro de 2019 12:48
  • Thanks nethead-hmd the problem has been solved

    reset twice when you see the windows logo then it will open on the safe mood from there select "Last known good configuration" then it will continue to stage 3 and 4 and after that the server will open

    quinta-feira, 28 de novembro de 2019 06:35
  • Workaround is to interrupt boot and use Safe Mode. It will still reboot at the same stage trying to boot into safe mode but next boot works.

    I tried this two different way and neither worked.

    1 - tried hitting f8 and booting into safe mode, system never moved past loading files in safe mode and hung

    2 - booted from external media and went into repair mode, then rebooted. system went right back to endless loop

    anything else i can try?

    quinta-feira, 28 de novembro de 2019 20:20
  • ran into same issue affecting multiple Server 2012 vm's on ESXi over the past few weeks with some using wsus on a domain and others not on a domain not using wsus.  The majority resolved after booting into safe mode with networking and rebooting.  Memory utilization spike was noted on some which lead to temporarily increasing the vm memory allocation while troubleshooting which or may not have contributed to the fix.  Had a couple not resolved from safe mode alone which would not fully boot in safe mode.  Eventually fixed through some combination of safe mode attempts, selecting last known good configuration, and running dism + sfc offline from an install iso.  Example boot loop from latest that required additional offline steps:

    • Editado tektotket quarta-feira, 4 de dezembro de 2019 23:12
    quarta-feira, 4 de dezembro de 2019 22:55
  • This workaround worked for me. Because I was not near the machine, I remoted into the host server opened the affected VM with Hyper-V launched the onscreen keyboard and select the FN 8 key that way. Using my local keyboard didn't work.

    Thanks for the article saved me some time and pain.

    sexta-feira, 6 de dezembro de 2019 05:42
  • As per case we opened to MS:

    As a Bug has been filed they should be working on a resolution.
    As per the answer to prevent this ? MS recommended not installing the latest servicing stack and November CU..

    Apparently, we already installed the patches and safe mode helped to resolved this issue.

    On the machines that experienced this behavior, after we applied the work around, we uninstalled and installed the patches again but the servers booted up without problems. We also tried different scenarios but can't replicate the issue.

    Has anyone opened a case to Microsoft? it is unclear to us what causes this issue since we only installed SSU, OS cumulative and IE patch. 

    sábado, 7 de dezembro de 2019 10:22
  • One server down today, the safe mode helped. Thank you. 
    quarta-feira, 11 de dezembro de 2019 13:42
  • This solution resolved my errors from the Microsoft updates loop on my Windows Server 2012 servers and a couple of organizations.  What a rude way to start the day.  Thanks for posting the solution nethead-hmd.
    quarta-feira, 11 de dezembro de 2019 17:08
  • Same issue again this morning after "buggy patch Tuesdays"... after I was up to 3 AM updating some server firmware for a client, get woken at 6:45 am from another customer complaining they are down...  Same problem from last month with the "boot loop" on a 2012 virtual machine.

    Thanks to the thread, used the "remote into host", "wait for it to reboot when Stage 1 gets to 100%", "turn off VM immediately when power comes on" and "set startup delay to 5 seconds", "start on screen keyboard (osk)", "power affected VM" and IMMEDIATELY start doing/repeating "FN -> F8", until you get a boot options screen, then select "safe mode".  Upon reboot, it will skip to Stage 5 and roll back... eventually restarting again and you will now boot up.

    Unfortunately, I had 4 such calls this morning from down customers (not to mention my office too).  I don't know which update caused this issue this time.  From what I can see in the install history, the only 3 common installs were KB4532920 (2019-12 servicing stack update or SSU), KB4533096, KB4530691 (2019-12 monthly roll up).  Clearly it suggest on 0691 that SSU be done first... wonder if there is some conflict between the two.  

    MS needs to get their act together and fix this BS.

    quarta-feira, 11 de dezembro de 2019 19:01
  • @ Microsoft: it's beyond belief what you let loose on a server operating system.

    I had to pinch myself and wondered whether it was some kind of candid camera prank.

    But no, it was true, sad but true.

    As the previous person said, get your act together!

    quarta-feira, 11 de dezembro de 2019 20:05
  • This worked on the two servers I tried it on. Below worked on two that this didn't work on.

    The previous two I did:

    ------------ windows update failed - how to fix - 11Dec2019
    failed update puts windows in to infinte reboot

    On our servers - hard reboot hit F11 - to stop windows from booting and get boot menu - then choose boot normal and quickly hit F8 - which gives you windows repair - choose Repair Windows - troubleshoot -dos prompt - change directory to c:\windows\winSxS and rename anything with pending to pending.old
    This was marked as the solution in Dec 2019 on some sites.

    What above didn't fix -do hard reset, choose F11 - to stop windows boot and get boot menu- then choost boot normal and QUICKLY hit F8 to get windows repair menu. Choose boot into safe mode with command prompt - it will reboot like infinite, do it again a few times and you'll get into safe mode with command prompt. When you get there do shutdown /r /t 0 , this should restart one more time only put you into Windows. It recovered two of my machines.

    quinta-feira, 12 de dezembro de 2019 01:55
  • This killed a client's MSX box running on ESX 6.5 last night. At least I could remote in and do the 'F8 / Safe Mode' trick which seems to have fixed it.

    As it's an Exchange box I will now have to leave it for a week or so to schedule a down time window to dig into it.

    OOI, several other W2012R2 VMs updated fine...

    Patch pls Microsoft!

    quinta-feira, 12 de dezembro de 2019 10:30
  • Today automatically updated 6 servers 2012 (non-R2). Both physical and virtual machines. Installed KB4530691 and KB4530698 . 4 of them stuck at reboot loop. All solved by triggering F8 -> Safe mode. Safe mode reboots itself and finally boots to logon screen. Great work Windows Update Team!!! :(
    • Sugerido como Resposta Stone Foo segunda-feira, 16 de dezembro de 2019 04:28
    quinta-feira, 12 de dezembro de 2019 12:34
  • same ploblem | start on safe mode | restart | work fine!


    • Sugerido como Resposta conker123 sábado, 18 de abril de 2020 16:15
    • Não Sugerido como Resposta conker123 sábado, 18 de abril de 2020 16:15
    quinta-feira, 12 de dezembro de 2019 15:33
  • Same issue here. Windows Server 2012. Boot Loop. -> Safe Mode F8 helps
    quinta-feira, 12 de dezembro de 2019 18:07
  • Same here, Windows 2012, endless loop, just did the Safe mode F8, restarted and again endless loop. What do you mean by just restart? Do you mean entering safe mode, logging and working to uninstall patches or just try to log in?

    This is not working for me...  Microsoft you really F, up this time....


    quinta-feira, 12 de dezembro de 2019 19:42
  • At the end it did work, but
    1. I downloaded Windows 2012 Server Evaluation ISO image.

    2.  Create a DISC with that ISO file.

    3.  Put it in my server CD tray.
    4.  For some magic, I was able to make work F8 (not by using the CD) into de boot menu, where I was able to navigate to restart. 
    5. After several attempts It did log into windows.
    6. Restarted again, blue screen with Error Kernel, after collecting error started again.
    7. I let the PC run normally, it took a while, but now is working.

    I'm using a Workstation with ASUS motherboard X99 WS in case you wondering how on earth I have a CD still...


    • Editado patoduck quinta-feira, 12 de dezembro de 2019 22:14
    quinta-feira, 12 de dezembro de 2019 20:31
  • Just ran into this issue, and the workaround of safemode does work.

    Does anyone know if any official documentation from Microsoft on why this is happening?  I was thinking about opening a case with them to get them to answer why.  Have some critical servers that need to be patched... and it happen on our primary DHCP server... Need some answers Microsoft...

    quinta-feira, 12 de dezembro de 2019 20:48
  • Many thanks to nethead-hmd  Windows Server 2012 here, physical machine. Had a hard time catching the right time to interrupt boot but it finally worked.
    quinta-feira, 12 de dezembro de 2019 21:35
  • We see this issue if the Servicing Stack Update is installed at the same time as a monthly update.  If the SSU installs first, it exits with 0 as expected, the rollup exits with 3010 and everything is good after the reboot.  If it happens the other way around, Rollup first exits with 3010, then SSU exits with 3010 also, and we get the reboot loop.

    We now deploy the SSU separately and then follow with the monthly rollup.

    sexta-feira, 13 de dezembro de 2019 01:16
  • does windows update deploy the patches in ascending way or the other way around? 
    sábado, 14 de dezembro de 2019 03:53
  • I'm chiming in here as I rebooted the 2012 server that runs the accounting software for a customer this morning, to my horror, it ended up in the same reboot loop!!!  I was pondering whether I should restore the vm at some point when I came across this thread.  I rebooted into safe mode once, which flashed the login screen for a split second, didn't even get time to login, then it rebooted again, this time successfully.

    The 3 December 2019 updates I installed were:  KB4530677, KB4530698, KB4530691

    sábado, 14 de dezembro de 2019 14:59
  • 2012 server in ESXI / Backup AD, reboot loop, got into safmode booted, then shut down, then rebooted; this worked. I am shutting down updates till this is fixed.
    sábado, 14 de dezembro de 2019 17:22
  • thanks, the problem has been fixed

    I restarted the system in safe mode and it reverts an update. Now reboot correctly.

    segunda-feira, 16 de dezembro de 2019 09:42
  • We had this issue on eight out of nine 2012 servers in our environment after patching this month.

    Excellent testing from Microsoft this month...

    segunda-feira, 16 de dezembro de 2019 10:37
  • We also had 5 2012 servers in Hyper-V to get stuck in boot loop.  Safe mode fixed it, thanks!  Hardest part was getting F8 key recognized and pressed quickly enough.
    segunda-feira, 16 de dezembro de 2019 17:30
  • Solved two with safe-mode.

    I had one that booting to safe mode did not resolve the issue.  Safe Mode seemed to not correctly load; and it would seemingly just crash and reboot.

    I booted into Recovery Mode, Troubleshoot, Command Prompt.  Tried dism /image:d:\ /scratchdir:d:\scratch /cleanup-image /revertpendingchanges but that resulted in 0x800f082f which in the log seemed to point to file issues.  So then I ran SFC /scannow /OffWinDir:d:\ /OffBootDir:d:\ which stated it found corrupted files, but I did not comprehend the details in the CBS.log.  I tried dism /revertpendingchanges again, but it returned the same result.  So I rebooted, and after rebooting; it automatically failed installing Stage 1 and stated it was reverting the update.

    Technology Administrator Erie County (Career and) Technical School.

    segunda-feira, 16 de dezembro de 2019 18:22
  • Thank you for this.  It resolved my issue.
    quarta-feira, 18 de dezembro de 2019 04:06
  • As this issue continues into december, is there any official response from Microsoft on status? This issue will cripple any auto update windows server 2012 box at a minimum and make patch night a living hell at the worst. 

    We cannot deploy sec updates responsibly until we have assurance the issue has been addressed. 

    quarta-feira, 18 de dezembro de 2019 17:49
  • SHIFT+F8 will get you into Server 2012's Advanced Boot Options Menu

    You can choose Safe Mode etc. from there, a simple option before you get into booting to installation disk and using command prompt.

    I am spreading the word after spending a day attempting to fix a boot loop by booting to an install DVD and trying and failing to use Command Prompt to run bcdedit

    After finally managing to locate the Safe Mode option, the server immediately started up after finishing "configuring updates" at the Windows splash screen.

    Hope this works for anyone whose servers are crippled by Windows updates

    • Sugerido como Resposta JosiasMJr terça-feira, 31 de dezembro de 2019 13:25
    quinta-feira, 19 de dezembro de 2019 11:03
  • Second Me, my system also went in the reboot loop after a update, there was no way out of it, unless i  did what was respectfully posted above, 

    waited for the system to restart, held down F8 and F4 at the same time, advanced boot menu loaded, 

    and started in safe mode, 

    once started, validated and bounced the machine, 

    everything was working fine.

    sexta-feira, 20 de dezembro de 2019 02:57
  • I m glad i ve read this.. tqvm for the solution. so now what s next.. do we hv to wait for another update from microsoft oh what?

    sábado, 21 de dezembro de 2019 07:03
  • Workaround is to interrupt boot and use Safe Mode. It will still reboot at the same stage trying to boot into safe mode but next boot works.
    working with me. thanks 
    segunda-feira, 23 de dezembro de 2019 11:05
  • Thank you! We had this today and repeated F8 & shift+F8 attempts wouldn't work to access. It was only after I used the "reset" function within the VMware client (x2), rather than restart or power off, that brought the pesky 2012 server into troubleshooting mode and I was able to access the safe mode option. Booted into safe mode, then restarted the server once, logged in as normal and now everythings OK. Thanks for posting the reset x2 trick
    • Editado MS-it2020 segunda-feira, 30 de dezembro de 2019 21:53
    segunda-feira, 30 de dezembro de 2019 21:49
  • SHIFT-F8 was the best and easiest solution so far. Thanks a lot for that, DPK jobsbody.  I needed no more than 5 minutes to solve.  Worked fine for my server. (HP Proliant ML350P gen8).

    How I did it IN DETAILS:

    In my case, the server was rebooting in loop trying to install the november 2019 update stuck on phase 1 of 4.  I needed to enter safe mode to stop the update installation.

    I turned power on and kept SHIFT pressed while pressing F8 repeatedly.
    The server went all its initial configurations and entered a RAID / DISK menu. As this menu was not the desired one, I simply pressed ESC to exit and continued pressing SHIFT-F8 repeatedly.

    After that Windows finally entered its Boot Options Menu as described above by DPK jobsbody, and I could choose  "Safe Mode without Network". The screen remained black for some time and the computer restartet. Finally a message appeared now saying the update was on phase 4 of 4 and then another message saying something like  "There was a failure attempting to install the updates" and that "it was reverting the changes".   (Thank God) !!  :)

    On the next boot, Server 2012 restartet normally.  

    terça-feira, 31 de dezembro de 2019 13:14
  • Found the SSU install order to be the true cause in our environment as well.  Impacted Server 2012 only.  If the SSU (KB4532920) installs after the CU it enters a boot loop upon restart.  

    Why MS doesn't assign a 'weighted' install priority to SSU's so Software Center or Windows Update will pull them first is mind boggling.  

    segunda-feira, 6 de janeiro de 2020 18:20
  • We had this same issue. Server 2012 (no R2), Domain Controller, stuck in a reboot loop after an udpate. Rebooting into Safe Mode resolved this as well. Here's the steps I used:

    Booted into a Gandolf's WinPE disk. (You can do the same using a 2012 ISO & command line)
    Navigated to C:\Windows\servicing
    Renamed TrustedInstaller.exe to _TrustedInstaller.exe


    Was able to log into Server 2012 now, but have a lot of issues because TrustedInstaller is not running.

    Run the command
    bcdedit /set {bootmgr} displaybootmenu yes

    Navigated to C:\Windows\servicing and named _TrustedInstaller.exe back to TrustedInstaller.exe


    Now you see the boot option Server 2012, but that is the only option. Hit F8 one more time and additional options are displayed.

    Choose Safe Mode (I originally chose safe mode with networking and this failed).

    Login via Safe Mode. (If it auto reboots, try it one more time. It should work the second time.)

    Login and wait 30 seconds to a minute.


    Choose the Server 2012 option and log into server normally.

    Run command to turn off boot options
    bcdedit /set {bootmgr} displaybootmenu no

    Reboot one more time for testing. Should be all set now.

    Thank you everyone for your notes and I hope the above notes helps someone.

    • Editado JoshSRitch quinta-feira, 9 de janeiro de 2020 14:48
    quarta-feira, 8 de janeiro de 2020 22:11