none
windows 10 não está acessando servidor samba RRS feed

  • Pergunta

  • Tenho 3 servidores samba na minha rede para compartilhamento de pastas entre as estações, tenho duas máquinas com windows 10 instalado com uma máquina consigo acessar normalmente os três servidores porem com a outra só consigo acessar 1 servidor.

    A mensagem que aparece é "o windows não pode acessar o dispositivo ou caminho especificado" outra coisa curiosa é que antigamente eu conseguia acessar normalmente os três servidores com a mesma maquina que agora não consigo. Não fiz nenhuma alteração acredito a unica coisa de diferente foi a atualização do sistema windows 10.

    Alguém pode me ajudar a resolver este problema?

    sexta-feira, 10 de agosto de 2018 15:49

Respostas

  • Obrigado a todos que responderam, eu consegui resolver o meu problema.

    Para resolver eu baixei o windows 10 pelo site da microsoft e formatei com a opção que apaga arquivos, configurações e aplicativos, como se fosse formatar do zero. Depois de formatar fiz o teste e acessou normalmente os três servidores.

    Eu acredito que o windows armazena de alguma forma dados de acesso feito em servidor de protocolo smb e quando formatei apagou esse registro e consegui acessar novamente. gostaria de saber se tem como apagar os dados de acesso sem precisar formatar.

    • Marcado como Resposta IgorFKModerator quinta-feira, 16 de agosto de 2018 17:14
    quinta-feira, 16 de agosto de 2018 16:01

Todas as Respostas

  • O seu servidor Samba é isso? = https://pt.wikipedia.org/wiki/Samba_(software)

    Tem que olhar como está feito a configuração da placa e rede (TCP/IP versão 4) dos servidores e dos computadores, sendo que o servidor não pode estar com o endereço IP como automático.  Como tem vários servidores na rede, na configuração TCP/IP versão 4, no item avançado, no item WINS tem que cadastrar ali o endereço IP de todos os servidores, todos os switch, todos os roteadores. Gateway = IP do roteador.


    Ana Mercedes Gauna | IT Consultant | Microsoft Partner: 5126593 | Skype: amgauna@hotmail.com | Site: http://www.anagauna.eti.br | http://www.amgauna.com.br | Blog: http://anagauna.wordpress.com | If you have been able to help, please check the answer as correct.

    • Sugerido como Resposta IgorFKModerator segunda-feira, 13 de agosto de 2018 12:33
    sexta-feira, 10 de agosto de 2018 18:08
  • Obrigado por responder Ana,

    configurei o servidor wins porém não surtiu efeito, os ips dos servidores samba estão estáticos e sim samba que tenho é aquele mencionado no link da wikipedia.

    Uma coisa q percebi é que o código do erro que aparece é 0x80004005 e tentei formatar o windows preservando os arquivos do usuário e utilizando o cd do windows 10 porem o erro continuou o mesmo eu estava pensando em formatar pela opção que limpa tudo do windows pois parece que as configurações de acessos que ficaram salvas mesmo após formatar estão causando o problema. O único servidor que consigo acessar eu nunca tinha tentado acessar nesta máquina antes do problema acontecer e por tanto nao tinha registro de acesso armazenado.


    segunda-feira, 13 de agosto de 2018 12:46
  • Qual e sua compilação, por a caso seria a 1803?

    Caso seja bem vindo bem vindo ao grupo!

    segunda-feira, 13 de agosto de 2018 14:43
  • O Microsoft Windows Server, versão 2008, versão 2012, versão 2016, é 64 bits (x64).  Em Painel de Controle, item Sistemas, verifica e confirma se a sua versão instalada é de 64 bits (x64).  Em Painel de Controle, item Programas e Recursos, caso tenha drivers 32 bits (x86) instalados, tem que fazer o download da versão 64 bits (x64) desses drivers, e depois tem que desinstalar os drivers 32 bits (x86), e depois reinicia o servidor.  Idem quanto ao Microsoft Windows 10 (versão 64 bits).

    Quando existe drivers 32 bits (x86) e aplicativos 32 bits (x86) instalados em sistema operacional de 64 bits, costuma ocorrer problemas depois, e problemas no download com Windows Update. 

    O servidor e os computadores que tem pastas compartilhadas, não podem ter endereço IP automático, o endereço IP tem que ser fixo.  Isso é configurado na placa de rede, em TCP-IP versão 4, o gateway é o roteador, o DNS primário é endereço IP do teu servidor.  Caso tenha vários roteadores, vários switch, vários servidores, no item avançado em Wins se coloca o endereço IP dessas máquinas.


    Ana Mercedes Gauna | IT Consultant | Microsoft Partner: 5126593 | Skype: amgauna@hotmail.com | Site: http://www.anagauna.eti.br | http://www.amgauna.com.br | Blog: http://anagauna.wordpress.com | If you have been able to help, please check the answer as correct.

    • Sugerido como Resposta IgorFKModerator segunda-feira, 13 de agosto de 2018 16:34
    segunda-feira, 13 de agosto de 2018 15:02
  • obrigado pela resposta Tiago,

    o estranho é que estava funcionando antes e também tem um servidor que acessa então o problema deve ter solução.

    segunda-feira, 13 de agosto de 2018 19:33
  • Cara a parada é o seguinte, eu já tenho um post a 40 dias e ninguém da uma solução definitiva sobre o assunto.

    Percebi que para essa compilação (1803) as maquinas não resolve domínio simples exemplo:

    domínio "empresa"

    Só resolver como com domínio compostos exemplo:

    domínio "empresa.net"

    Case volte para versão (1709) ou faça uma instalação com midia antiga vai resolver, após instalação só não retira do domínio caso contrario já era!!

    Agora imagine o problema, que após uma atualização, você vai ter que provisionar o seu domínio novamente...

    Acho isso um absurdo!!

    estou aguardando um posicionamento da MS.

    https://social.technet.microsoft.com/Forums/pt-BR/3624c8da-72d5-4c8c-9e42-c9990ca89c0f/problema-para-ingressar-estao-no-do-dominio-com-windows-10-pro-1803?forum=win10itprosetupPT#3624c8da-72d5-4c8c-9e42-c9990ca89c0f

    https://social.technet.microsoft.com/Forums/pt-BR/6aaf432a-7d09-4e2e-af28-611051f7e1d6/problema-para-ingressar-windows-10-pro-1803-no-domnio-windows-server-2012-r2?forum=win10itprogeneralPT

    https://social.technet.microsoft.com/Forums/windows/en-US/4c2a029b-327a-4ad7-a2ce-7bd4fcc25226/windows-10-after-update-1803-odbc-sql-server-connect-problem?forum=win10itprogeneral

    segunda-feira, 13 de agosto de 2018 21:28
  • Tiago A Silva,

    Desde o Microsoft Windows Server 2003, quando o usuário quer usar um domínio, o domínio tem que ser um domínio próprio internet que existe, por exemplo: suaempresa.com.br  ou um domínio local:  computador.local

    Em Painel de Controle, no item Sistemas,  no item "domínio, nome do computador, grupo de trabalho" clica no lado direito em [alterar as configurações], no item "renomear este computador" clica em [alterar], no item alterar a associação de grupo de trabalho, a direita clica em [Mais...]  e digita o sufixo DNS primário do seu computador e marca a caixa [x] "Alterar DNS sufixo primário quando a participação do domínio for alterada", de depois cllica em [Ok].

    http://underpop.online.fr/w/windows/sysdmw/sysdm_ident_change_domain_name.htm


    Ana Mercedes Gauna | IT Consultant | Microsoft Partner: 5126593 | Skype: amgauna@hotmail.com | Site: http://www.anagauna.eti.br | http://www.amgauna.com.br | Blog: http://anagauna.wordpress.com | If you have been able to help, please check the answer as correct.

    terça-feira, 14 de agosto de 2018 00:50
  • Cara Ana Gauna,

    Como podemos observar neste tópico, trata-se de um Linux, ou seja, estamos falando de um servidor Samba ok.

    Apesar que o Samba funciona muito parecido com Windows Server, mesmo assim ainda tem suas particularidades.  

    No meu caso tenho dois clientes como o mesmo problema que o colega, um cliente como Samba 4 e outro cliente com 2008 server. 

    Nos links que eu postei, outras pessoas também estão com o mesmo problema, então não é um problema isolado, de fato é um problema de atualização da compilação (1803), para certificar que esse caso está relacionado a essa compilação, tive o cuidado de executar um laboratório com maquinas virtuais, para garantir o teste a cada passo fui realizando um ponde de goback quando voltei para versão anterior (1709) o problema foi sanado.


    https://social.technet.microsoft.com/Forums/en-US/59183715-0c04-44f7-b5ea-bb37da4125a5/unable-to-join-domain-with-new-windows-10-computers-build-1803?forum=win10itpronetworking



    terça-feira, 14 de agosto de 2018 01:25
  • Servidor Samba eu nunca usei.  Servidor Linux eu já usei anos atrás.  Notebook com Linux instalado nele, eu já usei anos atrás e exclui a partição do Linux e criei de novo a partição, formatei e instalei o Windows 7 no notebook.  Teve uma vez que eu comprei dois computadores desktop com o Linux instalado neles, eu também exclui a partição do Linux, recriei a partição, formatei e instalei o Windows 7 neles.  Eu nunca gostei do Linux, eu prefiro o Windows...   

    Mas no Linux eu já prestei atenção em uma coisa.  Existe sistema operacional Linux de 32 bits (x86), e também existe sistema operacional Linux de 64 bits (x64).  Tem que prestar atenção nisso no Linux, se ele sendo a versão de 64 bits e deixa instalar nele drivers de 32 bits (x86).  Pode ocorrer também de algo não funcionar direito.  Por exemplo o Java, ele existe na versão 32 bits(x86) e na versão 64 bits(x64) para o Linux:

    http://www.oracle.com/technetwork/pt/java/javase/downloads/jre8-downloads-2133155.html

    Pode ser que em sistema operacional Linux de 64 bits, com drives 32 bits (x86) instalados nele, algo não esteja funcionando direito, igual como acontece no Microsoft Windows Server que é versão 64 bits.  No Microsoft Windows Server (que é versão 64 bits) quando existe drivers 32 bits (x86) ou aplicativos 32 bits (x86) instalados nele, costuma ocorrer alguns problemas depois, e um desses problemas ocorre nos downloads automáticos do Windows Update. Para corrigir o problema, tem que em Painel de Controle, item Programas e Recursos,  fazer a desinstalação de todos os drivers de 32 bits (x86), fazer o download e a instalação da versão 64 bits (x64) desses drivers, e por último reiniciar o servidor. Idem o mesmo em Windows 7 (versão 64 bits, idem em Windows 8.1 (versão 64 bits) e idem em windows 10 (versão 64 bits).

    Boa noite


    Ana Mercedes Gauna | IT Consultant | Microsoft Partner: 5126593 | Skype: amgauna@hotmail.com | Site: http://www.anagauna.eti.br | http://www.amgauna.com.br | Blog: http://anagauna.wordpress.com | If you have been able to help, please check the answer as correct.


    • Editado Ana Gauna terça-feira, 14 de agosto de 2018 02:26
    terça-feira, 14 de agosto de 2018 02:24
  • Notei uma coisa, no Linux versão 32 bits, os drivers dele são referidos como Linux (386).

    https://docs.tsuru.io/0.2/download.html

    Pelo jeito é igual, tanto no Linux como no Windows, tem que se prestar atenção se o sistema operacional Windows / Linux , é versão 64 bits (x64) ou se ele é versão 32 bits (x86) (386) antes de instalar os drivers.  Não se deve instalar drivers de 32 bits, dentro de sistema operacional de 64 bits. Isso ocorre erros depois.


    Ana Mercedes Gauna | IT Consultant | Microsoft Partner: 5126593 | Skype: amgauna@hotmail.com | Site: http://www.anagauna.eti.br | http://www.amgauna.com.br | Blog: http://anagauna.wordpress.com | If you have been able to help, please check the answer as correct.

    terça-feira, 14 de agosto de 2018 03:04
  • Oi Ana,

    Pode fica tranquila esta tudo rodando com 64 bits, fica tranquila que o problema não está relacionado ao Linux mais sim ao Windows 10 (1803) tanto na versão 32 como a 64 bits

    Depois executa um lab para teste?

    Grato.

    terça-feira, 14 de agosto de 2018 11:11
  • Eu tenho um outro computador com o Windows 10 que foi atualizado do Windows 7 (versão 64 bits), em 2016, foi depois reinstalado o Windows 10 nele em 2017, e ele ainda está funcionando perfeito.  Mas de ontem (13/08/2018) para hoje (14/08/2018), nele, o Windows 10 recebeu uma atualização nova. Fui agora olhar qual é  a compilação do Windows 10 nele e vi que é a 1803 (ele veio automático).

    Para ver essa informação da compilação do Windows 10, tem que clicar no lado esquerdo no icone "Configuração", e depois clicar no ícone "Sobre".  Eu verificar e analisar.  A primeira vista, ele parece estar funcionando perfeitamente. Ali mostra se a versão do Windows 10, que está instalado, é um sistema operacional de 64 bits (x64) ou 32 bits (x86). 

    Eu tenho um outro computador, que está parado, sem usar, e disponível só para testar aplicativos... Vou testar essa versão atualizando um Windows 7 (versão 32 bits).

    Vou fazer o download em arquivo ISO e testar...  Eu achei esse link abaixo de download...

    Windows 10 (Abril 2018) (versão 1803) Download 

    https://www.baboo.com.br/windows-10/download-do-windows-10-april-2018-update/

    https://www.baboo.com.br/windows-10/novidades-no-windows-10-april-2018-update/

     


    Ana Mercedes Gauna | IT Consultant | Microsoft Partner: 5126593 | Skype: amgauna@hotmail.com | Site: http://www.anagauna.eti.br | http://www.amgauna.com.br | Blog: http://anagauna.wordpress.com | If you have been able to help, please check the answer as correct.





    • Editado Ana Gauna terça-feira, 14 de agosto de 2018 16:08
    terça-feira, 14 de agosto de 2018 15:59
  • Eu vou fazer o download dessa versão Windows 10 Enterprise (para testar)

    Windows 10 Enterprise Downloadhttps://www.microsoft.com/pt-br/evalcenter/evaluate-windows-10-enterprise

     


    Ana Mercedes Gauna | IT Consultant | Microsoft Partner: 5126593 | Skype: amgauna@hotmail.com | Site: http://www.anagauna.eti.br | http://www.amgauna.com.br | Blog: http://anagauna.wordpress.com | If you have been able to help, please check the answer as correct.

    terça-feira, 14 de agosto de 2018 16:48
  • boa tarde Tiago, obrigado pela resposta!

    Aqui eu tenho uma maquina com windows 10 compilação 1803, que está funcionando normalmente e acessando os três servidores samba tranquilamente, porém na outra máquina que também é windows 10 o acesso só eh possível em um servidor samba, nos outros dois servidores aparece uma mensagem "o windows não pode acessar o dispositivo ou caminho especificado". Para acessar o servidor samba eu segui este as instruções deste link http://tremarinti.blogspot.com/2018/01/windows-10-nao-acessa-pastas-no.html

    Só não entendi porque não consigo acessar 2 servidores sendo que a configuração dos três servidores são iguais e o domínio são respectivamente \\fileserver, \\server2, \\samba. O \\samba acessa normalmente.

    terça-feira, 14 de agosto de 2018 17:03
  • Aqui comigo, eu tenho computadores com Windows 7 (versão 32 bits e versão 64 bits instalado), e eu tenho computadores com Windows 10 (versão 64 bits instalado).

    No computador com Windows 10, clica no icone da janela, depois clica no icone de Configuração, depois clica em Sistema, depois clica em Sobre, para poder saber se o seu Windows 10 instalado é versão de 64 bits (x64) ou versão de 32 bits (x86).

    Depois clica no icone Configuração, clica em Ethernet, clica em alterar opções de adaptador, isso irá mostrar as conexões de rede. Clica em uma das conexões de rede (que está visualizando ali) com o botão direito do mouse, e escolhe propriedades, para poder alterar as configurações da placa de rede em TCP/IP versão 4. 

    No item Conexões de rede, no item Propriedades Ethernet, clica no item Rede, clica no item Avançado, clica em DNS, ali tem como cadastrar todos os endereços DNS que estão sendo utilizados na sua rede, e tem como acrescentar os sufixos DNS primários específicos para cada conexão de rede.

    Clica em opções avançadas (lado direito da tela de video) e marque a caixa (*) para ativar a descoberta da rede, ativar a configuração automática de dispositivos conectados a rede, e no item perfil pessoal e privado, clica [x) em compartilhamento de arquivos e impressoras.

    No item Todas as Redes, no item compartilhamento de pasta pública, clica na caixa (*) ativar compartilhamento para que qualquer pessoa com acesso a rede possa ler e gravar arquivos em pastas públicas.


    Ana Mercedes Gauna | IT Consultant | Microsoft Partner: 5126593 | Skype: amgauna@hotmail.com | Site: http://www.anagauna.eti.br | http://www.amgauna.com.br | Blog: http://anagauna.wordpress.com | If you have been able to help, please check the answer as correct.

    • Sugerido como Resposta IgorFKModerator terça-feira, 14 de agosto de 2018 19:04
    terça-feira, 14 de agosto de 2018 17:47
  • Obrigado a todos que responderam, eu consegui resolver o meu problema.

    Para resolver eu baixei o windows 10 pelo site da microsoft e formatei com a opção que apaga arquivos, configurações e aplicativos, como se fosse formatar do zero. Depois de formatar fiz o teste e acessou normalmente os três servidores.

    Eu acredito que o windows armazena de alguma forma dados de acesso feito em servidor de protocolo smb e quando formatei apagou esse registro e consegui acessar novamente. gostaria de saber se tem como apagar os dados de acesso sem precisar formatar.

    • Marcado como Resposta IgorFKModerator quinta-feira, 16 de agosto de 2018 17:14
    quinta-feira, 16 de agosto de 2018 16:01
  • Boa Noite Américo,

    Quando baixou o Windows e depois que realizou a instalação, ele veio com a compilação 1803?

    Grato.

    quinta-feira, 16 de agosto de 2018 22:38
  • Bom dia Tiago,

    sim o que está instalado é 1803. O servidor samba que tenho é bem simples só uso para compartilhar pastas e fazer teste nenhum é pdc então não sei se em pdc o windows 10 1803 apresenta problemas.

    segunda-feira, 20 de agosto de 2018 11:11
  • Windows 10 até a compilação 1709 entrava como uma luva no Samba 4.7.1. Agora essa 1803 está dando um trabalhão, forçando muita gente a trabalhar como workgroup e não domain.
    quarta-feira, 19 de setembro de 2018 18:24
  • estava com esse problema ontem, baixei a versão enterprise e ela acessa o servidor windows normalmente porem os samba como oracle linux e o freenas informa erro como se nao existisse 

    SOLUÇÃO

    IR ATÉ ATIVAR RECURSOS DO WINDOWS >> MARCAR A OPÇÃO COMPARTILHAMENTO SMB 

    TUDO QUE FOR RELACIONADO AO COMPARTILHAMENTO SMB ATIVE PQ TEM VERSÕES ATÉ DE WINDOWS Q UTILIZAM ESSES PROTOCOLOS

    após isso o acesso fluiu mais que faca na manteiga

    terça-feira, 12 de março de 2019 15:34
  • Tive o mesmo problema com a versão 1809. Após formatar a máquina apagando todos os arquivos consigo acesso a 3 servidores samba normalmente mas 1 servidor parou de funcionar o acesso. Note que já ativei  opção do Windows para permitir acesso a compartilhamentos com SMB 1.

    Já pesquise na net mas ainda sem uma luz.

    quinta-feira, 11 de julho de 2019 15:26
  • Tive o mesmo problema com a versão 1809. Após formatar a máquina apagando todos os arquivos consigo acesso a 3 servidores samba normalmente mas 1 servidor parou de funcionar o acesso. Note que já ativei  opção do Windows para permitir acesso a compartilhamentos com SMB 1 e reiniciei a maquina mas mesmo assim continua não funcionando.

    Já fiz procedimentos no registro conforme orientação da microsoft abaixo.

    Para habilitar ou desabilitar o SMBv1 no servidor SMB, configure a seguinte chave do Registro:

    Subchave do Registro: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters
    Entrada do Registro: SMB1
    REG_DWORD: 0 = Desabilitado
    REG_DWORD: 1 = Habilitado
    Padrão: 1 = Habilitado (Nenhuma chave do Registro é criada)

    Para habilitar ou desabilitar o SMBv2 no servidor SMB, configure a seguinte chave do Registro:

    Subchave do Registro:HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters
    Entrada do Registro: SMB2
    REG_DWORD: 0 = Desabilitado
    REG_DWORD: 1 = Habilitado
    Padrão: 1 = Habilitado (Nenhuma chave do Registro é criada)

    Deve ser algum outro detalhe.

    Já pesquise na net mas ainda sem uma luz.


    quinta-feira, 11 de julho de 2019 15:28