Windows 7 - "Cannot complete setup" of Windows XP Mode


  • I am running Win 7 OEM 64 bit PRO on new PC:

    AMD FX-8120, Gigabyte GA-990FXA-UD3 MOBO, latest BIOS

    The setup gets to 99% then fails with the above message. So far I have tried:

    Ensuring Virtualisation is on in BIOS

    There are no bootable disks in the drive

    I am running as admin with my own account logon name

    I have run SFC - no conflicts

    Yes I have downloaded the correct XP mode file

    I have re-installed Win 7 and tried to run before installing any drivers or apps  - same problem.

    Now what? I tried vmware but the standalone converter gave me an error message saying it was not configured properly.  I suspect either a policy problem with Win 7 or a MOBO bios incompatibility. Anyone got any ideas?

    18 decembrie 2011 00:37


Toate mesajele

  • Hi,


    It seems this is an incompatible issue between Windows XP Mode and AMD Bulldozer-based processors, I will report this issue to our related product team. If there is any update, I would keep following in this post.

    Alex Zhao

    TechNet Community Support

    19 decembrie 2011 08:57
  • Thanks Alex


    20 decembrie 2011 05:55
  • @robonline
    I believe I'm seeing this same issue as well, I've got a windows 7 system that was running with an Athlon II 250 on which Windows XP mode installed and worked perfectly.
    However when I upgraded the CPU to an AMD FX-8150 (in an otherwise unchanged system) Windows XP mode no longer starts properly, it seems to hang before the Virtual PC starts to boot the OS (so possibly either during BIOS POST, or right at the transition.
    I've discovered that it doesn't ALWAYS fail, and if power of the Virtual PC and Start it again a few times in quick succession it seems to then get past what ever point causes the problem and then boots the XP Virtual PC and it works normally until it's next turned off.
    So if you need XP mode (as I do for some work applications) the (crazy) work around might be to install XP mode with a none bulldozer CPU (if the try, try, try again method doesn't get the installer to work) you can probably get it to start once you change back to your bulldozer CPU by simply trying to start the installed OS a few times in short succession.
    Many thanks for looking into this!
    20 decembrie 2011 12:17
  • Was there a BIOS upgrade available for your mobo when you upgraded the processor?
    Colin Barnhorst Windows 7 Ultimate x64 on DIY with 6GB ram.
    20 decembrie 2011 14:13
  • Yeah there was which I applied before installing the new chip, I've even checked a few times since then to make sure that there's not been a subsequent fix and there's been nothing yet.



    For reference the motherboard is a ASUS Crosshair V Formula running BIOS 0813 which is the latest ASUS Update offers me

    Edit 2:

    I had a look on the ASUS website directly, and there were two newer version, so I've updated to BIOS 1003 but the problem remains unchanged.

    20 decembrie 2011 15:56
  • Thanks d-A

    Looks strongly like a bulldozer problem. I was going bananas looking for the usual software gremlins. It'll be interesting to see what the product team gurus come up with.

    21 decembrie 2011 03:11
  • Hi Alex

    A post on this thread suugests nstalling KB2519949.  The article on the KB appears to have a circular reference to itself:

    "For more information about how to integrate the hotfix package on to the media that is used to install the operating system, click the following article number to view the article in the Microsoft Knowledge Base:

    2519949  You cannot install Windows XP Mode on a Windows 7-based computer that has an AMD Bulldozer-based multicore processor installed"
    It also appears to be only relevant to Vista or Win Server 2008.  Would this work on Win 7 64?
    30 decembrie 2011 00:23
  • Hi robonline,


    I have consulted some people about this hotfix before, this has been pulled temporarily. It isn't ready yet.

    Alex Zhao

    TechNet Community Support

    30 decembrie 2011 01:01
  • I have the same motherboard (Asus Crosshair V), same processor (FX 8150), same BIOS (1003), and, last but not least, the SAME PROBLEM. I have also eliminated every known suspect (no boot disk in DVD drive, VM not disabled in BIOS, no firewall, etc.).
    3 ianuarie 2012 00:11
  • Based on the other posts in this thread you probably should contact Microsoft Support.

    Colin Barnhorst Windows 7 Ultimate x64 on DIY with 6GB ram.
    3 ianuarie 2012 00:16
  • Based on the other posts in this thread you probably should contact Microsoft Support.

    Colin Barnhorst Windows 7 Ultimate x64 on DIY with 6GB ram.

    I wish I knew how to do that ... without it costing me a fortune.
    3 ianuarie 2012 01:35
  • I think d-ArkAngel's swapping of CPU chips to get XP Mode to work is a clincher. The problem is, you can't get to talk to an accredited Microsoft representative to get an official answer.  Alex (see above) mentioned that he would talk to the product team, but so far MS has not officially commented. This needs to chamge as a great many people who are buying XP Pro just to get XP Mode are going to be more than a little disappointed.
    3 ianuarie 2012 04:49
  • @robonline,

    "This needs to chamge as a great many people who are buying XP Pro just to get XP Mode are going to be more than a little disappointed."

    No one has to purchase XP to use XP Mode.  XP Mode IS XP Pro SP3 already installed in a vm and free to Windows 7 Professional, Enterprise, and Ultimate users.

    If someone buys XP in order to create a new vm in Windows Virtual PC then he might be able to use VMWare Player.  I would check the VMWare forums to make sure that the cpu is not a problem for VMWare Player also. 

    Colin Barnhorst Windows 7 Ultimate x64 on DIY with 6GB ram.
    3 ianuarie 2012 05:01
  • Typo  I meant Win 7 PRO of course! By the way, VMware doesn't appear to work either, but that may be for other reasons.
    3 ianuarie 2012 07:27
  • For what its worth, I have the same problem.  AMD FX6100, Asus M5A99X EVO Mobo w/bios 0705, and Win 7 Pro 64 oem sp1.
    4 ianuarie 2012 04:31
  • I also have been fighting this "Cannot complet setup- try again" issue for two days.  ASUS M5A88-M with AMD3+ FX4100.  Virtualization enabled in BIOS, Microsoft® Hardware-Assisted Virtualization Detection Tool says good to go.  I have been searching for logs all over the PC to see what is stopping the setup from completing.  SO FAR UNSUCESSFUL.
    4 ianuarie 2012 05:40
  • what happens if you disable HAV in the BIOS?  Does the setup complete?
    4 ianuarie 2012 06:18
  • @p23185

    And that touches on another issue. I believe error messages ought to display a status code indicating why and where there was a problem. "Oh, it went wrong" is not good enough. At worst, the message should point to an error log. Not good software engineering...

    4 ianuarie 2012 06:37
  • ...and for what its worth, I am having the exact same problem.  Win 7 Ultimate, FX6100, HP motherboard.  Is there a way to get notified when there is a fix?
    6 ianuarie 2012 02:13
  • I have the same problem..

    Operating System: Windows 7 Ultimate 64-bit (6.1, Build 7600) (7600.win7_rtm.090713-1255)
    Language: English (Regional Setting: English)
    BIOS: BIOS Date: 10/20/10 09:47:36 Ver: 08.00.10
    Processor: AMD FX(tm)-8120 Eight-Core Processor (8 CPUs), ~3.8GHz
    Memory: 8192MB RAM
    Windows Dir: C:\Windows
    DirectX Version: DirectX 11

    I recieve the same generic error message as robonline, It seems to be an issue with the new FX processors..



    • Editat de Celkath 7 ianuarie 2012 19:09
    7 ianuarie 2012 19:09
  •      Your problem may be in your firewall settings, or IE security and privacy settings. I have only had one problem using virtualXP when I disabled somethimg that it needed to communicate with the host. Uninstalled it-reinstalled and left allow exceptions alone in firewall!
    8 ianuarie 2012 01:01
  • It's nothing to do with firewalls. Read my previous post. I re-installed Win 7 with no drivers, no apps, no FW & it didn't work. Read d-ArkAngel on swapping processors.  Also read Alex's response to my earlier mail, MS are aware there's a problem.
    8 ianuarie 2012 01:39
  • It's nothing to do with firewalls. Read my previous post. I re-installed Win 7 with no drivers, no apps, no FW & it didn't work. Read d-ArkAngel on swapping processors.  Also read Alex's response to my earlier mail, MS are aware there's a problem.

    Same here.  I did the same thing (in general)... same results.

    I also ran into similar trouble with (among other things) it failing to do a full-format on a USB 3.0 HardDrive (Verbatim/Samsung 3TB) I use for backups.  (Quick format was OK and a CHKDSK came out 100% OK.)

    Plugged it into my old system and it formats with no problem on the old one.

    ---   old has  ASUS Crosshair  IV  Formula  with  Phenom II X6 1100T (6 core, Pre-Bulldozer)

    ---  new has  ASUS Crosshair  V  Formula  with  FX 8150 (8 core 3.6GHz 'Bulldozer')

    Symptoms similar to the XP Mode problem ... it just comes back and says it cant do it ... without any reason why.

    In summary, the Bulldozers apparently have problems with:

    --  XP Mode (VM within Win7)

    --  Full-Format of USB 3.0 Hard-Drives.

    --  Who knows what else will crawl out of the Windwork

    Also:  I've run that test and confirmed that my BIOS, etc is setup to allow VM.




    9 ianuarie 2012 08:31
  • This should fix things:

    Sorry for the delay.


    19 ianuarie 2012 07:18
  • This hotfix fixed the problem for me, 5 power offs, 5 successful power ups.
    19 ianuarie 2012 14:46
  • Fixed for me too!

    Thanks for the help guys

    20 ianuarie 2012 09:14
  • Thanks.  XP mode is working now.
    23 ianuarie 2012 03:00
  • I had the same problem with the same specs as JTDECK even with the BIOS updated... AMD FX6100, Asus M5A99X EVO Mobo w/bios 0901 and Win 7 Pro 64 oem sp1 and the hotfix mentioned below worked! YOU HAVE TO REQUEST IT AND COPY THE LINK IN YOUR E-MAIL AND PASTE IT IN YOUR BROWSER. The hotfix file started to automatically download the 472kb zip file, 348kb unzipped. We needed xp mode to run Autocad 2000 and it now does thanks to this chain.
    • Propus ca răspuns de drobster 2 februarie 2012 21:24
    2 februarie 2012 21:24
  • I have an FX8350, which evidently has a "Piledriver" core? Does this fix work for that?  My daughter is wanting to play Sim Safari and everyone seems to think XP Mode might make it work.

    I keep getting the same error as listed in this thread.

    I have WIn 7 pro 64bit
    An ASUS Sabertooth 990FX motherboard

    22 martie 2013 05:07
  • Dear all. I am working with a Lenovo E535 With AMD A8 4500 APU with Windows 7 Pro.

    After hundred of times getting the message that windows cannot finish the setup at 99% of instalation. I get one way to DO IT.

    Looks like the problem is with AMD Virtualization Hardware.

    So just disable the hardware Virtualization on your BIOS in your Phisical Machine.

    Later even when windows says you shuold eneable the hardware virtualization becouse the procesor supports the function just downlaoad and install the hotfix to make virtualization by software.

    After that istall the actualization for XP mode. KB..... and later install Windows XP Mode.

    I can note only a small problem USB 3.0 is not working at all. USB 2.0 is working perfectly and all the other fuction of network and remote units in Phisical machine are working normally.

    Y hope it works for everybody.

    I am engineer in Automation, I bought this computer becouse last one fail. So is very hard after get new computer and pay for Windows Pro have this problem with Virtual Machine.

    Even after installed if I enable the Hardware Virtualization the Virtual PC can't work. I dont know if there is already a fix for this problem.

    At least now I can work. Becouse the software for PLC programing is only running under XP.

    Best Regards to Everybody.


    22 martie 2013 12:00
  • It worked - thanks Lalithra Fernando [MSFT] 
    5 iulie 2013 18:22
  • Only to say that the fix works well with AMD A-Series APU, too.

    Tested succesfully on an A10-7850K.

    10 octombrie 2014 10:54
  • Hello,

    Same problem now with AMD A10-7870K...hotfix doesn't fix this one.... Please help. Thanks

    5 august 2015 02:27

  •    Hi fastleo63, Make sure you run the hot fix 64 bit version for Win7 64 or the 32 for the 32.  The 64 is hidden -- you have to click to see it.  See below.

       Yes, confirm, it worked on AMD A10-7860K on a Gigabyte F2A88XM-D3HP motherboard. It installed with full integration of host drives and USB.  Runs in full screen. VM relative speed same as ICore 7.

    430158_intl_x64_zip.exe from

    make sure to pickup the 64 (for Win 7 64) -- it is hidden - click  
    "Show hotfixes for the platform and language of your browser"
    to see it.

    • Editat de FMik 13 august 2016 00:54
    13 august 2016 00:46