none
Hyper-V Error 15350 - VT-x enabled - RRS feed

  • Întrebare

  • Hyper-V is failing to launch any VM's.

    When I try to run VMs (newly created, both generation 1 and 2) I receive the error:
    "Hyper-V Manager
    '<vm name>' failed to start.
    Virtual machine '<vm name>' could not be started because the hypervisor is not running.

    Error 15350 appears in event viewer every time the Hyper-V service is (attempted) to be started with the message "The virtualization infrastructure driver (VID) is not running." Other than the events generated when I try to start the VMs this is the only real clue I could find.

    This error appears in event viewer both after reboot and after trying to restart the service (from Hyper-V manager action tab stop and then start service).

    I have confirmed in my BIOS (Motherboard is P8P67 Pro running BIOS version 1502) that VT-x is enabled, and also confirmed this using Intel processor identification utility.

    EDIT: Forgot to mention, CPU is an i5 2500k. OS is Windows 8.1 Pro.


    • Editat de ToddMurphy joi, 2 octombrie 2014 10:22
    joi, 2 octombrie 2014 10:21

Răspunsuri

  • Issue now resolved, the BIOS update reset the Virtualisation setting to disabled. Also the option moved slightly and changed from VT-x to Intel Virtualisation Technology.

    In summary: The issue was with the P8P67 Pro Version 1502 BIOS. After doing an upgrade to the latest BIOS, then re-enabling Virtualisation in the BIOS then doing a cold boot the issue was resolved.

    • Marcat ca răspuns de ToddMurphy sâmbătă, 4 octombrie 2014 11:53
    sâmbătă, 4 octombrie 2014 11:53

Toate mesajele

  • VT-X needs to be enabled.  Data Execution Prevention needs to be disabled.  Then the box must be cold booted. (if it is a laptop, pull the battery).

    If you have antivirus engines running (other than the one built into the OS) disable them and see if it makes a difference - as exclusion rules may not be set properly.

    Some search results:

    http://social.technet.microsoft.com/Forums/windows/en-US/0efcfe10-1741-4fc4-8d81-6ef4bf3eae0f/hyperv-keeps-breaking-event-id-15350-the-virtualization-infrastructure-driver-vid-is-not?forum=w8itprovirt

    http://social.technet.microsoft.com/Forums/windowsserver/en-US/f8fde61c-06c6-4ecb-a34d-5bf4ab334fd3/hyperv-on-windows-8-the-virtualization-infrastructure-driver-vid-is-not-running?forum=winserverhyperv


    Brian Ehlert
    http://ITProctology.blogspot.com
    Learn. Apply. Repeat.

    joi, 2 octombrie 2014 15:53
  • Just to confirm, that is DEP DISABLED? I was under the impression that DEP Enabled is a requirement for Hyper-V, just want to confirm this to make sure I test the correct thing.
    • Editat de ToddMurphy vineri, 3 octombrie 2014 04:37
    vineri, 3 octombrie 2014 04:37
  • Okay, have disabled DEP (or 'Intel XD Bit') in my BIOS and confirmed VT-x is enabled (already was) then shutdown my desktop computer, removed the power cable (just to be sure) for 10 seconds before plugging it back and then turning it back on. After startup I disabled my anti-virus Avast and Super Anti-Spyware.

    The same error is still occuring "The virtualization infrastructure driver (VID) is not running." when trying to start the service in hyper-v manager.

    I also still get the same error as above advising that the hypervisor is not running when I try to start my VMs.

    Thanks very much for the help so far. Is there anything further that I can test to try and resolve this issue?

    vineri, 3 octombrie 2014 08:21
  • I have now re-enabled DEP and done a cold boot. Same errors again as above.
    vineri, 3 octombrie 2014 08:33
  • Hi,

    Meanwhile, have you checked the version of your BIOS? Sometimes, this issue can be caused by an outdated BIOS, so make sure to have the latest version. You can look for the detailed information in the manufacture website.

    You can also run administrative command prompt

    bcdedit /set hypervisorlaunchtype auto

    then restart the PC, check the result.


    Yolanda Zhu
    TechNet Community Support

    vineri, 3 octombrie 2014 09:15
    Moderator
  • I just finished updating my BIOS (only a few minutes ago) from version 1502 to Version 3602 and unfortunately the same issues are still occurring. As mentioned above my motherboard is the ASUS P8P67 Pro (more info on the Motherboard here: http://www.asus.com/Motherboards/P8P67_PRO/HelpDesk_Download/).

    I previously confirmed that the hypervisolaunnchtype was set to auto, this was something I confirmed before starting this thread. I'll run your command anyway though just to be sure and update the thread again shortly.

    vineri, 3 octombrie 2014 09:27
  • After running the command above "bcdedit /set hypervisorlaunchtype auto" I am still continuing to get the same errors as before.

    EDIT: And doing a reboot to after running that command of course.

    EDIT2: By the way just to clarify, the BIOS version 3602 I updated to earlier is the latest version.


    • Editat de ToddMurphy vineri, 3 octombrie 2014 10:00
    vineri, 3 octombrie 2014 09:58
  • Hyper-V client also requires SLAT support (in those first links).

    You need to validate your chipset, not just the motherboard. You could have the right motherboard but a reduced functionality chipset.

    Have you contacted the manufacturer?


    Brian Ehlert
    http://ITProctology.blogspot.com
    Learn. Apply. Repeat.

    vineri, 3 octombrie 2014 13:03
  • No I have not yet contacted the manufacturer. I will give that a try.

    I might also try a temporary fresh second install to see if maybe it will work if I set everything up from scratch.

    sâmbătă, 4 octombrie 2014 11:24
  • I have just ran "SystemInfo" in cmd and had the following output toward the end:

    Hyper-V Requirements:      VM Monitor Mode Extensions: Yes
                               Virtualization Enabled In Firmware: No
                               Second Level Address Translation: Yes
                               Data Execution Prevention Available: Yes

    So it appears that my PC does support SLAT but Virtualization is not enabled in firmware. I have VT-x enabled in my BIOS so I'm really not sure what else could be missing.

    sâmbătă, 4 octombrie 2014 11:33
  • Issue now resolved, the BIOS update reset the Virtualisation setting to disabled. Also the option moved slightly and changed from VT-x to Intel Virtualisation Technology.

    In summary: The issue was with the P8P67 Pro Version 1502 BIOS. After doing an upgrade to the latest BIOS, then re-enabling Virtualisation in the BIOS then doing a cold boot the issue was resolved.

    • Marcat ca răspuns de ToddMurphy sâmbătă, 4 octombrie 2014 11:53
    sâmbătă, 4 octombrie 2014 11:53
  • Thanks for the help Brian and Yolanda, much appreciated :)
    sâmbătă, 4 octombrie 2014 11:53
  • Brian, thanks for your expertise, but may I ask you to clarify your point about "Data Execution Prevention needs to be disabled"?

    MS says that it should absolutely be enabled, it is a "must" requirement.

    The issue is, I am getting Hyper-V-VMMS error 15350 with everything otherwise set right (with Hyper-V features obviously on; W10 Pro) and I am not even trying to start any new VMs just yet, the error appears just on the OS' own startup.

    duminică, 24 martie 2019 07:52